Subject: IRP Claims related to draft-enyedi-rtgwg-mrt-frr-algorithm

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Tue, 8 Oct 2013 18:28:00 +0000

Hi!

In parallel to the WG Adoption Call, I want to formally ask the authors (no additional contributors are listed in the latest version of the draft) to please respond to this message indicating whether or not you are aware of any relevant IPR.  The draft will not progress (pending the results of the WG Adoption Call) until we have received a response from each author.

Thanks!

Alvaro.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Tue, 22 Oct 2013 17:22:45 +0000

Ping!

So far none of the authors have replied.

Alvaro.

On 10/8/13 2:28 PM, "Alvaro Retana (aretana)" <[email-masked]<mailto:[email-masked]>> wrote:

Hi!

Thanks!

Alvaro.

---

From: Alia Atlas <[email-masked]>
Date: Tue, 22 Oct 2013 17:34:04 +0000

Sorry!  I don't believe that I know of any IPR claims by Juniper on draft-enyedi-rtgwg-mrt-algorithm-04, but I can't speak for Gabor or Andras as far as their IPR goes.

Alia

-------- Original message --------
From: "Alvaro Retana (aretana)" <[email-masked]>
Date: 10/22/2013 1:23 PM (GMT-05:00)
To: [email-masked]
Cc: [email-masked]
Subject: Re: IRP Claims related to draft-enyedi-rtgwg-mrt-frr-algorithm

Ping!

Alvaro.

Hi!

Thanks!

Alvaro.

---

From: Chris Bowers <[email-masked]>
Date: Tue, 22 Oct 2013 17:39:35 +0000

I don't know of any IPR claims by Juniper on draft-enyedi-rtgwg-mrt-algorithm-04, either.

Chris

From: Alia Atlas [mailto:[email-masked]]
Sent: Tuesday, October 22, 2013 12:34 PM
To: Alvaro Retana (aretana); [email-masked]
Cc: [email-masked]
Subject: Re: IRP Claims related to draft-enyedi-rtgwg-mrt-frr-algorithm

Alia

-------- Original message --------
From: "Alvaro Retana (aretana)" <[email-masked]<mailto:[email-masked]>>
Date: 10/22/2013 1:23 PM (GMT-05:00)
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: IRP Claims related to draft-enyedi-rtgwg-mrt-frr-algorithm

Ping!

Alvaro.

Hi!

Thanks!

Alvaro.

---

From: Gábor Sándor Enyedi <[email-masked]>
Date: Tue, 22 Oct 2013 20:13:32 +0000

I sorry too. I don't know about any IPR by Ericsson. Ericsson doesn't like software patents, and this draft is only describing algorithms.
BR,

Gabor

Alia Atlas <[email-masked]> wrote:

Alia

-------- Original message --------
From: "Alvaro Retana (aretana)" <[email-masked]>
Date: 10/22/2013 1:23 PM (GMT-05:00)
To: [email-masked]
Cc: [email-masked]
Subject: Re: IRP Claims related to draft-enyedi-rtgwg-mrt-frr-algorithm

Ping!

Alvaro.

Hi!

Thanks!

Alvaro.

---

From: Abishek Gopalan <[email-masked]>
Date: Tue, 22 Oct 2013 11:25:46 -0700

I am not aware of any IPR cliams on draft-enyedi-rtgwg-mrt-algorithm-04
either.

Thanks,
Abishek

On Tue, Oct 22, 2013 at 10:39 AM, Chris Bowers <[email-masked]> wrote:

>  I don’t know of any IPR claims by Juniper on
> draft-enyedi-rtgwg-mrt-algorithm-04, either.****
>
> ** **
>
> Chris****
>
> ** **
>
> *From:* Alia Atlas [mailto:[email-masked]]
> *Sent:* Tuesday, October 22, 2013 12:34 PM
> *To:* Alvaro Retana (aretana);
> [email-masked]
>
> *Cc:* [email-masked]
> *Subject:* Re: IRP Claims related to draft-enyedi-rtgwg-mrt-frr-algorithm*
> ***
>
>  ** **
>
> Sorry!  I don't believe that I know of any IPR claims by Juniper on
> draft-enyedi-rtgwg-mrt-algorithm-04, but I can't speak for Gabor or Andras
> as far as their IPR goes. ****
>
> ** **
>
> Alia****
>
>
>
>
> ****
> Ping!****
> ** **
> So far none of the authors have replied.****
>
> ** **
>
> Alvaro.****
>
> ** **
>
> On 10/8/13 2:28 PM, "Alvaro Retana (aretana)" <[email-masked]> wrote:**
> **
>
> ** **
>
>   Hi!****
>
> ** **
>
> In parallel to the WG Adoption Call, I want to formally ask the authors
> (no additional contributors are listed in the latest version of the draft)
> to please respond to this message indicating whether or not you are aware
> of any relevant IPR.  The draft will not progress (pending the results of
> the WG Adoption Call) until we have received a response from each author.*
> ***
>
> ** **
>
> Thanks!****
>
> ** **
>
> Alvaro.****
>
>

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Wed, 23 Oct 2013 19:16:02 +0000

On 10/22/13 4:13 PM, "Gábor Sándor Enyedi" <[email-masked]<mailto:[email-masked]>> wrote:

[WG Chair Hat Off]

Gabor (and Andras, and Alia and Chris):

I don't know about any IPR . . . his draft is only describing algorithms.

It's interesting to me that there are IPR disclosures (from both Ericsson and Juniper) attached to the architecture draft, but not to this draft.

https://datatracker.ietf.org/ipr/search/?option=document_search&document_search=draft-ietf-rtgwg-mrt-frr-architecture

I would have thought that the IPR would be attached here (in the algorithm draft) since it provides the details of how the architecture can be implemented.

Given the discussion (in the thread where I made some comments to the algorithm draft) about where the limits of the algorithm vs the profile are, and whether one is part of the other or not, it surprises me that no one has claimed any IPR on this draft: there seems to be significant leakage and overlap  between what's in the architecture and how the algorithm operates.  In my mind, that either means that the claims over the architecture are very narrow, or that something should be declared for the algorithm.

It would be nice if you checked again about the overlap, or if you clarified what specifically is covered in the architecture draft.  Of concern to me are the terms from Ericsson ("Reasonable and Non-Discriminatory License to All Implementers with Possible Royalty/Fee.").  I realize that it is out of the scope of the WG to talk about the applicability of terms, but this is not the first time that this topic comes up; take a look at the minutes from IETF 82:  http://www.ietf.org/proceedings/82/minutes/rtgwg.txt

Thanks!

Alvaro.

---

From: Alia Atlas <[email-masked]>
Date: Wed, 23 Oct 2013 15:28:45 -0400

[WG Chair Hat off]

Hi Alvaro,

To my knowledge, there are various IPR claims on the architecture draft.
 Obviously, people must read the various
IPR claims andi make their own decisions.

a) On using the MRT algorithm for fast-reroute with trying MRT-BLUE and
going to MRT-RED if that fails.  (Initial approach
    in the first versions of the draft).
b) MRT forwarding encapsulations
c) Partial deployment computations for MRT-FRR - but the part in the
algorithm draft is just a simplification of the MRT algorithm
    so it can be called.
d) Various multicast-related aspects.

draft-enyedi-rtgwg-mrt-algorithm is based on Gabor's dissertation work.
 The extensions to that for computing which MRT to use
for an alternate were developed jointly in the IETF context.

I don't believe that (b), (c), or (d) apply to the algorithm draft.  Andras
and Gabor can answer more whether they think that (a)
applies.

Alia

On Wed, Oct 23, 2013 at 3:16 PM, Alvaro Retana (aretana)
<[email-masked]>wrote:

>  On 10/22/13 4:13 PM, "Gábor Sándor Enyedi" <
> [email-masked]> wrote:
>
>  [WG Chair Hat Off]
>
>  It's interesting to me that there are IPR disclosures (from both
> Ericsson and Juniper) attached to the architecture draft, but not to this
> draft.
>
>
>  I would have thought that the IPR would be attached here (in the
> algorithm draft) since it provides the details of how the architecture can
> be implemented.
>
>  Given the discussion (in the thread where I made some comments to the
> algorithm draft) about where the limits of the algorithm vs the profile
> are, and whether one is part of the other or not, it surprises me that no
> one has claimed any IPR on this draft: there seems to be significant
> leakage and overlap  between what's in the architecture and how the
> algorithm operates.  In my mind, that either means that the claims over the
> architecture are very narrow, or that something should be declared for
> the algorithm.
>
>  It would be nice if you checked again about the overlap, or if you
> clarified what specifically is covered in the architecture draft.  Of
> concern to me are the terms from Ericsson ("Reasonable and
> Non-Discriminatory License to All Implementers with Possible
> Royalty/Fee.").  I realize that it is out of the scope of the WG to talk
> about the applicability of terms, but this is not the first time that this
> topic comes up; take a look at the minutes from IETF 82:
> http://www.ietf.org/proceedings/82/minutes/rtgwg.txt
>
>  Thanks!
>
>  Alvaro.
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>
>