Subject: Moving Forward with MRT (WAS: Re: [mpls] maturity of the MRT technology)

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Fri, 21 Nov 2014 18:58:34 +0000

On 11/21/14, 6:49 AM, "Stewart Bryant (stbryant)" <[email-masked]<mailto:[email-masked]>> wrote:

[Stewart: Not directing this e-mail specifically at you…but at the WG.]

[Took off the draft-atlas-mpls-ldp-mrt alias since this is not a discussion specific to that draft.]

[Also took off the mpls alias as I intend to focus the discussion on the rtgwg process/consensus.  Left mpls-chairs as an FYI..we can later circle back to the mpls list.]

. . .
At the end of the day the utility of MRT depends on who is
interested in deploying it, and as far as I know, none of the
domain wide IPFRR solutions have made it into production networks.
If there are operators prepared to deploy MRT  in their production
networks then obviously it is headed for the standards track.
If it is destined to join the  ranks of the many "possible" domain
wide solutions, then it is clearly still at the informational/
experimental stage of its life.

It is true that MRT has been discussed widely in the WG (and offline)..and that no technical issues exist.

Just as a reminder, the rtgwg charter (in the description of the work related to FRR) reads: "All work in this area should be specifically evaluated by the WG in terms of practicality and applicability to deployed networks.”

Note that this statement doesn’t mean that we need deployments, or even people saying that they want/intend to deploy the technology.  It means that the WG should think of whether a proposal is applicable to deployed networks.  I would like to hear comments specific to this statement.

Thanks!

Alvaro.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Fri, 21 Nov 2014 19:02:27 +0000

On 11/21/14, 1:58 PM, "Alvaro Retana (aretana)" <[email-masked]<mailto:[email-masked]>> wrote:

[No hats on.]

As a datapoint I would like to expand a little on the message that Janos Farkas (cc’d) sent to the list on Nov/9 (Subject: 'proceeding with draft-ietf-rtgwg-mrt-frr-algorithm’).  In it he mentions that IEEE 801.1Qca (which is an amendment that involves 802.1aq SPB) leverages MRT, which means that the IEEE thinks the technology is applicable to deployed networks.  I’ll let Janos explain more if anyone has any questions.

Thanks!

Alvaro.

---

From: <[email-masked]>
Date: Fri, 28 Nov 2014 11:25:19 +0000

Alvaro, all

For my specific uses cases, it's no secret that for SPRING capable networks, I believe that, as of today, TI-LFA is the most attractive solution (compared to RLFA, MRT, RSVP-TE).
TI-LFA has been (partially) implemented in production code, we have tested it and it works very well including in a multi-vendor environment.
Yet in the short term, TI-LFA currently still lacks some IETF/industry wide/plateform wide maturity and in the short/medium/long term some networks may not have SPRING capability (e.g. IEEE ones I would presume) hence I don't think that we can exclude others FRR solutions (e.g. RLFA, MRT).

MRT has been much worked on in RTGWG and I don't recall any technical issue. (I have to admit that I have not reviewed the theoretical part of the algo)
I support progressing the work in the WG, up to RFC publication. As of today, Standard Track seems reasonable to me, but I guess this may be discussed by the IESG when time will come.

Thanks,
Bruno

From: rtgwg [mailto:[email-masked]] On Behalf Of Alvaro Retana (aretana)
Sent: Friday, November 21, 2014 7:59 PM
To: [email-masked]
Cc: [email-masked]; Stewart Bryant (stbryant)
Subject: Moving Forward with MRT (WAS: Re: [mpls] maturity of the MRT technology)

[Stewart: Not directing this e-mail specifically at you...but at the WG.]

. . .

Just as a reminder, the rtgwg charter (in the description of the work related to FRR) reads: "All work in this area should be specifically evaluated by the WG in terms of practicality and applicability to deployed networks."

Note that this statement doesn't mean that we need deployments, or even people saying that they want/intend to deploy the technology.  It means that the WG should think of whether a proposal is applicable to deployed networks.  I would like to hear comments specific to this statement.

Thanks!

Alvaro.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.