Subject: Soliciting viewpoints and comments on source/destination routing

From: "Fred Baker (fred)" <[email-masked]>
Date: Fri, 14 Nov 2014 21:52:38 +0000

The chairs have asked me to solicit review and commentary on

https://datatracker.ietf.org/doc/draft-baker-rtgwg-src-dst-routing-use-cases
https://tools.ietf.org/html/draft-baker-rtgwg-src-dst-routing-use-cases
  "Requirements and Use Cases for Source/Destination Routing", Fred Baker,
  2014-10-21

There are at least two layers of discussion. One, as a working group, do we agree that there is a problem to solve here? I obviously think there is, but I am one voice. Two, if the draft were to become a working group draft, what would need to be added or changed?

---

From: Jeroen Massar <[email-masked]>
Date: Fri, 14 Nov 2014 23:32:22 +0100

> "Requirements and Use Cases for Source/Destination Routing", Fred
> Baker, 2014-10-21
> 
> There are at least two layers of discussion. One, as a working group,
> do we agree that there is a problem to solve here?

Not really as there are lots of people who are getting multiple
upstreams and are doing source based routing.

As an example:
http://blog.altimos.de/2013/07/ipv6-source-address-routing-with-multiple-uplinks-sixxs/

Mostly a 'solved' problem thus. But it depends on your use cases.

> I obviously think there is, but I am one voice.

I think it might be worthwhile documenting the pro/cons and how to do
things.

But RFC3178 does a reasonable job at that already, hence maybe you could
add to RFC3178 in the form of a 'bis' variant?

Greets,
 Jeroen

---

From: Ole Troan <[email-masked]>
Date: Mon, 24 Nov 2014 15:03:40 +0100

Jeroen,

> Mostly a 'solved' problem thus. But it depends on your use cases.

the examples you cite seem to be static setups. yes, you can do source routing by configuring essentially static routes in every router. for a multi-prefix multi-homed network, we need a dynamic routing protocol to support it.

> add to RFC3178 in the form of a 'bis' variant?

different assumptions I believe. we are assuming ingress filtering at the ISPs and no additional service from the ISPs (like tunnels and dynamic routing).

MHMP IPv6 essentially puts the host in charge of the multi-homing decision.

cheers,
Ole