Subject: Routing in the DC - Next Steps

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Thu, 27 Jul 2017 14:55:32 +0000

Hello!

At last week’s rtgwg meeting in Prague [1], I outlined what I think should be the next steps related to potential new IETF work for Routing in the DC.  This message presents the same points for discussion “on the list”.

Data Centers, because of their topologies (traditional and emerging), traffic patterns, need for fast restoration and low human intervention, among other things, are driving a set of routing solutions specific to them.  Some of these solutions are incremental in nature, but others have resulted in new proposals.  I believe that the requirements coming from the DC will most likely result in several solutions – in this case, one size probably doesn’t fit all.

In consultation with the rtgwg Chairs and Alia (who is the responsible AD for rtgwg), we have agreed to hold a non-WG-Forming BOF at IETF 100 (Singapore) [*].  The intent of this BOF is to discuss the special circumstances that surround Routing in the DC (what is the problem?), and potential new solutions.  The objective is *not* to hold a popularity contest and find a winning solution – but to determine whether there is interest and energy in the community to work on them.  If there is significant interest and energy (beyond the proponents) around a specific new solution (or solutions), then we can consider chartering an effort around it – but let’s cross that bridge when we get to it.

Jeff Tantsura has volunteered to help coordinate the proponents of this BOF, i.e. people interested in discussing and describing the problem, requirements, etc.  While I would like to see documents describing the special circumstances in the DC, at this point I don’t expect them to be published as RFCs.

I will be setting up a mailing list in the next couple of days so that we can focus the discussion there.  I will also be announcing BOF chairs – they will run the meeting, coordinate the agenda and would be the ones who should be contacted if anyone wants time to present a potential new solution.  I will be the responsible AD.

The focus of this effort is on new potential solutions: ones that may require a standalone effort (WG) – I don’t expect work/discussions on related incremental enhancements in an existing WG to be delayed or deferred.

Thanks!

Alvaro.

[1] http://etherpad.tools.ietf.org:9000/p/notes-ietf-99-rtgwg?useMonospaceFont=true
[*] Pending discussion with the IESG/IAB, of course.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Mon, 31 Jul 2017 17:01:42 +0000

Hi!

I have received several private responses to this effort, all from people willing to contribute. :-)

To make the discussion easier, I have asked for the creation of a new mailing list which is available now!  Please subscribe and start the discussion!

     https://www.ietf.org/mailman/admin/dcrouting

Thanks!

Alvaro.

Thumb-typed and autocorrected..

On Jul 27, 2017, at 9:55 AM, Alvaro Retana (aretana) <[email-masked]<mailto:[email-masked]>> wrote:

I will be setting up a mailing list in the next couple of days so that we can focus the discussion there.

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Mon, 31 Jul 2017 17:04:34 +0000

Hi,

The below link appears to be for admin (facing password prompt). I think below is the right link

https://www.ietf.org/mailman/listinfo/dcrouting

Thanks,
Nagendra

From: routing-discussion <[email-masked]> on behalf of "Alvaro Retana (aretana)" <[email-masked]>
Date: Monday, July 31, 2017 at 1:01 PM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: Routing in the DC - Next Steps

Hi!

Thanks!

Alvaro.

---

From: Fred Baker <[email-masked]>
Date: Mon, 31 Jul 2017 10:05:02 -0700

> On Jul 31, 2017, at 10:01 AM, Alvaro Retana (aretana) <[email-masked]> wrote:
> 
> Hi!
> 

Did you mean https://www.ietf.org/mailman/listinfo/dcrouting?

:-)

> On Jul 27, 2017, at 9:55 AM, Alvaro Retana (aretana) <[email-masked]> wrote:
> 
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Mon, 31 Jul 2017 17:05:46 +0000

Sorry, here's the right link:  https://www.ietf.org/mailman/listinfo/dcrouting

On Jul 31, 2017, at 12:01 PM, Alvaro Retana (aretana) <[email-masked]<mailto:[email-masked]>> wrote:

Hi!

Thanks!

Alvaro.