Subject: I-D Action: draft-ietf-rtgwg-arp-yang-model-02.txt

From: [email-masked]
Date: Sun, 10 Mar 2019 23:00:03 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Routing Area Working Group WG of the IETF.

        Title           : YANG Data Model for ARP
        Authors         : Feng Zheng
                          Bo Wu
                          Robert Wilton
                          Xiaojian Ding
	Filename        : draft-ietf-rtgwg-arp-yang-model-02.txt
	Pages           : 16
	Date            : 2019-03-10

Abstract:
   This document defines a YANG data model for the management of the
   Address Resolution Protocol (ARP).  It extends the basic ARP
   functionality contained in the ietf-ip YANG data model, defined in
   RFC 8344, to provide management of optional ARP features and
   statistics.

   The YANG data model in this document conforms to the Network
   Management Datastore Architecture defined in RFC 8342.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-arp-yang-model/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-rtgwg-arp-yang-model-02
https://datatracker.ietf.org/doc/html/draft-ietf-rtgwg-arp-yang-model-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-rtgwg-arp-yang-model-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: tom petch <[email-masked]>
Date: Thu, 14 Mar 2019 17:06:43 +0000

I see a number of changes in this I-D cf -01 and would be interested to
hear the authors' comments thereon; I don't disagree with them but some
I wonder at (while others seem obvious:-)

Tom Petch

----- Original Message -----
From: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, March 11, 2019 6:00 AM

> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 26 Mar 2019 09:43:01 +0000

Hi Tom,

Sorry for the slow reply.

I have just presented on this in RTGWG, pasting from the slides:

We have made the following changes:
- Editorial improvements to introductory text, security sections
- Simplified model - trying to align to minimal viable subset of vendor config, so removed:
   Global static ARP entries, ARP probe configuration, Grat ARP drop config flag
- Fix dynamic ARP global default setting
- Aligned global and interface config
- Improved YANG formatting
- Added discontinuity timestamp for counters

Based on the slides presented, and the two issues that we raised, and the comments that I received, I think that adding the discontinuity counter was a mistake, so it will be removed again, and the counters will instead by bound to the interface stats discontinuity counter.  Vendor implementations could deviate this behaviour if required.

The other issue was what default should be used for grat ARP config.  The conclusion here is that the default should be undefined, but the model will suggest that adding a deviation to specify the device default for grat ARP may be helpful to clients.

Thanks,
Rob

> -----Original Message-----
> From: rtgwg <[email-masked]> On Behalf Of tom petch
> Sent: 14 March 2019 18:07
> To: [email-masked]
> Subject: Re: I-D Action: draft-ietf-rtgwg-arp-yang-model-02.txt
> 
> I see a number of changes in this I-D cf -01 and would be interested to hear the
> authors' comments thereon; I don't disagree with them but some I wonder at
> (while others seem obvious:-)
> 
> Tom Petch
> 
> 
> > Internet-Draft directories: http://www.ietf.org/shadow.html or
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg