Subject: Regarding dependency to type "routing-instance-ref"

From: "PATNA CHANDRAPPA, NAVEEN KUMAR" <[email-masked]>
Date: Wed, 1 May 2019 16:19:48 +0000

Hi Team ,

   Greetings,

  Sub : Regarding dependency to type "routing-instance-ref"

   I am referring to the gre yang files from github that exits, in order to support configuration to gre feature.
   While implementing i am facing an issue to find dependency for leaf "routing-instance".
   I require some guidance or suggestion regarding the same.

  please find the details below which explains more about the issue.

   Files : ietf-gre-tunnel.yang(2015-10-13) , [email-masked]
   source : https://github.com/YangModels/yang/tree/master/experimental/ietf-extracted-YANG-modules
   Imported yang files : ietf-interfaces, ietf-inet-types, ietf-routing
   Issue : Unable to find "routing-instance-ref" from imported file from latest ietf-routing yang file.
   Reference in latest routing yang file : doesn't exist
   Reference in old routing yang file :

    /* Type Definitions */

     typedef routing-instance-ref {
       type leafref {
         path "/rt:routing/rt:routing-instance/rt:name";
       }
       description
         "This type is used for leafs that reference a routing instance
          configuration.";
     }

   Details:  The "routing-instance-ref" for the leaf "routing-instance" which is present at two places in the file ,
                  1)In config data under container->gre-tunnels in list->gre  and the
                    2)other in operational data grouping tunnel-gre-states.
                    doesn't exist in latest routing.yang ([email-masked]) file. It is present only in old ietf-routing.yang (2015-05-25) file.
                    I can't refer old file replacing new routing.yang file as the new file is currently supporting other feature related yang files.

    Can you kindly suggest any soultion pertaining to this issue ?
    Also provide the details if there exists any latest updated gre yang file.

    I have also attached these files for reference.
    ietf-gre-tunnel.yang
    [email-masked] (new)
    ietf-routing.yang(old)

with best regards,
NAVEEN KUMAR PATNA CHANDRAPPA

Service provider at Siemens Canada Limited
DI PA CI RC R&D SW2
300 Applewood Crescent
Concord ON L4K 5C7, Canada
mailto:[email-masked]

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 2 May 2019 18:36:55 +0000

The GRE Model has expired and needs to be updated - https://www.ietf.org/archive/id/draft-liu-intarea-gre-tunnel-yang-00.txt

I would think it would reference a network instance similar to a regular interface is done in https://www.rfc-editor.org/rfc/rfc8529.txt

Good Luck,
Acee

From: "PATNA CHANDRAPPA, NAVEEN KUMAR" <[email-masked]>
Date: Wednesday, May 1, 2019 at 12:20 PM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Routing WG <[email-masked]>, Acee Lindem <[email-masked]>, Yingzhen Qu <[email-masked]>
Cc: "NGUYEN, Andy" <[email-masked]>, "NGUYEN, TANG" <[email-masked]>
Subject: Regarding dependency to type "routing-instance-ref"

  Hi Team ,

   Greetings,

  Sub : Regarding dependency to type “routing-instance-ref”

   Issue : Unable to find “routing-instance-ref” from imported file from latest ietf-routing yang file.

    /* Type Definitions */

   Details:  The “routing-instance-ref” for the leaf "routing-instance" which is present at two places in the file ,

with best regards,