Subject: Re: I-D Action: draft-ietf-rtgwg-qos-model-01.txt

From: t petch <[email-masked]>
Date: Wed, 15 Apr 2020 12:16:53 +0100

Aseem

I would like you to think more deeply about the YANG prefix.  Prefix 
need to be easy to use, to read, view and need to be unique, ideally 
across the IETF.  At the same time, they need to be compact, especially 
when used in lengthy references such as when statements (as RFC8407 
says, they SHOULD be short); and it is helpful when they show which part 
of the IETF they relate to; thus across many traffic engineering modules 
you find te... being used.

I think that your choices do not meet such requirements.  'policy' could 
be anywhere, from tcp to art to routing.  In fact there is a more widely 
used routing policy model already and it chooses 'rtpol' which I think a 
sound choice.

You have seven and I think at the very least they should be recognisably 
part of the same set, starting with the same few letters.  'qos' perhaps.

And after that another two, three or four letters to indicate which part 
of QoS, such as 'pol' for policy.

I would urge you to consider this now.  It may mean hundreds of text 
changes to the I-D but that is better done now that at Last Call.

Tom Petch

On 01/01/1970 00:00, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Routing Area Working Group WG of the IETF.
>
>          Title           : YANG Model for QoS
>          Authors         : Aseem Choudhary
>                            Mahesh Jethanandani
>                            Norm Strahle
>                            Ebben Aries
>                            Ing-Wher Chen
>          Filename        : draft-ietf-rtgwg-qos-model-01.txt
>          Pages           : 90
>          Date            : 2020-04-09
>
> Abstract:
>     This document describes a YANG model for Quality of Service (QoS)
>     configuration and operational parameters.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-rtgwg-qos-model/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-rtgwg-qos-model-01
> https://datatracker.ietf.org/doc/html/draft-ietf-rtgwg-qos-model-01
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=3Ddraft-ietf-rtgwg-qos-model-01
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 15 Apr 2020 11:33:25 +0000

The prefixes should probably include "qos-" and an abbreviated model descriptor. For example, qos-class, qos-actn, qos-pol, qos-trgt, qos-q-pol, qos-sched, and qos-diffsrv. 
Thanks,
Acee

On 4/15/20, 7:17 AM, "rtgwg on behalf of t petch" <[email-masked] on behalf of [email-masked]> wrote:

    Aseem

    Tom Petch