Subject: Re: WG last call for draft-ietf-rtgwg-policy-model

From: tom petch <[email-masked]>
Date: Mon, 5 Oct 2020 11:20:47 +0000

From: Acee Lindem (acee) <[email-masked]>
Sent: 18 September 2020 21:02

Hi Tom,
I went ahead and fixed and ran it through a spell-checker.

<tp>
Acee
 
a technical thought - I'll send some editorial thoughts separately.

YANG document order is not defined and so you have ordered-by user in suitable places.  I am wondering if there could still be an ambiguity if there are several modifications to the same value e.g. metric.  If one modification takes the value below the minimum of above the maximum, then the result of the next modification will be different than if the order was different.

I cannot decide whether this is completely ruled out by the ordered-by user or not.  Maybe the document needs to say that document order is undefined and that users must not rely on condition/action being evaluated in the order shown except where ordered by user.

Tom Petch

Thanks,
Acee

On 9/17/20, 6:35 AM, "tom petch" <[email-masked]> wrote:

    From: Acee Lindem (acee) <[email-masked]>
    Sent: 16 September 2020 18:47

    Hi Tom, et al,
    I have clarified the usage of policy chain and added the normative language in the YANG description constraints - which I believe is the right approach.

    <tp>

    Looks good.

    Some more trivia:-(
    In container prefixes you fixed the 'is is' but I did not notice
    'outcome outcome'
    or
    'statisfied'
    Sigh.  I suggest holding these (which my spell-checking MUA is complaining about:-) until something else comes along.

    Tom Petch
    Thanks,
    Acee

    On 9/16/20, 12:33 PM, "tom petch" <[email-masked]> wrote:

        From: Acee Lindem (acee) <[email-masked]>
        Sent: 16 September 2020 16:53
        To: tom petch; Acee Lindem (acee); Chris Bowers; RTGWG
        Cc: rtgwg-chairs
        Subject: Re: WG last call for draft-ietf-rtgwg-policy-model

        Hi Tom,

        On 9/16/20, 6:01 AM, "tom petch" <[email-masked]> wrote:

            From: Acee Lindem (acee) <[email-masked]>
            Sent: 15 September 2020 21:37

            Hi Tom, Chris, et al,
            I've moved the non-normative sections to appendixes in the -22 version. Also, at the risk of being redundant, I included an explicit reference for the unpopular BGP sub-module prefixes.

            <tp>
            Looks good.

            Every time I read this, I see something:-(  So some trivia for as and when a new version is needed:

            container prefixes has 'is is'
        <acee>
        Fixed in -22.
        </acee>

            container conditions /returns control the/returns control to the/
        <acee>
        Fixed in -22
        </acee>

            and
            should or SHOULD? (an AD is bound to ask if we meant this:-)

        <acee>
        I think it should... Started a thread on this amongst YANG doctors. There is no consistency in published models on "description" statement validation. However, in times we've discussed this on the NETMOD list, these descriptions are normative.
        </acee>

            'chain' is probably worth expanding on.  It appears in 4.4 and is relied on in s.5 without ever a formal definition and it might not be obvious how it is represented in the YANG model. I infer that it is the leaf-list import-policy or export-policy but chain does not appear in the descriptions thereof.  So I think a sentence in 4.4 saying what a chain looks like as YANG would help as would a mention of chain alongside list in the description of export-policy and import-policy.  If my inference is wrong, then please tell me what a chain is!

        <acee>
        Good catch. I think the problem here is that "policy chain" is used for both the list of import or export policies and the list of statement within a called policy. This is clearly wrong and policy chain should only be used for the former.  Let me assure my co-authors agree.

        <tp2>
        Well yes, I think I coped with that one but it is more that I cannot program a chain in YANG the way I can in other languages, forward pointers, backward pointers and so on,  and an ordered by user leaf-list is not an immediately obvious substitute to so I would add in s.4/s.5
        'A policy chain is represented in YANG by a user-ordered leaf-list such as ...'
        and then in the YANG
        'This leaf-list implements a policy  chain as described in ...'

        Tom Petch
        Thanks,
        Acee
        </acee>

        Thanks,
        Acee

            Tom Petch

            Thanks
            Acee

            On 9/10/20, 6:10 PM, "rtgwg on behalf of Acee Lindem (acee)" <[email-masked] on behalf of acee=[email-masked]> wrote:

                Hi Tom,

                As previously noted, the BGP model augments the routing-policy model and not the other way around. Hence, resolution of BGP model issues is not a prerequisite for publication of this YANG model. AFAIK, none of the open issues with the BGP model are related to its augmentation of the routing-policy model.

                Now, I'd like to see the BGP model issues addressed and the model progress as much as you but there is absolutely nothing unusual regarding its treatment.

                Thanks,
                Acee

                On 9/10/20, 11:44 AM, "rtgwg on behalf of tom petch" <[email-masked] on behalf of [email-masked]> wrote:

                    From: rtgwg <[email-masked]> on behalf of Chris Bowers <[email-masked]>
                    Sent: 09 September 2020 21:07

                    RTGWG,

                    I think there is rough WG consensus to submit draft-ietf-rtgwg-policy-model to the IESG for publication.  I will include a description of the discussion related to draft-ietf-idr-bgp-model in the shepherd writeup.  It will likely take the IESG several months to publish draft-ietf-rtgwg-policy-model.  If there are changes in draft-ietf-idr-bgp-model that make it desirable to change the text of the example in draft-ietf-rtgwg-policy-model before publication, then any changes in draft-ietf-rtgwg-policy-model will be discussed within RTGWG.

                    <tp>
                    Chris
                    The other thought that I had was that the treatment of bgp-model, which I would regard as unusual, might attract some interesting comment from such as Genart or Opsdir reviews so it might be valuable to get those done earlier rather than later.

                    Tom Petch

                    Thanks,
                    Chris

                    _______________________________________________
                    rtgwg mailing list
                    [email-masked]
                    https://www.ietf.org/mailman/listinfo/rtgwg

                _______________________________________________
                rtgwg mailing list
                [email-masked]
                https://www.ietf.org/mailman/listinfo/rtgwg

---

From: tom petch <[email-masked]>
Date: Mon, 5 Oct 2020 11:42:06 +0000

Hi Tom,

Acee

mmm a spell checker, that's a challenge.  I have read the whole I-D this time to see if I could spot anything else:-)  Nothing substantial that warrants a revised I-D but ...

You have  a 'SHOULD not' and two 'MUST not'  where the 'not' needs capitalising.

Abstract
perhaps
/and based/ and is based/

Terminology
I suggest adding a line or two about each of 
Policy chain, Policy definition, Policy statement.  To me the three terms are not intuitive and I have to stop and think which is which in the text descriptions - I would find it valuable to be able to refer back to Terminology rather than to the different parts of section 4 to clarify my mind.  This is the only semi-substantial comment.

s.4.4
/some major implementation/some major implementations/
/creating policies ... are/creating policies ... is/

s.5
/policy statement are/policy statement is/

s.9
/YANG modules/YANG module/

revision reference
the title of this I-D has changed over time

/subtract  the specified value to/subtract the specified value  from/

I-D reference 
the references to the two I-D are odd but that is likely a quirk of the tools.

Tom Petch

Thanks,
Acee

    Hi Tom, et al,

    <tp>

    Looks good.

    Some more trivia:-(

    Tom Petch
    Thanks,
    Acee

        Hi Tom,

            Hi Tom, Chris, et al,

            <tp>
            Looks good.

            and

        <acee>

        <acee>

        <tp2>

        Tom Petch
        Thanks,
        Acee
        </acee>

        Thanks,
        Acee

            Tom Petch

            Thanks
            Acee

                Hi Tom,

                Thanks,
                Acee

                    RTGWG,

                    <tp>
                    Chris

                    Tom Petch

                    Thanks,
                    Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 5 Oct 2020 17:58:57 +0000

Hi Tom, 

There can only be one "set-metric" action per statement and the statements are order-by-user. Hence, I don't see how there is ambiguity. 

Thanks,
Acee

On 10/5/20, 7:21 AM, "tom petch" <[email-masked]> wrote:

    Hi Tom,

    <tp>
    Acee

    Tom Petch

    Thanks,
    Acee

        Hi Tom, et al,

        <tp>

        Looks good.

        Some more trivia:-(

        Tom Petch
        Thanks,
        Acee

            Hi Tom,

                Hi Tom, Chris, et al,

                <tp>
                Looks good.

                and

            <acee>

            <acee>

            <tp2>

            Tom Petch
            Thanks,
            Acee
            </acee>

            Thanks,
            Acee

                Tom Petch

                Thanks
                Acee

                    Hi Tom,

                    Thanks,
                    Acee

                        RTGWG,

                        <tp>
                        Chris

                        Tom Petch

                        Thanks,
                        Chris

---

From: Yingzhen Qu <[email-masked]>
Date: Mon, 5 Oct 2020 20:59:50 +0000

Hi Tom,

Thank you for the review. I've uploaded version -26 to address your comments. Detailed response below.

Thanks,
Yingzhen

On 10/5/20, 4:43 AM, "rtgwg on behalf of tom petch" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Tom,

    Acee

[YQ]: fixed.

    Abstract
    perhaps
    /and based/ and is based/
[YQ]: I think this should be "based". How about leave it to RFC editor?

    Terminology
    I suggest adding a line or two about each of 
    Policy chain, Policy definition, Policy statement.  To me the three terms are not intuitive and I have to stop and think which is which in the text descriptions - I would find it valuable to be able to refer back to Terminology rather than to the different parts of section 4 to clarify my mind.  This is the only semi-substantial comment.
[YQ]: I added "Policy chain" and "Policy statement" since we already have "Routing policy".

    s.4.4
[YQ]: fixed.

    s.5
[YQ]: fixed.

    s.9
[YQ]: fixed.

    revision reference
[YQ]: fixed.

[YQ]: fixed.

    I-D reference 

    Tom Petch

    Thanks,
    Acee

        Hi Tom, et al,

        <tp>

        Looks good.

        Some more trivia:-(

        Tom Petch
        Thanks,
        Acee

            Hi Tom,

                Hi Tom, Chris, et al,

                <tp>
                Looks good.

                and

            <acee>

            <acee>

            <tp2>

            Tom Petch
            Thanks,
            Acee
            </acee>

            Thanks,
            Acee

                Tom Petch

                Thanks
                Acee

                    Hi Tom,

                    Thanks,
                    Acee

                        RTGWG,

                        <tp>
                        Chris

                        Tom Petch

                        Thanks,
                        Chris

                        _______________________________________________
                        rtgwg mailing list
                        [email-masked]
                        https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frtgwg&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7Cc9741d6228c54ba5b33e08d86923e429%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637374950177428780&amp;sdata=qkFSLpS8u%2F9xdebJW%2B1zFs3bNpd1aTbUluoGpvAfgLY%3D&amp;reserved=0

                    _______________________________________________
                    rtgwg mailing list
                    [email-masked]
                    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frtgwg&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7Cc9741d6228c54ba5b33e08d86923e429%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637374950177428780&amp;sdata=qkFSLpS8u%2F9xdebJW%2B1zFs3bNpd1aTbUluoGpvAfgLY%3D&amp;reserved=0

    _______________________________________________
    rtgwg mailing list
    [email-masked]
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frtgwg&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7Cc9741d6228c54ba5b33e08d86923e429%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637374950177428780&amp;sdata=qkFSLpS8u%2F9xdebJW%2B1zFs3bNpd1aTbUluoGpvAfgLY%3D&amp;reserved=0