Subject: [Technical Errata Reported] RFC9067 (6844)

From: RFC Errata System <[email-masked]>
Date: Thu, 10 Feb 2022 09:10:32 -0800 (PST)

The following errata report has been submitted for RFC9067,
"A YANG Data Model for Routing Policy".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6844

--------------------------------------
Type: Technical
Reported by: Kris Lambrechts <[email-masked]>

Section: 7.2. grouping prefix

Original Text
-------------
       leaf mask-length-upper {
         type uint8 {
           range "1..128";
         }

Corrected Text
--------------
       leaf mask-length-upper {
         type uint8 {
           range "0..128";
         }

Notes
-----
With the original definition, it is not possible to specify an exact match for the default routes (0.0.0.0/0 and ::/0) which is a valid use case.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC9067 (draft-ietf-rtgwg-policy-model-31)
--------------------------------------
Title               : A YANG Data Model for Routing Policy
Publication Date    : October 2021
Author(s)           : Y. Qu, J. Tantsura, A. Lindem, X. Liu
Category            : PROPOSED STANDARD
Source              : Routing Area Working Group
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 11 Feb 2022 18:13:04 +0000

This is a legitimate problem for 0.0.0.0/0 given that all components of a list key are required. In the case of a prefix-list, the prefix and mask length limits are all part of the key and, hence, required. It will need to be fixed in a BIS version or augmentation allowing separate list dependent on what is specified (such is done in our Cisco IOS-XE native model): 

https://github.com/YangModels/yang/blob/master/vendor/cisco/xe/1771/Cisco-IOS-XE-ip.yang#L2888

It would be nice if YANG supported lists with variable length keys. 

Thanks,
Acee

On 2/10/22, 12:10 PM, "RFC Errata System" <[email-masked]> wrote:

    Original Text
    -------------
           leaf mask-length-upper {
             type uint8 {
               range "1..128";
             }

    Corrected Text
    --------------
           leaf mask-length-upper {
             type uint8 {
               range "0..128";
             }

    Notes
    -----

    Instructions:
    -------------

---

From: Alvaro Retana <[email-masked]>
Date: Fri, 11 Feb 2022 20:02:36 +0100

[Removed RFC Editor.]

Thanks Acee!

I am marking the report as “Hold for Document Update” because the
resolution is not to simply correct the text, but the model requires a
revision.

Thanks!

Alvaro.

On February 11, 2022 at 1:13:11 PM, Acee Lindem (acee) ([email-masked])
wrote:

This is a legitimate problem for 0.0.0.0/0 given that all components of a
list key are required. In the case of a prefix-list, the prefix and mask
length limits are all part of the key and, hence, required. It will need to
be fixed in a BIS version or augmentation allowing separate list dependent
on what is specified (such is done in our Cisco IOS-XE native model):

Thanks,
Acee

On 2/10/22, 12:10 PM, "RFC Errata System" <[email-masked]>
wrote:

Original Text
-------------
leaf mask-length-upper {
type uint8 {
range "1..128";
}

Corrected Text
--------------
leaf mask-length-upper {
type uint8 {
range "0..128";
}

Notes
-----
With the original definition, it is not possible to specify an exact match
for the default routes (0.0.0.0/0 and ::/0) which is a valid use case.

Instructions:
-------------