Subject: [Technical Errata Reported] RFC9067 (6845)

From: RFC Errata System <[email-masked]>
Date: Thu, 10 Feb 2022 09:20:06 -0800 (PST)

The following errata report has been submitted for RFC9067,
"A YANG Data Model for Routing Policy".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6845

--------------------------------------
Type: Technical
Reported by: Kris Lambrechts <[email-masked]>

Section: 7.2.

Original Text
-------------
               list prefix-list {
                 key "ip-prefix mask-length-lower mask-length-upper";
                 description
                   "List of prefixes in the prefix set.";
                 uses prefix;
               }

Corrected Text
--------------
               list prefix {
                 key "ip-prefix mask-length-lower mask-length-upper";
                 description
                   "List of prefixes in the prefix set.";
                 uses prefix;
               }

Notes
-----
The name of this list is not natural and makes instance data hard to read. This is very apparent in the example in Appendix B.  Policy Examples

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC9067 (draft-ietf-rtgwg-policy-model-31)
--------------------------------------
Title               : A YANG Data Model for Routing Policy
Publication Date    : October 2021
Author(s)           : Y. Qu, J. Tantsura, A. Lindem, X. Liu
Category            : PROPOSED STANDARD
Source              : Routing Area Working Group
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 10 Feb 2022 17:30:30 +0000

This is a rather subjective comment since at this YANG data node is, in fact, a list. There are many models that follow this format even it seems a bit verbose in the xml examples. Also, it is a moot point since changing this would be a non-backward compatible YANG change. Please reject this Errata. 
Thanks,
Acee

On 2/10/22, 12:20 PM, "RFC Errata System" <[email-masked]> wrote:

    Section: 7.2.

    Original Text
    -------------
                   list prefix-list {

    Corrected Text
    --------------
                   list prefix {

    Notes
    -----

    Instructions:
    -------------

---

From: Alvaro Retana <[email-masked]>
Date: Fri, 11 Feb 2022 18:53:12 +0000

[Removed rfc-editor.]

I agree with Acee.  I’m marking this report as rejected.

Thanks!

Alvaro.

On February 10, 2022 at 12:30:35 PM, Acee Lindem (acee) ([email-masked])
wrote:

This is a rather subjective comment since at this YANG data node is, in
fact, a list. There are many models that follow this format even it seems a
bit verbose in the xml examples. Also, it is a moot point since changing
this would be a non-backward compatible YANG change. Please reject this
Errata.
Thanks,
Acee

On 2/10/22, 12:20 PM, "RFC Errata System" <[email-masked]>
wrote:

Section: 7.2.

Original Text
-------------
list prefix-list {

Corrected Text
--------------
list prefix {

Notes
-----
The name of this list is not natural and makes instance data hard to read.
This is very apparent in the example in Appendix B. Policy Examples

Instructions:
-------------