Subject: [sacm] Fw: Re: [Netconf] [netmod] development plan

From: Eric Walker <[email-masked]>
Date: Fri, 9 Aug 2013 10:18:40 -0600

I wrote:

>But if I might propose sorting out the use
>cases first, without introducing details that would necessarily imply
>an agent-based architecture if such details can be omitted, that
>might be something that people would want to consider.  That way we
>would be working from customer value back to architecture, which will
>help to avoid over-engineering things.

It occurs to me that a set of use cases have already been approved, although I have not had a chance to review them.  Perhaps as an assistance to those of us who have yet to come up to speed on this discussion, any architectural proposals could make a passing reference to the customer problem being solved, even at the risk of repeating things a little for those who are closely following the discussion?

Also, am I to understand that the initial SACM standard will go beyond some existing products?  I had the impression at one point that the initial revision would seek to capture what existing products are doing and then, later on, we could iterate and modify it organically.  This is my preferred approach.

Eric

---

From: Stephen Hanna <[email-masked]>
Date: Fri, 9 Aug 2013 17:52:09 +0000

Actually, we have not achieved WG consensus on the use cases yet. We agreed to make the use case draft into a WG document but that does not mean that there's WG consensus that it's done. It just means that this draft is a good starting point for the project of listing and agreeing on the use cases.

While this has been a fun diversion from the use cases, I agree with Eric's original email. We should REFOCUS on the USE CASES and not jump into architecture and implementation. This whole discussion started with a discussion about whether NetConf will be useful. Discussing that is getting way ahead of ourselves. Let's stop and go back to use cases.

Dave Waltermire, how soon can we expect to have another use case draft? Or should we just start sending more comments on the current draft?

Thanks,

Steve

From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Walker
Sent: Friday, August 09, 2013 12:19 PM
To: Waltermire, David A.; Adam Montville; Baker, Jon; Romascanu, Dan (Dan); Gunnar Engelbach; David Harrington; [email-masked]
Subject: [sacm] Fw: Re: [Netconf] [netmod] development plan

Eric

---

From: "Waltermire, David A." <[email-masked]>
Date: Fri, 9 Aug 2013 17:57:22 +0000

I am hoping to have an update of the use case draft by the end of next week.  I also plan to post some questions throughout the week.  Please continue to discuss the current draft and to contribute any new use cases.

Thanks,
Dave

From: Stephen Hanna [mailto:[email-masked]]
Sent: Friday, August 09, 2013 1:52 PM
To: Eric Walker; Waltermire, David A.; Adam Montville; Baker, Jon; Romascanu, Dan (Dan); Gunnar Engelbach; David Harrington; [email-masked]
Subject: RE: [sacm] Fw: Re: [Netconf] [netmod] development plan

Thanks,

Steve

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Eric Walker
Sent: Friday, August 09, 2013 12:19 PM
To: Waltermire, David A.; Adam Montville; Baker, Jon; Romascanu, Dan (Dan); Gunnar Engelbach; David Harrington; [email-masked]<mailto:[email-masked]>
Subject: [sacm] Fw: Re: [Netconf] [netmod] development plan

Eric