Subject: [sacm] Endpoint ID Design Team Notes: 2015-09-18

From: "Haynes, Dan" <[email-masked]>
Date: Fri, 18 Sep 2015 16:57:25 +0000

Hi Everyone,

Here are the notes from the Endpoint ID Design Team Meeting (EID-DT).

Attendees

*         Ron Colvin

*         Henk Birkholz

*         Dave Waltermire

*         Danny Haynes

Note Well

Agenda

*         Quick review of open action items

*         Further discuss the triple example with updates

*         Discuss how it could be integrated into the Information Model

*         Information Model update at the Virtual Interim (9/24)

*         Next steps

Materials

*         Slides from meeting (see attached)

*         2015-09-04 EID-DT Notes (http://www.ietf.org/mail-archive/web/sacm/current/msg03271.html)

*         Network Interface Definition (https://github.com/sacmwg/draft-ietf-sacm-terminology/blob/master/draft-ietf-sacm-terminology.md)

*         #25 SACM components (except at endpoints) MUST have time sync (https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/25)

Notes

*         There was a question regarding discussion from the 2015-09-04 EID-DT meeting around a comment made about representing more complex constructs using a Yang-like representation.  The group couldn't exactly remember the comment, but, the main point was that the conceptualization of constructs in the Information Model should be represented in a neutral manner to prevent people from confusing it with a data model.  For example, if a Yang-like model was used.  It was explained how some information models use a Yang-like syntax.  The group decided it would be good to find examples of both and share them with the broader working group to decide what makes the most sense for us.

*         The group went through the open action items from the 2015-09-04 EID-DT Meeting.

o   Henk is still working on updating the triples example.

o   Dave is going to select a few information models that represent constructs in a neutral way.  Henk is going to select a few information models that represent constructs in a Yang-like manner.  The different information models will be shared with the working group for feedback on how we should represent our information model.  This should cover the action item to share links of IETF documents that could be used as a model to represent our information model.  The group would like to discuss this during this at the virtual interim meeting next week (9/24).

o   Henk provided a draft definition for "network interface" in the Terminology draft on GitHub.  Feedback would be greatly appreciated.

o   The action item to review the differences between 01 and 02 of the Information Model remains open.  To address this item, a message will be sent to the list explaining the issue and ask for a last call for objections before it is closed out.  It can always be opened back up at a later time.

o   Danny is going to add a GitHub issue for the accuracy of timestamp data and raise it with the list.

o   Danny is working to update the Information Model on GitHub to include the proposed changes.

*         There was discussion about the accuracy of timestamp data issue.  It was noted that it might be more of an  operational consideration.  We need to figure out if we are just trying to say timestamps are important or if we are saying that we need a high-assurance mechanism for timestamps.   This issue really breaks down into three different areas:

o   Level of assurance of the timestamp (and possibly any attribute collected off the endpoint)

o   Freshness of the timestamp and data as well as how we use the endpoint

o   How the timestamp is interpreted (observation, publication, etc.).  See Henk's comment in GitHub Information Model issue #25 for more information.

*         It was noted that timestamp accuracy, what attributes designate an endpoint, and possibly others things belong in an Operational Considerations section because they are very dependent on the organization or mechanism leveraging them.  This new section would come before the Security Considerations section.  It was also noted that the Information Model should have a Privacy Considerations Section.  Sections for Operational Considerations and Privacy Considerations will be added to the Information Model.

*         The group discussed the Information Model Update at the virtual interim meeting.  The group agreed it would be best to briefly discuss what we have been doing, but, focus the majority of the time discussing open issue.

Action Items

*         Continue to update the example of using triples and annotate the example so it can be shared with the list. (Henk Birkholz)

*         Research and share examples of how other information models represent their constructs which can be reviewed for that may be SACM Information Model. (Dave Waltermire and Henk Birkholz)

*         Send a message to the list making a last call for objections to the issue around resolving the differences between revisions 01 and 02 of the IM to determine what text, if any, is missing. (Danny Haynes)

*         Add a GitHub issue regarding the accuracy of timestamp data and raise with the list.  (Danny Haynes)

*         Make the proposed changes to the Information Model and include a sentence or two to describe what information goes in each new section.  Update on GitHub. (Danny Haynes)

Please let me know if I missed anything, got anything wrong, or if you have any questions.

Adam will post the recordings when they are ready.

Have a great weekend.

Thanks,

Danny

---

From: Adam Montville <[email-masked]>
Date: Mon, 21 Sep 2015 07:24:03 -0500

Danny, thank you for posting these notes.

I’ve put the recording and slides from this meeting in my Dropbox share (along with the recording from the last meeting): https://www.dropbox.com/sh/bs0hioy5qh6qzr1/AAA2lzSwCFE_pfYMlpP3bRu_a?dl=0 <https://www.dropbox.com/sh/bs0hioy5qh6qzr1/AAA2lzSwCFE_pfYMlpP3bRu_a?dl=0>

Kind regards,

Adam

> On Sep 18, 2015, at 11:57 AM, Haynes, Dan <[email-masked]> wrote:
> 
> Hi Everyone,
> 
> ·         Ron Colvin
> ·         Henk Birkholz
> ·         Dave Waltermire
> ·         Danny Haynes
> ·         Quick review of open action items
> ·         Further discuss the triple example with updates
> ·         Discuss how it could be integrated into the Information Model
> ·         Information Model update at the Virtual Interim (9/24)
> ·         Next steps
>  
> Materials
> ·         Slides from meeting (see attached)
> ·         2015-09-04 EID-DT Notes (http://www.ietf.org/mail-archive/web/sacm/current/msg03271.html <http://www.ietf.org/mail-archive/web/sacm/current/msg03271.html>)
> ·         Network Interface Definition (https://github.com/sacmwg/draft-ietf-sacm-terminology/blob/master/draft-ietf-sacm-terminology.md <https://github.com/sacmwg/draft-ietf-sacm-terminology/blob/master/draft-ietf-sacm-terminology.md>)
> ·         #25 SACM components (except at endpoints) MUST have time sync(https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/25 <https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/25>)
>  
> Notes
> ·         There was a question regarding discussion from the 2015-09-04 EID-DT meeting around a comment made about representing more complex constructs using a Yang-like representation.  The group couldn’t exactly remember the comment, but, the main point was that the conceptualization of constructs in the Information Model should be represented in a neutral manner to prevent people from confusing it with a data model.  For example, if a Yang-like model was used.  It was explained how some information models use a Yang-like syntax.  The group decided it would be good to find examples of both and share them with the broader working group to decide what makes the most sense for us.
>  
> ·         The group went through the open action items from the 2015-09-04 EID-DT Meeting. 
> o   Henk provided a draft definition for “network interface” in the Terminology draft on GitHub.  Feedback would be greatly appreciated.
> ·         There was discussion about the accuracy of timestamp data issue.  It was noted that it might be more of an  operational consideration.  We need to figure out if we are just trying to say timestamps are important or if we are saying that we need a high-assurance mechanism for timestamps.   This issue really breaks down into three different areas:
> o   How the timestamp is interpreted (observation, publication, etc.).  See Henk’s comment in GitHub Information Model issue #25 for more information.
>  
> ·         It was noted that timestamp accuracy, what attributes designate an endpoint, and possibly others things belong in an Operational Considerations section because they are very dependent on the organization or mechanism leveraging them.  This new section would come before the Security Considerations section.  It was also noted that the Information Model should have a Privacy Considerations Section.  Sections for Operational Considerations and Privacy Considerations will be added to the Information Model.
>  
> ·         The group discussed the Information Model Update at the virtual interim meeting.  The group agreed it would be best to briefly discuss what we have been doing, but, focus the majority of the time discussing open issue.  
>  
> Action Items
> ·         Continue to update the example of using triples and annotate the example so it can be shared with the list. (Henk Birkholz)
> ·         Research and share examples of how other information models represent their constructs which can be reviewed for that may be SACM Information Model. (Dave Waltermire and Henk Birkholz)
> ·         Send a message to the list making a last call for objections to the issue around resolving the differences between revisions 01 and 02 of the IM to determine what text, if any, is missing. (Danny Haynes)
> ·         Add a GitHub issue regarding the accuracy of timestamp data and raise with the list.  (Danny Haynes)
> ·         Make the proposed changes to the Information Model and include a sentence or two to describe what information goes in each new section.  Update on GitHub. (Danny Haynes)
>  
> <Endpoint ID Design Team 9-18-2015.pptx>_______________________________________________
> sacm mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sacm <https://www.ietf.org/mailman/listinfo/sacm>