Subject: Re: [sacm] Short Term Path Forward

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 1 Sep 2015 11:51:03 +0000

Can somebody volunteer to prepare a ‘solution drafts’ review for the interim?

Thanks and Regards,

Dan

From: Waltermire, David A. [mailto:[email-masked]]
Sent: Saturday, August 22, 2015 9:39 PM
To: Haynes, Dan; Romascanu, Dan (Dan); [email-masked]
Subject: RE: [sacm] Short Term Path Forward

There are a number of older, expired SACM drafts that we considered during working group formation that can be resurrected as solution drafts. Here are a couple:

•         https://datatracker.ietf.org/doc/draft-montville-sacm-asset-identification/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dmontville-2Dsacm-2Dasset-2Didentification_&d=BQMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=uXyt-S2uPnbtCwoyaKMQbTTeBqeRfMv8LvhKCAqYFH8&s=tVfwQNTFHY7JdaR0K-u_ipGeoh7T4U7Bql0e7-zCTwk&e=> - This provides a data model for expressing identification information for a number of asset types that is implemented in a number of commercial products. It relates well to the Endpoint IDT work, but needs a good deal of updating based on recent advancements.

•         https://tools.ietf.org/html/draft-davidson-sacm-asr-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Ddavidson-2Dsacm-2Dasr-2D00&d=BQMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=uXyt-S2uPnbtCwoyaKMQbTTeBqeRfMv8LvhKCAqYFH8&s=TF3Gq1VYOlVV379k0BKat9wc0Z8PYt5koD4S6fpAdZ4&e=> - This is a generalized evaluation reporting data model for aggregate results.

Thanks,
Dave

From: sacm [mailto:[email-masked]] On Behalf Of Haynes, Dan
Sent: Thursday, August 20, 2015 4:07 PM
To: Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [sacm] Short Term Path Forward

Hi Dan,

I would also include the drafts associated with the TCG Endpoint Compliance Profile (ECP) on your list.  ECP provides guidance on how to apply NEA and TNC standards for monitoring and securely exchanging endpoint posture information.

•         draft-fitzgeraldmckay-sacm-endpointcompliance-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dfitzgeraldmckay-2Dsacm-2Dendpointcompliance_&d=BQMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=uXyt-S2uPnbtCwoyaKMQbTTeBqeRfMv8LvhKCAqYFH8&s=bWsSWLGHKt9Zp5wzKUgW33I95s-0uoICYpUCNPnaIT8&e=>

•         draft-haynes-sacm-ecp-mapping-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dhaynes-2Dsacm-2Decp-2Dmapping_&d=BQMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=uXyt-S2uPnbtCwoyaKMQbTTeBqeRfMv8LvhKCAqYFH8&s=6kl066rvr1ASgJX40XlsBizLDId-Nih7qFtGASSqmsI&e=>

Thanks,

Danny

From: sacm [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Thursday, August 20, 2015 2:12 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [sacm] Short Term Path Forward

Hi all,

When you refer to ‘shifting focus to solutions documents’ what are the ‘solutions documents’ that you have in mind?

The closes to ‘solutions documents’ seem to be:

-          draft-hansbury-sacm-oval-info-model-mapping-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dhansbury-2Dsacm-2Doval-2Dinfo-2Dmodel-2Dmapping_&d=BQMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=uXyt-S2uPnbtCwoyaKMQbTTeBqeRfMv8LvhKCAqYFH8&s=6GvXqDvy7NIHo7QCJITBawRlhdxsPeEMz7sf3UrKzMA&e=>

-          draft-salowey-sacm-xmpp-grid-02<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dsalowey-2Dsacm-2Dxmpp-2Dgrid_&d=BQMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=uXyt-S2uPnbtCwoyaKMQbTTeBqeRfMv8LvhKCAqYFH8&s=GgLF-7ISJYSDGvjzPafx9rxxlICU9zST1LkgHCoHZEY&e=>

Are there other? Are folks preparing other contributions?

Thanks and Regards,

Dan

From: sacm [mailto:[email-masked]] On Behalf Of Waltermire, David A.
Sent: Thursday, August 20, 2015 7:26 PM
To: Haynes, Dan; Jim Schaad; 'Jessica Fitzgerald-McKay'; 'Ira McDonald'
Cc: 'Adam W. Montville'; [email-masked]<mailto:[email-masked]>
Subject: Re: [sacm] Short Term Path Forward

+1. Danny has summed up very concisely the core of what I was suggesting in my original post.

My other concern is that we may burn out many of the active editors on our core documents. To avoid this, we need to sustain and increase the level of participation by drawing in more active participants. My hope is this will have the positive effect of increasing parallelization of activities, allowing us to make more progress on both core, transport, and data model drafts as time passes.

I very much want to see this effort succeed.

Sincerely,
Dave

From: Haynes, Dan [mailto:[email-masked]]
Sent: Wednesday, August 19, 2015 12:40 PM
To: Jim Schaad <[email-masked]<mailto:[email-masked]>>; 'Jessica Fitzgerald-McKay' <[email-masked]<mailto:[email-masked]>>; 'Ira McDonald' <[email-masked]<mailto:[email-masked]>>
Cc: 'Adam W. Montville' <[email-masked]<mailto:[email-masked]>>; Waltermire, David A. <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [sacm] Short Term Path Forward

I am in favor shifting focus to solutions documents and editing the core working group documents as necessary to generate greater participation.  I think this approach will also help us identify any gaps in our core documents.

I also agree we should try to do more work and reach consensus on the list.

Thanks,

Danny

From: sacm [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Monday, August 17, 2015 11:32 PM
To: 'Jessica Fitzgerald-McKay' <[email-masked]<mailto:[email-masked]>>; 'Ira McDonald' <[email-masked]<mailto:[email-masked]>>
Cc: 'Adam W. Montville' <[email-masked]<mailto:[email-masked]>>; 'Waltermire, David A.' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [sacm] Short Term Path Forward

I am not really a primary person, so I cannot really say what is or is not a good idea in the group.  However, I don’t know that there is enough of the architecture or IM drafts for me to be able to decide if a proposal is a real one or not.  What would it mean to have a DM draft that is used to implement the IM draft if the IM draft does not even exist to a 25% level of definition?  I am just guessing about what level the IM exists because I don’t understand what the bounds of the document are.

I don’t know if a protocol document addresses a problem in the Architecture without that draft first giving me an outline of the protocols that need to be in place in order to implement the solutions.  What protocols are needed, what do they need to do, who are they talking to?

The requirements draft is in a place where it can be parked, if that is the will of the group.  The terminology draft will never really be parked, but it should be a low maintenance draft in any event.  I would like to see more work done on the architecture and IM drafts to be done so that I can understand what the solutions are supposed to be doing before they would get parked.

I am not surprised at the lack of noise, first it is summer and that is a common time for people to be on vacation.  Second, this has never been a list which has generated a lot of messages as that does not seem to be the way that people communicated.  This may become a problem when documents go to the IESG as it makes it harder for the ADs to judge consensus as the consensus was not established on the list but in phone calls and f2f meetings.

Jim

From: sacm [mailto:[email-masked]] On Behalf Of Jessica Fitzgerald-McKay
Sent: Monday, August 17, 2015 9:13 AM
To: Ira McDonald
Cc: Waltermire, David A.; <[email-masked]<mailto:[email-masked]>>; Adam W. Montville
Subject: Re: [sacm] Short Term Path Forward

Thanks to Dave, Ira and the chairs for sharing their thoughts. Like Ira, I think parking some of the high-level documents to focus on solutions proposals makes a lot of sense. It gives us the opportunity to leverage the work done so far on the SACM architecture, information model, requirements and terminology, while still allowing us to edit these documents as needed. As Dave pointed out, focusing on solutions will likely help us generate more interest in this work, which will take some of the pressure off the editors who have worked so hard to get us to this point.
I am concerned about the lack of traffic on these proposals, though. I would have thought the group would be full of opinions on the best path forward. Do others out there have thoughts on where we should focus our efforts?
Thanks,
Jess

On Thu, Aug 13, 2015 at 2:35 PM, Ira McDonald <[email-masked]<mailto:[email-masked]>> wrote:
Hi Dave,

+1
I especially like "parking" several documents (rather than premature WG last call)
and getting on with a focus on solutions documents in the near term.
Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic<https://urldefense.proofpoint.com/v2/url?u=http-3A__sites.google.com_site_blueroofmusic&d=BQMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=AtTjH6xUybuK_5BZKaCvQNEvpMAjXipyzGvkpMBfXZA&s=O88wGMywKk4j9PWfCwv5mVKgqtNjaDlPzWHve_jU3qg&e=>
http://sites.google.com/site/highnorthinc<https://urldefense.proofpoint.com/v2/url?u=http-3A__sites.google.com_site_highnorthinc&d=BQMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=AtTjH6xUybuK_5BZKaCvQNEvpMAjXipyzGvkpMBfXZA&s=FBYPi5p8252nGgfMoMccLF4018mdS3Xv3hSe0MgIG7s&e=>
mailto: [email-masked]<mailto:[email-masked]>
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Aug 13, 2015 at 12:42 PM, Waltermire, David A. <[email-masked]<mailto:[email-masked]>> wrote:
I have been thinking about how we can increase the output of the working group. We have a number of members that are working very hard to advance the requirements, architecture, and information model drafts. This is not a criticism of that hard work; work that I am very grateful for. At the same time we have not been making much progress on solution drafts, which we need to do. It might be good to put a larger emphasis on working on solutions drafts, which will mean a lesser emphasis on the informational drafts we have been focused on.

To accomplish this we may want to do the following:

1)      We should consider breaking the scope of our work up into a number of iterations, starting small and increasing over time. We should identify a smaller area of work that has a high degree of interest. We should work on this area until we get to a WGLC stage, and then we should start the next iteration without starting the IESG process.

2)      We need to bring in additional active participants in the working group to advance more work. To do this we need to start working on solutions that resonate with vendors and customers to peak their interest.

3)      We have made a bunch of progress on terminology. We should wrap this work up and use it going forward.

4)      We should wrap up the current iterations of the requirements, architecture, and information model in a few weeks and table these documents for some time without starting the IESG process. This will free resources to develop, review, and advance solution drafts. We can revisit these documents when we make progress on solutions.

5)      We should refocus the active SACM participants on creating and submitting solution drafts. I know I haven’t had much time to work on solutions due to my available time being spent on the information model work. This should help to elicit interest from new participants to join and participate in the working group. This should have the effect of increasing the amount of work we can do in parallel in the mid-term.

How does this sound? Do you think this would set us on a better course?

Thanks,
Dave

From: sacm [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Adam W. Montville
Sent: Wednesday, August 12, 2015 3:30 PM
To: <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>>
Subject: [sacm] Short Term Path Forward

Hi.

Dan and I would like to take this opportunity to remind the working group of our near-term goals:

  *   2nd WGLC for Requirements draft - there are still a few outstanding issues and we have not yet heard from the authors that this draft is ready for WGLC
  *   WGLC for Architecture draft - there are still many outstanding issues for this draft.  It’s probably not ready for WGLC, but we should work to get there as soon as possible.
  *   We also expect contributions in the solution/protocol space and/or review of such contributions already in place

     *   It is perfectly acceptable for such contributions to cover portions of our use cases

Please let us know if you have any questions or concerns.

Kind regards,

The Chairs

_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=BQMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=AtTjH6xUybuK_5BZKaCvQNEvpMAjXipyzGvkpMBfXZA&s=JcHW2MgXDbMRTtRCO7YUh9lVlhA-0D5DjfTabTSQrHc&e=>

_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=BQMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=AtTjH6xUybuK_5BZKaCvQNEvpMAjXipyzGvkpMBfXZA&s=JcHW2MgXDbMRTtRCO7YUh9lVlhA-0D5DjfTabTSQrHc&e=>

---

From: "Haynes, Dan" <[email-masked]>
Date: Fri, 25 Sep 2015 14:19:03 +0000

I just wanted to revive this thread since we didn’t get to discuss it in great detail during the virtual interim meeting yesterday.

Right now, from the feedback on the list, it seems the WG is leaning towards shifting focus to solutions drafts.  However, there is some concern that without complete enough WG documents, the WG will not be able to properly evaluate solution proposals.

It would be great if we can reach consensus on this as soon as possible (next week would be great) so that we can go into IETF 94 with a clear path forward.  Given this would represent a shift in focus by the WG, is this something WG chairs would need to do?

Thanks,

Danny

From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Tuesday, September 01, 2015 7:51 AM
To: Waltermire, David A. <[email-masked]>; Haynes, Dan <[email-masked]>; [email-masked]
Subject: RE: [sacm] Short Term Path Forward

Thanks and Regards,

Dan

From: Waltermire, David A. [mailto:[email-masked]]
Sent: Saturday, August 22, 2015 9:39 PM
To: Haynes, Dan; Romascanu, Dan (Dan); [email-masked]<mailto:[email-masked]>
Subject: RE: [sacm] Short Term Path Forward

Thanks,
Dave

Hi Dan,

Thanks,

Danny

Hi all,

Thanks and Regards,

Dan

Sincerely,
Dave

Thanks,

Danny

Jim

+1

Thanks,
Dave

Hi.

Kind regards,

The Chairs