Subject: Re: [sacm] Proposed Updates to the Structure of the Information Model Draft

From: "Haynes, Dan" <[email-masked]>
Date: Wed, 16 Sep 2015 12:29:14 +0000

Given that I haven’t heard any objections to the proposed changes, I am going to make them and issue a pull request to GitHub.

Please let me know if you have any questions or concerns.

Thanks,

Danny

From: Ira McDonald [mailto:[email-masked]]
Sent: Wednesday, August 26, 2015 2:46 PM
To: Haynes, Dan <[email-masked]>; Ira McDonald <[email-masked]>
Cc: [email-masked]
Subject: Re: [sacm] Proposed Updates to the Structure of the Information Model Draft

Hi Danny,

+1
Please make all of the proposed changes to the structure of the SACM Info Model.

Afterward, we can go on splitting hairs but have a much better document organization
that reflects our current understanding of the problem space.
Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]<mailto:[email-masked]>
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Aug 26, 2015 at 2:16 PM, Haynes, Dan <[email-masked]<mailto:[email-masked]>> wrote:
I just wanted to follow-up on this thread.

So far, there has been some discussion around how to classify a network interface (hardware component vs. software component vs. software interface).  I think this is a good discussion and should definitely continue.

However, I haven’t heard any feedback on the proposed changes to the structure of the Information Model listed below.  Without any feedback from the broader group, unless there are objections, I am inclined to make these changes to the structure of the Information Model because members of the Endpoint ID Design Team were in favor of them, they will give us a good framework from which to fill out the document moving forward, and so that the changes get captured in a document and don’t just get lost on the list.

I would like to have all of these changes to the Information Model addressed prior to the SACM Virtual Interim Meeting on September 24th so that we can discuss them then and if we decide to take the approach of shifting our focus to solution drafts, we will have a good stopping point.

Please let me know what you think.  All feedback is greatly appreciated.

Thanks,

Danny

From: sacm [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Haynes, Dan
Sent: Wednesday, August 19, 2015 12:42 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [sacm] Proposed Updates to the Structure of the Information Model Draft

During the past two Endpoint ID Design Team (EID-DT) meetings [1][2], we have discussed proposed changes to the structure of the Information Model draft.  The general consensus among the members, at the last two EID-DT meetings, was that the proposed changes to the structure of the Information Model were reasonable and should be accepted into the Information Model draft.  Given that, we wanted to propose these changes to the broader working group for feedback prior to making any updates to the draft.

Here is a summary of the proposed changes.

•         Combine the “Introduction” and “Problem Statement” sections.  Move the “Changes in Revision 01”, “Changes in Revision 02”, and “Mapping to SACM Use Cases” to an Appendix.

•         Add an “Information Model Framework” section.  This section describes the core concepts, constructs, and relationships that are used to model Assets and Elements in the Information Model.

•         Add an “Information Model Assets” section.  This section defines the different types of Assets used in the Information Model and the relationships between them.

•         Add an “Information Model Elements” section.  This section defines specific concrete constructs to be implemented by data models.  One example of this might be a network address as described in Lisa’s Terminology Meeting Notes [3].  This section will absorb the current “Elements of the SACM Information Model” section.

For more information about the proposed changes, please see the latest draft of the Information Model table of contents (updated-im-toc-814.docx) which I have attached for your convenience.  There are also some other open questions in the comments of the document such as whether or not a few sections can be deleted.  It would be great to get feedback on these as well if you have time, but, I would say getting feedback on the changes listed above is the most critical.  I can always just open issue trackers for the remaining questions and they can be addressed later.

If there is consensus that these changes make sense, I will update the Information Model draft in GitHub.  I will also add a sentence or two, for each section, to capture what information should go there.  This will be especially important if the working group decides to table the core working group documents (Requirements, Architecture, and Information Model) drafts in favor of working on solution drafts as is being discussed on the list [4].  By the way, if you haven’t chimed in on this thread please do :) as this decision will impact how the working group proceeds moving forward in the short term.

Anyways, please let me know what you think about these changes or if you have any questions.  I look forward to hearing your feedback.

Thanks,

Danny

[1] 8/7 EID-DT Meeting http://www.ietf.org/mail-archive/web/sacm/current/msg03147.html
[2] 8/14 EID-DT Meeting http://www.ietf.org/mail-archive/web/sacm/current/msg03177.html
[3] Terminology Notes http://www.ietf.org/mail-archive/web/sacm/current/msg03145.html
[4] Short Term Path Forward http://www.ietf.org/mail-archive/web/sacm/current/msg03163.html

_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm

---

From: "Haynes, Dan" <[email-masked]>
Date: Wed, 23 Sep 2015 20:23:36 +0000

Hi Everyone,

The structural changes to the Information Model are now up on GitHub (https://github.com/sacmwg/draft-ietf-sacm-information-model/blob/master/draft-ietf-sacm-information-model.xml).  Unfortunately, I committed directly to the master branch rather than my own repository :(.  Sorry about that.

The diff can be found here (https://github.com/sacmwg/draft-ietf-sacm-information-model/commit/4918789e86936cd53a1340830803ae74eb02d63e).

I have also attached a text version for your convenience.

Let me know if you have any questions.

Thanks,

Danny

From: sacm [mailto:[email-masked]] On Behalf Of Haynes, Dan
Sent: Wednesday, September 16, 2015 8:29 AM
To: Ira McDonald <[email-masked]>
Cc: [email-masked]
Subject: Re: [sacm] Proposed Updates to the Structure of the Information Model Draft

Thanks,

Danny

From: Ira McDonald [mailto:[email-masked]]
Sent: Wednesday, August 26, 2015 2:46 PM
To: Haynes, Dan <[email-masked]<mailto:[email-masked]>>; Ira McDonald <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [sacm] Proposed Updates to the Structure of the Information Model Draft

Hi Danny,

+1

Thanks,

Danny

Thanks,

Danny