Subject: [sacm] [draft-ietf-sacm-architecture] Clarify the potential use of existing transport protocols for collection as part of the SACM Architecture (#46)

From: david-waltermire-nist <[email-masked]>
Date: Tue, 03 Nov 2015 23:25:24 -0800

In Section 4 the text states that:

"Those interfaces are outside the scope of SACM."

This text is concerning for a number of reasons:
1) It is not clear which interfaces this text is referencing.
2) IMHO, adapting the referenced protocols to exchange SACM information and to integrate with control plane functions is within the scope of SACM.
3) The architecture draft should not be defining what the scope of SACM is. This should fall to the SACM charter.

To address this concern, I'd like to suggest the following changes:

Old:

   A variety of protocols, such as SNMP, NETCONF, NEA protocols
   [RFC5209], and other similar interfaces, may be used for collection
   of data from the target endpoints by the Posture Information
   Provider.  Those interfaces are outside the scope of SACM.

New:

   A variety of protocols, such as SNMP, NETCONF, NEA protocols
   [RFC5209], and other similar interfaces, may be used for collection
   of data from the target endpoints by the Posture Information
   Provider. If any such protocol is adopted by SACM, additional
   specification will be required to describe how the protocol will
   support the exchange of SACM assessment information. Furthermore, it
   will be necessary to define how such a protocol integrates with or
   provides specific control and/or data plane functions defined by
   this architecture.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-architecture/issues/46

---

From: Christopher Inacio <[email-masked]>
Date: Fri, 06 Nov 2015 13:36:44 -0800

Would there be a mandatory to implement protocol?

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-architecture/issues/46#issuecomment-154549085

---

From: adammontville <[email-masked]>
Date: Fri, 13 Nov 2015 14:13:28 -0800

@nacho319 Your question feels loaded...  Do you have an opinion?

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-architecture/issues/46#issuecomment-156573767

---

From: Chris Inacio <[email-masked]>
Date: Mon, 16 Nov 2015 01:11:16 +0000

I don’t think I really have a horse in the race on this, but I’ve heard various folks voice the strong opinion that there would have to be a mandatory to implement protocol for compatibility.

Maybe if I create a protocol then I can pick it.   :)

--
Chris Inacio
[email-masked]

> On Nov 13, 2015, at 5:13 PM, adammontville <[email-masked]> wrote:
> 
> —
> Reply to this email directly or view it on GitHub.
> 
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm

---

From: "Waltermire, David A." <[email-masked]>
Date: Mon, 16 Nov 2015 14:34:50 +0000

I believe we need MTIs to be defined for interoperability. What isn't clear to me at this time is if we can have one MTI to "rule them all" or if we need different MTIs to address different types of devices (e.g., network infrastructure, mobile, desktop, server, etc.). I believe this should be a topic for discussion as we work to complete the architecture.

Dave

-----Original Message-----
From: sacm [mailto:[email-masked]] On Behalf Of Chris Inacio
Sent: Sunday, November 15, 2015 8:11 PM
To: sacmwg/draft-ietf-sacm-architecture <reply+00a6c4d1c6c9b9061140[email-masked]>
Cc: sacm <[email-masked]>; sacmwg/draft-ietf-sacm-architecture <[email-masked]>
Subject: Re: [sacm] [draft-ietf-sacm-architecture] Clarify the potential use of existing transport protocols for collection as part of the SACM Architecture (#46)

--
Chris Inacio
[email-masked]