Subject: [sacm] [draft-ietf-sacm-information-model] designing a network interface (#34)

From: Danny Haynes <[email-masked]>
Date: Tue, 24 Nov 2015 07:18:48 -0800

When we design an network interface, we should make sure to review the relevant discussions on the list mailing list.

https://www.ietf.org/mail-archive/web/sacm/current/msg03199.html

http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/34

---

From: "Wolfkiel, Joseph L CIV DISA ID (US)" <[email-masked]>
Date: Tue, 24 Nov 2015 15:53:43 +0000

So maybe we need a separate construct called network "connection" to actually describe a relationship between an endpoint and a network?  If the consensus is that "interface" is a hardware term, then that's good.  We just also need a configuration term to describe how an endpoint is configured to use an interface to transmit data on a given network.  Following the trail also leads to discussing terms like "socket" and "session", some of which are already authoritatively defined.

Joseph L. Wolfkiel
SCM Engineering Lead
DISA ID52
Fort Meade DISA Acquisiton Bldg Cube A4A58E
Work: (301) 225-8820
Gov Cell: (571) 814-8231
[email-masked]

-----Original Message-----
From: sacm [mailto:[email-masked]] On Behalf Of Danny Haynes
Sent: Tuesday, November 24, 2015 10:19 AM
To: sacmwg/draft-ietf-sacm-information-model
Subject: [Non-DoD Source] [sacm] [draft-ietf-sacm-information-model] designing a network interface (#34)

All active links contained in this email were disabled. Please verify the identity of the sender, and confirm the authenticity of all links contained within the message prior to copying and pasting the address to a Web browser. 

________________________________

Caution-https://www.ietf.org/mail-archive/web/sacm/current/msg03199.html < Caution-https://www.ietf.org/mail-archive/web/sacm/current/msg03199.html > 

Caution-http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html < Caution-http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html > 

—
Reply to this email directly or view it on GitHub < Caution-https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/34 > . <Caution-https://github.com/notifications/beacon/AKbE0VL-uXRBm9YtcqseHrlPusAVwnZ4ks5pJHdYgaJpZM4Goc5a.gif>

---

From: Ira McDonald <[email-masked]>
Date: Tue, 24 Nov 2015 11:03:30 -0500

Hi Danny and Joseph,

To be network and transport agnostic, I suggest subsuming both
"connection" and "session" under the application security term
"association" (e.g., which can be applied to DTLS between two
systems).

The terms "connection" and "session" (especially) have been
blurred badly in recent years.  The idea of importance though
is the application data flow to/from an endpoint and some
server system.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Nov 24, 2015 at 10:53 AM, Wolfkiel, Joseph L CIV DISA ID (US) <
[email-masked]> wrote:

> So maybe we need a separate construct called network "connection" to
> actually describe a relationship between an endpoint and a network?  If the
> consensus is that "interface" is a hardware term, then that's good.  We
> just also need a configuration term to describe how an endpoint is
> configured to use an interface to transmit data on a given network.
> Following the trail also leads to discussing terms like "socket" and
> "session", some of which are already authoritatively defined.
>
> Joseph L. Wolfkiel
> SCM Engineering Lead
> DISA ID52
> All active links contained in this email were disabled. Please verify the
> identity of the sender, and confirm the authenticity of all links contained
> within the message prior to copying and pasting the address to a Web
> browser.
>
>
> When we design an network interface, we should make sure to review the
> relevant discussions on the list mailing list.
>
> Caution-https://www.ietf.org/mail-archive/web/sacm/current/msg03199.html
> < Caution-https://www.ietf.org/mail-archive/web/sacm/current/msg03199.html
> >
>
> Caution-http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html <
> Caution-http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html >
>
> —
> Reply to this email directly or view it on GitHub < Caution-
> https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/34 > .
> <Caution-
> https://github.com/notifications/beacon/AKbE0VL-uXRBm9YtcqseHrlPusAVwnZ4ks5pJHdYgaJpZM4Goc5a.gif
> >
>
>
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>
>

---

From: "Wolfkiel, Joseph L CIV DISA ID (US)" <[email-masked]>
Date: Tue, 24 Nov 2015 16:10:54 +0000

As long as it's defined somewhere.  If "association" is where we define the configuration settings, key exchanges, session parameters, etc. that allow an endpoint to identify itself to/on and communicate over a given network for a period of time, then that's also OK. 

Joseph L. Wolfkiel
SCM Engineering Lead
DISA ID52

-----Original Message-----
From: sacm [mailto:[email-masked]] On Behalf Of Ira McDonald
Sent: Tuesday, November 24, 2015 11:04 AM
To: Wolfkiel, Joseph L CIV DISA ID (US); Ira McDonald
Cc: [email-masked]; sacmwg/draft-ietf-sacm-information-model
Subject: Re: [sacm] [Non-DoD Source] [draft-ietf-sacm-information-model] designing a network interface (#34)

Hi Danny and Joseph,

systems).

server system.

Cheers,

- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
Caution-http://sites.google.com/site/blueroofmusic < Caution-http://sites.google.com/site/blueroofmusic > 
Caution-http://sites.google.com/site/highnorthinc < Caution-http://sites.google.com/site/highnorthinc > 
Caution-mailto: [email-masked] < Caution-mailto:[email-masked] > 
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Nov 24, 2015 at 10:53 AM, Wolfkiel, Joseph L CIV DISA ID (US) <[email-masked] < Caution-mailto:[email-masked] > > wrote:

	Joseph L. Wolfkiel
	SCM Engineering Lead
	DISA ID52
	Fort Meade DISA Acquisiton Bldg Cube A4A58E
	Work: (301) 225-8820 < tel:%28301%29%20225-8820 > 
	Gov Cell: (571) 814-8231 < tel:%28571%29%20814-8231 > 
	[email-masked] < Caution-mailto:[email-masked] > 

	-----Original Message-----
	From: sacm [Caution-mailto:[email-masked] < Caution-mailto:[email-masked] > ] On Behalf Of Danny Haynes
	Sent: Tuesday, November 24, 2015 10:19 AM
	To: sacmwg/draft-ietf-sacm-information-model
	Subject: [Non-DoD Source] [sacm] [draft-ietf-sacm-information-model] designing a network interface (#34)

	

	Caution-Caution-https://www.ietf.org/mail-archive/web/sacm/current/msg03199.html < Caution-https://www.ietf.org/mail-archive/web/sacm/current/msg03199.html >  < Caution-Caution-https://www.ietf.org/mail-archive/web/sacm/current/msg03199.html < Caution-https://www.ietf.org/mail-archive/web/sacm/current/msg03199.html >  >
	
	Caution-Caution-http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html < Caution-http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html >  < Caution-Caution-http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html < Caution-http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html >  >
	
	—
	Reply to this email directly or view it on GitHub < Caution-Caution-https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/34 < Caution-https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/34 >  > . <Caution-Caution-https://github.com/notifications/beacon/AKbE0VL-uXRBm9YtcqseHrlPusAVwnZ4ks5pJHdYgaJpZM4Goc5a.gif < Caution-https://github.com/notifications/beacon/AKbE0VL-uXRBm9YtcqseHrlPusAVwnZ4ks5pJHdYgaJpZM4Goc5a.gif > >

	_______________________________________________
	sacm mailing list
	[email-masked] < Caution-mailto:[email-masked] > 
	Caution-https://www.ietf.org/mailman/listinfo/sacm < Caution-https://www.ietf.org/mailman/listinfo/sacm >

---

From: Ira McDonald <[email-masked]>
Date: Tue, 24 Nov 2015 12:07:40 -0500

Hi Joseph,

Agreed - I suggest that we need to capture the "stack" of connectivity
(e.g., IPSec, TLS/DTLS or SSH or ..., and the application layer channel
binding) in the proposed "association" container.

And referenced but separate from an "association" we need a "network
interface" (vaguely layer 2, although with tunneling this blurs a lot).

Cheers,
- Ira

On Tue, Nov 24, 2015 at 11:10 AM, Wolfkiel, Joseph L CIV DISA ID (US) <
[email-masked]> wrote:

> As long as it's defined somewhere.  If "association" is where we define
> the configuration settings, key exchanges, session parameters, etc. that
> allow an endpoint to identify itself to/on and communicate over a given
> network for a period of time, then that's also OK.
>
> Joseph L. Wolfkiel
> SCM Engineering Lead
> DISA ID52
> Caution-http://sites.google.com/site/blueroofmusic < Caution-
> http://sites.google.com/site/blueroofmusic >
> Caution-http://sites.google.com/site/highnorthinc < Caution-
> http://sites.google.com/site/highnorthinc >
> [email-masked] < Caution-mailto:
> [email-masked] > > wrote:
>
>
>         So maybe we need a separate construct called network "connection"
> to actually describe a relationship between an endpoint and a network?  If
> the consensus is that "interface" is a hardware term, then that's good.  We
>         From: sacm [Caution-mailto:[email-masked] < Caution-mailto:
> [email-masked] > ] On Behalf Of Danny Haynes
>         Subject: [Non-DoD Source] [sacm]
> [draft-ietf-sacm-information-model] designing a network interface (#34)
>
>         All active links contained in this email were disabled. Please
> verify the identity of the sender, and confirm the authenticity of all
> links contained within the message prior to copying and pasting the address
> to a Web browser.
>
>
>         When we design an network interface, we should make sure to review
> the relevant discussions on the list mailing list.
>
>         Caution-Caution-
> https://www.ietf.org/mail-archive/web/sacm/current/msg03199.html <
> >  < Caution-Caution-
> https://www.ietf.org/mail-archive/web/sacm/current/msg03199.html <
>         Caution-Caution-
> http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html < Caution-
> http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html >  <
> Caution-Caution-
> http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html < Caution-
> http://www.ietf.org/mail-archive/web/sacm/current/msg03531.html >  >
>
>         —
>         Reply to this email directly or view it on GitHub <
> Caution-Caution-
> https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/34 <
> Caution-
> https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/34 >
> > . <Caution-Caution-
> < Caution-
>         Caution-https://www.ietf.org/mailman/listinfo/sacm < Caution-
> https://www.ietf.org/mailman/listinfo/sacm >
>
>
>
>
>