Subject: [sacm] Consensus Call: Parking Architecture Draft

From: "Adam W. Montville" <[email-masked]>
Date: Sun, 15 Nov 2015 09:55:51 -0600

Hi All:

At some point in the past we’ve talked about the possibility of “parking” certain foundational drafts while we look at solutions.  Doing so would, presumably, afford us the ability to go back and change things in our foundation as we discover new knowledge during the course of working on solutions.

However, during our sessions in Yokohama it was clear that we weren’t necessarily aligned on taking such an approach.  In particular, it seemed as though parking our Architecture draft [1] was not desired by the participants in the room.  Part of our Way Forward [2] requires us to determine our approach on the list.

This message begins such a consensus call.  Please voice your opinion on the matter by December 5, 2014.  “Parking” the architecture draft could mean progressing it through WGLC (when it’s ready), but holding off on IESG submission until a later date (after we’ve done some solutions work).

Kind regards,

Adam

[1] http://datatracker.ietf.org/doc/draft-ietf-sacm-architecture/ <http://datatracker.ietf.org/doc/draft-ietf-sacm-architecture/>
[2] https://mailarchive.ietf.org/arch/msg/sacm/GJ63fhXqrjjm11YKTQf-d6mXB38 <https://mailarchive.ietf.org/arch/msg/sacm/GJ63fhXqrjjm11YKTQf-d6mXB38>

---

From: Leif Johansson <[email-masked]>
Date: Mon, 16 Nov 2015 11:06:12 +0100

On 2015-11-15 16:55, Adam W. Montville wrote:
> Hi All:
> 
> At some point in the past we’ve talked about the possibility of 
> “parking” certain foundational drafts while we look at solutions.
> Doing so would, presumably, afford us the ability to go back and
> change things in our foundation as we discover new knowledge during
> the course of working on solutions.
> 
> However, during our sessions in Yokohama it was clear that we
> weren’t necessarily aligned on taking such an approach.  In
> particular, it seemed as though parking our Architecture draft [1]
> was not desired by the participants in the room.  Part of our Way
> Forward [2] requires us to determine our approach on the list.
> 
> This message begins such a consensus call.  Please voice your
> opinion on the matter by December 5, 2014.  “Parking” the
> architecture draft could mean progressing it through WGLC (when
> it’s ready), but holding off on IESG submission until a later date
> (after we’ve done some solutions work).

Personally I don't understand how you can look for solutions when
you don't know what you are looking for.

In general I'm not a big fan of the "requirements document"-style in
the IETF but this WG seems comparatively unclear on what it wants
and so I think the architecture draft provides important guidance
for the WG.

For instance the question of security model I raised in Yokohama
would have significant impact on both architecture and solutions.
	
	Cheers Leif

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 16 Nov 2015 12:19:18 +0000

Hi Leif,

One clarification to your position statement  - this call for consensus is targeting the architecture draft. We plan to proceed with the requirements draft (no parking for this one). 

I hope this helps (rather than confuses).

Regards,

Dan

> -----Original Message-----
> From: sacm [mailto:[email-masked]] On Behalf Of Leif Johansson
> Sent: Monday, November 16, 2015 12:06 PM
> To: [email-masked]
> Subject: Re: [sacm] Consensus Call: Parking Architecture Draft
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> > At some point in the past we've talked about the possibility of
> > "parking" certain foundational drafts while we look at solutions.
> > However, during our sessions in Yokohama it was clear that we weren't
> > necessarily aligned on taking such an approach.  In particular, it
> > seemed as though parking our Architecture draft [1] was not desired by
> > the participants in the room.  Part of our Way Forward [2] requires us
> > to determine our approach on the list.
> >
> > This message begins such a consensus call.  Please voice your opinion
> > on the matter by December 5, 2014.  "Parking" the architecture draft
> > could mean progressing it through WGLC (when it's ready), but holding
> > off on IESG submission until a later date (after we've done some
> > solutions work).
> 
> Personally I don't understand how you can look for solutions when you don't
> know what you are looking for.
> 
> In general I'm not a big fan of the "requirements document"-style in the IETF
> but this WG seems comparatively unclear on what it wants and so I think the
> architecture draft provides important guidance for the WG.
> 
> For instance the question of security model I raised in Yokohama would have
> significant impact on both architecture and solutions.

---

From: Leif Johansson <[email-masked]>
Date: Mon, 16 Nov 2015 13:20:48 +0100

> I hope this helps (rather than confuses).

Yeah I got that and my comments are (imo) applicable to the architecture
draft too.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 16 Nov 2015 12:22:10 +0000

Fine. 

Thanks and Regards,

Dan

> From: Leif Johansson [mailto:[email-masked]]
> Sent: Monday, November 16, 2015 2:21 PM
> To: Romascanu, Dan (Dan); [email-masked]
> > One clarification to your position statement  - this call for consensus is
> targeting the architecture draft. We plan to proceed with the requirements
> draft (no parking for this one).
> >
> >>> weren't necessarily aligned on taking such an approach.  In
> >>> opinion on the matter by December 5, 2014.  "Parking" the
> >>> architecture draft could mean progressing it through WGLC (when it's
> >>> ready), but holding off on IESG submission until a later date (after
> >>> we've done some solutions work).
> >>
> >> Personally I don't understand how you can look for solutions when you
> >> don't know what you are looking for.
> >>
> >> the IETF but this WG seems comparatively unclear on what it wants and
> >> so I think the architecture draft provides important guidance for the WG.
> >>