Subject: [sacm] [sacmwg/vulnerability-scenario] StrongTNC Push SWID + SWIMA (#40)

From: adammontville <[email-masked]>
Date: Tue, 07 Nov 2017 13:34:50 +0000 (UTC)

Andreas: strongTNC is now pushing complete SWID tags and SWIMA events in real-time to the sacm/swidtags and sacm/events topics, respectively. The current encoding of the push items is XML.

Experience gained:
- It might be better to annouce new SWID tags by pushing either the tagID or the unique softwareID, only. Subscribers can then download the [potentially huge] SWID tag directly from the strongTNC publisher via the REST interface.
- Should the REST URI be included in the push message for ease of use?
- If yes, might a JSON encoding of the push messages be preferable?
- Currently there is no persistence of the published messages. A subscriber can read them once and after that just the last message of each topic (node) which is cached. Should the Openfire XMPP server persist all messages?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/vulnerability-scenario/issues/40

---

From: adammontville <[email-masked]>
Date: Tue, 07 Nov 2017 14:32:30 +0000 (UTC)

Closed #40.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/vulnerability-scenario/issues/40#event-1329800802