Subject: FW: I-D ACTION:draft-zuccherato-9798-3-sasl-01.txt

From: Robert Zuccherato <[email-masked]>
Date: Wed, 12 Jul 2000 11:01:18 -0400

Hi,

I just thought I would let the list know that Magnus and I have resubmitted
our draft describing a public-key based SASL mechanism.  We have addressed
some of the specific comments that people had and attempted to provide a
little bit more motivation.

As was discussed on this list earlier, the main motivation of this draft is
to provide authentication in environments where, for various architectural
reasons, the endpoint of the TLS session is not the same as the application
endpoint.  However, it was mentioned to us recently that our draft also
supports the situation where a user initially establishes a server-side
authenticated connection, browses around, and then requests a certain URL
which requires client authentication.  This mechanism allows this "upgrade"
in authentication without requiring a re-negotiation of the TLS session.

	Robert Zuccherato. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, July 11, 2000 6:31 AM
> Subject: I-D ACTION:draft-zuccherato-9798-3-sasl-01.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 
> 	Title		: ISO/IEC 9798-3 Authentication SASL Mechanism
> 	Author(s)	: R. Zuccherato, M. Nystrom
> 	Filename	: draft-zuccherato-9798-3-sasl-01.txt
> 	Pages		: 15
> 	Date		: 10-Jul-00
> 	
> This document defines a SASL [RFC2222] authentication mechanism based
> on ISO/IEC 9798-3 [ISO3] and FIPS PUB 196 [FIPS] entity
> authentication.  This mechanism only provides authentication using
> X.509 certificates [X509].  It has no effect on the protocol
> encodings and does not provide integrity or confidentiality services.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-zuccherato-9798-3-sasl-01.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-zuccherato-9798-3-sasl-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-zuccherato-9798-3-sasl-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Robert Zuccherato <[email-masked]>
Date: Wed, 12 Jul 2000 11:01:18 -0400

Hi,

	Robert Zuccherato. 

Send a message to:
	[email-masked].
In the body type: