Subject: Re: Subject: SASL/GSSAPI proposed change of base32 alphabet

From: "Douglas E. Engert" <[email-masked]>
Date: Fri, 22 Mar 2002 11:03:58 -0600

The Globus Project(tm) has the GSI which is a GSSAPI over SSL and we do have
it working with SASL and OpenLDAP. I don't think the renaming would be a problem, but am
cc'ing others in Globus who might know. 

"Booker C. Bense" wrote:
> 
> Date: Thu, 21 Mar 2002 09:42:48 -0800
> From: [email-masked] (John Myers)
> User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
> X-Accept-Language: en-us, en
> MIME-Version: 1.0
> To: [email-masked], ietf-sasl <[email-masked]>
> Content-Type: text/plain; charset=us-ascii; format=flowed
> Content-Transfer-Encoding: 7bit
> 
> I have been requested to replace the base32 specification in the
> (expired) SASL GSSAPI internet draft with a reference section 3 of
> draft-josefsson-base-encoding-03.txt.  This would mean a change in the
> encoding alphabet, breaking any implementations of the existing draft
> which use mechanisms other than Kerberos or SPNEGO.
> 
> I would like to know if there exist any deployed implementations that
> would be so broken.  If there are, I think we would instead want to keep
> the encoding currently in the SASL GSSAPI draft, calling it by a name
> other than "base32".
> 
> -++**==--++**==--++**==--++**==--++**==--++**==--++**==
> This message was posted through the Stanford campus mailing list
> server.  If you wish to unsubscribe from this mailing list, send the
> message body of "unsubscribe ietf-cat-wg" to [email-masked]

-- 

 Douglas E. Engert  <[email-masked]>
 Argonne National Laboratory
 9700 South Cass Avenue
 Argonne, Illinois  60439 
 (630) 252-5444

---

From: Tony Hansen <[email-masked]>
Date: Sat, 23 Mar 2002 18:18:44 -0500

Changing the definition of base32 at this point would not be backwards
compatible.

Simon already includes two versions of base32 (Canonical and Extended
Hex) in his document. I think it would be better if Josefsson were to
add a description of THIS version of base32, in addition to any others
it has. It could be called the "Visually Safe" base 32 alphabet, because
it does not use any digits that could be mistaken for visually close
letters.

If that were done, then the SASL GSSAPI doc could say it uses that
encoding.

	Tony Hansen
	[email-masked]

---

From: [email-masked] (John Myers)
Date: Sat, 23 Mar 2002 21:33:08 -0800

>Changing the definition of base32 at this point would not be backwards
With what implementation or implementations would it not be backwards 
compatible?

---

From: Tony Hansen <[email-masked]>
Date: Wed, 27 Mar 2002 23:22:06 -0500

"Douglas E. Engert" <[email-masked]> just posted a note, saying:

	The Globus Project(tm) has the GSI which is a GSSAPI over SSL 
	and we do have it working with SASL and OpenLDAP. I don't think
	the renaming would be a problem, but am cc'ing others in Globus
	who might know. 

I'd say that's sufficient to go the other route.

	Tony

---

From: [email-masked] (John Myers)
Date: Wed, 27 Mar 2002 22:09:30 -0800

>I'd say that's sufficient to go the other route.
A GSSAPI over SSL implementation would not use the encoding defined in 
the GSSAPI over SASL document.  They would instead use the EXTERNAL SASL 
mechanism.

---

From: Tony Hansen <[email-masked]>
Date: Thu, 28 Mar 2002 12:35:30 -0500

I stand corrected.

Are we certain that all sasl developers are actively watching this list?
It seems silly for someone to develop a sasl solution and NOT be
watching this list, but should we worry about that?

	Tony Hansen
	[email-masked]

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 28 Mar 2002 09:55:40 -0800

>Are we certain that all sasl developers are actively watching this list?

I am certain that not all SASL developers are actively
watching this list.  But, then, I don't think that's
necessary.  I believe we have sufficient participation
to further this work.

>watching this list, but should we worry about that?

No.  We shouldn't worry about silly people.

I note the process provides amble opportunity for comment.
For these I-Ds, that process will likely include a 4 week
IETF Last Call period.

Kurt

---

From: "Douglas E. Engert" <[email-masked]>
Date: Fri, 22 Mar 2002 11:03:58 -0600

--

---

From: Tony Hansen <[email-masked]>
Date: Sat, 23 Mar 2002 18:18:44 -0500

Tony Hansen
	[email-masked]

---

From: [email-masked] (John Myers)
Date: Sat, 23 Mar 2002 21:33:08 -0800

---

From: Tony Hansen <[email-masked]>
Date: Wed, 27 Mar 2002 23:22:06 -0500

Tony

---

From: [email-masked] (John Myers)
Date: Wed, 27 Mar 2002 22:09:30 -0800

---

From: Tony Hansen <[email-masked]>
Date: Thu, 28 Mar 2002 12:35:30 -0500

I stand corrected.

	Tony Hansen
	[email-masked]

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 28 Mar 2002 09:55:40 -0800

Kurt