Subject: Re: rfc2831bis: A2 when qop-value=token

From: Alexey Melnikov <[email-masked]>
Date: Sat, 01 Nov 2003 14:41:30 +0000

Hallvard B Furuseth wrote:

>Alexey Melnikov writes:
>  
>
>>Hallvard B Furuseth wrote:    
>>
>>>rfc2831bis 2.1.1 "Step One" says:
>>>
>>>       qop-options       = "qop" "=" <"> qop-list <">
>>>       qop-list          = 1#qop-value
>>>       qop-value         = "auth" | "auth-int" | "auth-conf" |
>>>                            token
>>>
>>>2.1.2.1 "Response-value" and 2.1.3 "Step Three" define A2 when qop is
>>>"auth", "auth-int" and "auth-conf", but not when it is <token>.
>>>      
>>>
>>Token is specifically for future extensions, if you see a qop value you 
>>don't recognize - you have to ignore it.
>>If you recognize nothing, you have to fail the authentication exchange.
>>
>>Do you want any clarifications on this to be added to the document.
>>    
>>
>
>Not sure.  I think it would be good to mention that 'token is for future
>extensions' somewhere.  And perhaps that these extensions must define
>A2, since rfc2831bis does not.
>
Ok, I've clarified this.

Alexey

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 01 Nov 2003 14:41:30 +0000

Ok, I've clarified this.

Alexey