Subject: [savi] (no subject)

From: lintao 00450 <[email-masked]>
Date: Sun, 19 Apr 2009 00:25:48 +0800

Hi, all

I'm puzzled by one ip address on multiple interface in the charter. I wish someone to clear it, thank you very much.

If one host have multiple interface with on ip address, and they connect to one switch, how should the switch forward the 

back packet to the host? Which port is the right back port?

+------------------------+
+     SWITCH             +
+                        +
+----+---+---+---+-------+
     |   |
+----+---+--------+
+     HOST        +
+                 +
+-----------------+

Anycast shouldn't be the source address of the parcket from the host, and I haven't seen the usage of anycast in this 

condition. If it's used in load balancing in server farm, there haven't savi requirement.

I think this isn't the important factor is savi. How does anyone think about it?

---

From: Fred Baker <[email-masked]>
Date: Sun, 19 Apr 2009 00:16:13 -0400

I general, different interfaces get different addresses, since an IP  
address (IPv4 or IPv6) is the address of an interface.

I can think of two scenarios in which a system might use the same IP  
address on two interfaces. One is, properly, a misconfiguration, but  
probably would in fact work for most purposes. In that, the two  
interfaces on on the same LAN and therefore use identical prefixes,  
and one could imagine them being configured with the same address.  
SLAAC should not result in a common address, though, due to DAD. The  
other is a case in which an address is assigned to a virtual interface  
such as a loopback interface, and routing is told that both of the  
interfaces are appropriate router-router paths to get to that "remote"  
address. In that case, the rules of multipath routing apply.

On Apr 18, 2009, at 12:25 PM, lintao 00450 wrote:

> Hi, all
>
> I'm puzzled by one ip address on multiple interface in the charter.  
> I wish someone to clear it, thank you very much.
>
> If one host have multiple interface with on ip address, and they  
> connect to one switch, how should the switch forward the
>
> Anycast shouldn't be the source address of the parcket from the  
> host, and I haven't seen the usage of anycast in this
>
> _______________________________________________
> savi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/savi

---

From: Lin Tao <[email-masked]>
Date: Wed, 22 Apr 2009 18:09:42 +0800

Thank you very much! I'm sorry so late. It's misconfiguration in the frist 
scenario,  so that is not permitted in savi, isn't that? 

In the second scenario, the device connect the host must have multipath
function. I think this is not in switch now, isn't that?

So I think the same IP address on twon interfaces needn't be considered
in savi. How do you think?

Thanks.

---

From: Fred Baker <[email-masked]>
Date: Wed, 22 Apr 2009 04:30:19 -0700

I would find using the same IP address on two interfaces highly  
unusual in the IP architecture. SO, we needn't address it.

---

From: "Greg Daley" <[email-masked]>
Date: Thu, 23 Apr 2009 08:59:10 +1000

Hi Fred, 

Do we have a way of handling the HSRP/VRRP/Clustering of addresses?

Greg

---

From: Lin Tao <[email-masked]>
Date: Thu, 23 Apr 2009 09:03:09 +0800

Thank you very much!

---

From: Lin Tao <[email-masked]>
Date: Thu, 23 Apr 2009 09:15:43 +0800

I think the HSRP/VRRP/Clustering addresses wouldn't used in savi
scenario. These addresses are public-known and serve
the users, so they must configured specially. For example, they will
be configured in special port on switch. Is this correct?

----- Original Message ----- 
From: "Greg Daley" <[email-masked]>
To: "Fred Baker" <[email-masked]>; "Lin Tao" <[email-masked]>
Cc: "SAVI Mailing List" <[email-masked]>
Sent: Thursday, April 23, 2009 6:59 AM
Subject: Same IP, two interfaces (maybe not at same time)

Hi Fred, 

Greg

---

From: Fred Baker <[email-masked]>
Date: Wed, 22 Apr 2009 18:46:54 -0700

> Do we have a way of handling the HSRP/VRRP/Clustering of addresses?

Cisco IP Source Guard marks the interfaces as "unprotected", because  
they are router interfaces and therefore send datagrams (from a layer  
2 perspective) that contain source addresses that are not theirs.  I  
would suggest the same approach in SAVI.

---

From: Dave Thaler <[email-masked]>
Date: Thu, 23 Apr 2009 08:00:29 -0700

>From RFC 4291:

> 2.  IPv6 Addressing
>
>   IPv6 addresses are 128-bit identifiers for interfaces and sets of
>   interfaces (where "interface" is as defined in Section 2 of [IPV6]).
>   There are three types of addresses:
>
>    Unicast:   An identifier for a single interface.  A packet sent to a
                                    ^^^^^^
>               unicast address is delivered to the interface identified
>               by that address.
>
>    Anycast:   An identifier for a set of interfaces (typically
                                  ^^^^^^^^             ^^^^^^^^^
>               belonging to different nodes).  A packet sent to an
>               anycast address is delivered to one of the interfaces
>               identified by that address (the "nearest" one, according
>               to the routing protocols' measure of distance).
>
>    Multicast: An identifier for a set of interfaces (typically
>               belonging to different nodes).  A packet sent to a
>               multicast address is delivered to all interfaces
>               identified by that address.

So in the IP architecture, the same IP address on two interface
is possibly (only) for an anycast address (for which you don't do DAD),
but not for a unicast address.

And of course if you're using a single virtual interface in the
second case, a unicast address is fine.

-Dave

---

From: Lin Tao <[email-masked]>
Date: Fri, 24 Apr 2009 09:02:41 +0800

Thank you very much!