Subject: [savi] some comments on savi-cps

From: ZhangDong <[email-masked]>
Date: Tue, 21 Apr 2009 16:33:56 +0800

Hi Jun,

It seems that some language problems appear in the document. IMHO, the document need to be revised better in language. I guess that it is useful for the readers to understand the cps solution clearly.  
I have seen some grammar and expression mistakes. I only list two examples below. 
>6. Definition of Anchor
>... 
>This document doesn't specify which entities can be used as anchor, 
>and how secure these anchors. 
This sentence is vague and it has grammar mistake. "How secure these anchors are" or "how to secure these anchors", which one is the right meaning?

>Whenever a DHCPv4 request is received from attaching host, and the 
>requested IP address does not exist in the binding table, the device 
>will generate an entry in the Binding State Table (BST), set the 
>state field to be DHCPv4_START. The lifetime of this entry is set to 
>be MAX_DHCP_RESPONSE_TIME.  
I think the word "be" here is surplus. "The lifetime of this entry is set to MAX_DHCP_RESPONSE_TIME. " Am i right?

>8.3.1. Process of ND Snooping 
>
>This process is designed for stateless auto-configuration assigned 
>IPv6 address and manually configured IPv6 address. 
I guess that ND snooping  also might be used for CGA generation. Because CGA generation uses DAD in the same way.

>1. Divide the address space of SAVI nodes and non-SAVI nodes; 
>2. Partition SAVI nodes and non-SAVI nodes to different VLANs. 
What are definitions of the savi nodes and the non-savi nodes? Do you mean that a savi-node already has the binding entry in the savi device?
I think that in the case of VLAN, the DAD may be disabled. I mean the duplicate address message cannot go through from one vlan to another. So it still has the possibility of address collision. Right? 

Thanks a lot.

Dong Zhang

---

From: "Jun Bi" <[email-masked]>
Date: Wed, 22 Apr 2009 02:48:22 +0800

Hi Dong,

Thank you, we will take a look your comments and revise.

thanks,
Jun
----- Original Message ----- 
From: "ZhangDong" <[email-masked]>
To: "Jun Bi" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, April 21, 2009 4:33 PM
Subject: some comments on savi-cps

> Hi Jun,
>
> It seems that some language problems appear in the document. IMHO, the 
> document need to be revised better in language. I guess that it is useful 
> for the readers to understand the cps solution clearly.
> This sentence is vague and it has grammar mistake. "How secure these 
> anchors are" or "how to secure these anchors", which one is the right 
> meaning?
>
> What are definitions of the savi nodes and the non-savi nodes? Do you mean 
> that a savi-node already has the binding entry in the savi device?
> I think that in the case of VLAN, the DAD may be disabled. I mean the 
> duplicate address message cannot go through from one vlan to another. So 
> it still has the possibility of address collision. Right?
>
>
> Thanks a lot.
>
> Dong Zhang
>
>