Subject: [savi] FW: Consensus call on "unregistered" source addresses

From: "Guang Yao" <[email-masked]>
Date: Thu, 23 Jul 2009 22:37:03 +0800

> >>>>
> >>>>
> >>> [Guang Yao]
> >>> See rfc3315 18.1.2
> >>> The host _MUST_ send CONFIRM when
> >>> 	o  The client reboots.
> >>>
> >>>    o  The client is physically connected to a wired connection.
> >>>
> >>>    o  The client returns from sleep mode.
> >>>
> >>>    o  The client using a wireless technology changes access points.
> >>>
> >>>
> >>>
> >> so the node is not mandated to send a confirm when the switch that it
is
> >> connected reboots as long as it remains the same
> >>
> >>
> >> regards, marcelo
> >>
> > [Guang Yao]
> > You must be kidding.
> > When the switch reboot, its ports are first turned down: then the client
is
> > disconnected;
> >
> 
> is the host _physically_ disconnected?
[Guang Yao] 
How can a host know it is _physically_ disconnected? Through watching
whether its cable is unplugged by EYE?
 Or through electrical signal?

> > then turned on: then the client will be connected to the port. This is
the
> > second case.

---

From: "Guang Yao" <[email-masked]>
Date: Thu, 23 Jul 2009 23:18:20 +0800

-----Original Message-----
From: Guang Yao [mailto:[email-masked]] 
Sent: Thursday, July 23, 2009 11:18 PM
To: 'marcelo bagnulo braun'; 'Jun Bi'
Cc: 'SAVI Mailing List'; 'Christian Vogt'; 'Guang Yao'
Subject: RE: [savi] Consensus call on "unregistered" source addresses

> so basically also for the dhcp case, the cps solution is incompatible
> with legacy switches i.e. savi and legacy devices cannot be connected
> int he same subnetwork

[Guang Yao] 
I wonder which sentence so tenebrous makes you think of that.

> we haven't yet clarified the disconnected versus physically disconnected
> issue
[Guang Yao] 
Please see my previous mail.
There is no eye on the host, it cannot see that its cable has been
_physically_ unplugged.
All it can do is through electoral signal.
If you emphasize _physically_ disconnected, then every computer must need a
camera or a force transducer
to make sure it is _physically_ disconnected.

> 
> Regards, marcelo
> 
> 
> 
> >      thanks,
> >      Jun
> >
> > Regards, marcelo
> >
> >
> >> I did see it during the test and I think you could also observe it if
> >> you snoop the packet.
> >>
> >> Thanks,
> >> Jun Bi
> >>
> >>>>>>
> >>>>> [Guang Yao]
> >>>>> See rfc3315 18.1.2
> >>>> so the node is not mandated to send a confirm when the switch that
> >>>> it is
> >>> [Guang Yao] You must be kidding.
> >>> When the switch reboot, its ports are first turned down: then the
> >>> client is
> >>> disconnected;
> >>>
> >>
> >>> then turned on: then the client will be connected to the port. This
> >>> is the
> >>> second case.
> >>>
> >>>>
> >>>>>> Regards, marcelo
> >>
> >>
> >>
> >
> > _______________________________________________
> > savi mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/savi
> >
> >
> >
> >
> 
> _______________________________________________
> savi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/savi

---

From: "Jun Bi" <[email-masked]>
Date: Sat, 1 Aug 2009 00:12:52 +0200

Forwad a message to the list.

thanks,
Jun
----- Original Message ----- 
From: Huan Huan 
To: [email-masked] 
Cc: [email-masked] ; savi ; [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] 
Sent: Wednesday, July 29, 2009 7:07 AM
Subject: Re:Re: [savi] Consensus call on "unregistered" source addresses

Hi Folk,

This is Huan from IPv6 Ready Logo techincal group. The IPv6 Forum (http://www.ipv6forum.com) IPv6 Ready Logo Program is a conformance and interoperability testing program intended to increase user confidence by demonstrating that IPv6 is available now and is ready to be use. For the detail information, you can check: http://www.ipv6ready.org/.

I saw the following information in the mailing list and had done some test on DHCPv6 implementors, so maybe I can answer this question.
>> Jun Bi wrote:
>> During our real test on CPS, host did send CONFIRM when it change to 
>> another port or switch reboot
>
> Did you test all implementations that exist?
We had several test cases about "Confirm". For example, in the interoperability test case 1.2 and 1.8(DHCPv6 Interoperability Test Suite v1.0.4). We assume a DHCPv6 client disconnect into the link0 and then connect into it(test case 1.2) or move into a new link1(test case 1.8). The topologys as following:

Test case1.2:
----------+------------------+
----------------link0
          |                   |
   DHCPv6_Client  DHCPv6_Server
Test case1.8:
----------+-------------+-----+----------------link0
          |               |      |
   DHCPv6_Client |   DHCPv6_Server1
                         |
                         Router
                          |
-------------------------+-----+-----------------link1
                              DHCPv6_Server2

We also had some other test cases on commference test, in order to exam the confirm packet format.
During our test, we found the "Vista" and some open source softwares (Wide or TRAC) are supporting the 
"confirm" message. Another open source dhcpv6 client "dibbler" didn't support it and I had modify some
source code to make it support "confirm" now.

Best Regards,

Huan