Subject: [scim] SCIM Provider deletion of multivalued sub-attributes via PATCH

From: "Schooler,Corey" <[email-masked]>
Date: Mon, 19 Sep 2016 21:49:31 +0000

Should service providers support the removal of multi-valued sub-attributes via the PATCH meta.attributes section?

example:
{
    "meta": {
        "attributes": [
            "addresses.region", "phoneNumbers.primary"
        ]
    }
}

CONFIDENTIALITY NOTICE This message and any included attachments are from Cerner Corporation and are intended only for the addressee. The information contained in this message is confidential and may constitute inside or non-public information under international, federal, or state securities laws. Unauthorized forwarding, printing, copying, distribution, or use of such information is strictly prohibited and may be unlawful. If you are not the addressee, please promptly delete this message and notify the sender of the delivery error by e-mail or you may call Cerner's corporate offices in Kansas City, Missouri, U.S.A at (+1) (816)221-1024.

---

From: Shelley <[email-masked]>
Date: Fri, 23 Sep 2016 14:48:37 -0500

Neither the PATCH documentation [1], attribute notation [2], nor filter
documentation [3] include any examples nor clarification regarding
multi-valued sub-attributes, so I'd be curious to know the specification's
intent with respect to this as well and/or the expectations from other
service providers / consumers.

I can't think of too many use cases for removing multi-valued
sub-attributes with the core schema via PATCH (update all emails so that
none are primary? remove the formatted addresses from all addresses?), and
can only think of a couple potential use cases for referencing
sub-attributes via filtering (e.g. return all users that live in a
particular country); however, it would be good to get some clarification on
whether these should still be supported, and if so, confirmation as to how
these attributes should be notated.

[1]
http://www.simplecloud.info/specs/draft-scim-api-01.html#edit-resource-with-patch
[2]
http://www.simplecloud.info/specs/draft-scim-api-01.html#attribute-notation
[3]
http://www.simplecloud.info/specs/draft-scim-api-01.html#rfc.section.3.2.2.1

On Mon, Sep 19, 2016 at 4:49 PM, Schooler,Corey <[email-masked]>
wrote:

> Should service providers support the removal of multi-valued
> sub-attributes via the PATCH meta.attributes section?
>
> example:
> {
>     "meta": {
>         "attributes": [
>             "addresses.region”, "phoneNumbers.primary"
>         ]
>     }
> }
>
> CONFIDENTIALITY NOTICE This message and any included attachments are from
> Cerner Corporation and are intended only for the addressee. The information
> contained in this message is confidential and may constitute inside or
> non-public information under international, federal, or state securities
> laws. Unauthorized forwarding, printing, copying, distribution, or use of
> such information is strictly prohibited and may be unlawful. If you are not
> the addressee, please promptly delete this message and notify the sender of
> the delivery error by e-mail or you may call Cerner's corporate offices in
> Kansas City, Missouri, U.S.A at (+1) (816)221-1024.
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>
>