Subject: [scim] Update on Okta’s SCIM promotional activities & invitation for collaboration

From: Kevin Gough <[email-masked]>
Date: Thu, 8 Sep 2016 19:17:38 +0000

Over the last 6 months, Okta’s significantly increased it’s investment in promoting the SCIM standard to ISVs looking to enable provisioning via an IdP for their apps.

We’ve consolidated our efforts into a SCIM provisioning developer program<http://developer.okta.com/standards/SCIM/scim_developer_program>, which includes a free hands-on implementation workshop<http://okta.litmos.com/self-signup/register/328927?type=1> run by our training team, an automated test suite that runs on Runscope, dedicated developer support, and Okta & beta customer validation testing.

So far, we’ve had 50 ISVs join the program. At our Oktane user conference last week, we announced<https://www.okta.com/blog/2016/08/oan-expands-behind-the-firewall-below-the-app-adds-networking-and-iaas-integrations/> that Envoy<https://www.okta.com/blog/2016/06/how-provisioning-improves-envoys-customer-and-visitor-experience/>, PingBoard, VividCortex, and Lucid Software<https://www.okta.com/blog/2016/06/provisioning-is-a-win-win-for-lucid-software/> had graduated from the program with successful SCIM implementations. As part of Oktane, we also briefed analysts, including Gartner, Forrester, and Ovum, on our support for SCIM and progress to date.

While we’re generating some initial momentum, it seems we need to press harder to ensure this standard sticks and adoption grows.

Gregg Kreizman from Gartner seemed almost surprised to hear that we had 50 ISVs in our program. And one of our recent program applicants stated that the http://www.simplecloud.info/ site seemed bare bones, and wondered if the standard was really still alive.

My questions:
1) How are others currently promoting the standard?

2) Who in this consortium is interested in investing in a more collaborative promotion of the standard, be it joint workshops, articles on devsites, more documentation / code samples, case studies, etc.?

Feel free to reply to all or reach out to me directly with ideas or to signal interest.
Thanks.

- Kevin

Director, Product Marketing

Okta

---

From: Phil Hunt <[email-masked]>
Date: Thu, 8 Sep 2016 13:09:48 -0700

SCIM and simplecloud.info is very much alive.  On my side, Oracle just announced IDCS which is SCIM based in its entirety.

Agree the SimpleCloud.info site could use some updating.  Do we have a contact email for simplecloud?  Might be a better place update info to a single contact rather than on this list which should be about new extension discussions and/or errata regarding RFC7643/7644.

One of the issues with IETF is they don’t do much in the way of promotion or certification. There has been some discussion about possibly getting a certification program started at OIDF (though it hasn’t gone far yet) where we recently posted a draft for enabling SCIM as a CRUD capable UserInfo endpoint for Connect.

Might I also suggest a meeting up at the next IIW?  We can discuss next steps and futures there.

Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Sep 8, 2016, at 12:17 PM, Kevin Gough <[email-masked]> wrote:
> 
> We’ve consolidated our efforts into a SCIM provisioning developer program <http://developer.okta.com/standards/SCIM/scim_developer_program>, which includes a free hands-onimplementation workshop <http://okta.litmos.com/self-signup/register/328927?type=1> run by our training team, an automated test suite that runs on Runscope, dedicated developer support, and Okta & beta customer validation testing. 
> 
> So far, we’ve had 50 ISVs join the program. At our Oktane user conference last week, we announced <https://www.okta.com/blog/2016/08/oan-expands-behind-the-firewall-below-the-app-adds-networking-and-iaas-integrations/> that Envoy <https://www.okta.com/blog/2016/06/how-provisioning-improves-envoys-customer-and-visitor-experience/>, PingBoard, VividCortex, and Lucid Software <https://www.okta.com/blog/2016/06/provisioning-is-a-win-win-for-lucid-software/> had graduated from the program with successful SCIM implementations. As part of Oktane, we also briefed analysts, including Gartner, Forrester, and Ovum, on our support for SCIM and progress to date. 
> 
> Gregg Kreizman from Gartner seemed almost surprised to hear that we had 50 ISVs in our program. And one of our recent program applicants stated that the http://www.simplecloud.info/ <http://www.simplecloud.info/> site seemed bare bones, and wondered if the standard was really still alive.
> 
> 
> My questions:  
> _______________________________________________
> scim mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/scim <https://www.ietf.org/mailman/listinfo/scim>

---

From: Samuel Erdtman <[email-masked]>
Date: Mon, 12 Sep 2016 08:12:27 +0200

Hi Phil & Kevin,

I agree the simplecloud.info site could be improved.

I have recently moved the site to its own github project (
https://github.com/erdtman/simplecloud.info) and connected it to
automatically deploy on heroku when pushing new versions.

So if you are interested in updating and improving the site I would be
happy to accept pull requests or add you as collaborators.

//Samuel

On Thu, Sep 8, 2016 at 10:09 PM, Phil Hunt <[email-masked]> wrote:

> SCIM and simplecloud.info is very much alive.  On my side, Oracle just
> announced IDCS which is SCIM based in its entirety.
>
> Agree the SimpleCloud.info <http://simplecloud.info> site could use some
> updating.  Do we have a contact email for simplecloud?  Might be a better
> place update info to a single contact rather than on this list which should
> be about new extension discussions and/or errata regarding RFC7643/7644.
>
> One of the issues with IETF is they don’t do much in the way of promotion
> or certification. There has been some discussion about possibly getting a
> certification program started at OIDF (though it hasn’t gone far yet) where
> we recently posted a draft for enabling SCIM as a CRUD capable UserInfo
> endpoint for Connect.
>
> www.independentid.com
> [email-masked]
> Over the last 6 months, Okta’s significantly increased it’s investment in
> promoting the SCIM standard to ISVs looking to enable provisioning via an
> IdP for their apps.
>
> We’ve consolidated our efforts into a SCIM provisioning developer program
> <http://developer.okta.com/standards/SCIM/scim_developer_program>, which
> includes a free hands-onimplementation workshop
> <http://okta.litmos.com/self-signup/register/328927?type=1> run by our
> training team, an automated test suite that runs on Runscope, dedicated
> developer support, and Okta & beta customer validation testing.
>
> So far, we’ve had 50 ISVs join the program. At our Oktane user conference
> last week, we announced
> <https://www.okta.com/blog/2016/08/oan-expands-behind-the-firewall-below-the-app-adds-networking-and-iaas-integrations/>
>  that Envoy
> <https://www.okta.com/blog/2016/06/how-provisioning-improves-envoys-customer-and-visitor-experience/>,
> PingBoard, VividCortex, and Lucid Software
> <https://www.okta.com/blog/2016/06/provisioning-is-a-win-win-for-lucid-software/>
>  had graduated from the program with successful SCIM implementations. As
> part of Oktane, we also briefed analysts, including Gartner, Forrester, and
> Ovum, on our support for SCIM and progress to date.
>
> While we’re generating some initial momentum, it seems we need to press
> harder to ensure this standard sticks and adoption grows.
>
> Gregg Kreizman from Gartner seemed almost surprised to hear that we had 50
> ISVs in our program. And one of our recent program applicants stated that
> the http://www.simplecloud.info/ site seemed bare bones, and wondered if
> the standard was really still alive.
>
>
> My questions:
> 2) Who in this consortium is interested in investing in a more
> collaborative promotion of the standard, be it joint workshops, articles on
> devsites, more documentation / code samples, case studies, etc.?
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>
>
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>
>