Subject: Re: [scim] SCIM Compliance Test Tools?

From: "Karaimin, Aleyidin" <[email-masked]>
Date: Mon, 7 Dec 2020 16:30:56 +0000

Hello,
Maybe I noticed this thread too late. However, I would like to suggest tool that our team exposed to the open source. https://github.com/SAP/scimono/tree/master/scimono-compliance-tests
Basically, it is a java library helping implementors to build SCIM v2.0 API’s. In addition, it contains tool that can be run against any target system to verify whether it is SCIM v2.0 compliant. It is very helpful for our use cases. Furthermore, I will be glad to receive any additional feedback.
Best Regards
Aleydin
From: Phil Hunt <[email-masked]>
Date: Friday, 13 November 2020, 21:56
To: Danny Mayer <[email-masked]>
Cc: SCIM WG <[email-masked]>
Subject: Re: [scim] SCIM Compliance Test Tools?

Danny,

I am not aware of any compliance/testing tools yet. It has certainly been talked about.

SCIM is basically a RESTful API wth  JSON documents. I just use tools like Postman, PAW etc.

Also, check out simplecloud.info<http://simplecloud.info> for the list of implementations.

Best,

Phil Hunt
@independentid
[email-masked]<mailto:[email-masked]>

On Nov 13, 2020, at 10:55 AM, Danny Mayer <[email-masked]<mailto:[email-masked]>> wrote:

I've been trying to find tools that I can use to figure out my SCIM V2.0 implementation and I'm having trouble finding anything useful. The client provisioner is failing but it's not clear why. Are there any recommended tools that might help with this to pinpoint the failures?

Thanks,

Danny

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: Danny Mayer <[email-masked]>
Date: Tue, 8 Dec 2020 13:33:26 -0500

I have managed to find a number of testing tools. Here's a summary.

  SCIM Testing

Here are a number of tools that can be used for testing SCIM 2 compliance.

    1.WSO-incubator

https://github.com/wso2-incubator/scim2-compliance-test-suite 
<https://github.com/wso2-incubator/scim2-compliance-test-suite>

This is a java implementation that creates a war file which needs to be 
installed on a Tomcat or similar server.

Currently this tool complains about Bulk testing even though our 
implementation does not support it and attempts to remove the Bulk 
testing part have made no difference.

    2.Suvera

https://github.com/suvera/scim2-compliance-test-utility 
<https://github.com/suvera/scim2-compliance-test-utility>

This is a java implementation and creates a jar file that is run locally 
and you just specify the port to use. This has been useful in testing 
but requires you to look at the output logging from the command line to 
see exactly where the errors are.

    3.SAP

https://github.com/SAP/scimono/tree/master/scimono-compliance-tests 
<https://github.com/SAP/scimono/tree/master/scimono-compliance-tests>

This has not yet been looked at.

Thanks everyone for their input.

Danny

On 12/7/20 11:30 AM, Karaimin, Aleyidin wrote:
>
> Hello,
>
> Maybe I noticed this thread too late. However, I would like to suggest 
> tool that our team exposed to the open source. 
> https://github.com/SAP/scimono/tree/master/scimono-compliance-tests 
> <https://github.com/SAP/scimono/tree/master/scimono-compliance-tests>
>
> Basically, it is a java library helping implementors to build SCIM 
> v2.0 API’s. In addition, it contains tool that can be run against any 
> target system to verify whether it is SCIM v2.0 compliant. It is very 
> helpful for our use cases. Furthermore, I will be glad to receive any 
> additional feedback.
>
> Best Regards
>
> Aleydin
>
> *From: *Phil Hunt <[email-masked]>
> *Date: *Friday, 13 November 2020, 21:56
> *To: *Danny Mayer <[email-masked]>
> *Cc: *SCIM WG <[email-masked]>
> *Subject: *Re: [scim] SCIM Compliance Test Tools?
>
> Danny,
>
> Also, check out simplecloud.info <http://simplecloud.info> for the 
> list of implementations.
>
> Best,
>
> Phil Hunt
>
> @independentid
>
> [email-masked] <mailto:[email-masked]>
>
>
>
>     I've been trying to find tools that I can use to figure out my
>     SCIM V2.0 implementation and I'm having trouble finding anything
>     useful. The client provisioner is failing but it's not clear why.
>     Are there any recommended tools that might help with this to
>     pinpoint the failures?
>
>     Thanks,
>
>     Danny
>
>     [email-masked] <mailto:[email-masked]>