Subject: [scim] SCIM use cases

From: julien <[email-masked]>
Date: Mon, 28 Feb 2022 17:45:05 +0100

Hello all,

Most of SCIM use cases I could find are to synchronize users and groups 
between (SaaS) applications/services and a centralized Identity Provider.

Are you aware of a use case of SCIM, where a SCIM API is directly used 
by an admin or tool?

If so, are you aware of any SCIM server/demo/mock for testing purposes?

Thanks,
Julien

-- 
Julien Schneider
Tel: +49 721 170293 16
Fax: +49 721 170293 179

http://www.audriga.com | http://www.twitter.com/audriga

--------------------------------------------------------------------------
audriga GmbH | Durlacher Allee 47 | 76131 Karlsruhe
Sitz der Gesellschaft: Karlsruhe - Amtsgericht Mannheim - HRB 713034
Geschäftsführer: Dr. Frank Dengler, Dr.-Ing. Hans-Jörg Happel
--------------------------------------------------------------------------

---

From: "Matt Peterson (mpeterso)" <[email-masked]>
Date: Mon, 28 Feb 2022 20:50:19 +0000

Julien,

We use SCIM extensively to back-end user/group "pickers" and/or user/group "finders" in our admin UIs -- both webUIs.  These UIs almost always appear in the portions of our products where authorization is being granted to an application resource for user (or group of users).

I would argue that this is a very common use case when the IDP (that authenticated a federated user) also provides a SCIM interface for this purpose.

--
Matt

-----Original Message-----
From: scim <[email-masked]> On Behalf Of julien
Sent: Monday, February 28, 2022 9:45 AM
To: [email-masked]
Subject: [scim] SCIM use cases

CAUTION: This email originated from outside of the organization. Do not follow guidance, click links, or open attachments unless you recognize the sender and know the content is safe.

Hello all,

Most of SCIM use cases I could find are to synchronize users and groups between (SaaS) applications/services and a centralized Identity Provider.

Are you aware of a use case of SCIM, where a SCIM API is directly used by an admin or tool?

Thanks,
Julien

--
Julien Schneider
Tel: +49 721 170293 16
Fax: +49 721 170293 179

https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.audriga.com%2F&amp;data=04%7C01%7Cmatt.peterson%40oneidentity.com%7C274e05f93920470f785808d9fad9b7e7%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637816635281605638%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=ufObUTSCExQY8ysqh0Lb2uoxOLbIdQpyVa5uiuyds2I%3D&amp;reserved=0 | https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.twitter.com%2Faudriga&amp;data=04%7C01%7Cmatt.peterson%40oneidentity.com%7C274e05f93920470f785808d9fad9b7e7%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637816635281605638%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=7uUemuOhETH5SyNxsqdFGd1d1tI8rtn0ODhcLDvqfdw%3D&amp;reserved=0

--------------------------------------------------------------------------
audriga GmbH | Durlacher Allee 47 | 76131 Karlsruhe Sitz der Gesellschaft: Karlsruhe - Amtsgericht Mannheim - HRB 713034
Geschäftsführer: Dr. Frank Dengler, Dr.-Ing. Hans-Jörg Happel
--------------------------------------------------------------------------

_______________________________________________
scim mailing list
[email-masked]
https://nam12.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fscim&amp;data=04%7C01%7Cmatt.peterson%40oneidentity.com%7C274e05f93920470f785808d9fad9b7e7%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637816635281605638%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=oVN7L8Hw9xdw8rYPyeydcFkg%2F03neufkK9VPqEvmG6s%3D&amp;reserved=0

---

From: Danny Mayer <[email-masked]>
Date: Mon, 28 Feb 2022 18:22:48 -0500

You should look at Phil Hunt's pages here: https://i2scim.io/ He has 
sample implementations you can look at.

Danny

On 2/28/22 11:45 AM, julien wrote:
> Hello all,
>
> Most of SCIM use cases I could find are to synchronize users and 
> groups between (SaaS) applications/services and a centralized Identity 
> Provider.
>