Subject: [Sdn] draft agenda for the Proposed Software Defined Networking Research Group (sdnrg)

From: David Meyer <[email-masked]>
Date: Mon, 16 Jul 2012 08:31:48 -0700

All,

Please find attached the draft agenda for our meeting in Vancouver. I
want to thank everyone who proposed talks; there just wasn't time to
accept them all and still leave time to discuss the charter of the RG.

Thanks again,

Dave

---

From: Edward Crabbe <[email-masked]>
Date: Mon, 16 Jul 2012 09:16:21 -0700

With one correction:  I'm going to be presenting on optimization algos for
inter-DC TE, not ephemeral state in datacenters.  ^_^

On Mon, Jul 16, 2012 at 8:31 AM, David Meyer <[email-masked]> wrote:

> _______________________________________________
> sdn mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/sdn
>
>

---

From: David Meyer <[email-masked]>
Date: Mon, 16 Jul 2012 09:19:44 -0700

Thnx, fixed...--dmm

---

From: Tina TSOU <[email-masked]>
Date: Mon, 16 Jul 2012 23:48:14 +0000

Dear chairs,
We specifically asked slot for 
http://datatracker.ietf.org/doc/draft-yin-sdn-sdni/
before. Both privately to Dave and publicly to the list.
The presenter is Diego Lopez.

Thank you,
Tina

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> David Meyer
> Sent: Monday, July 16, 2012 9:20 AM
> To: Edward Crabbe
> Cc: Nick Feamster; Thomas Nadeau; SDN IRTF list
> Subject: Re: [Sdn] draft agenda for the Proposed Software Defined
> Networking Research Group (sdnrg)
> 
> Thnx, fixed...--dmm
> 
>

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 16 Jul 2012 21:46:11 -0400

We did review the draft. It was deemed to be a "near-term" solution that did not fit in with the "longer term research in the area of SDN" (proposed) charter of the group. Remember that the IRTF is not a place to standardize near-term solutions such as protocol specifications.

	--Tom

---

From: marcelo bagnulo braun <[email-masked]>
Date: Tue, 17 Jul 2012 07:29:26 +0200

Hi

Thanks for the agenda.

One question: I see only one of the presetnations has a document we can 
read to prepare the meeting. Are the other documents associated or 
related to the other issues that will be disucssed that we can read?

Regards, marcelo

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 17 Jul 2012 10:19:00 +0000

Hi Thomas,

>       We did review the draft. It was deemed to be a "near-term" solution that did not fit in with the "longer term research in the area of SDN" (proposed) charter of the group. Remember that the I…

As I tried to express some time ago when discussing on whether the draft was
"long-termed" enough, I do think that exploring the aspects of domain
interoperation (architectures, protocols, formalization...) is an interesting issue
for research.

If we agree on this point, I think this concrete draft could be seen as a first step
in exploring that direction.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at.
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: David Meyer <[email-masked]>
Date: Tue, 17 Jul 2012 06:23:25 -0700

On Mon, Jul 16, 2012 at 10:29 PM, marcelo bagnulo braun
<[email-masked]> wrote:
> Hi
>
> Thanks for the agenda.
>
> One question: I see only one of the presetnations has a document we can read
> to prepare the meeting. Are the other documents associated or related to the
> other issues that will be disucssed that we can read?

The only draft is the one I cited in the agenda. The rest are either
positions (like Bob's) or new work.

--dmm

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 17 Jul 2012 22:32:48 +0000

Diego, 

You stated that "exploring the aspects of domain interoperation (architectures, protocols, formalization...) is an interesting issue for research."

Today BGP is widely deployed protocol to interconnect massive number of domains. 
There is also multi-domain PCE work on going in IETF. 

Why do you still think "domain interoperation"  is "long term SDN research" work? 

Thanks, Linda Dunbar

> Diego R. Lopez
> Sent: Tuesday, July 17, 2012 5:19 AM
> To: Thomas Nadeau
> Cc: David Meyer; Nick Feamster; Crabbe Edward; SDN IRTF list; Tina TSOU
> >       We did review the draft. It was deemed to be a "near-term"
> solution that did not fit in with the "longer term research in the area
> of SDN" (proposed) charter of the group. Remember that the IRTF is not
> a place to standardize near-term solutions such as protocol
> specifications.
> 
> Este mensaje se dirige exclusivamente a su destinatario. Puede
> consultar nuestra política de envío y recepción de correo electrónico
> en el enlace situado más abajo.
> This message is intended exclusively for its addressee. We only send
> and receive email on the basis of the terms set out at.

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 18 Jul 2012 15:28:19 +0000

Hi Linda,

> Why do you still think "domain interoperation"  is "long term SDN research" work?

Because I asume that inter-domain communication for SDN goes beyond the routing
updates you can exchange with BGP.

The use of SDN should allow for a richer semantics in network description, allowing
different levels of abstraction and information hiding (in the spirit of what is
being done around ALTO), the support for much finer-grained security controls (closer
to JOSE and ABFAB than to SIDR, if you allow me to continue namimg related IETF WGs),
and the potential exchange of additional data suitable to influence the other domain
decisions, as could be the case of energy consumption figures, information related to
IT infrastructure in the case of cloud, reputation scores...

Furthermore, if one of the SDN promises is achieved and software engineering tools
can be applied to network design and operation (static checkers, compilers,
debuggers...) inter-domain exchanges should need a formal model similar to current
inter-process communication and/or multithread concurrent programming. And
northbound interfaces must be considered as well when incorporating this inter-domain
exchanges.

As I said, I don't think BGP is well suited to address all these issues. And even if
we consider BGP as a possible option for (some of) them, doing so would require a
certain  degree of research.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 18 Jul 2012 15:41:05 +0000

Diego, 

Thank you very much for elaborating all those inter-domain areas which are definitely worth of "long term" research. 

It will be very helpful for SDNrg to have a slot for people to show those desired "richer semantics of network" for research community to work on. 

Linda

> Sent: Wednesday, July 18, 2012 10:28 AM
> To: Linda Dunbar
> Cc: Thomas Nadeau; SDN IRTF list; Tina TSOU; Nick Feamster; David Meyer;
> Crabbe Edward
> > You stated that "exploring the aspects of domain interoperation
> (architectures, protocols, formalization...) is an interesting issue
> for research."
> >

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 18 Jul 2012 11:44:41 -0400

Please raise this during the charter discussion, which we've allocated quite a bit of time for.

	--Tom

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 18 Jul 2012 15:48:31 +0000

Tom, 

Thanks. I will. See you in Vancouver. 

Linda

> Thomas Nadeau
> Sent: Wednesday, July 18, 2012 10:45 AM
> To: Linda Dunbar
> Cc: SDN IRTF list; Tina TSOU; Nick Feamster; David Meyer; Crabbe Edward;
> Diego R. Lopez
> > Thank you very much for elaborating all those inter-domain areas
> which are definitely worth of "long term" research.
> >
> > It will be very helpful for SDNrg to have a slot for people to show
> those desired "richer semantics of network" for research community to
> work on.
> >
> >
> > Linda
> >
> >>> Today BGP is widely deployed protocol to interconnect massive
> number
> >> of domains.
> >> Because I asume that inter-domain communication for SDN goes beyond
> the
> >> routing
> >> different levels of abstraction and information hiding (in the
> spirit
> >> of what is
> >> and the potential exchange of additional data suitable to influence
> the
> >> other domain
> >> debuggers...) inter-domain exchanges should need a formal model
> similar
> >> to current
> >> inter-process communication and/or multithread concurrent
> programming.
> >> And
> >> As I said, I don't think BGP is well suited to address all these
> issues.
> >> And even if
> >> we consider BGP as a possible option for (some of) them, doing so
> would
> >> require a

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 18 Jul 2012 15:52:19 +0000

> Thanks. I will. See you in Vancouver.

So will I! :)

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091

---

From: "Keshav.A.K." <[email-masked]>
Date: Thu, 19 Jul 2012 13:00:14 +0530

Dear all,

I have some of the basic query w.r.t IP network about this architecture 

O Provide northbound APIs for applications so they can program
   underlying network properties such as bandwidth assignments,
   network isolation, routing properties, redundancy properties, or security
requirements.

"any thoughts how to apply for hop by hop IP based network, or any thoughts
of brining flow to IP network" ?

O Provide covered SDN domain network topology view to applications so that
applications can define data flow and     flow path within the view.

"This is L2 physical topology or L3 logical topology" ? 
"How this be Global-topology  built at central entity coming from multiple
NOS" ? 

Regards,
Keshava.A.K.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tina
TSOU
Sent: Tuesday, July 17, 2012 5:18 AM
To: David Meyer; Edward Crabbe
Cc: Nick Feamster; Thomas Nadeau; SDN IRTF list
Subject: Re: [Sdn] draft agenda for the Proposed Software Defined Networking
Research Group (sdnrg)

Dear chairs,

Thank you,
Tina

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 21 Jul 2012 06:58:34 +0200

Tom,

So you prefer to spend time on charter rather then discuss proposals ? 
Very interesting in the light of the below comment from Lars just few 
days ago:

"I'd think that it would be useful to plan and hold this meeting as if 
the research group were already chartered, i.e., focus on presenting and 
discussing research topics (rather than charter text, as we often do on 
the IETF side.) Charter text is much less important for us than in the 
IETF, because we have no short-term deliverables."

Best,
R.