Subject: [Sdn] SDN-Related Drafts

From: Margaret Wasserman <[email-masked]>
Date: Wed, 31 Oct 2012 09:02:11 -0400

I'd like to call your attention to a couple of Internet-Drafts on SDN security that we published in preparations for the IETF meeting in Atlanta.  The first discusses security requirements for an SDN solution, and the second provides an analysis of the security properties of the ONF OpenFlow protocol.  The two drafts can be found here:

http://tools.ietf.org/html/draft-hartman-sdnsec-requirements-00
http://tools.ietf.org/html/draft-mrw-sdnsec-openflow-analysis-00

While neither of these drafts concerns a research topic, per se, when we approached the Internet and Security ADs about discussing these drafts in Atlanta, they pointed us at the proposed SDN Research Group.  So, here we are!

Would it be possible for us to present these drafts at the SDNRG meeting in Atlanta?  We'd like to get feedback on the drafts and encourage other people to contribute to this work.

Thanks,
Margaret

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 31 Oct 2012 12:26:11 -0400

Hi Margaret,

On Oct 31, 2012, at 9:02, Margaret Wasserman <[email-masked]> wrote:

> I'd like to call your attention to a couple of Internet-Drafts on SDN security that we published in preparations for the IETF meeting in Atlanta.  

Being interested in SDN, I will read these, so thanks for the pointers. 

<snipped>

> Would it be possible for us to present these drafts at the SDNRG meeting in Atlanta?  We'd like to get feedback on the drafts and encourage other people to contribute to this work.

I'll leave that determination to the chairs. However, I would think it's a bit early for this. I realize the need to inject security from the start of a project (rather than back porting it); however, this "project" hasn't really started yet (afaik). 

What might be useful at this point is to insert a clause in the charter so that if the RG indeed gets chartered or formed (or whatever the procedure is), security is forefront. 

Just mho. 

Thanks,
Kireeti

> Thanks,
> Margaret
> 
> _______________________________________________
> sdn mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/sdn

---

From: David Meyer <[email-masked]>
Date: Wed, 31 Oct 2012 09:31:38 -0700

What might be useful at this point is to insert a clause in the charter so
> that if the RG indeed gets chartered or formed (or whatever the procedure
> is), security is forefront.
>

Very good point. Added to the draft charter.

--dmm

---

From: Rob Sherwood <[email-masked]>
Date: Wed, 31 Oct 2012 09:46:06 -0700

[I'm open to feedback around this is a topic if the list is interested
in discussing -- otherwise I can move this to personal email]

Hi Margaret,

I just took a quick look at your draft-mrw-sdnsec-openflow-analysis-00
draft and it seems like there are some valid concerns being raise --
thanks for that.  That said, I wonder why you aren't raising these
concerns in the ONF itself?  If I understand your co-authors
affiliation correctly, there are certainly members of their company
who can help you with this.

In any case, I've forwarded a link of your draft to the right people
in the ONF (specifically, the extensibility working group --
https://www.opennetworking.org/working-groups/extensibility) and
thanks for the work, but I'm hoping to maybe connect you with the
right folks so the protocol can be improved independent of folks like
me acting as go between.

Please let me know what you think and thanks,

- Rob
.

On Wed, Oct 31, 2012 at 6:02 AM, Margaret Wasserman
<[email-masked]> wrote:
>
> I'd like to call your attention to a couple of Internet-Drafts on SDN
> security that we published in preparations for the IETF meeting in Atlanta.
> The first discusses security requirements for an SDN solution, and the
> second provides an analysis of the security properties of the ONF OpenFlow
> protocol.  The two drafts can be found here:
>
> While neither of these drafts concerns a research topic, per se, when we
> approached the Internet and Security ADs about discussing these drafts in
> Atlanta, they pointed us at the proposed SDN Research Group.  So, here we
> are!
>
> Would it be possible for us to present these drafts at the SDNRG meeting in
> Atlanta?  We'd like to get feedback on the drafts and encourage other people
> to contribute to this work.
>
> Thanks,
> Margaret
>
>