Subject: [Sdn] Draft SDNRG 90 minutes posted

From: David Meyer <[email-masked]>
Date: Tue, 29 Jul 2014 17:28:18 -0700

Draft minutes here:
http://www.ietf.org/proceedings/90/minutes/minutes-90-sdnrg

Thanks to Damien for taking notes.

--dmm

---

From: AshwoodsmithPeter <[email-masked]>
Date: Wed, 30 Jul 2014 13:48:28 +0000

Dave a few minor corrections to the minutes. Not sure if they get fixed but just for the record ;)

Peter

o Alpha fair traffic engineering using SDN                                   15 minutes
  Peter Ashwood-Smith <[email-masked]>

[dave] why does that need to be convexe?

CORRECTION: I think you asked “are the goals actually convex?”

[author] I canâ€™t cover that here, trust me they are but I donâ€™t have time to explain

conclusion : can be computed very fast on NetFPGA to globally optimise the network

CORRECTION: Its “FPGA” not NetFPGA .. NetFPGA is a specific device which we did not use, need to change where its used below too.

[yakov] in many cases you cannot preempt flows
[author] I am aware of that problem
[luyan] why does has to be combined with segment routing?
[author] does not need, but I am biased against source routing :)

CORRECTION: “I believe I said I’m biased in favor of source routing because of the large number of paths required”

[luyan] how many labels can you handles between millions nodes?

CORRECTION” I believe she was asking about the label depth

[author] that implies a large amount of state
[author] that does not work with lose routing, I must be able to bind to a precise link
[luyan] then you will have a lot of segments and so many labels on the stack of packets

CORRECTION I thought I answered “source routing is not equal to label stacks”

[xiaoqing] how do you rate allocation accross the flows?

[author] it is not every single possible path between route and destination but the good ones. How do you place the flows on good paths

CORRECTION I believe I said “reasonable paths between source and destination that cover most of the ‘cut’ between source and destination” and I think this was part of the answer to luyan.

[xiaoqing] if you consider it as a SDN? why in hard?

CORRECTION “why in hardware” was I think the question

[author] you need a mechanism to deal with very high performance vector operations if you have general purpose hardware able to do vector stuff it can do the job, but I donâ€™t know such hardware. We looked at GPU but moved to fpga. We tried multi-processors but memory exchanges between cores were a problem

CORRECTION fixed some typos in the above.

[xiaoqing] how to enforce all the flow rates to all applications?
[author] the output of the decision is input of traffic policers.  Of course you have some mismatch between the optimal and the real but if you scale up the number of flows it is closer and closer to the optimal

CORRECTION fixed some typos in above.

From: sdn [mailto:[email-masked]] On Behalf Of David Meyer
Sent: Tuesday, July 29, 2014 8:28 PM
To: SDN IRTF list
Subject: [Sdn] Draft SDNRG 90 minutes posted

Draft minutes here: http://www.ietf.org/proceedings/90/minutes/minutes-90-sdnrg

--dmm

---

From: David Meyer <[email-masked]>
Date: Wed, 30 Jul 2014 07:15:36 -0700

Thanks. As I mentioned these are draft; Damien has other clean-ups as well.
Thanks for the comments.

--dmm

On Wed, Jul 30, 2014 at 6:48 AM, AshwoodsmithPeter <
[email-masked]> wrote:

> *CORRECTION:* I think you asked “are the goals actually convex?”
>
>
>
> *CORRECTION*: Its “FPGA” not NetFPGA .. NetFPGA is a specific device
> which we did not use, need to change where its used below too.
>
>
>
> *CORRECTION*: “I believe I said I’m biased *in favor* of source routing
> because of the large number of paths required”
>
>
>
> *CORRECTION*” I believe she was asking about the label depth
>
>
>
> *CORRECTION* I thought I answered “source routing is not equal to label
> stacks”
>
>
>
> [author] it is not every single possible path between route and
> destination but the good ones. How do you place the flows on good paths
>
>
>
> *CORRECTION* I believe I said “reasonable paths between source and
> destination that cover most of the ‘cut’ between source and destination”
> and I think this was part of the answer to luyan.
>
>
>
> *CORRECTION* “why in hardware” was I think the question
>
>
>
>
>
> [author] you need a mechanism to deal with very high performance vector
> operations if you have general purpose hardware able to do vector stuff it
> can do the job, but I donâ€™t know such hardware. We looked at GPU but
> moved to fpga. We tried multi-processors but memory exchanges between cores
> were a problem
>
>
>
> *CORRECTION* fixed some typos in the above.
>
>
>
> [author] the output of the decision is input of traffic policers.  Of
> course you have some mismatch between the optimal and the real but if you
> scale up the number of flows it is closer and closer to the optimal
>
>
>
> *From:* sdn [mailto:[email-masked]] *On Behalf Of *David Meyer
> *Sent:* Tuesday, July 29, 2014 8:28 PM
> *To:* SDN IRTF list
> *Subject:* [Sdn] Draft SDNRG 90 minutes posted
>
>
>
> Draft minutes here:

---

From: AshwoodsmithPeter <[email-masked]>
Date: Thu, 31 Jul 2014 17:06:53 +0000

Hey All,

Three quick points on the alpha fairness presentation that I gave at SDNRG last week:

1-      I got a lot of requests for the long paper. We sent out copies but if we missed anybody it is available at this link:

http://www.statslab.cam.ac.uk/~frank/PAPERS/hotsdn.html

2-      David asked about the convex nature of the problem and I hand waived about it ;) I spoke with Frank Kelley this morning and he emailed me the following more robust answer to David’s question, including some references:

The optimization problem is deliberately formulated to be convex (the maximization of a concave function over a convex region). In particular, we use the controlled splitting idea from T. Voice. Stability of multi-path dual congestion control algorithms. IEEE/ACM Transactions on Networking, 15(6):1231–1239, December 2007.

http://dl.acm.org/citation.cfm?id=1373478

The philosophy is that of J. He, J. Rexford, M. Chiang. Design for Optimizability: Traffic Management of a Future Internet http://link.springer.com/chapter/10.1007/978-1-84882-765-3_1

(or Don't optimize existing protocols, design optimizable protocols

http://dl.acm.org/citation.cfm?id=1273452 ).

3-  I believe I alluded to TCP actually doing a form of alpha-fairness as a distributed solution. A more precise answer is that TCP solves the problem where alpha=2 and the weights are 1/T_s where T_s is the round trip time for the connection. The reference is here: Reference:  e.g. Chapter 7.4 and 8.2 of http://www.statslab.cam.ac.uk/~frank/BOOKS/sn.html

As noted this will be presented at hotSDN and one of the authors will be there (Bill McCormik) and I’m sure he will be happy to answer detailed questions on any aspects of this work with the exception of the hardware implementation which we can only discuss at a high level.

Cheers,

Peter

From: David Meyer [mailto:[email-masked]]
Sent: Wednesday, July 30, 2014 10:16 AM
To: AshwoodsmithPeter
Cc: SDN IRTF list
Subject: Re: [Sdn] Draft SDNRG 90 minutes posted

Thanks. As I mentioned these are draft; Damien has other clean-ups as well. Thanks for the comments.

--dmm

On Wed, Jul 30, 2014 at 6:48 AM, AshwoodsmithPeter <[email-masked]<mailto:[email-masked]>> wrote:
Dave a few minor corrections to the minutes. Not sure if they get fixed but just for the record ;)

Peter

o Alpha fair traffic engineering using SDN                                   15 minutes
  Peter Ashwood-Smith <[email-masked]<mailto:[email-masked]>>

From: sdn [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of David Meyer
Sent: Tuesday, July 29, 2014 8:28 PM
To: SDN IRTF list
Subject: [Sdn] Draft SDNRG 90 minutes posted

--dmm

---

From: David Meyer <[email-masked]>
Date: Thu, 31 Jul 2014 12:00:41 -0700

Should have been done. --dmm

On Thu, Jul 31, 2014 at 11:44 AM, AshwoodsmithPeter <
[email-masked]> wrote:

>  Dave, looks like my comment is in moderation. I guess the links tripped
> it. Can you unblock it?
>
>
>
> Peter
>
>
>
> *From:* sdn [mailto:[email-masked]] *On Behalf Of *AshwoodsmithPeter
> *Sent:* Thursday, July 31, 2014 1:07 PM
> *To:* David Meyer; SDN IRTF list
>
> *Subject:* Re: [Sdn] Draft SDNRG 90 minutes posted
>
>
>
> Hey All,
>
>
>
> 1-      I got a lot of requests for the long paper. We sent out copies
> but if we missed anybody it is available at this link:
>
> 2-      David asked about the convex nature of the problem and I hand
> waived about it ;) I spoke with Frank Kelley this morning and he emailed me
> the following more robust answer to David’s question, including some
> references:
>
>
>
> *The optimization problem is deliberately formulated to be convex (the
> maximization of a concave function over a convex region). In particular, we
> use the controlled splitting idea from T. Voice. Stability of multi-path
> dual congestion control algorithms. IEEE/ACM Transactions on Networking,
> 15(6):1231–1239, December 2007.*
>
> *http://dl.acm.org/citation.cfm?id=1373478
> <http://dl.acm.org/citation.cfm?id=1373478>*
>
>
>
> *The philosophy is that of J. He, J. Rexford, M. Chiang. Design for
> Optimizability: Traffic Management of a Future Internet
> http://link.springer.com/chapter/10.1007/978-1-84882-765-3_1
> <http://link.springer.com/chapter/10.1007/978-1-84882-765-3_1>*
>
> *(or Don't optimize existing protocols, design optimizable protocols*
>
> *http://dl.acm.org/citation.cfm?id=1273452
> <http://dl.acm.org/citation.cfm?id=1273452> ).*
>
>
>
> 3-  I believe I alluded to TCP actually doing a form of alpha-fairness as
> a distributed solution*. A more precise answer is that TCP solves the
> problem where alpha=2 and the weights are 1/T_s where T_s is the round trip
> time for the connection. The reference is here: *Reference:  e.g. Chapter
> 7.4 and 8.2 of http://www.statslab.cam.ac.uk/~frank/BOOKS/sn.html
>
>
>
> As noted this will be presented at hotSDN and one of the authors will be
> there (Bill McCormik) and I’m sure he will be happy to answer detailed
> questions on any aspects of this work with the exception of the hardware
> implementation which we can only discuss at a high level.
>
>
>
> Cheers,
>
>
>
> Peter
>
>
>
>
>
> *From:* David Meyer [mailto:[email-masked] <[email-masked]>]
> *Sent:* Wednesday, July 30, 2014 10:16 AM
> *To:* AshwoodsmithPeter
> *Cc:* SDN IRTF list
> *Subject:* Re: [Sdn] Draft SDNRG 90 minutes posted
>
>
>

---

From: AshwoodsmithPeter <[email-masked]>
Date: Thu, 31 Jul 2014 18:44:40 +0000

Dave, looks like my comment is in moderation. I guess the links tripped it. Can you unblock it?

Peter

From: sdn [mailto:[email-masked]] On Behalf Of AshwoodsmithPeter
Sent: Thursday, July 31, 2014 1:07 PM
To: David Meyer; SDN IRTF list
Subject: Re: [Sdn] Draft SDNRG 90 minutes posted

Hey All,

Cheers,

Peter

--dmm

Peter

--dmm