Subject: Re: [Sdn] SDN Reading list

From: Peter Edge <[email-masked]>
Date: Tue, 9 Aug 2016 22:30:43 +0000

Hello Cristian,

Thanks for your hard word on the SDN Reading list. I am a regular user.

I am currently completing a Master of Science Research (MSCR) and my topic is "Security in the SDN Infrastructure". I am interested in security of the controllers, data plane devices and communication channels between SDN infrastructure components. This field has not been given the attention it deserves in recent years.

I would be willing to maintain the security offering in the list and wonder if there should be a separation between the infrastructure security and the existing "Security Solutions via SDN" oriented section. I would welcome some feedback on this idea.

Once again, well done and I look forward to the collaboration expanding and improving via the efforts of the community

Best regards,

Peter Edge

Computer Networking

School of Computing

Ara Institute of Canterbury

New Zealand

________________________________
From: sdn <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Tuesday, 9 August 2016 01:27
To: [email-masked]
Subject: sdn Digest, Vol 51, Issue 8

Send sdn mailing list submissions to
[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>
or, via email, send a message with subject or body 'help' to
[email-masked]

You can reach the person managing the list at
[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of sdn digest..."

Today's Topics:

1. Re: sdn Digest, Vol 51, Issue 1 (Julius Schulz-Zander)
2. About planes or layering (RE: SDN reading list)
(LUIS MIGUEL CONTRERAS MURILLO)

----------------------------------------------------------------------

Message: 1
Date: Tue, 2 Aug 2016 00:44:31 +0200
From: Julius Schulz-Zander <[email-masked]>
To: [email-masked], [email-masked]
Subject: Re: [Sdn] sdn Digest, Vol 51, Issue 1
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=us-ascii

Hi Cristian,

What is your opinion on moving the reading list to github and maintain it there as a webpage? In that case everyone could send pull requests and several people could maintain the reading list. Since there is also this great SDN survey on github [1], maybe it's possible to also put the repo there as a separate repository. I think it's worth a try. Currently, I point my students to both, your reading list and the SDN survey paper for bootstrapping. Thanks for the great work!

-Julius

[1] https://github.com/SDN-Survey<https://github.com/SDN-Survey>

> Am 01.08.2016 um 21:00 schrieb [email-masked]:<http://[email-masked]:>
>
> Send sdn mailing list submissions to
> [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
> https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>
> or, via email, send a message with subject or body 'help' to
> [email-masked]
>
> You can reach the person managing the list at
> [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of sdn digest..."
>
>
> Today's Topics:
>
> 1. Re: SDN reading list (Broadbent, Matthew)
> 2. Re: SDN reading list (King, Daniel)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 1 Aug 2016 10:58:20 +0000
> From: "Broadbent, Matthew" <[email-masked]>
> To: Cristian Lumezanu <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Subject: Re: [Sdn] SDN reading list
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="utf-8"
>
> Hello Cristian,
>
> Thank you for your time and effort compiling this reading list. It is certainly comprehensive and covers a number of topics; ideal for newcomers to the area.
>
> I would like to suggest, and also take responsibility for, a new sub-area: ?Content Delivery?. This would fit under the ?SDN Applications? title, and include work on how SDN can be used to improve and facilitate the delivery of video (and other types of media) across the Internet.
>
> Thanks
>
> Matt
>
> ?????????
> Matthew Broadbent
> School of Computing & Communications
> Lancaster University, UK
>
> On 27/07/2016, 16:36, "sdn on behalf of Cristian Lumezanu" <[email-masked] on behalf of [email-masked]> wrote:
>
> Hi everybody,
>
> I have been maintaining an SDN reading list (https://sites.google.com/site/sdnreadinglist/<https://sites.google.com/site/sdnreadinglist/>) for the last four years. My original goal was to provide a centralized repository of SDN research to better help both newcomers and experienced researchers navigate this rather new research area. The number of hits that the website receives every day makes me think that this effort was not in vain. However, as the field of SDN has grown rapidly in the past few years, so has the number of projects, conferences, and papers that I must keep track of and update. This is slowly taking up more time than I can allocate to it and the freshness of the list suffers.
>
> Therefore, I would like to turn the SDN reading list into a collaborative project. For this, I am looking for volunteers who would like to take over the task of updating (and keeping up-to-date) small parts of the site. A ?part? could be a sub-area of SDN research, such as ?verification? or ?monitoring and measurement". If it?s your own research area, even better, you are probably following all related work anyway and would need little time to keep your part up-to-date.
>
> If you can help with this, please send me a personal email with what sub-areas you are comfortable updating and any other constraints that you may have. Even if you don?t have time for this but you have suggestions for how this reading list might better serve the community, please send them along.
>
> Cristian
>
> _______________________________________________
> sdn mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>
>
>
>
> ------------------------------
>
> Message: 2
> Date: Mon, 1 Aug 2016 11:02:23 +0000
> From: "King, Daniel" <[email-masked]>
> To: Cristian Lumezanu <[email-masked]>
> Cc: "Broadbent, Matthew" <[email-masked]>, "[email-masked]"
> <[email-masked]>
> Subject: Re: [Sdn] SDN reading list
> Message-ID:
> <[email-masked]>
> Content-Type: text/plain; charset="utf-8"
>
> The reading list looks great, we will add a link to the site from our SDN RG Wiki page.
>
> BR, Dan.
>
> -----Original Message-----
> From: sdn [mailto:[email-masked]] On Behalf Of Broadbent, Matthew
> Sent: 01 August 2016 11:58
> To: Cristian Lumezanu <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Sdn] SDN reading list
>
> Hello Cristian,
>
> Thank you for your time and effort compiling this reading list. It is certainly comprehensive and covers a number of topics; ideal for newcomers to the area.
>
> I would like to suggest, and also take responsibility for, a new sub-area: ?Content Delivery?. This would fit under the ?SDN Applications? title, and include work on how SDN can be used to improve and facilitate the delivery of video (and other types of media) across the Internet.
>
> Thanks
>
> Matt
>
> ?????????
> Matthew Broadbent
> School of Computing & Communications
> Lancaster University, UK
>
> On 27/07/2016, 16:36, "sdn on behalf of Cristian Lumezanu" <[email-masked] on behalf of [email-masked]> wrote:
>
> Hi everybody,
>
> I have been maintaining an SDN reading list (https://sites.google.com/site/sdnreadinglist/<https://sites.google.com/site/sdnreadinglist/>) for the last four years. My original goal was to provide a centralized repository of SDN research to better help both newcomers and experienced researchers navigate this rather new research area. The number of hits that the website receives every day makes me think that this effort was not in vain. However, as the field of SDN has grown rapidly in the past few years, so has the number of projects, conferences, and papers that I must keep track of and update. This is slowly taking up more time than I can allocate to it and the freshness of the list suffers.
>
> Therefore, I would like to turn the SDN reading list into a collaborative project. For this, I am looking for volunteers who would like to take over the task of updating (and keeping up-to-date) small parts of the site. A ?part? could be a sub-area of SDN research, such as ?verification? or ?monitoring and measurement". If it?s your own research area, even better, you are probably following all related work anyway and would need little time to keep your part up-to-date.
>
> If you can help with this, please send me a personal email with what sub-areas you are comfortable updating and any other constraints that you may have. Even if you don?t have time for this but you have suggestions for how this reading list might better serve the community, please send them along.
>
> Cristian
>
> _______________________________________________
> sdn mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>
>
>
> _______________________________________________
> sdn mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> sdn mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>
>
>
> ------------------------------
>
> End of sdn Digest, Vol 51, Issue 1
> **********************************

------------------------------

Message: 2
Date: Sun, 7 Aug 2016 12:50:31 +0000
From: LUIS MIGUEL CONTRERAS MURILLO
<[email-masked]>
To: Dave Hood <[email-masked]>, Juliano Wickboldt
<[email-masked]>, "King, Daniel" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "Broadbent, Matthew"
<[email-masked]>, Cristian Lumezanu <[email-masked]>
Subject: [Sdn] About planes or layering (RE: SDN reading list)
Message-ID:
<[email-masked]>

Content-Type: text/plain; charset="utf-8"

Hi Dave,

Sorry for jumping late on this, I?m currently on holidays, with sporadic access to the email.

I agree with you on the importance of recursion. However I do not see that as a motivation for discarding the approach of separating concerns in planes or layers. I think there are a number of motivations for that, being some of them (from my point of view):

? Simpler and easier integration with ?legacy? (or conventional) systems. In other words, brownfield scenarios, quite relevant for operators.

? Risk of lock-in (either vendor or open source lock-in) for closed, monolithic control architectures without clear separation of concerns and not well defined open and extensible interfaces, with difficult (if not impossible) interoperability and interchangeability of functional components

? Unclear responsibilities for operational matters, e.g. for OAM/FCAPS/inventory/control tasks. But this also applies to service provision/delivery/decommission, where typically different organizations are responsible of different tasks in an operator

? More complex service/network diagnosis and troubleshooting

My personal view is that planes or layers help to make the problem more tractable and simple. This applies not only to the traditional control/management/resource planes, but also to the separation of end-service provision and operation from connectivity (or transport between service end-points), with separated responsible teams within service providers.

To that respect both RFC7426 and draft-irtf-sdnrg-layered-sdn provide architectural basis, allowing recursions, for sure.

Best regards

Luis

De: sdn [mailto:[email-masked]] En nombre de Dave Hood
Enviado el: mi?rcoles, 3 de agosto de 2016 20:22
Para: Juliano Wickboldt <[email-masked]>; King, Daniel <[email-masked]>
CC: Broadbent, Matthew <[email-masked]>; [email-masked]; Cristian Lumezanu <[email-masked]>
Asunto: Re: [Sdn] SDN reading list

I thought the list was interesting inasmuch as it did not include anything about SDN architecture. It would surely be worth listing SDN architecture 1.1<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR-521_SDN_Architecture_issue_1.1.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR-521_SDN_Architecture_issue_1.1.pdf>> [note: the 1.1 overview link below really refers to issue 1.0; it is out of date and should probably be removed from the listing], the relationship between SDN and NFV<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/onf2015.310_Architectural_comparison.08-2.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/onf2015.310_Architectural_comparison.08-2.pdf>>, and the paper on SDN and 5G slicing<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/Applying_SDN_Architecture_to_5G_Slicing_TR-526.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/Applying_SDN_Architecture_to_5G_Slicing_TR-526.pdf>>.

Because of heavily interrelated recursion, the idea of planes becomes less and less useful. One man?s data plane is another man?s control plane is another man?s applications plane. Management and control form a continuum, not separable planes. Services and orchestration and other concepts that appear in planar models are likewise relative and recursive. The upshot is that we are moving away from the idea of planes as useful modeling concepts. FWIW.

Dave

From: sdn [mailto:[email-masked]] On Behalf Of Juliano Wickboldt
Sent: Wednesday, August 03, 2016 9:41 AM
To: King, Daniel <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Broadbent, Matthew <[email-masked]<mailto:[email-masked]>>; Cristian Lumezanu <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Sdn] SDN reading list

Hi Cristian,

Great job organizing this list!

I would suggest that you add a "Management Plane" section under SDN Building Blocks, since you have "Control Plane" and "Data Plane" there already. I can be responsible for maintaining this section if you like. In ONF's architecture document (https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR_SDN-ARCH-Overview-1.1-11112014.02.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR_SDN-ARCH-Overview-1.1-11112014.02.pdf>) the Management Plane is defined. There is also an RFC 7426 that considers the Management Plane in SDN's architecture, a bit differently though (https://tools.ietf.org/html/rfc7426<https://tools.ietf.org/html/rfc7426>).

For example, design considerations for the management plane of SDN have been presented in "Software-Defined Networking: Management Requirements and Challenges. IEEE Communications Magazine: Network and service management series, Volume 53, Issue 1, January (2015). http://dx.doi.org/10.1109/MCOM.2015.7010546<http://dx.doi.org/10.1109/MCOM.2015.7010546>". There are several other studies published mainly in the network management community, i.e., IEEE-NOMS (ieee-noms.org<http://ieee-noms.org><http://ieee-noms.org<http://ieee-noms.org>>), IEEE-IM (ieee-im.org<http://ieee-im.org><http://ieee-im.org<http://ieee-im.org>>), and CNSM (cnsm-conf.org<http://cnsm-conf.org><http://cnsm-conf.org<http://cnsm-conf.org>>), that can be included in this section.

Best regards

________________________________

[http://www.inf.ufrgs.br/~jwickboldt/wp-content/uploads/inf_email.jpg<http://www.inf.ufrgs.br/~jwickboldt/wp-content/uploads/inf_email.jpg>]

Juliano Araujo Wickboldt
Postdoctoral researcher
http://www.inf.ufrgs.br/~jwickboldt/<http://www.inf.ufrgs.br/~jwickboldt/><http://www.inf.ufrgs.br/%7Ejwickboldt/<http://www.inf.ufrgs.br/%7Ejwickboldt/>>

On Mon, Aug 1, 2016 at 8:02 AM, King, Daniel <[email-masked]<mailto:[email-masked]>> wrote:
The reading list looks great, we will add a link to the site from our SDN RG Wiki page.

BR, Dan.

-----Original Message-----
From: sdn [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Broadbent, Matthew
Sent: 01 August 2016 11:58
To: Cristian Lumezanu <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Sdn] SDN reading list

Hello Cristian,

Thank you for your time and effort compiling this reading list. It is certainly comprehensive and covers a number of topics; ideal for newcomers to the area.

I would like to suggest, and also take responsibility for, a new sub-area: ?Content Delivery?. This would fit under the ?SDN Applications? title, and include work on how SDN can be used to improve and facilitate the delivery of video (and other types of media) across the Internet.

Thanks

Matt

?????????
Matthew Broadbent
School of Computing & Communications
Lancaster University, UK

On 27/07/2016, 16:36, "sdn on behalf of Cristian Lumezanu" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi everybody,

I have been maintaining an SDN reading list (https://sites.google.com/site/sdnreadinglist/<https://sites.google.com/site/sdnreadinglist/>) for the last four years. My original goal was to provide a centralized repository of SDN research to better help both newcomers and experienced researchers navigate this rather new research area. The number of hits that the website receives every day makes me think that this effort was not in vain. However, as the field of SDN has grown rapidly in the past few years, so has the number of projects, conferences, and papers that I must keep track of and update. This is slowly taking up more time than I can allocate to it and the freshness of the list suffers.

Therefore, I would like to turn the SDN reading list into a collaborative project. For this, I am looking for volunteers who would like to take over the task of updating (and keeping up-to-date) small parts of the site. A ?part? could be a sub-area of SDN research, such as ?verification? or ?monitoring and measurement". If it?s your own research area, even better, you are probably following all related work anyway and would need little time to keep your part up-to-date.

If you can help with this, please send me a personal email with what sub-areas you are comfortable updating and any other constraints that you may have. Even if you don?t have time for this but you have suggestions for how this reading list might better serve the community, please send them along.

Cristian

_______________________________________________
sdn mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>

_______________________________________________
sdn mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>
_______________________________________________
sdn mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener informaci?n privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilizaci?n, divulgaci?n y/o copia sin autorizaci?n puede estar prohibida en virtud de la legislaci?n vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma v?a y proceda a su destrucci?n.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinat?rio, pode conter informa??o privilegiada ou confidencial e ? para uso exclusivo da pessoa ou entidade de destino. Se n?o ? vossa senhoria o destinat?rio indicado, fica notificado de que a leitura, utiliza??o, divulga??o e/ou c?pia sem autoriza??o pode estar proibida em virtude da legisla??o vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destrui??o
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailarchive.ietf.org/arch/browse/sdn/attachments/20160807/50eb1aef/attachment.html<https://mailarchive.ietf.org/arch/browse/sdn/attachments/20160807/50eb1aef/attachment.html>>

------------------------------

Subject: Digest Footer

_______________________________________________
sdn mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>

------------------------------

End of sdn Digest, Vol 51, Issue 8
**********************************

---

From: Peter Edge <[email-masked]>
Date: Fri, 12 Aug 2016 23:20:41 +0000

Hi Sandra,

My apologies for missing your offer to help out on the security section. I am willing to assist in any way I can. As we both agree, more work is required on the securing of SDN infrastructure and a separation of literature is best for that.

Your security survey paper is an excellent resource. I have also read the "Principles and Practices for Securing Software-Defined Networks" paper from the ONF.

I see this as a great opportunity for a relatively new researcher as myself to get involved and collaborate in the early stages of this exciting era in networking. Hopefully I can contribute something along the way.

Best Regards,

Peter

________________________________
From: sdn <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Thursday, 11 August 2016 07:00
To: [email-masked]
Subject: sdn Digest, Vol 51, Issue 10

Today's Topics:

1. Re: sdn Digest, Vol 51, Issue 9 (Sandra Scott-Hayward)

Message: 1
Date: Wed, 10 Aug 2016 06:29:01 +0000
From: Sandra Scott-Hayward <[email-masked]>
To: "[email-masked]" <[email-masked]>
Subject: Re: [Sdn] sdn Digest, Vol 51, Issue 9
Message-ID:
<[email-masked]>
Content-Type: text/plain; charset="us-ascii"

Hi Peter,

I understand Cristian is trying to compile all the many positive responses he has received :-)

I also proposed to help maintain the security section so very happy to support you on that.

As you highlight, there is a classic split - Security with SDN and security of SDN. We address this in the paper "A Survey of Security in Software Defined Networks" (http://pure.qub.ac.uk/portal/en/publications/a-survey-of-security-in-software-defined-networks(88f854cd-8b26-4b47-a8d1-4c7f28302a2a).html<http://pure.qub.ac.uk/portal/en/publications/a-survey-of-security-in-software-defined-networks(88f854cd-8b26-4b47-a8d1-4c7f28302a2a).html>) Two sub-sections to the Security section of the reading list would probably be appropriate.

Best of luck with your research!

Kind Regards,
Sandra Scott-Hayward
Queen's University Belfast

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 10 August 2016 06:53
To: [email-masked]
Subject: sdn Digest, Vol 51, Issue 9

When replying, please edit your Subject line so it is more specific than "Re: Contents of sdn digest..."

Today's Topics:

1. Re: SDN Reading list (Peter Edge)

Message: 1
Date: Tue, 9 Aug 2016 22:30:43 +0000
From: Peter Edge <[email-masked]>
To: "[email-masked]" <[email-masked]>
Subject: Re: [Sdn] SDN Reading list
Message-ID:
<[email-masked]>

Content-Type: text/plain; charset="windows-1252"

Hello Cristian,

Best regards,

Peter Edge

Computer Networking

School of Computing

New Zealand

To subscribe or unsubscribe via the World Wide Web, visit https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn><https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>>
or, via email, send a message with subject or body 'help' to [email-masked]

You can reach the person managing the list at [email-masked]

When replying, please edit your Subject line so it is more specific than "Re: Contents of sdn digest..."

Today's Topics:

1. Re: sdn Digest, Vol 51, Issue 1 (Julius Schulz-Zander) 2. About planes or layering (RE: SDN reading list) (LUIS MIGUEL CONTRERAS MURILLO)

Message: 1

Hi Cristian,

-Julius

[1] https://github.com/SDN-Survey<https://github.com/SDN-Survey><https://github.com/SDN-Survey<https://github.com/SDN-Survey>>

> Am 01.08.2016 um 21:00 schrieb
> [email-masked]:<http://[email-masked]:><http://[email-masked]:<http://[email-masked]:>>
>
> https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn><https://www.irtf.org/mailman<https://www.irtf.org/mailman>
> /listinfo/sdn> or, via email, send a message with subject or body
> 'help' to [email-masked]
>
> You can reach the person managing the list at [email-masked]
>
> 1. Re: SDN reading list (Broadbent, Matthew) 2. Re: SDN reading list
> (King, Daniel)
>
>
> I have been maintaining an SDN reading list (https://sites.google.com/site/sdnreadinglist/<https://sites.google.com/site/sdnreadinglist/><https://sites.google.com/site/sdnreadinglist/<https://sites.google.com/site/sdnreadinglist/>>) for the last four years. My original goal was to provide a centralized repository of SDN research to better help both newcomers and experienced researchers navigate this rather new research area. The number of hits that the website receives every day makes me think that this effort was not in vain. However, as the field of SDN has grown rapidly in the past few years, so has the number of projects, conferences, and papers that I must keep track of and update. This is slowly taking up more time than I can allocate to it and the freshness of the list suffers.
>
> https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn><https://www.irtf.org/mailman<https://www.irtf.org/mailman>
> /listinfo/sdn>
>
>
>
> I have been maintaining an SDN reading list (https://sites.google.com/site/sdnreadinglist/<https://sites.google.com/site/sdnreadinglist/><https://sites.google.com/site/sdnreadinglist/<https://sites.google.com/site/sdnreadinglist/>>) for the last four years. My original goal was to provide a centralized repository of SDN research to better help both newcomers and experienced researchers navigate this rather new research area. The number of hits that the website receives every day makes me think that this effort was not in vain. However, as the field of SDN has grown rapidly in the past few years, so has the number of projects, conferences, and papers that I must keep track of and update. This is slowly taking up more time than I can allocate to it and the freshness of the list suffers.
>
> https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn><https://www.irtf.org/mailman<https://www.irtf.org/mailman>
> /listinfo/sdn>
>
>
> https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn><https://www.irtf.org/mailman<https://www.irtf.org/mailman>
> /listinfo/sdn>
>
> https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn><https://www.irtf.org/mailman<https://www.irtf.org/mailman>
> /listinfo/sdn>
>
>

Message: 2
To: Dave Hood <[email-masked]>, Juliano Wickboldt <[email-masked]>, "King, Daniel" <[email-masked]>

Hi Dave,

Best regards

Luis

De: sdn [mailto:[email-masked]] En nombre de Dave Hood Enviado el: mi?rcoles, 3 de agosto de 2016 20:22
Para: Juliano Wickboldt <[email-masked]>; King, Daniel <[email-masked]>
CC: Broadbent, Matthew <[email-masked]>; [email-masked]; Cristian Lumezanu <[email-masked]>
Asunto: Re: [Sdn] SDN reading list

I thought the list was interesting inasmuch as it did not include anything about SDN architecture. It would surely be worth listing SDN architecture 1.1<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR-521_SDN_Architecture_issue_1.1.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR-521_SDN_Architecture_issue_1.1.pdf><https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR-521_SDN_Architecture_issue_1.1.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR-521_SDN_Architecture_issue_1.1.pdf>>> [note: the 1.1 overview link below really refers to issue 1.0; it is out of date and should probably be removed from the listing], the relationship between SDN and NFV<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/onf2015.310_Architectural_comparison.08-2.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/onf2015.310_Architectural_comparison.08-2.pdf><https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/onf2015.310_Architectural_comparison.08-2.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/onf2015.310_Architectural_comparison.08-2.pdf>>>, and the paper on SDN and 5G slicing<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/Applying_SDN_Architecture_to<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/Applying_SDN_Architecture_to>
_5G_Slicing_TR-526.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/Applying_SDN_Architecture_to_5G_Slicing_TR-526.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/Applying_SDN_Architecture_to_5G_Slicing_TR-526.pdf>>>.

Dave

Hi Cristian,

I would suggest that you add a "Management Plane" section under SDN Building Blocks, since you have "Control Plane" and "Data Plane" there already. I can be responsible for maintaining this section if you like. In ONF's architecture document (https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR_SDN-ARCH-Overview-1.1-11112014.02.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR_SDN-ARCH-Overview-1.1-11112014.02.pdf><https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR_SDN-ARCH-Overview-1.1-11112014.02.pdf<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR_SDN-ARCH-Overview-1.1-11112014.02.pdf>>) the Management Plane is defined. There is also an RFC 7426 that considers the Management Plane in SDN's architecture, a bit differently though (https://tools.ietf.org/html/rfc7426<https://tools.ietf.org/html/rfc7426><https://tools.ietf.org/html/rfc7426<https://tools.ietf.org/html/rfc7426>>).

For example, design considerations for the management plane of SDN have been presented in "Software-Defined Networking: Management Requirements and Challenges. IEEE Communications Magazine: Network and service management series, Volume 53, Issue 1, January (2015). http://dx.doi.org/10.1109/MCOM.2015.7010546<http://dx.doi.org/10.1109/MCOM.2015.7010546><http://dx.doi.org/10.1109/MCOM.2015.7010546<http://dx.doi.org/10.1109/MCOM.2015.7010546>>". There are several other studies published mainly in the network management community, i.e., IEEE-NOMS (ieee-noms.org<http://ieee-noms.org><http://ieee-noms.org<http://ieee-noms.org>><http://ieee-noms.org<http://ieee-noms.org><http://ieee-noms.org<http://ieee-noms.org>>>), IEEE-IM (ieee-im.org<http://ieee-im.org><http://ieee-im.org<http://ieee-im.org>><http://ieee-im.org<http://ieee-im.org><http://ieee-im.org<http://ieee-im.org>>>), and CNSM (cnsm-conf.org<http://cnsm-conf.org><http://cnsm-conf.org<http://cnsm-conf.org>><http://cnsm-conf.org<http://cnsm-conf.org><http://cnsm-conf.org<http://cnsm-conf.org>>>), that can be included in this section.

Best regards

[http://www.inf.ufrgs.br/~jwickboldt/wp-content/uploads/inf_email.jpg<http://www.inf.ufrgs.br/~jwickboldt/wp-content/uploads/inf_email.jpg><http://www.inf.ufrgs.br/~jwickboldt/wp-content/uploads/inf_email.jpg<http://www.inf.ufrgs.br/~jwickboldt/wp-content/uploads/inf_email.jpg>>]

Juliano Araujo Wickboldt
Postdoctoral researcher
http://www.inf.ufrgs.br/~jwickboldt/<http://www.inf.ufrgs.br/~jwickboldt/><http://www.inf.ufrgs.br/~jwickboldt/<http://www.inf.ufrgs.br/~jwickboldt/>><http://www.inf.ufrgs.br/%7Ejwickboldt/<http://www.inf.ufrgs.br/%7Ejwickboldt/><http://www.inf.ufrgs.br/%7Ejwickboldt/<http://www.inf.ufrgs.br/%7Ejwickboldt/>>>

BR, Dan.

-----Original Message-----
From: sdn [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Broadbent, Matthew
Sent: 01 August 2016 11:58
To: Cristian Lumezanu <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Sdn] SDN reading list

Hello Cristian,

Thanks

Matt

?????????
Matthew Broadbent

Hi everybody,

I have been maintaining an SDN reading list (https://sites.google.com/site/sdnreadinglist/<https://sites.google.com/site/sdnreadinglist/><https://sites.google.com/site/sdnreadinglist/<https://sites.google.com/site/sdnreadinglist/>>) for the last four years. My original goal was to provide a centralized repository of SDN research to better help both newcomers and experienced researchers navigate this rather new research area. The number of hits that the website receives every day makes me think that this effort was not in vain. However, as the field of SDN has grown rapidly in the past few years, so has the number of projects, conferences, and papers that I must keep track of and update. This is slowly taking up more time than I can allocate to it and the freshness of the list suffers.

Cristian

_______________________________________________
sdn mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn><https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>>

_______________________________________________
sdn mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn><https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>>
_______________________________________________
sdn mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn><https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailarchive.ietf.org/arch/browse/sdn/attachments/20160807/50eb1aef/attachment.html<https://mailarchive.ietf.org/arch/browse/sdn/attachments/20160807/50eb1aef/attachment.html><https://mailarchive.ietf.org/arch/browse/sdn/attachments/20160807/50eb1aef/attachment.html<https://mailarchive.ietf.org/arch/browse/sdn/attachments/20160807/50eb1aef/attachment.html>>>

Subject: Digest Footer

_______________________________________________
sdn mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn><https://www.irtf.org/mailman/listinfo/sdn<https://www.irtf.org/mailman/listinfo/sdn>>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailarchive.ietf.org/arch/browse/sdn/attachments/20160809/0c73778a/attachment.html<https://mailarchive.ietf.org/arch/browse/sdn/attachments/20160809/0c73778a/attachment.html>>

Subject: Digest Footer

End of sdn Digest, Vol 51, Issue 9
**********************************

Subject: Digest Footer

End of sdn Digest, Vol 51, Issue 10
***********************************