Subject: Re: [Sdn] SDN reading list

From: "Broadbent, Matthew" <[email-masked]>
Date: Mon, 1 Aug 2016 10:58:20 +0000

Hello Cristian,

Thank you for your time and effort compiling this reading list. It is certainly comprehensive and covers a number of topics; ideal for newcomers to the area.

I would like to suggest, and also take responsibility for, a new sub-area: “Content Delivery”. This would fit under the “SDN Applications” title, and include work on how SDN can be used to improve and facilitate the delivery of video (and other types of media) across the Internet.

Thanks

Matt

―――――――――
Matthew Broadbent
School of Computing & Communications
Lancaster University, UK

On 27/07/2016, 16:36, "sdn on behalf of Cristian Lumezanu" <[email-masked] on behalf of [email-masked]> wrote:

    Hi everybody,
    
    I have been maintaining an SDN reading list (https://sites.google.com/site/sdnreadinglist/) for the last four years. My original goal was to provide a centralized repository of SDN research to better help both newcomers and experienced researchers navigate this rather new research area. The number of hits that the website receives every day makes me think that this effort was not in vain. However, as the field of SDN has grown rapidly in the past few years, so has the number of projects, conferences, and papers that I must keep track of and update. This is slowly taking up more time than I can allocate to it and the freshness of the list suffers.
    
    Therefore, I would like to turn the SDN reading list into a collaborative project. For this, I am looking for volunteers who would like to take over the task of updating (and keeping up-to-date) small parts of the site. A “part” could be a sub-area of SDN research, such as “verification” or “monitoring and measurement". If it’s your own research area, even better, you are probably following all related work anyway and would need little time to keep your part up-to-date.
    
    If you can help with this, please send me a personal email with what sub-areas you are comfortable updating and any other constraints that you may have. Even if you don’t have time for this but you have suggestions for how this reading list might better serve the community, please send them along.
    
    Cristian
    
    _______________________________________________
    sdn mailing list
    [email-masked]
    https://www.irtf.org/mailman/listinfo/sdn

---

From: "King, Daniel" <[email-masked]>
Date: Mon, 1 Aug 2016 11:02:23 +0000

The reading list looks great, we will add a link to the site from our SDN RG Wiki page. 

BR, Dan. 

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Broadbent, Matthew
Sent: 01 August 2016 11:58
To: Cristian Lumezanu <[email-masked]>
Cc: [email-masked]
Subject: Re: [Sdn] SDN reading list

Hello Cristian,

Thanks

Matt

―――――――――
Matthew Broadbent

    Hi everybody,

    
    
    Cristian

---

From: Juliano Wickboldt <[email-masked]>
Date: Wed, 3 Aug 2016 13:41:09 -0300

Hi Cristian,

Great job organizing this list!

I would suggest that you add a "Management Plane" section under SDN
Building Blocks, since you have "Control Plane" and "Data Plane" there
already. I can be responsible for maintaining this section if you like. In
ONF's architecture document (
https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR_SDN-ARCH-Overview-1.1-11112014.02.pdf)
the Management Plane is defined. There is also an RFC 7426 that considers
the Management Plane in SDN's architecture, a bit differently though (
https://tools.ietf.org/html/rfc7426).

For example, design considerations for the management plane of SDN have
been presented in "Software-Defined Networking: Management Requirements and
Challenges. IEEE Communications Magazine: Network and service management
series, Volume 53, Issue 1, January (2015).
http://dx.doi.org/10.1109/MCOM.2015.7010546". There are several other
studies published mainly in the network management community, i.e.,
IEEE-NOMS (ieee-noms.org), IEEE-IM (ieee-im.org), and CNSM (cnsm-conf.org),
that can be included in this section.

Best regards

------------------------------
*Juliano Araujo Wickboldt*
Postdoctoral researcher
http://www.inf.ufrgs.br/~jwickboldt/

On Mon, Aug 1, 2016 at 8:02 AM, King, Daniel <[email-masked]> wrote:

> Thank you for your time and effort compiling this reading list. It is
> certainly comprehensive and covers a number of topics; ideal for newcomers
> to the area.
>
> I would like to suggest, and also take responsibility for, a new sub-area:
> “Content Delivery”. This would fit under the “SDN Applications” title, and
> include work on how SDN can be used to improve and facilitate the delivery
> of video (and other types of media) across the Internet.
>
> Thanks
>
> Matt
>
> ―――――――――
> Matthew Broadbent
> On 27/07/2016, 16:36, "sdn on behalf of Cristian Lumezanu" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     Hi everybody,
>
>     I have been maintaining an SDN reading list (
> https://sites.google.com/site/sdnreadinglist/) for the last four years.
> My original goal was to provide a centralized repository of SDN research to
> better help both newcomers and experienced researchers navigate this rather
> new research area. The number of hits that the website receives every day
> makes me think that this effort was not in vain. However, as the field of
> SDN has grown rapidly in the past few years, so has the number of projects,
> conferences, and papers that I must keep track of and update. This is
> slowly taking up more time than I can allocate to it and the freshness of
> the list suffers.
>
>     Therefore, I would like to turn the SDN reading list into a
> collaborative project. For this, I am looking for volunteers who would like
> to take over the task of updating (and keeping up-to-date) small parts of
> the site. A “part” could be a sub-area of SDN research, such as
> “verification” or “monitoring and measurement". If it’s your own research
> area, even better, you are probably following all related work anyway and
> would need little time to keep your part up-to-date.
>
>     If you can help with this, please send me a personal email with what
> sub-areas you are comfortable updating and any other constraints that you
> may have. Even if you don’t have time for this but you have suggestions for
> how this reading list might better serve the community, please send them
> along.
>
>     Cristian
>

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Wed, 3 Aug 2016 14:43:04 -0300

Hi Cristian,

good idea to "crowdsource" this effort.

We tried something similar with our SDN survey by making it available
as a github repository:  https://github.com/SDN-Survey/latex/wiki
to keep the work alive over time with up-to-date arxiv versions:
http://arxiv.org/abs/1406.0440
Unfortunately, we only received a few pull requests and Email messages.

In any case, keeping a reading list up-to-date requires less efforts
compared to a survey.

We (cc: Gyanesh) would like to contribute to the Data plane realm. We
will send you a list of selected references per E-Mail.

If you could also add the github link of the SDN survey to its
reference under General design, maybe we can get more traction to
further contributions to that piece of work. Furthermore, keeping up
to date your reading list would pave the way for forthcoming revisions
of the survey by the original authors or new contributors...

Thanks,
Christian

On Wed, Aug 3, 2016 at 1:41 PM, Juliano Wickboldt
<[email-masked]> wrote:
> I would suggest that you add a "Management Plane" section under SDN Building Blocks, since you have "Control Plane" and "Data Plane" there already. I can be responsible for maintaining this section if you like. In ONF's architecture document (https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR_SDN-ARCH-Overview-1.1-11112014.02.pdf) the Management Plane is defined. There is also an RFC 7426 that considers the Management Plane in SDN's architecture, a bit differently though (https://tools.ietf.org/html/rfc7426).
>
> For example, design considerations for the management plane of SDN have been presented in "Software-Defined Networking: Management Requirements and Challenges. IEEE Communications Magazine: Network and service management series, Volume 53, Issue 1, January (2015). http://dx.doi.org/10.1109/MCOM.2015.7010546". There are several other studies published mainly in the network management community, i.e., IEEE-NOMS (ieee-noms.org), IEEE-IM (ieee-im.org), and CNSM (cnsm-conf.org), that can be included in this section.
>
> Best regards
>
> ________________________________
> Juliano Araujo Wickboldt
> Postdoctoral researcher

---

From: Dave Hood <[email-masked]>
Date: Wed, 3 Aug 2016 18:22:16 +0000

I thought the list was interesting inasmuch as it did not include anything about SDN architecture. It would surely be worth listing SDN architecture 1.1<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR-521_SDN_Architecture_issue_1.1.pdf> [note: the 1.1 overview link below really refers to issue 1.0; it is out of date and should probably be removed from the listing], the relationship between SDN and NFV<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/onf2015.310_Architectural_comparison.08-2.pdf>, and the paper on SDN and 5G slicing<https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/Applying_SDN_Architecture_to_5G_Slicing_TR-526.pdf>.

Because of heavily interrelated recursion, the idea of planes becomes less and less useful. One man’s data plane is another man’s control plane is another man’s applications plane. Management and control form a continuum, not separable planes. Services and orchestration and other concepts that appear in planar models are likewise relative and recursive. The upshot is that we are moving away from the idea of planes as useful modeling concepts. FWIW.

Dave

From: sdn [mailto:[email-masked]] On Behalf Of Juliano Wickboldt
Sent: Wednesday, August 03, 2016 9:41 AM
To: King, Daniel <[email-masked]>
Cc: [email-masked]; Broadbent, Matthew <[email-masked]>; Cristian Lumezanu <[email-masked]>
Subject: Re: [Sdn] SDN reading list

Hi Cristian,

For example, design considerations for the management plane of SDN have been presented in "Software-Defined Networking: Management Requirements and Challenges. IEEE Communications Magazine: Network and service management series, Volume 53, Issue 1, January (2015). http://dx.doi.org/10.1109/MCOM.2015.7010546". There are several other studies published mainly in the network management community, i.e., IEEE-NOMS (ieee-noms.org<http://ieee-noms.org>), IEEE-IM (ieee-im.org<http://ieee-im.org>), and CNSM (cnsm-conf.org<http://cnsm-conf.org>), that can be included in this section.

Best regards

[http://www.inf.ufrgs.br/~jwickboldt/wp-content/uploads/inf_email.jpg]

Juliano Araujo Wickboldt
Postdoctoral researcher
http://www.inf.ufrgs.br/~jwickboldt/<http://www.inf.ufrgs.br/%7Ejwickboldt/>

On Mon, Aug 1, 2016 at 8:02 AM, King, Daniel <[email-masked]<mailto:[email-masked]>> wrote:
The reading list looks great, we will add a link to the site from our SDN RG Wiki page.

BR, Dan.

-----Original Message-----
From: sdn [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Broadbent, Matthew
Sent: 01 August 2016 11:58
To: Cristian Lumezanu <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Sdn] SDN reading list

Hello Cristian,

Thanks

Matt

―――――――――
Matthew Broadbent

On 27/07/2016, 16:36, "sdn on behalf of Cristian Lumezanu" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

    Hi everybody,

    Cristian

    _______________________________________________
    sdn mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.irtf.org/mailman/listinfo/sdn

_______________________________________________
sdn mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/sdn
_______________________________________________
sdn mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/sdn

---

From: "Matta, Abraham I" <[email-masked]>
Date: Wed, 3 Aug 2016 19:29:41 +0000

Very much agree with Dave on the recursive nature of networks, see e.g.

http://csr.bu.edu/rina/papers/CoolSDN2014.pdf

Best,
ibrahim

From: sdn <[email-masked]> on behalf of Dave Hood <[email-masked]>
Date: Wednesday, August 3, 2016 at 2:22 PM
To: Juliano Wickboldt <[email-masked]>, "King, Daniel" <[email-masked]>
Cc: "Broadbent, Matthew" <[email-masked]>, "[email-masked]" <[email-masked]>, Cristian Lumezanu <[email-masked]>
Subject: Re: [Sdn] SDN reading list

Dave

Hi Cristian,

Best regards

[ttp://www.inf.ufrgs.br/~jwickboldt/wp-content/uploads/inf_email.jpg]

Juliano Araujo Wickboldt
Postdoctoral researcher

BR, Dan.

-----Original Message-----
From: sdn [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Broadbent, Matthew
Sent: 01 August 2016 11:58
To: Cristian Lumezanu <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Sdn] SDN reading list

Hello Cristian,

Thanks

Matt

―――――――――
Matthew Broadbent

    Hi everybody,

    Cristian

---

From: "WRIGHT, STEVEN A" <[email-masked]>
Date: Wed, 3 Aug 2016 20:04:24 +0000

+1

best regards
Steven Wright, MBA, PhD, JD.
NFV & SDN Industry Engagement
Standards & Industry Alliances
AT&T Services Inc.
1057 Lenox Park Blvd NE, STE 4D28
Atlanta, GA 30319
P: 404.499.7030

[email-masked]<mailto:[email-masked]>
@DrStevenAWright (personal)
www.linkedin.com/in/drstevenawright/<http://www.linkedin.com/in/drstevenawright/>

From: sdn [mailto:[email-masked]] On Behalf Of Matta, Abraham I
Sent: Wednesday, August 03, 2016 3:30 PM
To: Dave Hood <[email-masked]>; Juliano Wickboldt <[email-masked]>; King, Daniel <[email-masked]>
Cc: [email-masked]; Broadbent, Matthew <[email-masked]>; Cristian Lumezanu <[email-masked]>
Subject: Re: [Sdn] SDN reading list

Best,
ibrahim

From: sdn <[email-masked]<mailto:[email-masked]>> on behalf of Dave Hood <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, August 3, 2016 at 2:22 PM
To: Juliano Wickboldt <[email-masked]<mailto:[email-masked]>>, "King, Daniel" <[email-masked]<mailto:[email-masked]>>
Cc: "Broadbent, Matthew" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Cristian Lumezanu <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Sdn] SDN reading list

Dave

From: sdn [mailto:[email-masked]] On Behalf Of Juliano Wickboldt
Sent: Wednesday, August 03, 2016 9:41 AM
To: King, Daniel <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Broadbent, Matthew <[email-masked]<mailto:[email-masked]>>; Cristian Lumezanu <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Sdn] SDN reading list

Hi Cristian,

Best regards

Juliano Araujo Wickboldt
Postdoctoral researcher

BR, Dan.

-----Original Message-----
From: sdn [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Broadbent, Matthew
Sent: 01 August 2016 11:58
To: Cristian Lumezanu <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Sdn] SDN reading list

Hello Cristian,

Thanks

Matt

―――――――――
Matthew Broadbent

    Hi everybody,

    Cristian

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Wed, 3 Aug 2016 18:01:20 -0300

Hi Cristian,

good idea around "crowdsourcing" this effort.

Thanks,
Christian

---

From: Matt Mathis <[email-masked]>
Date: Wed, 10 Aug 2016 13:44:50 -0700

Can I suggest an addition?

FAUCET SDN blog: an open source SDN/OpenFlow controller for experimental
and enterprise networks.   https://faucet-sdn.blogspot.com/

Thanks,
--MM--
The best way to predict the future is to create it.  - Alan Kay

On Wed, Jul 27, 2016 at 8:36 AM, Cristian Lumezanu <[email-masked]>
wrote:

> Hi everybody,
>
> I have been maintaining an SDN reading list (https://sites.google.com/
> site/sdnreadinglist/) for the last four years. My original goal was to
> provide a centralized repository of SDN research to better help both
> newcomers and experienced researchers navigate this rather new research
> area. The number of hits that the website receives every day makes me think
> that this effort was not in vain. However, as the field of SDN has grown
> rapidly in the past few years, so has the number of projects, conferences,
> and papers that I must keep track of and update. This is slowly taking up
> more time than I can allocate to it and the freshness of the list suffers.
>
> Therefore, I would like to turn the SDN reading list into a collaborative
> project. For this, I am looking for volunteers who would like to take over
> the task of updating (and keeping up-to-date) small parts of the site. A
> “part” could be a sub-area of SDN research, such as “verification” or
> “monitoring and measurement". If it’s your own research area, even better,
> you are probably following all related work anyway and would need little
> time to keep your part up-to-date.
>

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Thu, 11 Aug 2016 13:58:47 -0300

Hi Matt and fellows,

Cool work on FAUCET (congrats to Josh Bailey and Chris Lorier!)

My understanding is that think Cristian L.reading list is focused on
scientific papers to build the reading list. Is there already one
publication around FAUCET?

In any case, I wanted to point interested folks to the initiative
towards putting together the comprehensive list of open source tools
in SDN, NFV, etc.

I recall Martin Casado keeping a webpage on OpenFlow projects, and
there have been other attempts to get such a knowledge hup
(sdnhub.org, sdxcentral directory).

We are working on an "always up-to-date catalogue" that will be
managed by the community as a Wiki --think Wikipedia for researchers
and practitioners in our softwarized (or not) networking domain.

To this end my proposal to feed Wiki with an initial content based is
to collaboratively collect in this spreadsheet all open source
projects we as the community are aware of:
https://docs.google.com/spreadsheets/d/1NHI4MZZWVDpxF_Rs7OOSTUa_aHL2ACUVA_Ov-YQs1DA/edit#gid=0

Please feel free to directly contribute in any of the following (but
not limiting) ways:
- Add more open source projects (as today 100+)
- Fill in any missing info, especially feel free to Review/Edit/Add as
many Tags as you feel apply to each project.
- Review/Edit/Add Tags collected in the tab "Tag"
- Distribute this call for help among your trusted peers / students / etc.
- Send feedback about the proposed strategy and share your suggestions
to move forward.
- ...

Thanks in advance for any contributions, if only each of us in these
lists would spend just 5 minutes contributing content, we will very
soon have an excellent starting point for the Wiki catalogue!

Warm regards,
Christian

On Wed, Aug 10, 2016 at 5:44 PM, Matt Mathis <[email-masked]> wrote:
> FAUCET SDN blog: an open source SDN/OpenFlow controller for experimental and
> enterprise networks.   https://faucet-sdn.blogspot.com/
>
> Thanks,
> --MM--
>> I have been maintaining an SDN reading list
>> (https://sites.google.com/site/sdnreadinglist/) for the last four years. My
>> original goal was to provide a centralized repository of SDN research to
>> conferences, and papers that I must keep track of and update. This is slowly
>> taking up more time than I can allocate to it and the freshness of the list
>> suffers.
>>