Subject: [Sdn] I need help regarding SDMN

From: Modhawi Alotaibi <[email-masked]>
Date: Wed, 3 Aug 2016 13:02:12 -0400

Hello,
I'm a PhD student, my research is on software defined mobile networks.
I have an architecture in mind that requires inter-communication among
distributed controllers.
My problem is that I couldn't find a simulation or emulation tool that
allows that feature(i.e. communication between multiple controllers to
exchange status or statistics).

So from your experience, can you suggest a tool that I can use to validate
my approach?

Thanks in advance for your help,

Best Regards,
Modhawi

---

From: Ali Haider <[email-masked]>
Date: Sun, 7 Aug 2016 21:08:37 +0500

I believe you can do this using mininet. If the solution is not readily
available you can always write an interface. This link
https://github.com/mininet/mininet/blob/master/examples/controllers.py
might be useful.

On Wed, Aug 3, 2016 at 10:02 PM, Modhawi Alotaibi <[email-masked]>
wrote:

> _______________________________________________
> sdn mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/sdn
>
>

-- 
*​Syed Ali Haider*, Ph.D
​Assistant Professor
School of Electrical Engineering and Computer Science
National University of Sciences ​and​ Technology
Sector H-12, Islamabad, Pakistan
​t: +92 51 90852109
​e: [email-masked]​
- - - - - - - - - - - - - - - - - - - - -