Subject: Re: [seamoby] Consideration on L3 paging area

From: James Kempf <[email-masked]>
Date: Thu, 9 Aug 2001 00:39:17 -0700

Yoshi,

>
>
>I've noticed that the definition of "paging area" is ambiguous in the
>DMHA requirement document.  Actually, it is not clear to me whether
>the paging area mentions L3 paging area or L2 paging area.
>
>I want to interpret it as the L3 paging area instead of L2 paging area
>in order to be more generic.  Otherwise, the Tracking Agent and Paging
>Agent defined in section 5 (Functional Architecture) cannot exist if
>underlying L2 technologies do not have L2 paging (thus there is no L2
>paging area), which seems to be unnecessarily restrictive.  The notion
>of L3 paging area would also be useful for separation of L2 dependent
>stuff from DMHA protocol, which would simplify the DMHA protocol
>specification and increase the degree of freedom in implementation.
>

Yes, that was the intent. L3 paging is of little interest unless it
allows more flexibility, for example, dynamically configured paging
areas. If paging areas are strictly tied to L2, this is not possible.

>If such an interpretation is allowed, the next issue is what the
>mapping between L3 paging area and L2 paging area should be.  It seems
>that the mapping is entirely implementation issue, and I want to make
>it out of the scope of DMHA specification.
>

I agree that it should be an implementation issue. The same goes for
the mapping of the actual implementation of paging signalling. How
or even whether it is mapped to a paging channel depends on the
underlying L2 protocol. The specification should just make it possible.

		jak

---

From: Pars MUTAF <[email-masked]>
Date: Thu, 09 Aug 2001 14:30:14 +0200

Hello;

In my opinion (humble), the following
decisions make  a "location tracking strategy"
(or whatever you want to call it):

- Use L2 or L3 paging areas? Or use underlying
    location tracking strategy?

- Paging areas are contigiuous or not? Overlaping
    or not? etc.

- Who initiates paging? A home agent?
    an hierarchical agent?, a last hop router? etc.

- How the paging areas are configured?
   By the operator? Automatically?

- What is the paging algorithm? Sequential polling?
   Multicast style? etc...

- Does a DMH send registrations upon every
    paging area crossing or not?

- and that kind of staff that you know all...

So, I completely agree with you: the above items
are out of the scope of the DMHA protocol.

But, I don't agree that this is an implementation issue.
How can the DM capable hosts, paging agents etc. can
agree on an implementation issue? This is not clear.

Formulated as follows, it is more clear for me:

The DMHA protocol should be flexible in support
of more than one location tracking strategies. DM
capable hosts and paging/tracking/monitoring
agents can agree on a particular strategy (which is
assigned a number), using a message exchange
supported by the DMHA protocol,  in a TLV formatted
option, for example. And, each strategy can have its own
message types and codes for its specific functionalities...

Clearly, this would be an obvious advantage of IP paging
over current systems: "location or administrative domain
or even time dependent location tracking strategies".

In addition, there is extensive research on zillions
of strategies, and so far there is not a convincing winner...
Someone can discover *in the futur* a new strategy, convince
others by simulation and benchmarking results, or even on
real IP mobility expericence... then everyone may prefer
this new strategy (the ONE). When this happens, the DMHA
protocol should be able to support it.

So, I want to imagine  that a particular Location Tracking
Strategy: "MY-LTS over DMHA" will be proposed as a
separate I-D ... (but, one should first design the DMHA
protocol :-).

In this case the network administrator will ask:
which LTS should I buy? That's his/her business...

Comments? Thanks...

Regards,
pars

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 09 Aug 2001 11:19:26 -0400

Perhaps some sort of capability notification or negotiation would be
necessary for DMHA protocol to be flexibile.

Yoshihiro Ohba

At Thu, 09 Aug 2001 14:30:14 +0200,

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 13 Aug 2001 12:00:53 -0500

Folks,
  Let me throw away my 2 cents.
What RFC 3154 refers to should be Layer 3 paging areas not Layer 2. We have no
business in Layer 2 paging areas. Hopefully by the time IETF's paging protocol
gets deployed in all IP networks, we are going to have only Layer 3 paging
areas.
  On terminology, DMHA does not correctly capture what we understand as paging,
it only captures part of the paging on the link for host alerting but not
finding where the mobile host is. So Layer 3 paging protocol or the like is to
be used.

Regards,
--
Behcet