Subject: RE: [seamoby] Comments on CT Reqs draft

From: George Tsirtsis <[email-masked]>
Date: Wed, 15 Aug 2001 04:00:03 -0400

-----Original Message-----
From: Kulwinder Atwal [mailto:[email-masked]]
Sent: Wednesday, August 15, 2001 12:43 AM
To: George Tsirtsis; 'Gary Kenward'; [email-masked]
Cc: Alan O'Neill; Michaela Vanderveen
Subject: Re: [seamoby] Comments on CT Reqs draft

----- Original Message -----
From: "George Tsirtsis" <[email-masked]>
To: "'Gary Kenward'" <[email-masked]>; <[email-masked]>
Cc: "Alan O'Neill" <[email-masked]>; "Michaela Vanderveen"
<[email-masked]>
Sent: Tuesday, August 14, 2001 6:47 PM
Subject: RE: [seamoby] Comments on CT Reqs draft

>
> -----Original Message-----
> From: Gary Kenward [mailto:[email-masked]]
> Sent: Tuesday, August 14, 2001 8:09 PM
> To: 'George Tsirtsis'; [email-masked]
> Cc: Alan O'Neill; Michaela Vanderveen
> Subject: RE: [seamoby] Comments on CT Reqs draft
>
>
> >
> > Comment 1
> > -----------
> > "4.9 All context information to be transferred MUST be
> > available at the
> >    AR performing the transfer, prior to the initiation of the context
> >    transfer.
> >
> >    The total context associated with the MN's traffic is composed of
> >    various types of feature context. To effect a rapid transfer, the
> >    context information has to be readily available when the AR begins
> >    the transfer. "
> >
> > This does not make sense as stated. What initiates the
> > gathering of all the
> > relevant context to be transferred? Or you just mean that all relevant
> > context is in close proximity to the CT code (i.e.: same
> > box)? By saying the
> > context MUST be ready when CT is initiated we just defer the
> > potential for
> > delay, we do not eliminate it...i.e.: one may not initiate CT
> > until it has
> > gathered all context but the gathering process could take
> > very long time.
> > We suggest something like the following:
> > "CT should not be slowed down by a process or feature
> > inability to make
> > appropriate context available to CT. CT SHOULD be able to
> > transfer context
> > as it becomes available.
> Your suggestion is syntactically incorrect, and thus harder to understand.
> The intent is as you surmised: to require that the context be at the AR,
> and not elsewhere when the transfer is to be initiated. There are many
> finer points that could be made, but with markedly diminishing importance.
>
> GT> Gary it does not make sense. My point here is that the requirement
> relates to timing considerations which are covered by other requirements
in
> this spec...weather the context is in or out of the AR it is a mute point
> and a protocol should not be held accountable for not doing it this way.
>

This requirement defines the scope of context transfer protocol.  It states
that the context carried by this protocol will be transferred by this
protocol between Peer Access Routers _only_.  Only the characteristics of
transferring context between Peer Access Routers will be considered in this
protocol.

GT> That is fine.

For example, we have ruled out the transfer of PDP context, and BTS context.

1.  Also, the protocol will not introduce additional messaging to bring in
context from somewhere else.

2.  The time required by some implementations to bring in the context from
somewhere else will not be included in the explicitly or implicitly in the
protocol design.

This requirement does not exclude a _particular_ implementation from storing
the context anywhere it chooses. 

GT> Or an implementation could go and pick it up from anywhere it exists at
the time it is needed and as long as that does not affect the CT protocol
itself then it should not matter, yes? My impression is that the requirement
as stated does not allow for that option, hence the comment.

 It only excludes that implementation
decision from affecting the protocol design.

At least, that is my recollection of the debate on the Design Team.

GT> Thanks
George

---

From: "Kulwinder Atwal" <[email-masked]>
Date: Wed, 15 Aug 2001 14:09:09 -0400

----- Original Message -----
From: "George Tsirtsis" <[email-masked]>
To: "'Kulwinder Atwal'" <[email-masked]>; <[email-masked]>
Cc: "Alan O'Neill" <[email-masked]>; "Michaela Vanderveen"
<[email-masked]>
Sent: Wednesday, August 15, 2001 4:00 AM
Subject: RE: [seamoby] Comments on CT Reqs draft

> itself then it should not matter, yes?

Correct.

- Kulwinder.

 My impression is that the requirement