Subject: RE: [seamoby] Update on Issues from IETF meeting

From: George Tsirtsis <[email-masked]>
Date: Thu, 16 Aug 2001 11:44:15 -0400

-----Original Message-----
From: Theo Pagtzis [mailto:[email-masked]]
Sent: Thursday, August 16, 2001 4:23 PM
To: Pat Calhoun
Cc: [email-masked]; Cedric Westphal; Henrik Levkowetz
Subject: Re: [seamoby] Update on Issues from IETF meeting

With all due respect I am in favour of the suggestion below. It provides
better notion of time and behaviour simultaneously for a CT protocol. 

However, I have one question: 

is it possible that it can happen proactively (before) AND reactively
(after) at the same time? 
Aren't these time event a bit mutually exclusive or at best OR-inclusive? 

What I am pointing basically is the AND. Shouldn't that be an OR? Boolean
logic, reasons clearly for that... 

GT>Actually no... Some context may need to be transfered early and some
late...e.g.: security keys (early) and header compression state (late)

George

---

From: Theo Pagtzis <[email-masked]>
Date: Thu, 16 Aug 2001 16:59:45 +0100

Hi George,

>      With all due respect I am in favour of the suggestion
>      below. It provides better notion of time and behaviour
>      simultaneously for a CT protocol.
>
>      is it possible that it can happen proactively (before) AND
>      reactively (after) at the same time?
>      What I am pointing basically is the AND. Shouldn't that be
>      an OR? Boolean logic, reasons clearly for that...
>
>      GT>Actually no... Some context may need to be transfered
>      early and some late...e.g.: security keys (early) and
>      header compression state (late)
>
>

I disagree with the no, but I agree that it may be _some_ cases where
the context is transfered, part of it early..(proactively) _and_ part
of it (late).

if

A means 'late'
B means 'early'

A  AND B means that both late and early have to happen _always_
(std boolean predicates)
A  OR  B means that either late OR early OR both can happen

I see A  OR  B as being much more open than A AND B

In other words A  OR  B captures the case you have described and does
suggest a change of the AND conjunct. to an OR inclusive disjunct..

Theo

UCL/ Mobile Systems