Subject: Re: [seamoby] What message should Paging Agent send out?

From: James Kempf <[email-masked]>
Date: Fri, 17 Aug 2001 11:11:25 -0700 (PDT)

>
>I start thinking this in a different way, but...
>
>I think that the question is; do we need clear distinction between
>L3 paging area and L2 paging area?
>
>For example, suppose that a L3 paging area consists of several L2
>paging areas which are based on different L2 technology. Then current
>Paging Agent has to know about different types of L2 technology and
>different types of L2 paging method. This might make the functionality
>of the Paging Agent difficult to understand.
>

Correct. It must map the L3 paging area into the L2 paging areas.

>Of course the current Paging Agent is a "functional" entity, but I
>think that things become easy to understand if we define the Paging
>Agent as a sender of L3 paging messages instead of various L2 paging
>messages dependent on the L2 system.
>

If we do that, we need to define a separate entity that converts
the L3 paging message into an L2 paging message.

One possibility would be to have one paging agent that
dealt with L3 paging and others that deal  with L2 paging.

>If the people who consider the seamoby paging think that this is a
>trivial issue and not worth considering any more, then leave the
>definition of Paging Agent as it is. I may be wrong...
>

We can certainly go back and modify the architecture if there
seems to be a concensus to do so, but it means we will have
to cycle the draft back through WG and IETF last call, which
is a somewhat time consuming process. I think we ought to
avoid that until we have some implementation experience
indicating that the current architecture is deficient, since
other issues may arise. Let's keep track of this issue
and see what comes out of the protocol design/prototyping
phase.

		jak

---

From: NAKAJIMA Nobuyasu <[email-masked]>
Date: Mon, 20 Aug 2001 16:31:13 -0400 (LDT)

> the L3 paging message into an L2 paging message.

Yes. I am thinking about this.

> and see what comes out of the protocol design/prototyping

Agreed.

Nobuyasu
-----
Nobuyasu Nakajima
Toshiba America Research, Inc.