Subject: RE: [Seamoby] CAR DiscoveryProtocol Requirements...

From: "Trossen Dirk (NRC/Boston)" <[email-masked]>
Date: Fri, 21 Dec 2001 13:55:02 -0500

Hi Vijay,

two comments:
- we are considering IPV4 as well IPV6, which brings naturally private
address spaces into play. As long as we are not considering entirely
public routers, any solution has to deal with this problem, which
therefore
makes it a requirement.

- It's certainly debatable that it makes a solution 'very complicated',
in particular since I don't know what kind of 'measure' you applied
for your statement. However, I'm sure that every requirement on its own 
makes the overall solution more complicated (this is certainly true for 
some others on the list of requirements). However, removing requirements

just for the sake of making life easier doesn't seem to be the right
way. 

Regards,

Dirk

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: Friday, December 21, 2001 1:41 PM
> To: Trossen Dirk (NRC/Boston)
> Cc: Govind Krishnamurthi; [email-masked]
> Subject: Re: [Seamoby] CAR DiscoveryProtocol Requirements...
> 
> 
> 
> how about "it makes the CAR discovery protocol very 
> complicated".
> 
> and tell me why its there in the first place..
> 
> all other requirements are fine.
> 
> Vijay
> 
> "Trossen Dirk (NRC/Boston)" wrote:
> > 
> > Hi,
> > 
> > is there any specific reason why you want to remove private
> > address space considerations?
> > 
> > Regards,
> > 
> > Dirk
> > 
> > > -----Original Message-----
> > > From: ext Vijay Devarapalli [mailto:[email-masked]]
> > > Sent: Friday, December 21, 2001 1:34 PM
> > > To: Govind Krishnamurthi
> > > Cc: [email-masked]
> > > Subject: Re: [Seamoby] CAR DiscoveryProtocol Requirements...
> > >
> > >
> > > hi all,
> > >
> > > Govind Krishnamurthi wrote:
> > > >
> > > > Hello all,
> > > > To add to James' mail. Please let us know if any of these
> > > > requirements need to be modified or whether any other 
> requirements
> > > > are needed.
> > > >
> > > > Regards,
> > > > Govind.
> > > >
> > > >         REQUIREMENTS FOR CAR DISCOVERY PROTOCOLS
> > > > >
> > > > >1. MUST translate L2 Ids (APs and ARs) to L3 Ids of ARs
> > > > >
> > > > >
> > > > >2. MUST support L2 devices of different technologies
> > > > >
> > > > >
> > > > >3. MUST support for L2 devices (and ARs) in
> > > private/site-local spaces
> > >
> > > Remove 3. everything else is fine.
> > >
> > > Vijay
> > >
> > >
> > > > >
> > > > >
> > > > >4. MUST communicate capability information between GAARs
> > > in a secure and
> > > > >reliable manner
> > > > >
> > > > >
> > > > >5. MUST use standard format for capabilities..
> > > > >  and this is TBD
> > > > >
> > > > >6. Protocol applicability - SHOULD (show of hands
> > > indicated that a MUST
> > > > >is needed here) support inter-domain as well as 
> Intra-domain scope
> > > > >
> > > > >
> > > > >7. MUST NOT introduce network elements dedicated to 
> CAR discovery.
> > > > >
> > > > >
> > > > >8. SHOULD minimize involvement of ARs which are not 
> GAARs in CAR
> > > > >discovery
> > > > >
> > > > >
> > > > >9. MUST NOT depend on a particular mobility management protocol
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >_______________________________________________
> > > > >Seamoby mailing list
> > > > >[email-masked]
> > > > >https://www1.ietf.org/mailman/listinfo/seamoby
> > > >
> > > > 
> _________________________________________________________________
> > > > Chat with friends online, try MSN Messenger:
> > > http://messenger.msn.com
> > > >
> > > > _______________________________________________
> > > > Seamoby mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/seamoby
> > >
> > > _______________________________________________
> > > Seamoby mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/seamoby
> > >
> 

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 21 Dec 2001 11:14:49 -0800

Dirk,

can you make IKE create an SA between two nodes (one having
a public address and another having a private address)?

does AAA route based on private address realm?

as for as I know neither is possible. (maybe I am wrong).

if an ISP wants context tranfer between two routers,
let it allocate public addresses for both.

Vijay