Subject: [Seamoby] Defining Paging Area

From: Kar Ann Chew <[email-masked]>
Date: Tue, 18 Dec 2001 16:01:34 +0000 (GMT)

Hi,
A simple question - How should Paging Areas be defined in IP network?

Most of the paging proposals mention how to detect change of PA, and
procedure of updating related entities, but not on how a PA is defined?.

Anyone, any pointers/advice on how to make paging area definition?  Or we
can simply leave is to cell planning people?

Cheers,
	Karann
++++++++++++++++++++++++++++++++++++++++++
Karann Chew
Mobile Communications Research Group
Centre for Communication Systems Research
University of Surrey, Guildford
Surrey GU2 7XH, United Kingdom
Tel: +44 (0) 1483-876001
Fax: +44 (0) 1483-876011
++++++++++++++++++++++++++++++++++++++++++

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Pars MUTAF <[email-masked]>
Date: Tue, 18 Dec 2001 17:46:43 +0100

Hello!

> Anyone, any pointers/advice on how to make paging area definition?

Our draft on DPAC (Dynamic Paging Area Configuration) might
interest you.

It is available at:
http://www.inrialpes.fr/planete/people/mutaf/draft-mutaf-dpac-00.txt

We will update it soon. Please do not hesistate to comment on it.

> Or we

This is also possible.

But, after years of (others') cellular experience, manual paging area
configuration has proven difficult and not efficient "at all".  Now,
with IP paging, we have the chance to change that.

Hence the motivation for paging area auto-configuration in
RFC3154.

Regards,
pars

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Tue, 18 Dec 2001 11:52:31 -0500

Hello Kar:

Following on Pars' note on IP paging, we developed the P-MIP 
protocol. While the P-MIP Internet Draft did not go into setting
up paging areas the following paper does. The 
approach discussed there contrast the work
from the INRIA team, which I like too. 

You can find the paper:

"Design and Performance of Mobile IP Paging," X. Zhang, J. 
Castellanos, and A. Campbell, ACM/Kluwer Mobile Networks 
and Applications (MONET), Special issue on Modeling Analysis 
and Simulation of Wireless and Mobile Systems, Vol 7, No. 2, 
March 2002 (to be published),

on the P-MIP page:

http://www.comet.columbia.edu/pmip/

The ns-2 source code is available there too. 

Best,
---
Andrew
http://comet.columbia.edu/~campbell

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> Pars MUTAF
> Sent: Tuesday, December 18, 2001 11:47 AM
> To: Kar Ann Chew
> Cc: [email-masked]
> Subject: Re: [Seamoby] Defining Paging Area
> 
> 
> 
> Hello!
> 
> 
> Kar Ann Chew wrote:
> 
> > Hi,

---

From: Marco Liebsch <[email-masked]>
Date: Tue, 18 Dec 2001 18:21:36 +0100

Hi,
in addition to the feedback already sent to the list, please be referred to
draft-renker-paging-ipv6-01.txt as well, which has some sections on L3 Paging
Areas and also appropriate references to the respective documents/papers.
Hope this helps.

Marco

---

From: "James Kempf" <[email-masked]>
Date: Tue, 18 Dec 2001 09:45:32 -0800

Kar Ann,

This is an entirely open question at this point. There is one draft out
there on the issue (draft-mutaf-dpac-00.txt),
but this just one approach, others are possible.

One of the major advantages of IP paging over strictly L2 paging is the
ability to do dynamic paging area configuration.
At some point, it might be useful to look into a protocol for dynamic
paging area configuration, but, for now,
I think it is more important that we get a paging protocol defined. Of
course, any paging area configuration protocol would
need to be independent of the policy used to configure the paging area.

            jak

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 18 Dec 2001 18:48:21 -0600

Hi Kar Ann,
  If you read:
draft-sarikaya-seamoby-mipv6hp-00.txt
and
draft-guri-seamoby-lahap-00.txt

you will see defined Layer 2 paging areas (I think that architecture picture
in draft-sarikaya-seamoby-mipv6hp is slightly more informative)
and Layer 3 PAs. L2 PAs are as in 2.5G and 3G cellular networks so mobile
operators define and set up such PAs. There are connected to APs which are L2
entities. They are static.
  As for L3 PAs, we defined them as collections of IP subnets with a Paging
Agent. There is multicast address for each PA and the paging agent can
address each PA by a single request message. This is I think a good design
and it had previously been proposed (I believe in HAWAII). These PAs are also
static.
  What Pars and Claude talk about as PAs I think is a cell level or L1
concept. I am having difficulty in understanding their theory. Hopefully they
will further develop it using L2 or L3 ideas so that we can grasp the theory
of dynamic paging areas. Only thereafter some standardization can be thought
of.

Hope this helps, I do not think that it is all mysterious these PAs. In
general IP paging concepts are much better understood now then before. Don't
they?

Regards,

--
Behcet

---

From: Pars MUTAF <[email-masked]>
Date: Wed, 19 Dec 2001 11:54:28 +0100

Hello,

> of dynamic paging areas. Only thereafter some standardization can be thought

Thank you for your comments (but I assume that your "L1" statement
was a joke).

A clarification: DPAC configures L3 paging areas.

Seems like there is an ambiguity in the current version of the DPAC text.
In fact, we should have chosen the term "IP subnet" instead of "cell". We
were thinking about "L3 cells" . An L3 cell comprises one or more L2
cells. An L3 cell is nothing but an IP subnet.

I'll change the text and adopt the same terminology (i.e. IP subnet)
as RFC3132 (IP paging problem statement).

Regards,
pars

---

From: Pars MUTAF <[email-masked]>
Date: Wed, 19 Dec 2001 15:29:03 +0100

Hello,

> but this just one approach, others are possible.

I agree that others are possible. We might have a different scheme
in another mobility scenario. I'd like emphasize which scenario our
DPAC is being designed for:

For example,  consider the case where a user moves towards a new
country which is "far far away" from his home town and
"for the first time in his life". This newly visited country might be
"Papua New Guina" for example.

Such big moves are allowed by Mobile IP. Our proposition
guarantees the availability of paging areas to the above user during
his trip. Because paging areas will be already configured using the
samples generated by the inhabitants of Papua. Currently, our
proposition is the "unique" policy (as far as I know) which has this
property. I think this is because there wasn't such a need before
Mobile IP.

But, in another scenario (movements inside a building for
example), one can imagine other policies which might be more
efficient than our proposition (more efficient in terms of paging
area shape, registration rate etc).

One can think of our proposition as a policy mostly suitable for
"public access networks".

From this point of view, it seems like we've monopolized the
term "dynamic paging area configuration" which is in fact
generic. I think we can change the title of our draft if WG
consensus says to do so.

> ability to do dynamic paging area configuration.

So, if IP paging becomes a real success, this may have a major
influence on the way the L2 engineers and cellular operators think?
I mean, in this case L2 paging areas may disappear in the future?
(the role of L2 being dormant mode support in a given subnet).

What do you think?

(please note that this is just a question, not an argument)

If this is possible, one should think of dynamic paging area
configuration (in its generic sense)  as the key factor in IP paging
protocol design.

Comments? Thanks.

Regards,
pars

---

From: "James Kempf" <[email-masked]>
Date: Wed, 19 Dec 2001 09:33:27 -0800

Pars,

> (the role of L2 being dormant mode support in a given subnet).

It is hard to tell, of course, but I think there are reasons for having
L2 paging support that are independent of static paging areas.
Having a separate paging channel that can contact the mobile
when it is in dormant mode and a paging area beacon channel
may result in better power efficiency on the mobile, for example.

What I hope will disappear are the static Location Area Identifiers
that are tied to GGSN/PDSN, i.e., to a particular subnet. These
are essentially data paging areas in the 3G standards. Static
subnet to paging area mappings tend to constrain network topology,
since they push for larger leaf subnets. Particularly with micro-
or picocells, flexibility in network design might lead to better
routing efficiency.

There is also the issue of multiple wireless interfaces on a
single device. What if there are 5 wireless interfaces on
a device? Confining the details of handling 5 different
L2 paging protocols to the last hop and letting IP
handle the details in the network seems like the correct
abstraction level, and is the traditional role IP has
played in hiding the details of L2.

            jak

---

From: Claude Castelluccia <[email-masked]>
Date: Thu, 20 Dec 2001 12:18:41 +0100

> of dynamic paging areas. Only thereafter some standardization can be thought

Behcet, all of our work is about L3 paging!
Why would we submit something about L1 or L2 paging area
configuration to Seamoby????
I am really surprised about your statement...

Claude.

--

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/

---

From: Claude Castelluccia <[email-masked]>
Date: Thu, 20 Dec 2001 12:14:29 +0100

Hello James,

> ability to do dynamic paging area configuration.

i agree but not only dynamic paging area configuration but also *per-host*
paging
area (i.e. IP provides the abilitity to customize the PA to each mobile
hosts' particular
communication and mobility pattern...

As you mentioned DPAC is only one approach but we are also working
on an architecture that is, i think, more general. This architecture is
described in
an upcoming SIGCOMM CCR issue and can be dowload at :
http://www.inrialpes.fr/planete/people/ccastel/sigcomm.ps

The WG comments on this paper would be very useful...

> need to be independent of the policy used to configure the paging area.

I agree , we need to make sure that any IP paging protocols that will be
standardized
can efficiently support Dynamic PA....but this is a very difficult task
without considering
Dynamic PA (and its requirements) from the start   (a bit like security and
MIPv6 ;-))

regards,
Claude.

--

---

From: "James Kempf" <[email-masked]>
Date: Thu, 20 Dec 2001 08:52:53 -0800

Claude,

I believe Bechet's difficulty was with the terminology of the paper
(cells, etc.)
rather than the content. Pars has already indicated that the term
subnets should probably been used instead of cells.

            jak