Subject: RE: [Seamoby] comments on CAR Discovery Requirements

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 14 Mar 2002 02:55:22 +0100

>I have some brief general comments on the
  > >draft and some minor specific ones. I'm afraid
  > >my old comment still applies. See below:
  > >
  > >General comments:
  > >
  > >1. I think (somewhere in the intro or a dedicated
  > >section) that there should be some description
  > >of the entities participating in the CAR
  > >discovery, without getting into a solution.
  > >I still think the requirements are vague because
  > >they don't explain which entities are affected
  > >by these requirements. They are on such a high level,
  > >that they could apply to anything.
  > 
  > [Govind] ASAIK, the requirements were designed for ANY protocol
  > involved in CAR discovery

=> This is the problem. The requirements are on such
high level, that makes it hard to address any 
issues in detail.

 irrespective what entities may actually
  > be part of in a solution. It might be difficult to anticipate
  > every solution and prepare requirements for different entities
  > probably in the solution.

=> We know the entities already don't we? 
The MN, The AR and one or more GAARs. There is 
nothing more is there ?

  > However, could you provide a paragraph to the WG so
  > that we can then understand your concern more clearly. I remember
  > you saying that you will be sending in some text but we 
  > never got it.

=> OK

  > >2. The security requirements are noon-existent
  > >as James said, and I don't think one requirement
  > >is enough, several issues need to be addressed:
  > >- Authorisation
  > >- DoS attacks
  > >- Replay protection
  > >....etc
  > >There needs to be a separate security section.
  > >And again, detailing these requirements will show
  > >who/which part of the protocol is affected by it.
  > 
  > [Govind] I guess James has proposed a requirement and
  > we are discussing this in a separate thread. May be
  > you can post your requirement there along with the justification
  > text there so that we don't have to deal with
  > two threads dealing with this topic.

=> OK, but this is not about a single requirement, 
you need to have a few of them.

  > >
  > >Requirement 3.3 seems to mix site-local/private
  > >addresses with IPv4/IPv6 and is a bit vague.
  > >This area is quite large and some proposals are
  > >already on the table in ngtrans. Can you be a bit
  > >specific with what is actually required?
  > 
  > [Govind] The requirement is very simple. It is
  >   attempting to look into a situation wherein APs
  > adjacent to each other may be
  > connected to ARs not directly reachable from each other.

=> The entire CAR discovery problem looks at
this scenario, but how does IPv4/v6, Site-local
issues come into this?

  > Again if this is not clear, could you send in text which
  > more appropriately describes what you have in mind.
  > 

=> I'll try, but I can't guarantee it. It doesn't
make the comments less valid though.

Hesham

  > 
  > 
  > 
  > 
  > 
  > _________________________________________________________________
  > Get your FREE download of MSN Explorer at 
  > http://explorer.msn.com/intl.asp.
  > 

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Thu, 14 Mar 2002 08:26:55 -0800

Re. the comments on security, maybe we need a more comprehensive threat
analysis such as Claude did for paging?
The requirement I did was pretty generic.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Thu, 14 Mar 2002 08:26:55 -0800

jak