Subject: Re: [Seamoby] Examples of CAR discovery

From: "Hemant Chaskar" <[email-masked]>
Date: Tue, 26 Mar 2002 21:31:21

Hi James:

I am bit confused. First the extension to requirement sounded fine to you, 
now it is not. What is you final opinion?

I am not proposing any optimization. There is core flaw in the original 
requirement that you have proposed. The requirement you proposed means 
following: As soon as AR sees MN attached to it, it blasts MN with set of 
GAARs and their capabilities. This is clearly inefficient. This is like 
empowering the network to spam MN with possibly unwanted information.

Sometimes you say MN must be in charge and sometimes you give leeway to 
network to ignore MN. Why is that?

BR,
Hemant

>From: "James Kempf" <[email-masked]>
>To: "Hesham Soliman \(ERA\)" <[email-masked]>,        
>"'Hemant Chaskar'" <[email-masked]>, <[email-masked]>
>Subject: Re: [Seamoby] Examples of CAR discovery
>Date: Tue, 26 Mar 2002 13:14:52 -0800
>
>
> >   > This looks good to me, but with a small attention to detail:
> >   >
> >   > What if MN does not want to receive such information or
> >   > does not want to
> >   > receive a part of it. Then, CAR discovery should not blast
> >   > it on MN.
> >
> > => The MN will ignore it if it doesn't
> > need it.
> >
> >  To
> >   > avoid this, we can slightly rephrase it as:
> >   >
> >   > "The CAR discovery protocol MUST provide the MN with GAAR
> >   > information, along
> >   > with capabilities, *whenever and as required by MN*."
> >   >
> > => I disagree this is a very strange
> > argument for removing the MN from the loop.
> > How does the AR know ?? Do we have to invent
> > another protocol that the MN should implement
> > to say no ?!
> >
> > Can we please make this simple?
> >
>
>Good point.
>
>I don't think we need to include optimizations in the requirements.
>Let's keep it simple.
>
>             jak
>
>
>_______________________________________________
>Seamoby mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/seamoby

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Tue, 26 Mar 2002 14:17:26 -0800

On second thought, let's keep it simple. Premature optimization often
has unintended consequences.

Sorry for the confusion. I'm having trouble keeping up with 200+ emails
a day.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Tue, 26 Mar 2002 14:17:26 -0800

jak