Subject: RE: [Seamoby] comments on CAR Discovery Requirements

From: [email-masked]
Date: Fri, 15 Mar 2002 09:32:47 -0500

James,

-----Original Message-----
From: ext James Kempf [mailto:[email-masked]]
Sent: Thursday, March 14, 2002 6:41 PM
To: Hemant Chaskar; [email-masked]
Subject: Re: [Seamoby] comments on CAR Discovery Requirements

Hemant,

I think it would be useful to have a threat analysis. The threat
analysis that was done for paging was extremely useful in uncovering
necessary security requirements. What you have listed below are fairly
high level goals. A more detailed threat analysis with these goals in
mind might turn up some more specific requiremnts.

[DOT]frankly speaking, I have my doubts that the output would be more
than now. What we are targetting right now is the clear and complete statement of 
security issues, and we are having progress in this. Plainly raising concerns 
without providing input is not what I see as a threat analysis. I don't 
see that any new process, called threat analysis or whatever, would bring 
more than the process now. 
If people are not willing to provide proper input (and that's what we 
need) now, why should they in a newly created threat analysis. It
simply creates a new process, and therefore new overhead without
guaranteeing any increased output.

Hesham has indicted some interest in participating, 

[DOT] Frankly, Hesham has been indicating his interest in participating
for quite a while, and several people, including myself, strongly invited
him to do so. Apart from raising concerns, other input has not been 
provided, only the promise to do so. If we want to have progress with
CAR discovery, we have to do the work rather than promising to do the
job. 

...perhaps you would like to as well?

[DOT] That's exactly the difference. Hemant has been participating in providing 
input in forms of requiremens for quite a while, so there is no need to invite 
him for participation. If we have to announce our interest again in providing
input, I'll do so, too.

Regards,

Dirk

----- Original Message -----
From: "Hemant Chaskar" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, March 14, 2002 11:00 PM
Subject: Re: [Seamoby] comments on CAR Discovery Requirements

> Hi James:
>
> Rather than starting from scratch again in Minneapolis, may I propose
that
> we start from the following baseline text for security requirements. I
think
> this text very clearly and explicitly brings out the security issues
> involved. If any additional statements are needed we can fill them in.
Sorry
> to repeat this, but I did not see any reference to earlier discussion
on
> this text in Hesham's email.
>
> "Solution to CAR discovery  MUST address the security concerns
involved in
> the various aspects such as GAAR discovery, capability exchange and
CAR
> selection. In particular,
>
> a) The solution MUST provide means for an AR to to verify that another
AR
> claiming to be its GAAR is genuine. In other words, the other AR is
indeed a
> GAAR and it is an authentic router. The authenticity of a router MAY
mean
> that it is authorized to act as an access router by the jurisdiction
of the
> environment (operator network, organizatoinal LAN, home network etc.)
that
> the router resides in.
>
> b)It MUST provide means for secure capability exchange between an AR
and its
> GAAR.
>
> c)It MUST provide secure means for the expression of MN requirements
to CAR
> selection algorithms."
>
> Regards,
> Hemant
>
> >From: "James Kempf" <[email-masked]>
> >To: "Hesham Soliman \(ERA\)" <[email-masked]>,
> >"'Govind Krishnamurthi'" <[email-masked]>, <[email-masked]>
> >Subject: Re: [Seamoby] comments on CAR Discovery Requirements
> >Date: Thu, 14 Mar 2002 14:34:29 -0800
> >
> >Hesham,
> >
> > >   > Re. the comments on security, maybe we need a more
> > >   > comprehensive threat
> > >   > analysis such as Claude did for paging?
> > >   > The requirement I did was pretty generic.
> > >
> > > => Agreed. No need for a separate doc. This
> > > is what I was hinting at when I said 'I can try'.
> > > Because this is something that will take time.
> > >
> >
> >Good, let's talk about this in the Minne-apple.
> >Maybe we can get together a small group
> >of volunteers to help. It should
> >not take much time, and I agree that we
> >don't need a separate document, but
> >I think we need something more than
> >we have now.
> >
> >             jak
> >
> >
> >_______________________________________________
> >Seamoby mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/seamoby
>
>
> _________________________________________________________________
> Join the world's largest e-mail service with MSN Hotmail.
> http://www.hotmail.com
>
>
> _______________________________________________
> Seamoby mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/seamoby
>

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "Eunsoo Shim" <[email-masked]>
Date: Sat, 16 Mar 2002 16:05:27 -0800

Hemant,

I think it is very difficult to verify that the AR claiming to be a GAAR is
indeed a GAAR even though it is very desirable. So I'd be reluctant to put
it as a requirement.
I have no problem about verifying the authenticity of a router.

> > GAAR and it is an authentic router.

Thanks.

Eunsoo

---

From: "Eunsoo Shim" <[email-masked]>
Date: Sat, 16 Mar 2002 16:05:27 -0800

Hemant,

Thanks.

Eunsoo

---

From: "Eunsoo Shim" <[email-masked]>
Date: Sat, 16 Mar 2002 18:34:43 -0800

I mean the purpose of security is to verify the authenticity of the message
sender and the integrity of the message rather than the correctness of the
information contained in the message. I think whether the claimed GAAR is
indeed a GAAR is about the correctness of the information.
Thanks.

Eunsoo

---

From: "Eunsoo Shim" <[email-masked]>
Date: Sat, 16 Mar 2002 18:34:43 -0800

Eunsoo