Subject: RE: [Seamoby] Dormant Mode Location Tracking by Mobility Protocol Issues

From: [email-masked]
Date: Fri, 1 Mar 2002 10:39:33 -0600

Yoshi,

>Why do you exclude a simple-ip host that is not plugged into the power
source? Moreover, why should we ignore power saving for plugged-in hosts?

There is no incentive to try to save power for stationary or plugged-in hosts.There is no useful (business) case so far.

>DMHA for simple-ip is required for stationary dormant hosts not to 
spend power (battery or plugged-in power) for processing unimportant 
packets (thus filtering trigger packets is necessary for DMHA).

If I understand you correctly, you want to use DMHA as an "application layer" protocol for stationary (non mip) hosts for selective packet filtering. I completly agree with you on this packet filtering concept in home and small office environments when you use gateways or application servers.  But this is handled elsewhere (IMPP) and their problem statement is even more general that they handle different modes for the hosts (including idle/dormant) and have defined application layer protocol/extensions for this.   Trying to achieve the same in Seamoby WG would be a big waste.  Moreover, packet filtering was never in the requirements!!

So the emphasis is on power saving and for mobile hosts.

>Now one important requirement is going to be compromized, 
independence of any mobility management protocol.  I disagree.

DMHA is not useful for non-mobile hosts, atleast not as much as it is required for the mobile hosts. So defining a protocol by just taking that requirement into account would violate req. 4.8 (support for existing MIP), anyways. Hence, we are trying to debate on the weight of this requirement. 

Regards,
Srini

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Fri, 1 Mar 2002 09:05:05 -0800

Srini,

> There is no incentive to try to save power for stationary or
plugged-in hosts.There is no useful (business) case so far.

Last spring during the height of California's power crisis, power use in
the state dropped by 10% because people started buying compact
fluorescent bulbs and took other power saving measures. The reason they
did this is beause the cost of electricity went up by a factor of 10
over the previous year. My own electricity bill dropped by about 30 kWH
a month for the same reason. If IP paging can help in reducing power
costs, then I think there is a big business reason for having it, to say
nothing of the CO2 and pollution saving.

            jak

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 1 Mar 2002 12:40:56 -0500

> There is no incentive to try to save power for stationary or plugged-in hosts.There is no useful (business) case so far.

This is wrong.  There is a business so far for supporting a kind of
DMHA for stationary hosts, MagicPacket, unfortunately it is not
standardized one.

Furthermore, I don't understand why a DMHA protocol design is affected 
by whether a host is plugged-in powered or battery powered.

> If I understand you correctly, you want to use DMHA as an "application layer" protocol for stationary (non mip) hosts for selective packet filtering. I completly agree with you on this packet filte…

This is also wrong.  There is a requirement for filtering in RFC3154:

4.3. Control of Broadcast/Multicast/Anycast

   The protocol SHOULD provide a filter mechanism to allow a Host prior
   to entering dormant mode to filter which broadcast/multicast/anycast
   packets active a page.  This prevents the Host from awakening out of
   dormant mode for all broadcast/multicast/anycast traffic.

In addition, IMPP is only for instant messaging, not for hosts that
does not have instant messaging but requires DMHA.

> DMHA is not useful for non-mobile hosts, atleast not as much as it is required for the mobile hosts. So defining a protocol by just taking that requirement into account would violate req. 4.8 (supp…

Then, could you explain how draft-ohba, for example, violates
req. 4.8?

> Srini

Yoshihiro Ohba