Subject: RE: [Seamoby] Examples of CAR discovery

From: "Hemant Chaskar" <[email-masked]>
Date: Tue, 26 Mar 2002 19:53:48

Hi Hesham:

Why do you think that anybody is trying to remove MN from loop? On the 
contrary, we are giving even more control to MN of deciding whether it wants 
to receive all the information, a part of it or none.

This fits well in line with giving end host absolute control over CAR 
discovery. If we do not have that extension to requirement, it seems that 
network is assuming on behalf of MN that MN does need all this information, 
when MN actually chooses not to. Of course, nothing prevents us from having 
a default case of blasting MN with all GAARs and their requirements.

Blindly blasting MN with requirements looks very inefficient to me. Further, 
this will in the future considerably restrict the detailedness of capability 
information that we can to consider.

Finally, you said below that MN can ignore it. But then, why spend wireless 
bandwidth and MN processing power (it takes processing power to ignore too) 
to receive unwanted information.

BR,
Hemant

>From: "Hesham Soliman (ERA)" <[email-masked]>
>To: "'Hemant Chaskar'" <[email-masked]>, [email-masked]
>Subject: RE: [Seamoby] Examples of CAR discovery
>Date: Tue, 26 Mar 2002 19:24:19 +0100
>
>   > This looks good to me, but with a small attention to detail:
>   >
>   > What if MN does not want to receive such information or
>   > does not want to
>   > receive a part of it. Then, CAR discovery should not blast
>   > it on MN.
>
>=> The MN will ignore it if it doesn't
>need it.
>
>  To
>   > avoid this, we can slightly rephrase it as:
>   >
>   > "The CAR discovery protocol MUST provide the MN with GAAR
>   > information, along
>   > with capabilities, *whenever and as required by MN*."
>   >
>=> I disagree this is a very strange
>argument for removing the MN from the loop.
>How does the AR know ?? Do we have to invent
>another protocol that the MN should implement
>to say no ?!
>
>Can we please make this simple?
>
>Hesham

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Tue, 26 Mar 2002 13:34:51 -0800

Hemant,

Premature optimization is never such a good idea. Let's leave it until
later. Main issue is that the MN gets the CAR info and makes the TAR
decision for ITHO.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Tue, 26 Mar 2002 13:34:51 -0800

Hemant,

            jak