Subject: Re: [Seamoby] Comments on the requirements draft

From: "Hemant Chaskar" <[email-masked]>
Date: Tue, 26 Mar 2002 17:37:14

Hi:

I think the main discussion issue that resulted in this email was:

What is the cost of scanning APs on other connection (this involves link 
establishment, authentication as you said, obtaining IP address, receiving 
capabilities). Note that, all this work (and associated power) will be 
wasted if the user does not like the capabilites at the end of day. Please 
let us know if you think this to be a relevant consideration at all.

Please ignore my comment about 3 or more APs.

Hemant

>From: "Michael A. Ramalho" <[email-masked]>
>To: "James Kempf" <[email-masked]>,        "Hemant Chaskar" 
><[email-masked]>, <[email-masked]>
>Subject: Re: [Seamoby] Comments on the requirements draft
>Date: Tue, 26 Mar 2002 11:14:13 -0500
>
>At 01:59 PM 3/25/2002 -0800, James Kempf wrote:
>
>> > Just to be ultra clear - Luxury of two interfaces is not a generic
>> > assumption for CAR discovery problem formulation. Two-connection WLAN
>>card
>> > is good for 2 APs, but what if there are 3 or 4 or 5 APs.
>> >
>
>This may sound like a stupid statement for some .... but even a single
>WLAN card can scan during periods of (relative) inactivity to search for
>beacons of other APs.
>
>Given this ability/possibility (depends on how the drivers were written),
>one would assume that two cards are more than enough to search
>for the (next) highest signal quality AP it can authenticate (or get
>required QoS) on. Thus while maintaining an existing session
>on one card  - you try to authenticate on the next best AP (in some
>sense, perhaps S/N, SSI, etc). Note that a "two association" SINGLE
>WLAN card may be possible in the future with "fast-retunable" WLAN
>cards - but it is clearly doable today with two cards. You only need
>to define heuristics for your MNs (e.g., default routes, etc.) to send
>the packets to/from the preferred association.
>
>So ... why exactly doesn't the two WLAN card case handle an
>arbitrary number of potential APs?
>
>
>>Does the MN have different interface cards for each or are they the
>>same?
>>
>>             jak
>>
>>
>>
>>
>>_______________________________________________
>>Seamoby mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/seamoby
>
>
>Michael A. Ramalho, Ph.D.
>Office email: [email-masked]
>Personal email: [email-masked]
>Office: +1.732.449.5762
>Cell: +1.732.809.0188
>
>
>_______________________________________________
>Seamoby mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/seamoby

_________________________________________________________________
Join the world’s largest e-mail service with MSN Hotmail. 
http://www.hotmail.com

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "Michael A. Ramalho" <[email-masked]>
Date: Tue, 26 Mar 2002 21:01:31 -0500

At 05:37 PM 3/26/2002 +0000, Hemant Chaskar wrote:
>capabilities).

No. The scanning only involves "listening". *IF* you decide that the candidate
is worth pursuing, then - and only then - do you waste (the more significant)
transmit power to associate/authenticate/etc...

So ... if you are on an AP with strong S/N and you hear 4 other
candidate APs that have poor S/N ... you will probably do nothing
terribly power consuming .... perhaps a re-scan with relatively
long inter-scan times. If the S/N is tanking on the link you are
using ... then you may want to look harder (scan more
often) ... and even try to associate with other APs before the
one you are on dies.

I see very little extra power being consumed if you connection
has relatively high S/N. Also remember that the receiver takes much
less power than the transmitter (details vary ... but less than 1/3 of
the total power I think is typical ... someone from a WLAN
manufacturer, like Flarion, might want to provide a more
precise estimate).

>Note that, all this work (and associated power) will be wasted if the user 
>does not like the capabilites at the end of day.

The heuristics driving the above decisions is simply an optimization
problem that trades off the availability/seamlessness of your connection
with the (optimization-based) "cost" of the extra power consumption. Different
strokes for different folks .... and thus another reason for the MN to decide.

>Please let us know if you think this to be a relevant consideration at all.
>

ACK

Hope this helps,

Michael Ramalho

>Join the world's largest e-mail service with MSN Hotmail. 
>http://www.hotmail.com
>
>

---

From: "Michael A. Ramalho" <[email-masked]>
Date: Tue, 26 Mar 2002 21:01:31 -0500

ACK

Hope this helps,

Michael Ramalho