Subject: Re: [Seamoby] Examples of CAR discovery

From: "Hemant Chaskar" <[email-masked]>
Date: Tue, 26 Mar 2002 17:19:07

Hi James:

This looks good to me, but with a small attention to detail:

What if MN does not want to receive such information or does not want to 
receive a part of it. Then, CAR discovery should not blast it on MN. To 
avoid this, we can slightly rephrase it as:

"The CAR discovery protocol MUST provide the MN with GAAR information, along 
with capabilities, *whenever and as required by MN*."

BR,
Hemant

>From: "James Kempf" <[email-masked]>
>To: "Hemant Chaskar" <[email-masked]>, <[email-masked]>
>Subject: Re: [Seamoby] Examples of CAR discovery
>Date: Tue, 26 Mar 2002 08:33:18 -0800
>
>Hemant,
>
>I prefer wording that specifically requires the MN to be involved in
>getting the CAR information. Thus:
>
>     The CAR discovery protocol MUST provide the MN with GAAR
>information, along with capabilities.
>
>This is clear and unambiguous about what network entity is in control
>during an intertechnology handover.
>
>             jak
>
>----- Original Message -----
>From: "Hemant Chaskar" <[email-masked]>
>To: <[email-masked]>
>Sent: Monday, March 25, 2002 9:32 PM
>Subject: Re: [Seamoby] Examples of CAR discovery
>
>
> > Hi:
> >
> > Some comments below:
> >
> >
> > >From: "James Kempf" <[email-masked]>
> > >To: "Eunsoo Shim" <[email-masked]>, <[email-masked]>
> > >Subject: Re: [Seamoby] Examples of CAR discovery
> > >Date: Mon, 25 Mar 2002 11:03:08 -0800
> > >
> > > > Please just let me remind you that the CAR discovery protocol also
> > >provides
> > > > mapping of L2 ID to IP address of the new AR which is necessary
>for
> > >the
> > > > low-latency handoff mechanism proposed in the MobileIP WG. So
>there is
> > >a
> > > > case CAR discovery is helpful for single technology handovers.
> > > >
> > >
> > >OK, so what you are saying is that there are two cases:
> > >
> > >1) Provding the MN with CAR information on what choices are available
> > >or, possibly, when the MN moves into an area where a new choice is
> > >possible, like moving into a hot spot area, for MNs that have
>multiple
> > >interfaces.
> > >
> > >2) Providing the AR with reverse address translation for CARs for MNs
> > >that have single interfaces and want fast handover support.
> > >
> >
> > >I agree.
> > >
> > >I don't get the feeling that these two cases are clearly delineated
>in
> > >the requirements. In fact, they seem to me like they are really two
> > >separate protocols.
> >
> > [HC] From the requirements perspective, what all the recent discussion
>is
> > about is probably the following requirement text (with supporting line
>that
> > CAR discovery is about comparing MN's requirements with GAAR
>capabilities
> > and slecting CARs from GAARs):
> >
> > "CAR discovery output MUST be retrievable, possibly selectively, by
>MN".
> > Also, I assume that there will the the following requirement as well
>(I
> > think that this was posted before IETF53 and I also saw some WG
>members
> > endorse it in IETF53 meeting): "MN requirements MUST be made available
>for
> > CAR discovery".
> >
> > This would mandate a CAR discovery functionality as follows:
> >
> > MN Requirements --(parameters)--> CAR Discovery Module --(output)-->
>MN
> >                                        ^
> >                                        |
> >                                        |
> >                          Capability information about GAARs
> >
> > Again, "CAR discovery module" can reside completely in MN, completely
>in AR
> > or combination depending upon environment, availability of
>multiplicity of
> > interfaces with MN etc. Further, the nature of MN requirements input
>and
> > corresponding output depends upon the environement in which CAR
>discovery is
> > being used. Also, whether the solution is organized into seperate
>protocols
> > or single protocol is a solution-specific aspect.
> >
> > (Note: The first requirement in requiremnet spec already says the
>address
> > translation part. We can keep it so given its importance for
>fast/seamless
> > handoffs, though it can be subsumed into above generic model (with
>"one
> > parameter = L2 id", "one capability information about GAARs = L2 to IP
>addr.
> > maps" and "output=IP address of CAR").)
> >
> > >
> > > > I understand the IETF is pro-end-point-control. Anyway, regarding
>your
> > > > question, couldn't we imagine a case when a network provider wants
>do
> > >a kind
> > > > of load-balancing between different access networks in the
>wireless
> > >overlay
> > > > network?
> > > >
> > >
> > >Sure, but I think that's a very special case. The more general case
>(and
> > >in fact, the case that is showing up *today*) is that one network
> > >provider owns one medium and the other another. Example: at the
>airport,
> > >the cellular provider owns the CDMA network and some WLAN provider
>owns
> > >the WLAN network.
> >
> > [HC]There is a concept of operator owned WLAN that is actually
>catching up.
> > Some systems are already rolled out in Europe if I am not mistaken.
>So, both
> > cases are very important - two media owned by two operators and two
>media
> > owned by single operator.
> >
> > BR,
> > Hemant
> >
> > _________________________________________________________________
> > MSN Photos is the easiest way to share and print your photos:
> > http://photos.msn.com/support/worldwide.aspx
> >
> >
> > _______________________________________________
> > Seamoby mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/seamoby
> >
>

_________________________________________________________________
Join the world’s largest e-mail service with MSN Hotmail. 
http://www.hotmail.com

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Tue, 26 Mar 2002 12:49:54 -0800

Sounds fine to me.

            jak

----- Original Message -----
From: "Hemant Chaskar" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, March 26, 2002 5:19 PM
Subject: Re: [Seamoby] Examples of CAR discovery

> Join the world's largest e-mail service with MSN Hotmail.
> http://www.hotmail.com
>
>

---

From: "James Kempf" <[email-masked]>
Date: Tue, 26 Mar 2002 12:49:54 -0800

Sounds fine to me.

            jak