Subject: Re: [Seamoby] Comments on the requirements draft

From: "Hemant Chaskar" <[email-masked]>
Date: Mon, 25 Mar 2002 17:34:19

Hi Teemu and James:

Just to be ultra clear - Luxury of two interfaces is not a generic 
assumption for CAR discovery problem formulation. Two-connection WLAN card 
is good for 2 APs, but what if there are 3 or 4 or 5 APs.

- Hemant

>From: "James Kempf" <[email-masked]>
>To: "Teemu Rinta-aho" <[email-masked]>
>CC: <[email-masked]>
>Subject: Re: [Seamoby] Comments on the requirements draft
>Date: Mon, 25 Mar 2002 08:54:45 -0800
>
>
> > I am not a layer 2 expert, but wouldn't that require that the
>interface
> > first does a layer 2 handover from the old access point to the new one
> > before anything can be done at the IP layer? And at that point all
> > communications going through the old AP/AR would cease... At least I
>don't
> > know any WLAN card or other L2 device that could attach to several
>access
> > points simultaneously.
> >
> > I thought CAR protocol was to be useful also in cases where you have
>only
> > one interface and you want to keep track of the CARs to make fast
> > handovers?
> >
>
>No, the assumption in this case is that the MN has *two* interfaces, for
>example, a cellular interface and a Bluetooth or WLAN interface. It
>could solicit the RA on one interface while the other had a full up
>connection.
>
>In the single interface case, you are right.
>
>         jak
>
>
>PS: there is a company in Japan that has announced a WLAN card allowing
>the interface to be on two channels at once. But that is not relevent to
>the current discussion.
>
>
>_______________________________________________
>Seamoby mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/seamoby

_________________________________________________________________
MSN Photos is the easiest way to share and print your photos: 
http://photos.msn.com/support/worldwide.aspx

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Mon, 25 Mar 2002 13:59:45 -0800

> is good for 2 APs, but what if there are 3 or 4 or 5 APs.

Does the MN have different interface cards for each or are they the
same?

            jak

---

From: "James Kempf" <[email-masked]>
Date: Mon, 25 Mar 2002 13:59:45 -0800

jak

---

From: Teemu Rinta-aho <[email-masked]>
Date: Tue, 26 Mar 2002 09:50:32 +0200 (EET)

> is good for 2 APs, but what if there are 3 or 4 or 5 APs.

Yes, I agree on that! I agree that the CAR discovery should work in
cases where there is only one interface in the MN which can only be
connected to one AP at a time.

BR,
Teemu

-- 
Teemu Rinta-aho                    Tel: +358 9 299 3078
NomadicLab, Ericsson Research      Fax: +358 9 299 5055
Oy L M Ericsson Ab                 Mobile: +358 40 562 3066
FIN-02131 Espoo, Finland           E-mail: [email-masked]

---

From: Teemu Rinta-aho <[email-masked]>
Date: Tue, 26 Mar 2002 09:50:32 +0200 (EET)

BR,
Teemu

---

From: "Michael A. Ramalho" <[email-masked]>
Date: Tue, 26 Mar 2002 11:14:13 -0500

> > is good for 2 APs, but what if there are 3 or 4 or 5 APs.

This may sound like a stupid statement for some .... but even a single
WLAN card can scan during periods of (relative) inactivity to search for
beacons of other APs.

Given this ability/possibility (depends on how the drivers were written),
one would assume that two cards are more than enough to search
for the (next) highest signal quality AP it can authenticate (or get
required QoS) on. Thus while maintaining an existing session
on one card  - you try to authenticate on the next best AP (in some
sense, perhaps S/N, SSI, etc). Note that a "two association" SINGLE
WLAN card may be possible in the future with "fast-retunable" WLAN
cards - but it is clearly doable today with two cards. You only need
to define heuristics for your MNs (e.g., default routes, etc.) to send
the packets to/from the preferred association.

So ... why exactly doesn't the two WLAN card case handle an
arbitrary number of potential APs?

>Does the MN have different interface cards for each or are they the

Michael A. Ramalho, Ph.D.
Office email: [email-masked]
Personal email: [email-masked]
Office: +1.732.449.5762
Cell: +1.732.809.0188

---

From: "Michael A. Ramalho" <[email-masked]>
Date: Tue, 26 Mar 2002 11:14:13 -0500