Subject: [Seamoby] MN in charge: What does this mean?

From: "Govind Krishnamurthi" <[email-masked]>
Date: Wed, 27 Mar 2002 13:54:00 -0500

Maybe we should clarify first what it means to say that the MN is in charge. 
Making some computations in the network rather than the MN while
fully taking care of the MN's requirements does not mean that the MN is
not in charge is it? This is essentially done for various constraints,
which we have listed out ad nauseam.. so let me not repeat that again.

Thanks,
Govind

_________________________________________________________________
Join the world’s largest e-mail service with MSN Hotmail. 
http://www.hotmail.com

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 27 Mar 2002 20:00:07 +0100

> not in charge is it?

=> People are questioning this assumption that
the MN will pass some magic profile which
will allow the AR to know so much about the 
MN, without breaking privacy, AND still 
scale.... just give us some examples pleaaase.

 This is essentially done for various 
  > constraints,

=> Sorry but your earlier constraints are not 
agreeable to all of us. In umts today, there are
concersn about how often an RA should be sent, so
people will just deal with that. If you carry the 
information in an RA, then you\re reusing an already 
existing mechanism with its pros and cons. Nothing
new added here.

Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 27 Mar 2002 20:00:07 +0100

Hesham

---

From: "Govind Krishnamurthi" <[email-masked]>
Date: Wed, 27 Mar 2002 14:09:40 -0500

Hesham,
>scale.... just give us some examples pleaaase.

[Govind] You feel that the requirements cannot be made available to the
AR, which I don't necessarily agree. But apart from that what
do you think about the intial question about what does it mean that the
MN is in charge?

>existing mechanism with its pros and cons. Nothing
[Govind] Well it is agreeable to some of us.. thats a start :)
First regarding putting capabilities on the RAdv, whether this
is feasible or not depends on the nature of capabilities and what
they are. The Issues draft lists out several possibilities for capabilities. 
Is it possible for you take a look at that?
So dependent on granularity that you want to support on each of
these capabilities you may have to send it more frequently than
a RAdv. Also to receive a RtrAdv you have to be connected to the AP 
connected to that AR. But if you have several APs connected to different
ARs then how are you going to monitor all of them?

---

From: "Govind Krishnamurthi" <[email-masked]>
Date: Wed, 27 Mar 2002 14:09:40 -0500

Hesham,

---

From: "Govind Krishnamurthi" <[email-masked]>
Date: Wed, 27 Mar 2002 15:31:24 -0500

James,
I think the main point of contention is that why I started this thread.
What you say that the MN MUST physically get all the GAARs and their
capabilities. I think that is a little to restrictive. I don't think
that is necessary to accomplish the goal. I think the reason why
we are coming back to this requirement is because I guess we don't
see eye to eye on this :). But I sure hope we can soon.

Regards,
Govind.

>
>Govind,
>
>What about the requirement I posted:
>
>     The CAR discovery protocol MUST provide the MN with GAAR
>     information, along with capabilities.
>
>Exactly how this is implemented is solution space and therefore out of
>scope for the requirements.
>
>We keep coming back to this. :-)
>
>             jak

_________________________________________________________________
MSN Photos is the easiest way to share and print your photos: 
http://photos.msn.com/support/worldwide.aspx

---

From: [email-masked]
Date: Wed, 27 Mar 2002 15:51:06 -0500

James,

[DOT] The MN being 'in charge' should not imply that it receives information 
it probably doesn't need. MN 'in charge' can also mean that it can express what 
information it wants to receive. After receiving information, the MN is still 
'in charge' of the final decision though.

[DOT] Just to make some progress on this issue, may I propose the following wording:
    The CAR discovery protocol MUST provide the MN with GAAR
    information, along with capabilities. The information provision
    MUST/SHOULD avoid the transmission of unnecessary information.

[DOT] Does this accomplish your efficiency statement?

Dirk

---

From: [email-masked]
Date: Wed, 27 Mar 2002 16:03:47 -0500

James,

So propose a requirement that you think addresses our concerns. I've
proposed what I like, and from the response there look as if at least 2
and possibly 4 other working group members agree with me. There is
clearly a contingent of people that have spoken on the list who do not
agree with the way the current requirement is phrased, and I've gotten
private email from some people who can't speak out on the list but agree
with our position.

[DOT] Frankly, private emails are of no concern to the WG. However, please
have a look at my wording that addresses the avoidance of unnecessary 
information provision. This is the key issue at stake that is controversial
among a set of people that spoke out on the list.

Dirk

---

From: [email-masked]
Date: Wed, 27 Mar 2002 16:03:47 -0500

James,

Dirk

---

From: "Govind Krishnamurthi" <[email-masked]>
Date: Wed, 27 Mar 2002 16:03:51 -0500

James,
There have been several who haven't agreed too.
Regarding others who don't essentially make their opinions here on the list. 
Do we really have to take them  into consideration? I could point out 
several like that too, is it not? I really hope we don't go in that
direction.

I would think of making this sending the info the MN as an option requested 
by the MN as proposed by Hemant is a good start. It takes
care of your case when the MN wants it and it takes care of our case
when the MN does not also. What do you think?

Regards,
Govind.

_________________________________________________________________
Chat with friends online, try MSN Messenger: http://messenger.msn.com

---

From: "Govind Krishnamurthi" <[email-masked]>
Date: Wed, 27 Mar 2002 16:03:51 -0500

James,

Regards,
Govind.

---

From: "Govind Krishnamurthi" <[email-masked]>
Date: Wed, 27 Mar 2002 16:09:42 -0500

David,
I will be very happy to accept that this is a mis-interpretation
on my behalf if that is the case. Advance apologies if that is the case.

I thought that was the main point of contention with all the bandwidth
and power constraint discussion. Maybe if you point out to me
why th "MUST provide MN with GAAR and capabilities"
does not imply  transmitting  this
information over the wireless interface to the MN (always), then
maybe it would be more clear to me.

Regards,
Govind.

>I've been lurking for most of this thread, but I really have to stop
>now and ask where you are getting the extra text that you are paraphrasing.
>
>I see "MUST provide the MN with GAAR information".
>
>You paraphrase, "MUST physically get all the GAARs and their capabilities".
>
>I think if you re-read Jim's sentence, you'll see that you are somehow
>misunderstanding it.
>
>Personally, I say leave the line as it is.
>
>-Dave
>
>On Wednesday, 27 Mar 2002, Govind Krishnamurthi wrote:
> > James,
>--
>David Frascone
>                   Black Holes are Out of Sight
>

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com

---

From: "Govind Krishnamurthi" <[email-masked]>
Date: Wed, 27 Mar 2002 16:09:42 -0500

David,

Regards,
Govind.

---

From: "Hemant Chaskar" <[email-masked]>
Date: Wed, 27 Mar 2002 22:07:36

Hi James:

Count me on the agreement side for the requirement you have proposed as 3.4 
and 3.x.

I don't mean to nitpick, but one small thing. Can we say network "resources" 
instead of "bandwidth". Resources will include MN power too, as MN is a part 
of network anyway. But, I don't mean to stimulate discussion on this issue. 
We can move along without that if you think this is too much attention to 
detail.

BR,
Hemant

----------------------------------snip-------------------------------

>
>How about:
>
>         3.4 The CAR discovery protocol MUST provide the MN with GAAR
>information along with capabilities.
>
>         3.x The CAR discovery protocol MUST make efficient use of the
>network bandwidth and SHOULD avoid the transmission of unnecessary
>information.
>
>This puts both aspects of efficiency in one statement.
>
>             jak
>
---------------------------------------------------------------------

---

From: "Hemant Chaskar" <[email-masked]>
Date: Wed, 27 Mar 2002 22:07:36

Hi James:

BR,
Hemant

---

From: "Govind Krishnamurthi" <[email-masked]>
Date: Wed, 27 Mar 2002 17:17:20 -0500

Hello all,
If this is settled, I will incorporate these changes into
the requirement draft.

Thanks,
Govind.

>Join the world?s largest e-mail service with MSN Hotmail.
>http://www.hotmail.com
>
>

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 28 Mar 2002 17:48:32 +0100

I agree with the text James sent below. 

Cheers,
Hesham

  > -----Original Message-----
  > From: James Kempf [mailto:[email-masked]]
  > Sent: Thursday, March 28, 2002 12:29 AM
  > To: Govind Krishnamurthi; [email-masked]
  > I would say "provisionally." The Europeans are off line at 
  > the moment,
  > so we may see some traffic tomorrow when they are back up.
  > 
  > I will post these under a separate heading.
  > 
  >             jak
  > 
  > Sent: Wednesday, March 27, 2002 2:17 PM
  > > >Count me on the agreement side for the requirement you 
  > have proposed
  > as 3.4
  > > >and 3.x.
  > > >
  > > >instead of "bandwidth". Resources will include MN power 
  > too, as MN is
  > a
  > > >part
  > > >of network anyway. But, I don't mean to stimulate 
  > discussion on this
  > issue.
  > > >>         3.x The CAR discovery protocol MUST make 
  > efficient use of
  > the

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 28 Mar 2002 17:48:32 +0100

Cheers,
Hesham