Subject: RE: [Seamoby] Examples of CAR discovery

From: "Hemant Chaskar" <[email-masked]>
Date: Wed, 27 Mar 2002 01:04:46

Hi Henrik:

-------------------------------------snip------------------------------
> >
> > An example where such comparison may occur in network is when there is 
>only
> > one interface on MN and it can listen only to radio beacons of 
>surrounding
> > access points. This is similar to break-before-make handoff case. Here, 
>MN
> > cannot receive capabilities of GAARs without letting go the previous
> > connection. Do you think that such cases are not relevant and we should
> > exclude such cases right at the problem statement/requirements stage?
>
>I think that designing for the one access technology case will cripple
>the solution.

[HC] I do not understand your comment. Are you essentially saying that "This 
case is irrelevant for CAR discovery" or "Completely AR unassisted CAR 
discovery is optimal for this case too".

IMHO neither requirements nor problem statement should ignore any use cases. 
If they do, it should be explicitly stated so in the spec, so that designers 
are not misguided to apply solutions to cases for which they are not 
designed.

BR,
Hemant

>
>	Regards,
>		Henrik
>
>
>
>_______________________________________________
>Seamoby mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/seamoby

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "Henrik Levkowetz" <[email-masked]>
Date: Wed, 27 Mar 2002 02:28:25 +0100

> discovery is optimal for this case too".

No, i'm not saying this case is irrelevant, or that AR unassisted CAR discovery
is optimal ... for any case. I'm saying:

> are not misguided to apply solutions to cases for which they are not 

Nobody's ignoring any use cases. But if you focus on one sample to the
detriment of the rest, it will cripple your solution.

	Regards,
		Henrik

---

From: "Henrik Levkowetz" <[email-masked]>
Date: Wed, 27 Mar 2002 02:28:25 +0100

Regards,
		Henrik

---

From: Teemu Rinta-aho <[email-masked]>
Date: Wed, 27 Mar 2002 12:53:41 +0200 (EET)

Hi Henrik,

> I think that designing for the one access technology case will cripple

It is not clear to me what you mean with "one access technology". Do you
mean that the case where the MN has only one interface should not be
supported, or do you mean the people discussing the requirements assume
something about the underlying link-layer technology?

BR,
Teemu

-- 
Teemu Rinta-aho                    Tel: +358 9 299 3078
NomadicLab, Ericsson Research      Fax: +358 9 299 5055
Oy L M Ericsson Ab                 Mobile: +358 40 562 3066
FIN-02131 Espoo, Finland           E-mail: [email-masked]

---

From: Teemu Rinta-aho <[email-masked]>
Date: Wed, 27 Mar 2002 12:53:41 +0200 (EET)

Hi Henrik,

BR,
Teemu

---

From: "Henrik Levkowetz" <[email-masked]>
Date: Wed, 27 Mar 2002 12:14:25 +0100

> something about the underlying link-layer technology?

Neither.

The "one access technology case" is the case where your mobile node only
has one access technology, i.e. only one interface, and will not have more.

Designing for this case in particular, instead of designing for the general
case with multiple interfaces and technologies, will cripple our solution.

Designing for the general case will permit handling this special case,
and many many others.

	Regards,
		Henrik

---

From: Teemu Rinta-aho <[email-masked]>
Date: Wed, 27 Mar 2002 13:16:33 +0200 (EET)

> Designing for the general case will permit handling this special case,

OK. Thanks for the clarification. I agree with that.

---

From: Teemu Rinta-aho <[email-masked]>
Date: Wed, 27 Mar 2002 13:16:33 +0200 (EET)

---

From: "Henrik Levkowetz" <[email-masked]>
Date: Wed, 27 Mar 2002 12:14:25 +0100

Neither.

	Regards,
		Henrik