Subject: RE: [Seamoby] Dormant Mode Location Tracking by Mobility Protocol Issues

From: [email-masked]
Date: Fri, 1 Mar 2002 08:55:24 -0600

Hi Yoshi,

Please see my comment below. Thanks.

Rene Purnadi
Phone: +1 972.894.4897
Mobile: +1 972.342.3503
e-mail: [email-masked]

-----Original Message-----
From: ext Yoshihiro Ohba [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 6:30 PM
To: Sreemanthula Srinivas (NRC/Dallas)
Cc: [email-masked]; Purnadi Rene (NRC/Dallas);
[email-masked]; [email-masked]
Subject: Re: [Seamoby] Dormant Mode Location Tracking by Mobility
Protocol Issues

On Thu, Feb 28, 2002 at 05:11:57PM -0600, [email-masked] wrote:
> >>Are there any particular reason for de-emphasizing the need of DMHA
> for simple-ip?  I think the reason for using the word "DMHA" instead
> of "IP paging" is as a result of consideration of dormant simple-ip
> hosts as well as dormant mobile hosts.  We should also consider 
> simple-ip for the reason as I mentioned earlier.
> 
> Yes. When we talk about about simple-ip, we mean static hosts that are plugged into the power source which don't have any mobility built in them. Therefore, they don't require any dormancy. Please remember the first requirement for DMHA is to save power for lean terminals running on limited power (mobile, ofcourse). Now, can you exactly tell why we need DMHA for simple-ip?

Why do you exclude a simple-ip host that is not plugged into the power
source?

Moreover, why should we ignore power saving for plugged-in hosts?

DMHA for simple-ip is required for stationary dormant hosts not to 
spend power (battery or plugged-in power) for processing unimportant 
packets (thus filtering trigger packets is necessary for DMHA).

Paging does not come free. Some resources are used for paging. The justification of power saving (an other processing like you mentioned above) for plugged-in hosts must out weight the cost.

> 
> >>I don't understand why we need another paging apllication layer protocol 
> if we put the paging protocol as an application layer protocol. 
> 
> If we leave the simple-ip out (as we should),  it is only natural that paging protocol makes as an extension to the existing mobility protocol(s).  As of now, the applications (or application servers) are not aware of the mobility of the hosts.  For the same reason, paging protocol must be independent of the application layers above. 

Now one important requirement is going to be compromized, 
independence of any mobility management protocol.  I disagree.

We can create conceptual paging protocol that is independent of any mobility protocols, hence it fulfill 4.7. But, we also has to fulfill 4.8, therefore the working paging protocol should be an extension of the existing mobility protocol(s).

Yoshihiro Ohba

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Fri, 1 Mar 2002 08:21:39 -0800

> Instead of the term Simple IP we could say: Hosts that do not use MIP,
> they could be wireless or fixed. I do not think we should completely
> ignore paging support for these hosts.
> Having a design such that paging entities and their interactions are
> within a local network (Foreign network takes care of paging when MN
is
> in a visited network and Home network takes care of paging when MN is
at
> home) could provide a solution for both MIP hosts and Simple IP hosts
> (do not use MIP).
> The MAIN difference (not the only difference) between Simple IP
service
> and MIP service is the involvement of Home Agent (Home network, AAAH
> etc), so if we were to avoid anything to do with Home we could have a
> BASE solution that supports both hosts. To me, that BASE solution
should
> be Home - Independent.
> To have optimized solutions (whatever OPTIMIZED means), we would need
to
> use the base solution to come up with a solutions for Simple IP, MIPv4
> and MIPv6.
>

There is an assumption in the above that the mobility protocol is MIP.
The IRTF is
working on a micromobility routing protocol, and we would like the
paging solution
to work with that as well.

            jak

---

From: "Gary Kenward"<[email-masked]>
Date: Fri, 1 Mar 2002 12:06:46 -0500

Sorry, I just checked and noted that micromobility is listed under current
actives.

Gary Kenward

-------------------

I know that the micromobility problem was sent to the IRTF for
consideration,
but I had not heard of any decision by the IRTF routing working group to 
pursue it.

Have you heard of an official (or even unofficial) decision?

Gary Kenward

> From: [email-masked] 
> [mailto:[email-masked]]
> Sent: March 1, 2002 11:45
> To: [email-masked]; [email-masked]; 
> [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked]
> Subject: RE: [Seamoby] Dormant Mode Location Tracking by 
> Mobility Protocol Issues
> 
> 
> The IRTF is working on a micromobility routing protocol, and 
> we would like the
> paging solution to work with that as well.
> 
> 
> James, as it is, we have problems with existing requirements. 
> Now, you are bringing new requirements into the table. :)  
> 
> Please check the requirement 4.8.
> 
> 4.8. Support for Existing Mobility Protocols
> 
>    The IP paging protocol MUST specify the binding to the existing IP
>    mobility protocols, namely mobile IPv4 [2] and mobile IPv6 
> [3].  The
>    IP paging protocol SHOULD make use of existing 
> registration support.
> 
> Regards,
> Srini
>

---

From: [email-masked]
Date: Fri, 1 Mar 2002 15:51:07 -0600

>There is a particular Ethernet frame type defined in Intel's Wired For
Managment protocol that can be used to wake up a sleeping host. It was
defined as part of the government's Energy Star initiative. I think it
is now implemented by most NICs, including non-Intel ones. Most modern
operating systems have power management capabilities that allow
nonessential components, such as disk, screen, and even CPU, to be
turned off if not in use. The NIC card would be the only component that
is on.

This frame would serve as the L2 support for DMHA.

It is used for remote management of PCs for IT purposes. I cannot think of usage scenarios with DMHA.

---

From: [email-masked]
Date: Fri, 1 Mar 2002 18:12:06 -0600

>Can you explain why? If the host is fixed, all that is required is some
signal at L2 that causes the power management hardware to spin up the
disk and turn on the CPU.

It will certainly work to wake up the host. Anyway, if you feel that such problems are within the Seamoby charter then it is fine. However, I woould like to bring the following charter item description for DMHA.

Dormant Mode Host Alerting 

Third, the Working Group will define the requirements for Dormant Mode Host Alerting (DMHA) at the IP layer (also known as IP Paging) in networks, and a protocol will be developed to tackle this problem. DMHA is typically used in networks that support mobile devices that periodically enter dormant mode to reduce power consumption. DMHA enable network devices to track a mobile that has moved from its last point of attachment, while in dormant mode, allowing the mobile's packets to be delivered. 

All work produced by the Working Group will support both IPv4 and IPv6, will follow the congestion control principles in RFC2914 (BCP41), and will undergo a security review prior to WG last call. Protocols developed will be accompanied by MIBs. 

The Working Group will coordinate closely with the aaa, mobileip, pilc, and rohc working groups.