Subject: RE: [Seamoby] CAR Discovery Requirements

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Fri, 15 Mar 2002 16:57:22 -0600

Hi Dirk,

I think it is sufficient to point out that the CAR disc protocol
needs to provide means of signaling the necessary input
for the selection process, including network capabilities
and MN's preferences (profile). 
My point was that:
Since the selection process is either done by MN or oldAR
in the old network, no external signaling is necessary, because
they are both aware of MN's preferences, unless CAR
is happening at a different network entity at the old network.
And I don't think CAR is performed at the target network either,
do you? 

Regards,
Madjid
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, March 14, 2002 10:51 AM
To: Madjid Nakhjiri; [email-masked]
Subject: RE: [Seamoby] CAR Discovery Requirements

Hi Madjid,

I'm not saying that MN's requirements have to be spelled out again.
'Means to express the requirements' includes some mechanisms to
define these requirements somehow and the means that they can be used
as an input to the CAR discovery protocol. It is certainly possible that
the first part is done by currently existing protocols, but the
requirement merely states that the means are mandatory for the
CAR discovery solution, otherwise it cannot fulfil its task.

Maybe, here's some confusion in general sometimes that the requirements
always mandate NEW functionality. This is not the case. The requirements
merely describe the functionality that is needed to do the job. Whether
or not this will be done in the final proposal by existing protocols,
modifications to existing ones, or new mechanisms is out of the scope
of the requirements. 

Regards,

Dirk

-----Original Message-----
From: ext Nakhjiri Madjid-MNAKHJI1 [mailto:[email-masked]]
Sent: Thursday, March 14, 2002 10:59 AM
To: Trossen Dirk (NRC/Boston); [email-masked]
Subject: RE: [Seamoby] CAR Discovery Requirements

Sorry for the late response,

isn't MN's requirement spelled out in MN's user profile or
SLA or something else recorded in the policy server of the
MN's network? why does the MN has to express them again.
if the new network needs it (I don't know why it would in 
a CAR selection), then it can get it from old network, if the
old network needs, it gets it from policy server.
I think what this should concentrate on is:

CAR discovery protocol MUST provide means for signaling 
parameters needed for a TAR selection mechanims (regardless
of whether it is done at MN or at AR). 

I know that the selection process is out of scope, but providing
input for it should be in scope. signaling MN's requirements for
service is a different issue.

Regards,

Madjid

"3.xx Providing MN's requirement for Determination of CARs

The fundamental task of CAR discovery is to determine candidate
access routers (from the set of GAARs) that meet MN's requirements,
if known at the time of handoff. A CAR discovery protocol MUST 
determine a set of CARs that meet MN's requirements. For this, 
a CAR discovery protocol MUST provide means for the MN to express 
these requirements."

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "Trossen Dirk \(NRC/Boston\)" <[email-masked]>
Date: Mon, 18 Mar 2002 10:09:13 -0500

Hi Madjid,

Indeed, this requirement deals with one of the possible inputs in the CAR
discovery. Since network capabilities are covered already in the
requirements
(capability exchange), I wanted to put MN's requirements in there. Whether
the involved entities are already aware of these or not is a matter of the
solution,
but most likely they are.

Regards,

Dirk

----- Original Message -----
From: "ext Nakhjiri Madjid-MNAKHJI1" <[email-masked]>
To: <[email-masked]>; "Nakhjiri Madjid-MNAKHJI1"
<[email-masked]>; <[email-masked]>
Sent: Friday, March 15, 2002 5:57 PM
Subject: RE: [Seamoby] CAR Discovery Requirements

---

From: "Trossen Dirk \(NRC/Boston\)" <[email-masked]>
Date: Mon, 18 Mar 2002 10:09:13 -0500

Hi Madjid,

Regards,

Dirk