Subject: RE: [Seamoby] CARD between Routers - will CT do?

From: [email-masked]
Date: Thu, 16 Jan 2003 12:55:44 -0500

Hi James:

One suggestion: Referring second diagram below, we could design CARD agnostic to intra or inter classification, but assuming that ARs can establish SAs. Then, we provide subsections on how this would be achieved for intra case and inter case. Of this first subsection will be ready first (as it is easier) and we continue to work on second subsection over time. What do you think?

Hemant

-----Original Message-----
From: ext James Kempf [mailto:[email-masked]]
Sent: Thursday, January 16, 2003 12:49 PM
To: Hemant Chaskar; [email-masked]; Chaskar Hemant
(NRC/Boston)
Cc: [email-masked]; [email-masked]
Subject: Re: [Seamoby] CARD between Routers - will CT do?

What do you mean by an SA? An IPSec SA? If so, how do you propose to have the
routers use that for checking that the AP L2 addresses provided by the MN map
into IP addresses that are authorized to route on the service provider's
network?

Note that the IESG is requiring that the Security Considerations of all protocol
drafts describe, precisely, how the protocol will be secured. It is no longer
sufficient to say "use IPSec" or "use AAA". Requiring other protocols is OK, but
it must be specified precisely how those protocols are used for securing the
protocol in question.

            jak

----- Original Message -----
From: "Hemant Chaskar" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Wednesday, January 15, 2003 8:24 PM
Subject: Re: [Seamoby] CARD between Routers - will CT do?

> Hi Daichi:
>
> I do not think that establishment of SA between ARs should be within scope
> of CARD. We should start from pre-requisite that SA can be established
> between ARs. When ARs belong to same domain, this is simple. When they
> belong to different domain it is harder. In either case, there can be
> variety of ways to establish SAs - pre-shared key, domain specific
> certificates, AAA, credentials exchanged during SLAs or any other means. Why
> should CARD put any restriction on mechanism used to establish SA?
>
> So, instead of
>
>                       <--Interworking-->
>                              |
>          Intra-domain CARD   |       Inter-domain CARD
>                protocol      |          protocol
>          --------------------|------------------------------
>          Intra-domain SA     |       Inter-domain SA
>            mechanism         |          mechanism
>         (CARD specific?)     |       (CARD specific?)
>
> I am saying that, if possible, we should try,
>
>
>
>                        CARD protocol
>          ----------------------------------------------
>                               |
>          Intra-domain SA      |      Inter-domain SA
>             mechanisms        |         mechanisms
>         current/future best   |   (current/future best
>             practices)        |          practices)
>
> At this point, I cannot vouch for security of MN-report-based CARD approach.
> But, could you describe what kind of attacks do you think MN-report-based
> CARD is vulnerable to? In draft-trossen-seamoby-dycard-00.txt, we have shown
> that certain simple mechanisms can foil security attacks in MN-report-based
> CARD (To the least, if MN tells new AR arbitrary IP address as address of
> old AR, it can be detected). Also, the side effect of attacks, if any, does
> not adversely affect good MNs. But, of course, we could have missed some
> attack possibilities.
>
>
> Hemant
>
> >From: Daichi Funato <[email-masked]>
> >To: [email-masked]
> >CC: <[email-masked]>, <[email-masked]>, <[email-masked]>
> >Subject: Re: [Seamoby] CARD between Routers - will CT do?
> >Date: Wed, 15 Jan 2003 19:10:15 -0800
> >
> >Hi Hemant,
> >
> > > Hemant --> I think we can start protocol design under the assumptions
> >that
> > > (i) old and new ARs can establish SA between them, (ii) they are willing
> >to
> > > participate in CARD protocol. Then, there may not be any need for
> >intra-domain
> > > / inter-domain classification.
> >
> >What kind of security mechanisms are you assuming?
> >I think we should not leave the security mechanisms out of the scope.
> >
> >Especially, MN-report-based CARD is vulnerable to an attacker.
> >How to protect the communication is an essential part of CARD, I think.
> >Actually, IEEE IAPP includes a security mechanism by itself.
> >Do we neglect that part in CARD?
> >
> >IMHO, if CARD can provide secure keys for ARs, these can be used by CT
> >and FMIP as well. This is another type of capability discovery.
> >What do you think?
> >
> >Best regards,
> >Daichi
> >
> >-------------------------------------------------------------
> >Daichi Funato <[email-masked]>
> >DoCoMo Communications Laboratories USA, Inc.
> >
> >Confidential Note:
> >Privileged/Confidential Information may be contained in this e-mail
> >and any attachment to it. Unless you are the addressee indicated in
> >this e-mail, please notify immediately the sender by reply e-mail
> >that you have received this in error and delete it from your system.
> >You may not use, copy or deliver this e-mail or any information
> >contained in this e-mail to anyone.  Thank you very much.
> >-------------------------------------------------------------
> >
> >_______________________________________________
> >Seamoby mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/seamoby
>
>
> _________________________________________________________________
> Add photos to your e-mail with MSN 8. Get 2 months FREE*.
> http://join.msn.com/?page=features/featuredemail
>
>

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Thu, 16 Jan 2003 10:49:52 -0800

I think the specification should say nothing about intra or inter. I think it
should just tell how an AR can verify that an AP identifier obtained by the AR
from an MN is connected to an AR IP address that is authorized to route.

            jak

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Thursday, January 16, 2003 9:55 AM
Subject: RE: [Seamoby] CARD between Routers - will CT do?

> Hi James:
>
> One suggestion: Referring second diagram below, we could design CARD agnostic
to intra or inter classification, but assuming that ARs can establish SAs. Then,
we provide subsections on how this would be achieved for intra case and inter
case. Of this first subsection will be ready first (as it is easier) and we
continue to work on second subsection over time. What do you think?

---

From: "James Kempf" <[email-masked]>
Date: Thu, 16 Jan 2003 10:49:52 -0800

jak