Subject: RE: [Seamoby] CARD between Routers - will CT do?

From: [email-masked]
Date: Wed, 15 Jan 2003 17:22:21 -0500

Hi Eunsoo:

See below.

-----Original Message-----
From: ext Eunsoo Shim [mailto:[email-masked]]
Sent: Wednesday, January 15, 2003 8:03 PM
To: James Kempf; Chaskar Hemant (NRC/Boston); [email-masked]
Subject: Re: [Seamoby] CARD between Routers - will CT do?

I certainly agree that the inter-provider CARD should be more tricky than
the intra-provider CARD case.
BTW, the example given by Hemant is the following in my understanding.

"The MN hands over from an AR of an ISP to an AR of another ISP
(inter-provider handoff).
Then the MN can remember the IP address of the previous AR ( AR of the
previous ISP) and inform it to the new AR (AR of the new ISP to which the MN
is currently attached). So regardless of the willingness of the ISPs, the MN
can distribute the IP addresses and L2 IDs of the ARs of one ISP to another
ISP."

Hemant --> I agree.

Now the question is how the AR can verify the information delivered by the
MN, in particular, about the ARs of a different ISP.
That is the key security problem we have to tackle. 

Hemant --> If ARs in two ISP domains have to co-operate, we may require some kind of handoff SLA between them. If that is given, then it is reasonable to assume that ARs in two ISP domains can establish SA between them. If ARs could establish SA between them (either because of same domain ownership or because of handoff SLA), one security measure could be that new AR  asks old AR if MN was indeed attached to it in a reasonable past (say 1 s). If old AR says yes, new AR and old AR conclude that they are physical neighbors exchange IP address to L2 ID mapping info and continue to exchange capability info. The subsequent MNs handing off between them get seamless handoff experience.

And this is the question
James asked me, I think.

Hemant --> I think we can start protocol design under the assumptions that (i) old and new ARs can establish SA between them, (ii) they are willing to participate in CARD protocol. Then, there may not be any need for intra-domain / inter-domain classification.

     Hemant 

In the case the two ISPs are cooperative, the problem becomes similar to
that of the intra-provider CARD.

If not, well, then, each ISP should decide what to do.
Since the IP address and the L2 IDs can be disclosed anyway, I think, the
ISPs can get more benefits by cooperating with each other to verify the
information delivered by the MN. So I'd suggest we work on the protocol
design assuming/requiring the cooperation first.

Eunsoo

----- Original Message -----
From: "James Kempf" <[email-masked]>
To: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Wednesday, January 15, 2003 1:16 PM
Subject: Re: [Seamoby] CARD between Routers - will CT do?

> The MN only knows the other router after it has a link connection with the
other
> ISP. And that typically requires the MN to negotiate an authentication
exchange
> with the other ISP's NAS.
>
> In the example, the MN can hear the other ISP's AP layer 2 id, but,
because it
> hasn't negotiated an authentication exchange, it cannot discover the
address of
> the router.
>
> The router in the current ISP's network doesn't learn the other ISP's
router at
> all.
>
> Anyway, I'm not saying necessarily that the topic of interprovider CARD
should
> not be examined at some point, I just think that the problem is harder
than
> intraprovider CARD, and so probably ought to wait.
>
>             jak
>
> ----- Original Message -----
> From: <[email-masked]>
> To: <[email-masked]>; <[email-masked]>; <[email-masked]>
> Sent: Wednesday, January 15, 2003 8:25 AM
> Subject: RE: [Seamoby] CARD between Routers - will CT do?
>
>
> > Hi James:
> >
> > In event of IP-layer handoff, at some point MN needs to know IP address
of
> router it is going to connect to. So, MN will know IP address of new AR,
latest
> after handoff.
> >
> > I am not sure if I understood your example below.
> >
> > Hemant
> >
> > -----Original Message-----
> > From: ext James Kempf [mailto:[email-masked]]
> > Sent: Wednesday, January 15, 2003 11:18 AM
> > To: Chaskar Hemant (NRC/Boston); [email-masked]; [email-masked]
> > Subject: Re: [Seamoby] CARD between Routers - will CT do?
> >
> >
> > > Hemant --> I  agree with you that CARD should not mess with Internet
routing
> > infrastructure. With Mobile IP, MN will know its old router and new
router.
> > Thus, information about their geographical adjacency is already exposed
to
> third
> > party. CARD should only be concerned about this information (however you
> > distribute it and use it) without impacting routing infrastructure in
any way.
> > CARD is an edge phenomenon.
> > >
> >
> > The MN only knows the AP identifier, it doesn't know the router.
> >
> > For example, suppose I have an MN with an 802.11b card and two hotspot
> > providers, in different ASs, are providing service in the airport I
happen to
> be
> > in: one does the United lounge and the other does the rest of the
airport. If
> I
> > am standing next to the United lounge and using the provider for the
rest of
> the
> > airport, my laptop may be able to see the BSSID for the United lounge
but it
> > won't know anything about the IP routing infrastructure, unless, of
course,
> CARD
> > or some other protocol tells it. Similarly, the routers in the other
provider
> > won't know anything about the routers in the United provider.
> >
> >             jak
> >
> >
> >
> >
>
>

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Daichi Funato <[email-masked]>
Date: Wed, 15 Jan 2003 19:10:15 -0800

Hi Hemant,

> Hemant --> I think we can start protocol design under the assumptions that 
> (i) old and new ARs can establish SA between them, (ii) they are willing to 
> participate in CARD protocol. Then, there may not be any need for intra-domain 
> / inter-domain classification. 

What kind of security mechanisms are you assuming?
I think we should not leave the security mechanisms out of the scope.

Especially, MN-report-based CARD is vulnerable to an attacker.
How to protect the communication is an essential part of CARD, I think.
Actually, IEEE IAPP includes a security mechanism by itself.
Do we neglect that part in CARD?

IMHO, if CARD can provide secure keys for ARs, these can be used by CT
and FMIP as well. This is another type of capability discovery.
What do you think?

Best regards,
Daichi

-------------------------------------------------------------
Daichi Funato <[email-masked]>
DoCoMo Communications Laboratories USA, Inc.

Confidential Note:
Privileged/Confidential Information may be contained in this e-mail
and any attachment to it. Unless you are the addressee indicated in 
this e-mail, please notify immediately the sender by reply e-mail 
that you have received this in error and delete it from your system.
You may not use, copy or deliver this e-mail or any information
contained in this e-mail to anyone.  Thank you very much.
-------------------------------------------------------------

---

From: Daichi Funato <[email-masked]>
Date: Wed, 15 Jan 2003 19:10:15 -0800

Hi Hemant,

Best regards,
Daichi

Confidential Note:

---

From: "James Kempf" <[email-masked]>
Date: Thu, 16 Jan 2003 09:22:19 -0800

> Hemant --> I think we can start protocol design under the assumptions that (i)
old and new ARs can establish SA between them, (ii) they are willing to
participate in CARD protocol. Then, there may not be any need for intra-domain /
inter-domain classification.

Alternatively, an intermediary that would be more acceptable, such as a Radius
server, could be used. My initial point is that the two providers don't want to
expose their internal topology, even if they have an SA allowing inter-provider
handover.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Thu, 16 Jan 2003 09:22:19 -0800

jak

---

From: Marco Liebsch <[email-masked]>
Date: Thu, 16 Jan 2003 18:56:40 +0100

James,

do you refer to server-based SA establishment for inter-domain case 
only, or for any case,
inter- as well as intra-domain CARD?

marco

---

From: Marco Liebsch <[email-masked]>
Date: Thu, 16 Jan 2003 18:56:40 +0100

James,

marco

---

From: Daichi Funato <[email-masked]>
Date: Wed, 15 Jan 2003 18:50:06 -0800

Hi Hemant,

IMHO, if CARD can provide secure keys for ARs, it can be used by CT
and FMIP as well. This is another type of capability discovery.
What do you think?

Best regards,
Daichi

Confidential Note:

---

From: Daichi Funato <[email-masked]>
Date: Wed, 15 Jan 2003 18:50:06 -0800

Hi Hemant,

Best regards,
Daichi

Confidential Note: