Subject: Re: [Seamoby] CARD issue#30: L2 type indicators to be assigned by IANA

From: Marco Liebsch <[email-masked]>
Date: Fri, 01 Aug 2003 11:04:04 +0200

Following James' proposal, we can check whether of not there are
already type indicators assigned, which can be re-used.
However, in case there are no proper values available,
is it preferred to drop this field or should we go for requesting
a sample of technology IDs (Ethernet, IEEE802.11b, ...)?
I think it could be reasonable to have this indicator in a
L2 ID, hence I support James' proposal to request an ID for
one or two technologies.

What do you think?

marco

Vijay Devarapalli wrote:

>I dont see any other option. IANA assignment is needed.
>otherwise how can the AR and the MN agree to the same
>type values for different types of interfaces?
>
>  
>
>>One of the comments to the L2 ID sub-option was that
>>"L2-type" identifiers need to be assigned by IANA.
>>Now, I assume that in case we ask IANA for type
>>identifiers, we need to give also a list of interface
>>types. This lists needs then to be extended later for
>>future technologies...
>>    
>>
>
>this means there is a fundamental problem. maybe you
>should remove the L2 type field from the L2_ID suboption.
>it is considered optional already. the Sub-Option Len
>can indicate the length of the L2 ID field.
>
>  
>
>>I am not sure if this is really required for the
>>experimental protocol. Take into account that using
>>the L2-type identifier has been indicated to be
>>optional.
>>
>>Comments?
>>
>>marco
>>
>>_______________________________________________
>>Seamoby mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/seamoby
>>    
>>

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 06 Aug 2003 16:03:33 -0700

> L2 ID, hence I support James' proposal to request an ID for

sure. as long as IANA assigns L2 type values, there
wont be any interop problems.

Vijay