Subject: Re: [Seamoby] (virtual) hum on CARD open issues

From: "Hemant Chaskar" <[email-masked]>
Date: Tue, 05 Aug 2003 19:47:15 +0000

Having optional field may be bad/may not be bad, I do not know. But this has 
been case even in IPv6. There are optional headers in IPv6. If those can be 
handled, why can't this be? My 2 cents - Hemant.

>From: Vijay Devarapalli <[email-masked]>
>To: Singh Ajoy-ASINGH1 <[email-masked]>
>CC: "'Pat R. Calhoun'" <[email-masked]>, [email-masked]
>Subject: Re: [Seamoby] (virtual) hum on CARD open issues
>Date: Tue, 05 Aug 2003 11:23:14 -0700
>
>Singh Ajoy-ASINGH1 wrote:
> >
> > 4. Issue #5: Static vs. dynamic capability attributes. The editor 
>recommends that we keep the S-bit and use the 32-bit lifetime only when 
>really required for dynamic capabilities. This saves bandwidth, but does 
>complicate processing. Meeting consensus is to keep S-bit.
> >
> > AJOY-> We need WG consensus about this issue. So far Vijay has suggested 
>us to drop the "S" bit but we have not heard from other members of the WG.  
>Should we drop the "S" bit or keep it? Please send your comments.
>
>I suggested an alternative to make the lifetime field
>a bit shorter, from 4 bytes to 2 bytes. 65535 seconds
>should be enough to specify the lifetime of an attribute.
>
>you should also keep in mind the point Robert Chalmers
>made. having an optional field in the middle of a data
>structure is plain bad for implementations.
>
>Vijay
>
>_______________________________________________
>Seamoby mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/seamoby

_________________________________________________________________
Add photos to your messages with MSN 8. Get 2 months FREE*.  
http://join.msn.com/?page=features/featuredemail

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 05 Aug 2003 13:50:35 -0700

Hemant Chaskar wrote:
> handled, why can't this be? 

its a totally different thing. the entire IPv6 packet is
never copied onto a singe data structure. and IPv6 has a 
nice header chaining mechanism to process one protocol 
header after the other.

Vijay