Subject: RE: solving the SFTP text mode issue

From: Richard Whalen <[email-masked]>
Date: Fri, 10 May 2002 15:54:56 -0400

> 
> As for record-based text file formats... The basic assumption 
> of SFTP is
> that a file is a single binary block of data that may be 
> manipulated however
> one wants. I simply don't see how this can be reconciled with 
> record-based
> text files. SFTP simply wasn't designed with that in mind, 
> and I for one
> wouldn't like to see the protocol retrofitted with alien concepts.
> 

Then SFTP does not define a file Transfer protocol, it defines a file Access
protocol.

---

From: "denis bider" <[email-masked]>
Date: Fri, 10 May 2002 22:04:31 +0200

> Then SFTP does not define a file Transfer protocol,
> it defines a file Access protocol.

YES! That is entirely correct.

The commonly used term 'SFTP' is a horrible misnomer. I think we should
document that somewhere, and perhaps also provide a less misleading official
name. (Not 'filexfer'.)

---

From: David Terrell <[email-masked]>
Date: Fri, 10 May 2002 13:15:57 -0700

> document that somewhere, and perhaps also provide a less misleading official

Considering that this is already a solved problem by one protocol
out there, why don't we just define another subsystem (we might as
well have _two_, oh boy) for Kermit and be done with it?

-- 
David Terrell          | Just another satan-worshipping Harry Potter reader.
[email-masked]           | 
Nebcorp Prime Minister | 
http://wwn.nebcorp.com |

---

From: "Calvin Bebermeyer" <[email-masked]>
Date: Sun, 12 May 2002 05:45:23 -0500

For what it is worth,

SFTP is not an ftp implementation, thus the choice of "ftp" in the name was
not really a good one.

If someone were to port the SSH protocol to a mainframe, the everyday user
that is really not interested in computer inner workings would see really
strange text results on these transfers.

regards,
Calvin Bebermeyer
[email-masked]