Subject: Fw: solving the SFTP text mode issue

From: "Joseph Galbraith" <[email-masked]>
Date: Fri, 10 May 2002 14:24:13 -0600

Forgot it twice...

- Joseph

----- Original Message ----- 
From: "Joseph Galbraith" <[email-masked]>
To: <[email-masked]>
Sent: Friday, May 10, 2002 14:14
Subject: Re: solving the SFTP text mode issue

> > > Then SFTP does not define a file Transfer protocol,
> > > it defines a file Access protocol.
> >
> > YES! That is entirely correct.
> >
> > The commonly used term 'SFTP' is a horrible misnomer. I think we should
> > document that somewhere, and perhaps also provide a less misleading
> official
> > name. (Not 'filexfer'.)
> 
> I concur.  We need a new name.
> "SSH Secure File Access Protocol - SFAP"
> Well, that's just off the top of my head,
> and maybe not the best idea in the world.
> 
> If SFTP was really file transfer protocol
> we would have operations like:
> 
> SFTP_GET_FILE
> uint32 request id
> string file_path
> uint32 starting offset
> 
> and the response would be an arbitrary number of
> SFTP_DATA packets followed by a status packet
> 
> SFTP_DATA [n]
> uint32 request id
> string file_data
> 
> SFTP_STATUS
> uint32 request id
> uint32 status
> string text
> string language.
> 
> Joseph
>

---

From: "denis bider" <[email-masked]>
Date: Fri, 10 May 2002 23:39:27 +0200

> "SSH Secure File Access Protocol - SFAP"

I thought of that, but it sounds too much like "SPAM". :)

I suggest FMP for 'File Manipulation Protocol'. The acronym would sound
reasonably well, and the name wouldn't include the word 'Secure' because the
protocol can run over anything and doesn't itself provide any security.

[Please disregard my earlier message with the same subject if it arrives. It
appears it got scheduled for moderator approval because I forgot to use the
right email address.]

---

From: "denis bider" <[email-masked]>
Date: Sat, 11 May 2002 02:04:33 +0200

> I suggest FMP for 'File Manipulation Protocol'.
> The acronym would sound reasonably well, and
> the name wouldn't include the word 'Secure'
> because the protocol can run over anything
> and doesn't itself provide any security.

Or perhaps:

FXP - File Access Protocol
RFX - Remote File Access (protocol)

'Access' sounds less awkward than 'Manipulation'. 'Management' also begins
with M, but seems to carry a different meaning (managing whole files rather
than their contents). Also, acronyms containing the letter X usually sound
more seXy.

Any votes?

My vote currently goes to RFX, mainly because it sounds better.