Subject: [Sedate] Alvaro Retana's Block on charter-ietf-sedate-00-00: (with BLOCK and COMMENT)

From: Alvaro Retana via Datatracker <[email-masked]>
Date: Tue, 18 May 2021 08:30:57 -0700

Alvaro Retana has entered the following ballot position for
charter-ietf-sedate-00-00: Block

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-sedate/

----------------------------------------------------------------------
BLOCK:
----------------------------------------------------------------------

"The TC39 working group at ECMA have developed a format which is a good basis
for this work."

Is TC39 contributing its work to the IETF?  Is there an I-D or an ECMA
specification?  How much can that work be modified?  What about IPR?  Does
further work in TC39/ECMA depend on the output of this WG?  Is the workflow of
the IETF (process, consensus, etc.) ok with ECMA expectations?  There's no
mention in the charter about further coordination with TC39/ECM, is it needed?

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

[nit] The first sentence is very long.  Suggestion: start a second sentence with "However, ..."

---

From: Francesca Palombini <[email-masked]>
Date: Tue, 18 May 2021 16:18:58 +0000

Hi Alvaro,

Yes, TC39 delegates have submitted the draft that is the basis to start this working group (pending creation and subsequent adoption): https://datatracker.ietf.org/doc/html/draft-ryzokuken-datetime-extended-01. In order to make sure this is a coordinated effort, I also have confirmed with our liaison contact at ECMA TC39, Istvan Sebestyen, that this is important to ECMA TC39 and they are happy to collaborate with IETF about it. I  would assume they are aware of IETF process (since we have a liaison in place. I am not aware of IPRs on the document.
Do you believe we need to add a sentence about coordination? Anything else I might be missing?

Re - adding the document to the charter, I am more tempted to let the working group follow the process and adopt it, but I can also add a sentence about it being the basis for the wg if you think that's useful. 

Francesca

On 18/05/2021, 17:31, "iesg on behalf of Alvaro Retana via Datatracker" <[email-masked] on behalf of [email-masked]> wrote:

---

From: Alvaro Retana <[email-masked]>
Date: Tue, 18 May 2021 11:33:44 -0700

Francesca:

Hi!

Yes, I think that the coordination, if needed, should be clearly called out.

I looked at the draft.  It talks about extending ISO8601 — is coordination
with ISO also needed?

Also, I like the option of not seeding the charter with a specific draft.
But that’s up to you. :-)

Thanks!

Alvaro.

On May 18, 2021 at 12:19:01 PM, Francesca Palombini (
[email-masked]) wrote:

Hi Alvaro,

Yes, TC39 delegates have submitted the draft that is the basis to start
this working group (pending creation and subsequent adoption):
https://datatracker.ietf.org/doc/html/draft-ryzokuken-datetime-extended-01.
In order to make sure this is a coordinated effort, I also have confirmed
with our liaison contact at ECMA TC39, Istvan Sebestyen, that this is
important to ECMA TC39 and they are happy to collaborate with IETF about
it. I would assume they are aware of IETF process (since we have a liaison
in place. I am not aware of IPRs on the document.
Do you believe we need to add a sentence about coordination? Anything else
I might be missing?

Re - adding the document to the charter, I am more tempted to let the
working group follow the process and adopt it, but I can also add a
sentence about it being the basis for the wg if you think that's useful.

Francesca

On 18/05/2021, 17:31, "iesg on behalf of Alvaro Retana via Datatracker" <
[email-masked] on behalf of [email-masked]> wrote:

"The TC39 working group at ECMA have developed a format which is a good
basis
for this work."

Is TC39 contributing its work to the IETF? Is there an I-D or an ECMA
specification? How much can that work be modified? What about IPR? Does
further work in TC39/ECMA depend on the output of this WG? Is the workflow
of
the IETF (process, consensus, etc.) ok with ECMA expectations? There's no
mention in the charter about further coordination with TC39/ECM, is it
needed?

[nit] The first sentence is very long. Suggestion: start a second sentence
with "However, ..."

---

From: Francesca Palombini <[email-masked]>
Date: Tue, 18 May 2021 19:59:43 +0000

Alvaro,

What about adding the following text at the end of the charter:

The Working Group will coordinate with Ecma International TC39 and ISO TC154.

About the ISO coordination – yes, it definitely needs coordination, at least for awareness. I have actually already started the process in order to make sure this is also coordinated with ISO, and I have a contact. Do you (or anybody else in the IESG) know what is the process to set up an official liaison?

Thanks for the feedback!
Francesca

From: Alvaro Retana <[email-masked]>
Date: Tuesday, 18 May 2021 at 20:33
To: The IESG <[email-masked]>, Francesca Palombini <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Alvaro Retana's Block on charter-ietf-sedate-00-00: (with BLOCK and COMMENT)

Francesca:

Hi!

I looked at the draft.  It talks about extending ISO8601 — is coordination with ISO also needed?

Also, I like the option of not seeding the charter with a specific draft.  But that’s up to you. :-)

Thanks!

Alvaro.

On May 18, 2021 at 12:19:01 PM, Francesca Palombini ([email-masked]<mailto:[email-masked]>) wrote:
Hi Alvaro,

Francesca

On 18/05/2021, 17:31, "iesg on behalf of Alvaro Retana via Datatracker" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

---

From: Alvaro Retana <[email-masked]>
Date: Tue, 18 May 2021 13:24:32 -0700

Hi!

That text works for me.

About an official liaison; it’s an IAB function:
https://www.ietf.org/about/liaisons/

Alvaro.

On May 18, 2021 at 3:59:44 PM, Francesca Palombini (
[email-masked]) wrote:

Alvaro,

The Working Group will coordinate with Ecma International TC39 and ISO
TC154.

About the ISO coordination – yes, it definitely needs coordination, at
least for awareness. I have actually already started the process in order
to make sure this is also coordinated with ISO, and I have a contact. Do
you (or anybody else in the IESG) know what is the process to set up an
official liaison?

Thanks for the feedback!
Francesca

*From: *Alvaro Retana <[email-masked]>
*Date: *Tuesday, 18 May 2021 at 20:33
*To: *The IESG <[email-masked]>, Francesca Palombini <
[email-masked]>
*Cc: *"[email-masked]" <[email-masked]>, "[email-masked]" <
[email-masked]>
*Subject: *Re: Alvaro Retana's Block on charter-ietf-sedate-00-00: (with
BLOCK and COMMENT)

Francesca:

Hi!

Thanks!

Alvaro.

Hi Alvaro,

Francesca

---

From: Francesca Palombini <[email-masked]>
Date: Tue, 18 May 2021 20:30:32 +0000

Thanks! Updated.

I will address the rest of the non-blocking comments all at the same time, once everybody has had a chance to take a look.

And thank you, I was wondering about the official process to set one up, I’ll contact the IAB.

Francesca

From: Alvaro Retana <[email-masked]>
Date: Tuesday, 18 May 2021 at 22:24
To: The IESG <[email-masked]>, Francesca Palombini <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: Alvaro Retana's Block on charter-ietf-sedate-00-00: (with BLOCK and COMMENT)

Hi!

That text works for me.

About an official liaison; it’s an IAB function: https://www.ietf.org/about/liaisons/

Alvaro.

On May 18, 2021 at 3:59:44 PM, Francesca Palombini ([email-masked]<mailto:[email-masked]>) wrote:
Alvaro,

Thanks for the feedback!
Francesca

From: Alvaro Retana <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 18 May 2021 at 20:33
To: The IESG <[email-masked]<mailto:[email-masked]>>, Francesca Palombini <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Alvaro Retana's Block on charter-ietf-sedate-00-00: (with BLOCK and COMMENT)

Francesca:

Hi!

Thanks!

Alvaro.

Francesca

---

From: Alvaro Retana <[email-masked]>
Date: Tue, 18 May 2021 14:21:15 -0700

Hi!

I think that if you’re leading the text in about the document ("The TC39
working group at ECMA have developed a format which is a good basis for
this work.”) then you should specifically point to the draft.  Otherwise
the text gives the impression that the starting point will be an ECMA
document (not an I-D).   This is a non-blocking point, so I’m clearing the
BLOCK.

Thanks!

Alvaro.

On May 18, 2021 at 4:30:33 PM, Francesca Palombini (
[email-masked]) wrote:

Thanks! Updated.

I will address the rest of the non-blocking comments all at the same time,
once everybody has had a chance to take a look.

And thank you, I was wondering about the official process to set one up,
I’ll contact the IAB.

Francesca

*From: *Alvaro Retana <[email-masked]>
*Date: *Tuesday, 18 May 2021 at 22:24
*To: *The IESG <[email-masked]>, Francesca Palombini <
[email-masked]>
*Cc: *"[email-masked]" <[email-masked]>
*Subject: *Re: Alvaro Retana's Block on charter-ietf-sedate-00-00: (with
BLOCK and COMMENT)

Hi!

That text works for me.

Alvaro.

Alvaro,

Thanks for the feedback!
Francesca

Francesca:

Hi!

Thanks!

Alvaro.

Hi Alvaro,

Francesca