Subject: [Sedate] Update on charter

From: Francesca Palombini <[email-masked]>
Date: Thu, 24 Jun 2021 19:28:22 +0000

Hi all,

Thanks to John, Ned, Ujjwal, and Bron, with whom I have had offlist discussion and who have provided reviews and text, here is an update to the proposed charter: the scope is more restricted (and hopefully more clear), and it should address any remaining comments that have been raised.
If anybody has any more comments or concerns please let me know before Wednesday next week, as the charter is scheduled for approval by the IESG on Thursday July 1st.

Thanks,
Francesca

----------
RFC3339 defines a format as a profile of ISO 8601 that can reliably express an instant in time, either in UTC or in a local time along with the offset against UTC. However, datetime data often has additional context, such as the timezone or calendar system that was in use when that instant was recorded.

Particularly when using times for interval, recurrence, or offset calculations, it is necessary to know the context in which the timepoint exists. It is valuable to have a standard serialisation text format for this contextual data.

* This format must be able to round-trip through intermediate systems which do not understand the full context.
* Systems which don’t understand all the contextual fields must still be able to reliably extract the instant in time.

This format will be a companion to RFC3339 rather than a replacement, embedding unaltered RFC3339 data in a way that makes it easy to parse just the datetime data independently of the context.

Changes to RFC3339 are explicitly outside the charter for this working group. <<If a need for an RFC3339bis emerges, this group must recharter before performing that work. In this case, the changes to RFC3339 will need to be clearly motivated, evaluated and precisely scoped during the rechartering process, and will need to make only changes that keep the timestamp specification a profile of current versions of ISO 8601>> Stability of the RFC 3339 timestamp format is important to existing IETF protocols and the Internet generally and any rechartering process should frown on anything that would invalidate the existing timestamp format.

The working group will coordinate with ECMA International TC39 and ISO/TC154 to ensure that this work remains a strict extension of ISO 8601 and its various parts rather than becoming a conflicting standard.

---

From: Francesca Palombini <[email-masked]>
Date: Thu, 24 Jun 2021 19:49:09 +0000

Please, do ignore the "<<" and ">>" in the text, they are leftovers of copy paste. You can also see the updated charter text in the datatracker: https://datatracker.ietf.org/doc/charter-ietf-sedate/00-03/ .

Francesca

On 24/06/2021, 21:28, "Sedate on behalf of Francesca Palombini" <[email-masked] on behalf of francesca.palombini=[email-masked]> wrote:

    Hi all,

    Thanks,
    Francesca

    ----------

    -- 
    Sedate mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/sedate