Subject: Re: [Sedate] Follow-Up to Interim meeting today! (in just under 4 hours)

From: John C Klensin <[email-masked]>
Date: Thu, 21 Oct 2021 05:36:01 -0400

On Thu, 21 October 2021 06:24 UTC, Carsten Bormann wrote:

> We had some rather useful discussions yesterday (even if I
> couldn't talk because of, er, some collection of tool
> issues).

Agreed

> I hope I have been able to capture some of the discussion in
> the 7 issues at:
> 
> https://github.com/ietf-wg-sedate/draft-ietf-sedate-datetime-e
> xtended/issues
> 
> I assume the community assembled in this WG is mostly familiar
> with github, so maybe we can collect additional information
> and further opinions there.

Familiar, yes, and what I'm about to say is not intended to
reopen the discussion about principles.  I am quite familiar
with github.  However, for a number of reasons, including too
many other things making demands on my time and perhaps being
too old to learn new tricks, I find using it for a discussion
very painful and distracting and, in practice, won't do that.
If you want to use it as an issue tracker, that is great as long
as you make sure the pointer to the issues list (not just the
repository) is easily and readily available, but, if discussions
go on there, there is high risk of not hearing from me about
their content and conclusions until Last Call.

We should want to make it as easy as possible for someone coming
late --say next week, after IETF 112, or even later -- to catch
up.  That means a good email archive, an issue tracker, and good
minutes from meetings, but not materials scattered all over the
place.

There were a few other things said during the meeting that do
not seem to be on the issues list.  They may be just suggested
principles, not specific issues, so may not belong there, but
that illustrates my concern about scattering information around. 

For convenience, separate message follows.

   john

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 29 Oct 2021 17:48:34 +1100

> that illustrates my concern about scattering information around. 

I've posted the notes from the meeting to the minutes section in the datatracker now.

Regarding use of github issues vs mailing list.  Mailing list is great for discussion with all involved parties, and for any contentious issues.  I agree that it's a good idea.

Github issues are great for tracking the issues, and noting when they have been resolved in the documents.  Particularly when an email thread has covered multiple different issues with a draft, I've often seen authors come back with a new draft which didn't fix all the issues, because we're human and we forget things.  The issue tracker helps by having some of the state management go out of each human brain into a shared place that the authors can collaborate.  They can also tag specific git commits with the issue number which helps see what the diff is associated with.

I agree that subscribing the mailing list to the issues tends to create email noise.  I don't mind it because I can skip over it pretty quickly, but I'm also happy not having it.

My ideal goal is that authors workshop ideas wherever they feel most comfortable, with those who they know are interested - and obtain consensus on their changes through that discussion.  If authors choose a method which doesn't include everybody who has input, they'll discover their mistake at working group last call when their text is challenged and it becomes apparent that they didn't canvass consensus well enough!

In summary: authors, do whatever works best for you to find consensus and track progress -- on both technical design and specific text!

Cheers,

Bron.
--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]