Subject: Re: [Sedate] [ietf-wg-sedate/draft-ietf-sedate-datetime-extended] We seem to ignore the lessons learned and documented in RFC 6648 (“x-dash”). (#2)

From: Ujjwal Sharma <[email-masked]>
Date: Thu, 21 Oct 2021 12:08:37 +0530

CCing SEDATE

On 20/10/2021 22.11, cabo wrote:
> (Removing namespacing would remove about half of the text.)

Yes, but then any additional information that could be included would 
need a full RFC cycle. One of the main motivations behind this was to 
lower the barrier so that people don't deviate from the standards track 
like they did for timezones.

---

From: Ujjwal Sharma <[email-masked]>
Date: Thu, 21 Oct 2021 12:42:27 +0530

Also CCing other stakeholders directly for greater visibility.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 21 Oct 2021 09:18:11 +0200

> CCing SEDATE

I’m not sure we want all the discussion copied between both GitHub and the mailing list, but I’ll stick with this until the chairs intervene.

> Yes, but then any additional information that could be included would need a full RFC cycle.

There is space between not having extensibility at all and having a complicated way to registering namespaces where extensions can then be registered.

Why don’t we just register extensions?

> One of the main motivations behind this was to lower the barrier so that people don't deviate from the standards track like they did for timezones.

Exactly.

Make a registry for extensions, not for namespaces for extensions.
Think hard about the RFC 8126 policies applying to this (we can distinguish different policies for different kinds of names).

Grüße, Carsten