Subject: Re: [Sedate] Carsten Bormann will be co-author for datatime-extended

From: "Bron Gondwana" <[email-masked]>
Date: Sat, 16 Oct 2021 23:13:11 +1100

Hi Carsten and Ujjwal,

The interim at CalConnect is coming up in a few short days.  It would be great if you could get a new draft published by then, and we can isolate the remaining issues into github so we can point directly to them during the discussion.

Cheers,

Bron.

On Thu, Sep 30, 2021, at 20:01, Bron Gondwana wrote:
> Hi All,
> 
> Carsten has kindly agreed to join on as co-author of datetime-extended with Ujjwal.
> 
> The secretariat has created a github organisation for this working group, and I've created a repository for the authors to use and invited them as members.  I haven't pre-populated any issues there, but you can also create issues on the repository as well as emailing this list.
> 
> https://github.com/ietf-wg-sedate/draft-ietf-sedate-datetime-extended/
> 
> Cheers,
> 
> Bron.
> 
> --
>   Bron Gondwana, CEO, Fastmail Pty Ltd
>   [email-masked]
> 
> 

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 16 Oct 2021 16:38:32 +0200

Hi Bron, hi Ujjwal,

I’ll push what I have later today.
This will be one giant PR, because the editorial (and small technical) commits stack…
But I hope we can accept that quickly and go towards actual issues next.

Grüße, Carsten

> On 16. Oct 2021, at 14:13, Bron Gondwana <[email-masked]> wrote:
> 
> Hi Carsten and Ujjwal,
> 
> Sedate mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sedate

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 16 Oct 2021 21:37:00 +0200

> But I hope we can accept that quickly and go towards actual issues next.

https://github.com/ietf-wg-sedate/draft-ietf-sedate-datetime-extended/pull/1

After checking and merging the changes, the next step would be to look at the markdown (XML) comments added and decide which ones of these we can fix right away and which ones need to be converted into github issues.

BTW, I find the whole setup of separating single-character namespaces from multi-character ones really suspicious.  Why not have a single registry, with slightly different policies defined for the two kinds.  The requirements listed in Section 3.3 should mostly apply to either, shouldn’t they?  I didn’t want to make an editorial proposal until I understand why these are so clearly separated.

To kick-start the whole issue game already: https://github.com/ietf-wg-sedate/draft-ietf-sedate-datetime-extended/issues/2

Grüße, Carsten

---

From: "Bron Gondwana" <[email-masked]>
Date: Sun, 17 Oct 2021 18:17:37 +1100

Great, thanks - appreciate the quick turnaround.

Cheers,

Bron.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 19 Oct 2021 21:54:25 +0200

> https://github.com/ietf-wg-sedate/draft-ietf-sedate-datetime-extended/pull/1

I know this is a substantial PR — should I just go ahead and merge and resubmit for tomorrow?

Grüße, Carsten

---

From: Ujjwal Sharma <[email-masked]>
Date: Wed, 20 Oct 2021 03:12:39 +0530

Hi Carsten!

I am sorry for the delay, the PR is on my list, but because of TC39 next 
week, my plate is a bit too full right now. It's fine to merge and 
resubmit, yes.

Ujjwal

-- 
Ujjwal "Ryzokuken" Sharma (he/him)

Compilers Hacker, Node.js Core Collaborator and Speaker