Subject: Re: [sfc] Proposed additional text for section 3.4 of draft-ietf-sfc-nsh-10

From: Dave Dolson <[email-masked]>
Date: Wed, 26 Oct 2016 21:31:01 +0000

I’m in favor of defining the behavior for the case when the metadata schema is not known. Discard seems reasonable.

But I don’t think it needs to be "received". Hand-configured or hard-coded will suffice.
 -Dave

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Wednesday, October 26, 2016 8:29 AM
To: [email-masked]
Subject: [sfc] Proposed additional text for section 3.4 of draft-ietf-sfc-nsh-10

Dear SFC WG:

The following text has been proposed by Med and Lucy as an addition to section 3.4 of draft-ietf-sfc-nsh:

"This specification allows defining different semantics of metadata type 1 related mandatory context header, but the NSH header does not convey that semantic in the context headers. An SFC-aware SF MUST receive the data extraction schema first in order to get the data placed in the mandatory context header. How an SFC-aware SF gets the data extraction schema for the mandatory context header is outside the scope of this specification. This specification does not make any assumption about the content placed in the mandatory context header. Upon receiving an SFC packet with metadata type 1 present, if an SFC-aware SF is configured to use metadata but does not yet receive the data extraction schema for the mandatory context header, it MUST NOT process the packet and MUST log this error."

Before asking the editors of the document to make this change, I would like to hear opinions from other WG members so that consensus for this change may be reached. I would particularly like to hear opinions on the last sentence; specifically the ‘MUST NOT process’ as this implies that an SF must drop a packet if it is unable to process the metadata thereby breaking the chain. Do we need to be this strict or can we simply log an error and forward the packet through the chain?

Jim

---

From: Sumandra Majee <[email-masked]>
Date: Wed, 26 Oct 2016 23:02:22 +0000

>> But I don’t think it needs to be "received". Hand-configured or hard-coded will suffice.
[SM] I am fine with that. That is a what I would call a “implementer” friendly practical approach.

From: sfc <[email-masked]> on behalf of Dave Dolson <[email-masked]>
Date: Wednesday, October 26, 2016 at 2:31 PM
To: "Jim Guichard (jguichar)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [sfc] Proposed additional text for section 3.4 of draft-ietf-sfc-nsh-10

Dear SFC WG:

Jim