Subject: [sfc] Progressing of NSH metadata drafts

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Fri, 28 Oct 2016 14:51:10 +0000

Dear SFC WG:

Thank you to those that were able to attend our recent interim meeting.

One of the topics we investigated was how to progress drafts on metadata within the WG. As a WG we really need to make progress in this area.

We had a lively discussion around both type-1 and type-2 metadata.

At the interim meeting we reached a general agreement that we should adopt some of the type-1 allocation documents (initially the DC and Mobility allocations) and work toward WG consensus on the formats. While there was discussion on whether these documents should be informational or standards track, we agreed to initially adopt them as informational and move to a different track if the WG decides that is appropriate in the future.

We also reached a general agreement that we should call for the adoption of the type-2 TLV registry document (draft-quinn-sfc-nsh-tlv).

The chairs would like to emphasis that these agreements were preliminary as not all interested parties were in attendance at the interim meeting. Therefore, if there are objections or agreement to this path forward, please do indicate as such on the mailing list. If there are no substantive objections, the chairs will send separate emails shortly to request adoption of these drafts. Please look out for them and indicate on the mailing list whether you support adoption, and if not, why.

Jim

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 28 Oct 2016 14:00:22 -0500

Hi Jim,

I read the minutes. I was in the Interim.
Based on that, please see below:

On Fri, Oct 28, 2016 at 9:51 AM, Jim Guichard (jguichar)
<[email-masked]> wrote:
> One of the topics we investigated was how to progress drafts on metadata
> within the WG. As a WG we really need to make progress in this area.
>
>

First of all Thomas Narten's list was incomplete.

>
> At the interim meeting we reached a general agreement that we should adopt
> some of the type-1 allocation documents (initially the DC and Mobility
> allocations) and work toward WG consensus on the formats. While there was
> discussion on whether these documents should be informational or standards
> track, we agreed to initially adopt them as informational and move to a
> different track if the WG decides that is appropriate in the future.
>

I don't see anything in the minutes to suggest this.

>
> We also reached a general agreement that we should call for the adoption of
> the type-2 TLV registry document (draft-quinn-sfc-nsh-tlv).
>

Ditto.
I could not see even a mention of draft-quinn-sfc-nsh-tlv in the minutes.
How could we have reached an agreement to adopt it?

According to the minutes, the registry is supposed to have semantic
information, this is what it says:

once we have a type-2 registry, refer to the type-2 registry for semantics.

In order to have semantics, we need separate draft or drafts that do
contain semantics for the TLV or MD type 1 or 2 defined.
draft-quinn-sfc-nsh-tlv does not satisfy this requirement.
BTW no offense to the draft authors.

>
> The chairs would like to emphasis that these agreements were preliminary as
> not all interested parties were in attendance at the interim meeting.
> Therefore, if there are objections or agreement to this path forward, please
> do indicate as such on the mailing list.

Please see above.

Regards,

Behcet
>  If there are no substantive
> objections, the chairs will send separate emails shortly to request adoption
> of these drafts. Please look out for them and indicate on the mailing list
> whether you support adoption, and if not, why.
>
>
> Jim
>
>
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc
>

---

From: Lucy yong <[email-masked]>
Date: Fri, 28 Oct 2016 19:54:22 +0000

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Friday, October 28, 2016 9:51 AM
To: [email-masked]
Subject: [sfc] Progressing of NSH metadata drafts

Dear SFC WG:

[Lucy] I was in the meeting. This is not what I get from the meeting. Maybe one person voice this and discuss a bit, then move on due to time.

[Lucy] which are these drafts? Will this matter to MD-1? Now, more people support opaque approach for MD-1. If we go this approach, no need additional draft for MD-1 specification.

Regards,

Lucy

Jim

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Fri, 28 Oct 2016 20:48:56 +0000

Dear Lucy/Behcet,

Please review the recording starting at 1:10:38 where we discuss a summary of how to move forward with metadata. There were no comments/objections against the conclusion which was to get WG review of the different type-1/type-2 drafts with a view to adoption and that we would decide upon whether they are informational or standards track as we work through the normal WG processes for documents.

As I indicated in my email *the chairs will send separate emails shortly to request adoption of these drafts* which will give WG members time to review the documents and indicate their support (or not) for adoption.

I hope this helps clarify things.

Jim

From: Lucy yong <[email-masked]<mailto:[email-masked]>>
Date: Friday, October 28, 2016 at 3:54 PM
To: Jim Guichard <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Progressing of NSH metadata drafts

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Friday, October 28, 2016 9:51 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] Progressing of NSH metadata drafts

Dear SFC WG:

Regards,

Lucy

Jim

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Fri, 28 Oct 2016 20:52:13 +0000

Hi Lucy,

We are talking about the allocation drafts that Thomas listed during the interim meeting. Although the NSH specification itself will not define allocation schema for the opaque contexts, other drafts will such as the DC and broadband allocation drafts.

Jim

Dear SFC WG:

Regards,

Lucy

Jim