Subject: Re: [sidr] Working Group Last Call - draft-ietf-sidr-roa-format-06.txt

From: Rob Austein <[email-masked]>
Date: Mon, 23 Nov 2009 16:26:02 -0500

I have read (and implemented) this document, and support it going
forward.

My only comment from this review is that the text "If it is present it
MUST be ignored by the relying party" in sections 2.1.6.4.3 and
2.1.6.4.4 is perhaps a bit strong.  The text immediately following in
both cases is fine, and I believe expresses the real intent here: that
relying parties not use these timestamp fields in determining whether
a ROA is valid.  As stated, however, this could be construed as
forbidding an application that uses ROAs from using that field for any
purposes whatsoever, which seems excessive.

---

From: Samuel Weiler <[email-masked]>
Date: Wed, 25 Nov 2009 06:25:54 -0500 (EST)

I have reviewed the ROA format draft.  In, general, I'm fine with
sending it to the IESG now.  Thanks again to the editors for putting
together a readable doc.

As with the architecture document, I have some reservations about 
publishing the data format documents before the validation 
algorithm is solid, but I suspect this doc won't need to change.

It might be worthwhile to repeat in section 3 (validation) the
requirement from section 7.2 of the architecture draft that "...a
relying party must fetch new ROAs from the repository system before
taking any routing action in response to a ROA revocation."

-- Sam

---

From: Geoff Huston <[email-masked]>
Date: Mon, 30 Nov 2009 08:03:14 +1100

WG Co-Chair hat ON

I have seen three comments on this draft in response to this WG last call - which is perhaps on the very lower bound of what could be considered an acceptable demonstration of WG consensus with the document.

There have been positive responses in favour of moving this document forward from Terry Manderson, Sam Weiler and Rob Austein.

The review comments received have been entered into the tracker  as tickets #4, #12, and #13. 

It appears ticket #4 has resolved without requiring a change to the document, but the comments in tickets #12 and #13 (those made by Sam and Rob) are outstanding.

I would like to request the document's authors to respond to these comments, either in the tracker on on the mailing list, and provide an indication whether a further revision of the document is considered necessary to address these review comments. It appears appropriate to review the WG consensus position following the authors' response to these two outstanding review comments.

Also, I'd like to remind the authors of the previous request for an interoperability report.

thanks

   Geoff

  WG Co-Chair hat ON

On 28/10/2009, at 1:48 PM, Geoff Huston wrote:

> The WG chairs have received a Working Group Last Call request from the authors of draft-ietf-sidr-roa-format-06.txt.
> 
> The document (and the draft history) is at http://tools.ietf.org/html/draft-ietf-sidr-roa-format-06
> 
> The Last Call will end as of the close of business on Monday 23rd November - this is a longer period than a conventional 2 week last call period in order to include the forthcoming SIDR WG meeting at IETF 76.
> 
> The intended status of this document is proposed standard.
> 
> As usual, please address all comments to the WG mailing list, and please be clear in your comments to this last call if you are supporting the document's submission to the IESG or if you are opposed, or if you are not expressing a view either way. As there are a number of documents that are being last-called at this point in time it would be appreciated if responses could clearly identify which document is being referred to.
> 
> Also with this note I would like to request the document's authors to prepare an interoperability report.
> 
> Thanks,
> 
>  Geoff
> 
> WG Co-CHair hat ON
> 
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr