Subject: [sidr] wg consideration of IPR

From: Sandra Murphy <[email-masked]>
Date: Tue, 10 Nov 2009 13:49:06 -0500 (Eastern Standard Time)

One of the questions that we did not get to in the meeting Monday was a 
question of IPR.

An IPR claim has been registered against the wg draft 
draft-ietf-sidr-roa-validation-03.txt.  IPR issues were specifically 
mentioned as a deterrent in a recent call for wg adoption of a draft.

I'd like the wg to consider the wg stance on working on IPR'd 
technologies.  We can reject such work, we can allow such work, we can 
allow it with stipulations as to the acceptable terms, etc.

Express your opinion of what you would like to see and why.

--Sandy

---

From: George Michaelson <[email-masked]>
Date: Wed, 11 Nov 2009 08:52:02 +0900

On 11/11/2009, at 3:49 AM, Sandra Murphy wrote:

> One of the questions that we did not get to in the meeting Monday was a question of IPR.
> 
> An IPR claim has been registered against the wg draft draft-ietf-sidr-roa-validation-03.txt.  IPR issues were specifically mentioned as a deterrent in a recent call for wg adoption of a draft.

Because that is my understanding of the choice facing the IETF in all WG, that if faced with work which makes no IPR claim, and work which does, the IETF is entitled to, and in fact often does, preference the work with no IPR claim.

> 
> I'd like the wg to consider the wg stance on working on IPR'd technologies.  We can reject such work, we can allow such work, we can allow it with stipulations as to the acceptable terms, etc.
> 

I would like to see my voluntary contribution in the IETF be made in the spirit of openness and benefit to all. My personal preference is not to work on technologies which are encumbered by other people's IPR.

Of course your question is motivated by specifics. I would like to try and address the specifics.

In that spirit Sandy, I regard draft-pmohapat-sidr-pfx-validate as a functional attack or a kind of "DOS" on IETF process.  

In effect, by disclosing an IPR claim, and then extending it in an apparently capricious fashion to a current WG document that did not reflect the non-IETF contributions of any Cisco-employees, namely draft-ietf-sidr-roa-validation, the IPR claimants appear to be attempting some form of hijack of the IETF process. When Cisco employees attend IETF, and participate in the mailing lists, their contributions made openly are done so under the conditions of the 'note well' and so do not (in my opinion) buttress their IPR claim. If they have a moral right to recognition in the draft, I am happy to discuss this.

My co-author and I have discussed this IPR issue, and we specifically disclaim any personal IPR over the concepts that we believe reflect the WG's considerations on our document. This of course does not mean that these concepts are not subject to IPR claims, but Steve Kent's postings regarding prior art appear to be extremely relevant to the draft I co-authored, and the extension of the IPR claim by Cisco over this particular draft is not helpful.

I feel that this document is a reflection of ideas discussed openly in this WG, for a very long time, and I have already informed at least one potential prior-art holder that I and my co-author do not claim any rights over any technology or ideas in this document and nor does our employer.

If draft-pmohapat-sidr-pfx-validate was revised to reflect mechanisms, without claiming to define semantics, if it cited the existing WG draft which is on semantics and not mechanisms, recognised the contributions made to that draft by open WG process, and assuming that it also reflected the large body of prior art in routing security, I think a draft on mechanisms should be adopted.

-George

PS this is my individual response, and does not necessarily reflect the views of my co-author except where clearly stated.

---

From: Randy Bush <[email-masked]>
Date: Wed, 11 Nov 2009 11:32:41 +0900

george,

if you think that the two drafts cover much the same technology, and you
accept the sad reality that sometimes technologies in the ietf suffer
ipr attacks, can you explain why are you angry that the same ipr attack
is directed at the two drafts you think are similar?

randy

---

From: George Michaelson <[email-masked]>
Date: Wed, 11 Nov 2009 12:15:13 +0900

> is directed at the two drafts you think are similar?

If you think that, then say so.

Please don't "put words in my mouth" Randy. I don't agree with these statements and I don't want anyone to believe that because YOU said it, that it characterises how I feel.

The roa-validation draft I co-authored covered semantics of a ROA, while the other draft appeared to toe-tread on this work and then describe a mechanism of implementation. From my perspective there is an important distinction that was mentioned on the WG meeting on Monday between semantic interpretation and mechanism. So I disagree with your opening assertion.

I think we have a conceptual problem here.

You see two drafts, both 'victims' of an IPR attack.

I see a different thing. I see a causal chain

1) a draft is written by Geoff and myself in 2008.

2) in 2009 a draft is authored by Cisco and others.

3) in 2009 that draft is marked as having IPR claims attached to it, by Cisco. ie, they claim IPR over a draft *of their own authorship*

4) later in 2009 our original 2008 draft is notified it now is covered by these IPR claims. This was delivered to me after the initial lodgement relating to the Cisco authored draft. It appears to be an afterthought.

Again, can I stress that this is my own personal view.

-George

---

From: George Michaelson <[email-masked]>
Date: Wed, 11 Nov 2009 12:32:20 +0900

-George

---

From: Sandra Murphy <[email-masked]>
Date: Tue, 10 Nov 2009 22:42:36 -0500 (Eastern Standard Time)

> 2) in 2009 a draft is authored by Cisco and others.

2008,  actually.  The -00 draft was submitted Oct 08.

--Sandy

---

From: George Michaelson <[email-masked]>
Date: Wed, 11 Nov 2009 12:48:07 +0900

> 2008,  actually.  The -00 draft was submitted Oct 08.

I apologize. I stand corrected. Submitted Oct 08. 

The Draft I co-authored was submitted August 08. 

The IPR filing and subsequent application to the draft I co-authored was 2009 was it not?

-George

---

From: Sandra Murphy <[email-masked]>
Date: Tue, 10 Nov 2009 22:54:59 -0500 (Eastern Standard Time)

> The IPR filing and subsequent application to the draft I co-authored was 2009 was it not?

Initial filing was Nov 08.

--Sandy

---

From: George Michaelson <[email-masked]>
Date: Wed, 11 Nov 2009 13:35:30 +0900

I must apologize to the WG for having made a mistake in my dates. I have post-dated the work Geoff and I submitted, which actually hit the IETF draft status in February 2008.

I wish to revise my statements.

1) Geoff and I co-authored an individual submission in February of 2008.

	draft-huston-sidr-roa-validation-00

  this was subsequently adopted  August 7 2008

	draft-ietf-sidr-roa-validation-00

2) Pradosh Mohapatra and John Scudder edited a draft dated October 27, 2008

	draft-pmohapat-sidr-pfx-validate-00

3) In November 2008, Cisco filed IPR in respect of this draft. This is what I can tell from looking in the IETF IPR disclosure system. I received no notification of this, relating to my work.

4) In October 2009, I became aware of a Cisco IPR claim in respect of

       draft-pmohapat-sidr-pfx-validate-00

The IPR statement was lodged with the IETF dated November 18 2008.

5) In November 2009 I received direct notification from Cisco/IETF that the IPR claim was also applied to the draft I co-authored. 

This is an IPR statement dated November 2 2009

So, thats the time sequence as I see it, based on what I can recall from emails to sidr WG, personal mail, and the drafts found online.

-George

Again, this is my personal opinion. I speak for nobody else in this matter.