Subject: Re: [sidr] Working Group Last Call for draft-ietf-sidr-repos-struct-03.txt

From: Sandra Murphy <[email-masked]>
Date: Fri, 5 Mar 2010 18:01:57 -0500 (Eastern Standard Time)

In the last call, I noted that this draft had not had a significant amount 
of review in the wg.  In the last IETF meeting, Geoff and I both 
reiterated the need for comment on all last called drafts.
Even so, there has been only four comments on this draft (even counting 
mine which was made with wg chair hat off).

The history of the draft is that it was presented as an individual 
submission in IETF 66, IETF 71 and IETF 72 (briefly), it was proposed and 
adopted as a working group draft, and it has not been presented since. 
The versions that have been submitted since wg adoption have been 
boilerplate changes and other superficial changes only.  In the meantime, 
many of the drafts on which it relies have changed considerably

It is possible that the authors attained perfection without effort in this 
case.  I still would prefer that there was more evidence that the wg had 
adequately reviewed this document.

I can not now judge this draft as having consensus.  I have asked all 
those who responded positively to the call for adoption to review the 
current draft.  I have also asked authors of all drafts that refer to this 
draft to inform the wg that they have reviewed this draft and it is 
adequate for use in their work.  (I am making an exception where the 
authors of this draft and a referring draft overlap, of course.)

--Sandy

---

From: Danny McPherson <[email-masked]>
Date: Mon, 8 Mar 2010 07:37:38 -0700

Top post only..  

I agree with Sam's comments here.

Additionally, and not surprisingly, I'd also very much like to see 
my earlier comments on this document addressed before it warrants 
cycles for another full review on my part.

Thanks, 

-danny

On Nov 25, 2009, at 1:07 PM, Samuel Weiler wrote:

> As best I can tell, the technical substance of sidr-repos-struct-03 is in fine shape.  That said, I found the document difficult to review, largely due to the style of its writing.  While I recognize that this may be merely a matter of stylistic preference, I find the writing unnecessarily verbose and unapproachable.
> 
> I notice that the only two other WGLC reviews of this doc came from native English speakers, one of whom has been deeply involved in the work for years.  I think the doc has not gotten adequate review, I think that is in large part because of the writing.
> 
> I think this document would benefit greatly from an editorial pass, probably from a different editor.  Assuming someone can be found to do that, I support delaying the publication in the interest of producing a more readable document.
> 
> And, as I noted in my WGLC review of the architecture draft, I have some reservations about pushing these docs out without having the validation algorithm nailed down (including the handling of incremental deployment).  In the case of this document, noting that it has normative references to the architecture and manifests docs, which are more likely to see changes from changing the validation scheme, I don't see any harm in sending it forward.
> 
> 
> Specific suggestions
> 
> Danny McPherson's comments on ths draft from 3 December 2008 don't appear to have been incorporated nor responded to on the list. (e.g. "complete set" is still a strange phrasing, and the spelling nits haven't been fixed)
> 
> Rsync is not mentioned in the intro.  Instead of just referring to "publication points", adding the concreteness of "rsync" at that stage would help make the doc clearer.
> 
> Section 1: "A Resource Certificate describes an action by an Issuer that binds a list of IP address blocks and AS numbers to the Subject of a certificate, identified by the unique association of the Subject's private key with the public key contained in the Resource Certificate."  "describes an action"?  Surely there's a better way to say that.
> 
> I'm not sure that Section 2.2 paragraph on naming certificates is consistent with section 4's guidance on persistent naming.  Which may be more about how hard it was to understand section 2.2 than about any real differences.
> 
> 
> Nits
> 
> The rsync reference appears to be truncated.
> 
> Spelling:
> s/performss/performs/
> s/Becuase/Because/
> s/Whn/When/
> s/traveral/traversal/
> (and there are surely others, including some that Danny pointed out)
> 
> -- Sam
> 
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr