Subject: [Sidrops] [WGLC] draft-ietf-sidrops-8210bis-05 - Ends 31/January/2022

From: Keyur Patel <[email-masked]>
Date: Mon, 17 Jan 2022 22:29:30 +0000

Hi Folks:

A working group last call has been re-issued for draft-ietf-sidrops-8210bis-05, “The Resource Public Key Infrastructure (RPKI) to Router Protocol, Version 2”.  All the pending edits and discusses from the previous last call has been resolved. Please reply to the list with your comments. The WGLC will end on January 31st, 2022.

The draft can be found at https://datatracker.ietf.org/doc/html/draft-ietf-sidrops-8210bis. Authors, please reply indicating whether you're aware of any relevant IPR that hasn't been disclosed.

Regards,

Nathalie, Chris & Keyur

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 27 Jan 2022 17:48:35 -0500

Reminder about this standing WGLC which I think hasnt' seen any (at least
public) chatter...

On Mon, Jan 17, 2022 at 5:29 PM Keyur Patel <[email-masked]> wrote:

> _______________________________________________
> Sidrops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidrops
>

---

From: Tim Bruijnzeels <[email-masked]>
Date: Fri, 28 Jan 2022 11:09:15 +0100

Hi,

> On 27 Jan 2022, at 23:48, Christopher Morrow <[email-masked]> wrote:
> 
> Reminder about this standing WGLC which I think hasnt' seen any (at least public) chatter...
> 

First: I do not object against the content of this document.

So, please don't take the following as obstructive. On the contrary, I want to see what can be done to get everything moving..

From a formal perspective there is a normative reference to the aspa-profile document, so I think that means that document needs become an RFC before this - or at the same time. Formalities aside, it would be good to have the next versions of the ASPA profile (draft-ietf-sidrops-aspa-profile) and AS Path Verification (draft-ietf-sidrops-aspa-verification) available before calling this done.

In particular, we need clarity on whether we will have:
A - 1 or more provider ASNs (profile), and use AS 0 as a special case for 'no providers' (verification); or
B - 0 or more provider ASNs (profile), where 0 means 'no providers' (verification)

As written 8210-bis can cater for both cases - and as such this may not have to block. Still if the authors and WG decide to stick to option 'A', then the empty provider set (zero providers in the ASPA PDU) will never occur and it could be a locus for bugs and/or confusion.

So, let me repeat my questions to the authors of draft-ietf-sidrops-aspa-profile and draft-ietf-sidrops-aspa-verification. When will we see next versions? Will they use option A or B? And, finally, would you like me to suggest text for option B to get things moving? I am willing to spend cycles on this, but only by invitation and if you indicate that this would be considered constructive.

Tim

---

From: Ben Maddison <[email-masked]>
Date: Fri, 28 Jan 2022 16:13:22 +0200

Hi all,

> So, let me repeat my questions to the authors of draft-ietf-sidrops-aspa-profile and draft-ietf-sidrops-aspa-verification. When will we see next versions? Will they use option A or B? And, finally,…
+1 to all the above - this was almost the exact mail I was going to
write.

Also happy to assist with getting the other docs over the line if the
authors are low on cycles.

Cheers,

Ben