Subject: Re: [Sidrops] three 8210bis issues

From: Randy Bush <[email-masked]>
Date: Thu, 06 Jan 2022 15:27:45 -0800

tim, i believe that draft-ietf-sidrops-8210bis-05.foo should address
your issues.  please review when you get a chance.

randy

---

From: Tim Bruijnzeels <[email-masked]>
Date: Mon, 10 Jan 2022 10:15:17 +0100

Randy,

> On 7 Jan 2022, at 00:27, Randy Bush <[email-masked]> wrote:
> 

Kids are back to school so work can get done again by the parent..

Thank you for the changes. They now allow for the explicit distinction between the case where an ASPA exists for a customer ASN with an explicit empty set of providers vs not having an ASPA for that ASN.

I believe that this also enables changing the ASPA profile and verification documents to use the explicit empty set rather than overloading AS0. I have made some noises during the discussion that AS0 should be used - but that was based on the assumption that 8210bis did not allow for this distinction. Now that it does I prefer that an explicit empty set is used.

So, can I take this thread to ask the profile and verification document authors about their opinion on the use of the empty set of providers? I think the discussion happened mainly between me, Ben Madisson, Randy Bush and Job Snijders - if I am not mistaken. I think that the four of us are pretty much aligned on this now (again if I am not mistaken). If it is desired then I can suggest some specific text changes to this effect for both documents, but I do not wish to overstep.

Tim

---

From: Randy Bush <[email-masked]>
Date: Mon, 10 Jan 2022 03:28:07 -0800

thanks tim

i believe this clears the last discuss on wglc for 8210bis

good luck with the aspa docs :)

randy

On Mon, 10 Jan 2022 01:15:17 -0800,Tim Bruijnzeels wrote:
> Thank you for the changes. They now allow for the explicit distinction
> between the case where an ASPA exists for a customer ASN with an
> explicit empty set of providers vs not having an ASPA for that ASN.
> 
> I believe that this also enables changing the ASPA profile and
> verification documents to use the explicit empty set rather than
> overloading AS0. I have made some noises during the discussion that
> AS0 should be used - but that was based on the assumption that 8210bis
> did not allow for this distinction. Now that it does I prefer that an
> explicit empty set is used.
> 
> So, can I take this thread to ask the profile and verification
> document authors about their opinion on the use of the empty set of
> providers? I think the discussion happened mainly between me, Ben
> Madisson, Randy Bush and Job Snijders - if I am not mistaken. I think
> that the four of us are pretty much aligned on this now (again if I am
> not mistaken). If it is desired then I can suggest some specific text
> changes to this effect for both documents, but I do not wish to
> overstep.
> 
> Tim