Subject: [siesta] Eastbound - Westbound

From: Robert Moskowitz <[email-masked]>
Date: Thu, 28 Nov 2013 08:03:07 -0500

I *think* I have coined a new terminology that I have clearly stolen 
from others that talk about a southbound and northbound set of 
interfaces (e.g. Openflow).

A Siesta-like process, like my SSE, sits in user space next to a 
communicating application, performing the necessary session level 
security functions.  This SSE process MUST follow all the current Best 
Practices on maintaining a proper security boundary.  But SSE does not 
do the key management; next to it is a KMP also sitting in user space.

So to the east of SSE is the communicting application that is using its 
security services.  To the west of SSE is a KMP which actually manages 
the security state for SSE.

So unless someone else can point me to somewhere else where East/West 
bound interfaces and APIs are named as such...

Or is the app to the west and KMP to the east?

Sheesh, I got to finish packing and get on the road already!!  ;)'

---

From: "Diego R. Lopez" <[email-masked]>
Date: Thu, 28 Nov 2013 15:20:28 +0000

Hi,

I tend to imagine the KMP to the West and the application to the East, just because of the left-to-right order for the elements in a normal exchange.

And I have employed this similar idea of the "East/West-bound" interface when talking about SDN controller interconnection (actually, I always used "Eastbound" because of the above idea on order)

Be goode,

On 28 Nov 2013, at 14:03 , Robert Moskowitz wrote:

> I *think* I have coined a new terminology that I have clearly stolen from others that talk about a southbound and northbound set of interfaces (e.g. Openflow).
>
> A Siesta-like process, like my SSE, sits in user space next to a communicating application, performing the necessary session level security functions.  This SSE process MUST follow all the current Best Practices on maintaining a proper security boundary.  But SSE does not do the key management; next to it is a KMP also sitting in user space.
>
> So to the east of SSE is the communicting application that is using its security services.  To the west of SSE is a KMP which actually manages the security state for SSE.
>
> So unless someone else can point me to somewhere else where East/West bound interfaces and APIs are named as such...
>
> _______________________________________________
> siesta mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siesta

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 29 Nov 2013 09:59:04 -0500

> I tend to imagine the KMP to the West and the application to the East, just because of the left-to-right order for the elements in a normal exchange.

Kind of what I thought as well.  Great minds think alike!

> And I have employed this similar idea of the "East/West-bound" interface when talking about SDN controller interconnection (actually, I always used "Eastbound" because of the above idea on order)

Sigh.  Thought it would be obvious.  East/West that is.  But that means 
the 'coin' is out there so others will understand what we are refering to.

> Be goode,

Got 4 grandsons (6 yrs, 3 yrs, 2 yrs, 6 mos) here to enjoy and two sets 
of parents to take care of the messy diapers!

-- 
Standard Robert Moskowitz
Senior Technical Advisor
Security & Standards
Verizon Business Systems
C:248-928-6233
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit