Subject: Sieve - ABNF of block

From: "Wilbert de Graaf" <[email-masked]>
Date: Tue, 1 Dec 1998 19:36:52 +0100

I believe a block cannot contain -just- comments or be empty, like this:

... { 
    # commented for now
    # discard;
}

but this might be the intention. If not, these rules prevent this:

block = "{" commands "}"
commands  = *([WSP] command [WSP])
command = identifier ...

Maybe
commands = *[WSP] *([WSP] command [WSP])
although this does not really reprsent commands.

- Wilbert

---

From: Tim Showalter <[email-masked]>
Date: 1 Dec 1998 14:25:55 -0500

I have no problem with making the following legal in the grammar, taking 
Wilbert's suggestions.  As far as I know, they're just bugs in the
specification.

* blocks containing no commands
* scripts taking no commands

Tim

-- 
Tim Showalter <[email-masked]>