Subject: address test with multiple addresses?

From: Lawrence Greenfield <[email-masked]>
Date: 18 May 1999 17:04:37 -0400

How is the address test suppose to handle multiple addresses?

For instance, if my message has:

To: [email-masked], [email-masked]

and I test

if address :localpart :is "to" "sg3y" {
  fileinto "INBOX.silly";
}

does this match?  When should it match with multiple addresses?

Thanks,
Larry

---

From: Tim Showalter <[email-masked]>
Date: 19 May 1999 17:24:51 -0400

> Date: 18 May 1999 17:04:37 -0400
> From: Lawrence Greenfield <[email-masked]>
> 

My assumption is that it would work just like header, and that if any
address appeared in any named header, it would match.

Did you have something else in mind?

I'll clarify the text.  Any ideas?

Tim

---

From: Ned Freed <[email-masked]>
Date: Wed, 19 May 1999 21:50:48 -0700 (PDT)

> address appeared in any named header, it would match.

I agree with Tim's assessment (and FWIW, so does my implementation).

				Ned

---

From: Lawrence Greenfield <[email-masked]>
Date: 20 May 1999 08:58:40 -0400

Ok, this is the behavior implemented in CMU Sieve 1.1.

I think some clarifying language ("header" and "address" tests are
performed for each header present and for each address present, doing
a logical or of the results.)

Thanks,
Larry

				   Ned