Subject: Fileinto-except

From: "Madan Ganesh Velayudham" <[email-masked]>
Date: Wed, 5 Nov 2003 01:18:13 +0530

Hi,

	Please share your views on the attached document.

	I will submit a draft version after the queue is open.

	Sincerely,
	MG

	**************************
	Madan Ganesh Velayudham
	[email-masked]	
	+91-80-205-3108
	**************************
	+HP/STSD/Internet Services
	Bangalore, India

	Everything is possible

---

From: Cyrus Daboo <[email-masked]>
Date: Tue, 04 Nov 2003 15:07:30 -0500

Hi Madan,

--On Wednesday, November 05, 2003 01:18:13 AM +0530 Madan Ganesh Velayudham 
<[email-masked]> wrote:

| 	Please share your views on the attached document.
|
| 	I will submit a draft version after the queue is open.

Is the use of this meant to be to implement some sort of spam/virus 
checking? If so, then I think this is overloading sieve too far - sieve is 
not meant to be an anti-spam/anti-virus tool. Instead you should consider 
using proper tools for that, and hook in the spamtest/virustest extension 
into sieve.

-- 
Cyrus Daboo

---

From: "Madan Ganesh Velayudham" <[email-masked]>
Date: Wed, 5 Nov 2003 19:30:35 +0530

Hi Cyrus,

	Thanks for your comments.

> spamtest/virustest extension 

	I do not want to limit this to spam or virus checking. One of
the requirement
	for this is that I receive mails from certain individuals with
same attachment
	always, which I don't want to have in the mailbox and occupy
space.

	Instead I just be interested in the Main content of the message.

	The received message could indicate "a narration" that the
attachment has been 
	removed for the user.

	I'm planning to leverage imap-remove extension which I've
proposed recently.

	+MG

---

From: Rob Siemborski <[email-masked]>
Date: Wed, 5 Nov 2003 09:26:36 -0500 (EST)

> 	I will submit a draft version after the queue is open.

I'm not really sure there's enough detail in the attached document to go
on.  Excluding the lack of normal ID boilerplate and the spelling/grammar
problems, there is no syntax for the extension specified, nor are any
examples given.

It is also unclear how the mime part that is being excluded is being
specified, or how to exclude more than one mime part.  Without variables
(and better body tests), it is unclear to me that you can reliably target
a specific mime part in sieve.  (Or do you always just want to get rid of
part 2.1 of a message?)

-Rob

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Rob Siemborski | Andrew Systems Group * Research Systems Programmer
PGP:0x5CE32FCC | Cyert Hall 207 * [email-masked] * 412.268.7456
-----BEGIN GEEK CODE BLOCK----
Version: 3.12
GCS/IT/CM/PA d- s+: a-- C++++$ ULS++++$ P+++$ L+++(++++) E W+ N o? K-
w O- M-- V-- PS+ PE++ Y+ PGP+ t+@ 5+++ R@ tv-@ b+ DI+++ G e++ h r- y?
------END GEEK CODE BLOCK-----

---

From: "Madan Ganesh Velayudham" <[email-masked]>
Date: Wed, 5 Nov 2003 21:04:26 +0530

Hi Rob,

	Sorry for not describing the scope of this draft.

	Initially I would like to get comments like whether such an
	feature is already available; Basically whether it replicates
	the concept that is already done.

	I shall come up with the proper draft and send it for
discussion.

	Thanks for your understanding,
	MG

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Rob 
> Siemborski
> Sent: Wednesday, November 05, 2003 7:57 PM
> To: Madan Ganesh Velayudham
> Cc: [email-masked]
> Subject: Re: Fileinto-except
> 
> 
> 
> I'm not really sure there's enough detail in the attached 
> document to go on.  Excluding the lack of normal ID 
> boilerplate and the spelling/grammar problems, there is no 
> syntax for the extension specified, nor are any examples given.
> 
> It is also unclear how the mime part that is being excluded 
> is being specified, or how to exclude more than one mime 
> part.  Without variables (and better body tests), it is 
> unclear to me that you can reliably target a specific mime 
> part in sieve.  (Or do you always just want to get rid of 
> part 2.1 of a message?)
> 
> -Rob
> 
> Rob Siemborski | Andrew Systems Group * Research Systems 
> Programmer PGP:0x5CE32FCC | Cyert Hall 207 * 
> [email-masked] * 412.268.7456 -----BEGIN GEEK CODE BLOCK----
> Version: 3.12
> GCS/IT/CM/PA d- s+: a-- C++++$ ULS++++$ P+++$ L+++(++++) E W+ 
> N o? K- w O- M-- V-- PS+ PE++ Y+ PGP+ t+@ 5+++ R@ tv-@ b+ 
> DI+++ G e++ h r- y? ------END GEEK CODE BLOCK-----
> 
>