Subject: Administrator Vs User SIEVE scripts

From: "Madan Ganesh Velayudham" <[email-masked]>
Date: Tue, 4 Nov 2003 23:03:33 +0530

I assume all users can have sieve scripts to filter their mails.
In  
	addition to user specific sieve scripts, administrator/system
level 
	sieve script should also exist in order to override other user's
scripts.

	Does any of our SIEVE documents talk about this. 

	I guess multiscript draft should capture.
	Pls clarify. 

	Cheers,
	MG

---

From: [email-masked]
Date: Tue, 04 Nov 2003 10:44:54 -0800 (PST)

> 	sieve script should also exist in order to override other user's

Actually, it usually needs to be the other way around -- the user
needs the ability to override the site's filtering defaults.

> 	I guess multiscript draft should capture.

It is far from clear that we should be getting into classification
of scripts as user vs system vs domain vs whatever. This sort of thing
is always going to be highly implementation specific.

				Ned

---

From: "Madan Ganesh Velayudham" <[email-masked]>
Date: Wed, 5 Nov 2003 00:30:42 +0530

Ned,

	Thanks for your reply.

> 
> > 	I assume all users can have sieve scripts to filter 
> their mails. In
> Actually, it usually needs to be the other way around -- the 
> user needs the ability to override the site's filtering defaults.

	I think that that should not be the case. Because if site
decides 
	to reject mails from AAA.com and if user wants to accept, I
think
	site decision should be the first.

> It is far from clear that we should be getting into 
> classification of scripts as user vs system vs domain vs 
> whatever. This sort of thing is always going to be highly 
> implementation specific.

	I agree. Thanks again.

---

From: "Mark E. Mallett" <[email-masked]>
Date: Tue, 4 Nov 2003 14:30:10 -0500

> 	site decision should be the first.

That sort of thing sounds like system administrative/political policy
to me.

Especially if we take "reject" as its common non-sieve meaning, where
reject can mean one of SMTP refusal, firewall blackholing, filter
rejection, or any number of things.  At any rate there are some
cases where site policy should precede user decisions, and some
other cases where site policy is applied by default in the
abscense of user decisions.  Facilitating those choices could
be a language issue, but making them: probably not.

mm

---

From: [email-masked]
Date: Tue, 04 Nov 2003 11:28:08 -0800 (PST)

> 	site decision should be the first.

That's not how most of my customer's customers see it. There is far too much
ill-considered automated rejection of email that needs to be able to be able to
be overridden on a per-user basis.

				Ned

---

From: "Nigel Swinson" <[email-masked]>
Date: Tue, 4 Nov 2003 19:37:06 -0000

> site decision should be the first.

The solution is to have both.  Our Mailserver has a server level script (run
at SMTP level), where your admin could reject mail with a site wide policy.
The end user has no say on the actions in that script.  It also has an end
user sieve script where a user can file mail etc, but if that script takes
no actions, then it will end up in a server defined default mailbox script
that will take some default actions like spamtest/virustest etc.

So the end user can choose to opt out of some of the administrator defined
scripts, and not from others.  That way you put the decision of where to
filter in the hands of the administrator.

Cheers,

Nigel