Subject: Specification of ":mime" in vacation extension

From: Michael Haardt <[email-masked]>
Date: Mon, 02 Aug 2004 13:26:17 +0200

Hello,

when using ":mime", CMU Sieve 2.3 uses the MIME header and body
to build a message with Content-Type multipart/mixed, the only
part being the reason string.

The vacation draft refers to RFC 3028, which in turn does not
specify how such mails are composed.

Do other implementations work the same way? What's the reason
behind not adding the MIME header to the message header, thus
giving the script writer full control over the message? The
current specification (or lack thereof) would allow doing so.

Michael

---

From: [email-masked]
Date: Mon, 02 Aug 2004 10:05:50 -0700 (PDT)

> part being the reason string.

This seems like one possible way to do it. Another way would be to construct a
message containing a single MIME part specified in the reason string, without
putting it in a multipart/mixed.

> specify how such mails are composed.

Perhaps not in the sense of what's done with the part, but the specification
certainly defines what goes in the reason string.

> Do other implementations work the same way?

Our implementation doesn't use a multipart/mixed wrapper. It simply treats
the content as a MIME entity and wraps it inside of a message.

> What's the reason
> giving the script writer full control over the message?

So that things besides text/plain; charset=utf-8 can be returned.

> The

It is supposed to.

				Ned