Subject: Re: AD review of draft-ietf-sieve-3028bis-12

From: Alexey Melnikov <[email-masked]>
Date: Sun, 01 Apr 2007 15:12:27 +0100

Aaron Stone wrote:

>Everything looks good. A few more wordsmithing comments below.
>
>On Fri, Mar 30, 2007, Alexey Melnikov <[email-masked]> said:
>  
>
>>  Chris Newman wrote:
>>    
>>
>>>Alexey Melnikov wrote on 3/29/07 18:15 +0100:
>>>      
>>>
>>>>After discussing this with Cyrus: chairs would like to publish -12 +
>>>>RFC-editor's notes.
>>>>        
>>>>
>>>That's fine.  Send me RFC-editor notes I can paste into the ballot and 
>>>I'll push the draft forward.
>>>      
>>>
>>Ok, here is the list of changes I would like to propose (Can please 
>>someone else sanity check this!).
>>    
>>
>[snip]
>  
>
>>In section 2.7.1, 1st paragraph, replace the 2nd sentence:
>>
>>OLD:
>>   Match type arguments are supplied to those commands which allow them 
>>to specify
>>   what kind of match is to be performed.
>>NEW:
>>  Match type arguments control what kind of match is to be performed by 
>>commands.
>>    
>>
>The whole thing is pretty awkward. Here's the whole paragraph in -12:
>
>   There are three match types describing the matching used in this
>   specification: ":is", ":contains", and ":matches".  Match type
>   arguments are supplied to those commands which allow them to specify
>   what kind of match is to be performed.
>
>   These are used as optional arguments to tests that perform string
>   comparison.
>
>Suggest:
>
>   Commands which perform string comparisons may have an optional match
>   type argument. The three match types in this specification are ":is",
>   ":contains", and ":matches". 
>  
>
I like that.

>I don't think we need to define the word argument "argument". We only need
>to explain what "match type arguments" are.
>
>
>A bit later in the section, I suggest dropping the highlighted clause:
>
>2.7.3. Comparators
>
>
>   In order to allow for language-independent, case-independent matches,
>   the match type may be coupled with a comparator name.  The Internet
>   Application Protocol Collation Registry [COLLATION] provides the
>   framework for describing and naming comparators as used by this
>   specification.                                  ^^^^^^^^^^^^^^^
>   ^^^^^^^^^^^^^^
>
>The purpose of the registry is not to document what Sieve does. Rather,
>Sieve is just using the registry.
>  
>
Good point.

>[snip]
>  
>
>>Add to the end:
>>
>>10. Added encoded-character capability and deprecated (but did not remove)
>>   use of arbitrary binary octets in Sieve scripts.
>>11. Updated IANA registration template, and permit capability prefix
>>   registrations.  Prefix registrations outside "vnd." require IESG 
>>approval.
>>12. Added .sieve as a valid extension for sieve scripts.
>>    
>>
>Suggest:
>
>    11. Updated IANA registration template, and added IANA considerations
>        to permit capability prefix registrations.
>
>We don't need to repeat the "vnd." requirement, we just have to point the
>reader to that section of the document.
>  
>
Yes, this is better.

---

From: "Nigel Swinson" <[email-masked]>
Date: Tue, 3 Apr 2007 14:49:09 +0100

> OLD:
>    Note that for a message that is exactly 4,000 octets, the message is
>    neither ":over" 4000 octets or ":under" 4000 octets.
>                                ^^
> 
> NEW:
>    Note that for a message that is exactly 4,000 octets, the message is
>    neither ":over" 4000 octets nor ":under" 4000 octets.
>                                ^^^

If you are going to be in here, you might as well say:

    Note that for a message that is exactly 4,000 octets, the message is
-    neither ":over" 4000 octets or ":under" 4000 octets.
+   neither ":over" nor ":under" 4000 octets.

Nigel