Subject: encoded-character and unicode range violations

From: Michael Haardt <[email-masked]>
Date: Wed, 11 Apr 2007 09:36:26 +0200

Hello,

just sitting at the code, what shoulb be the result of:

  "${unicode:0000000}"

Seven digits, yet in range.  To me, it should be a NUL character, not
an error.  Let's not specify the number of digits at all, neither in
the grammar nor in the text, and just specify the range.

Michael

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 11 Apr 2007 17:54:52 +0100

>the grammar nor in the text, and just specify the range.
Speaking as a contributor: this would be fine with me.

---

From: "Aaron Stone" <[email-masked]>
Date: Wed, 11 Apr 2007 18:41:08 -0000

> Speaking as a contributor: this would be fine with me.

Ok, and is this an error or ignored?

    "${unicode:ffffff}"

Aaron

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 11 Apr 2007 19:55:05 +0100

>Ok, and is this an error or ignored?
For "unicode:" it is an error, as FFFFFF is bigger than 10FFFF

---

From: "Aaron Stone" <[email-masked]>
Date: Wed, 11 Apr 2007 19:10:29 -0000

> For "unicode:" it is an error, as FFFFFF is bigger than 10FFFF

Ok, that resolves all of my outstanding questions.
I'm all set to see updated text whenever you're ready.

Aaron