Subject: Re: [sieve] [draft-melnikov-sieve-external-lists] 2.2 Allow Extensions To Use List

From: Alexey Melnikov <[email-masked]>
Date: Sun, 30 Aug 2009 16:33:17 +0100

Ned Freed wrote:

>This proposal seems OK to me.
>
Ok, I've included this into my working copy.
Should the "string" test be required as well?
 [...]

>>--------------------------------------------------------------------------
>>[1] Proposal
>>--------------------------------------------------------------------------
>>    
>>
>>2.2.  :list match type
>>    
>>
>>   ABNF:
>>    
>>
>>      MATCH-TYPE  =/ ":list"
>>           ; only valid for supported tests
>>    
>>
>>   The new ":list" match type changes the interpretation of the "key-
>>   list" parameter to supported tests.  When the match type is ":list",
>>   the key-list becomes a list of names of externally stored lists.
>>   The external lists are queried, perhaps through a list-specific
>>   mechanism, and the test evaluates to "true" if any of the specified
>>   values matches any member of one or more of the lists.
>>    
>>
>>   Implementations MUST support "address", "envelope" and "header" tests.
>>   Implementations MAY support other tests but MUST raise a compile
>>   time error when a script contains any standard test where support has
>>   not been explicitly specified.
>>    
>>

---

From: Ned Freed <[email-masked]>
Date: Sun, 30 Aug 2009 10:21:30 -0700 (PDT)

> Should the "string" test be required as well?

Yes, I think if both variables and external lists are supported, the string
test must allow :list.

I'm not comfortable with this being required to be compile time error. Think
for a minute about the interaction with the ihave extension.

				Ned