Subject: Re: [sieve] [draft-melnikov-sieve-external-lists] Proposed Addition To Section 2.4

From: Robert Burrell Donkin <[email-masked]>
Date: Fri, 4 Sep 2009 11:37:08 +0100

On Thu, Aug 27, 2009 at 10:30 PM, Alexey
Melnikov<[email-masked]> wrote:
> [I am catching up with the mailing list, so stay with me if this was already
> discussed]
>
> Robert Burrell Donkin wrote:
>
>> On Tue, Jul 28, 2009 at 8:39 AM, Barry
>> Leiba<[email-masked]> wrote:
>>
>> <snip>
>>
>>>
>>> I'll also point out that in most cases (us geeks
>>> notwithstanding), the script will be generated under the covers.  So
>>> the user might, indeed, just type "MyList", and the icky-looking URI
>>> would be filled in for her.
>>>
>>
>> how might such a generator discover how to map "MyList" to
>> "tag:MyList" (say) in an interoperable fashion?
>>
>
> I am thinking this should be a ManageSieve extension, so that the Sieve
> engine can signal which URI types it supports.

this would be useful but how does it answer the specific question i posed above?

- robert

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 04 Sep 2009 20:14:12 +0100

>this would be useful but how does it answer the specific question i posed above?
The answer to your question depends on how the generator is interacting 
with the Sieve engine. If it is using ManageSieve to read/write Sieve 
scripts, it can use  a ManageSieve capability.

---

From: Robert Burrell Donkin <[email-masked]>
Date: Fri, 4 Sep 2009 20:45:19 +0100

On Fri, Sep 4, 2009 at 8:14 PM, Alexey
Melnikov<[email-masked]> wrote:
> The answer to your question depends on how the generator is interacting with
> the Sieve engine. If it is using ManageSieve to read/write Sieve scripts, it
> can use  a ManageSieve capability.

how does understanding what URI types a sieve engine supports help
with the mapping problem i asked about?

- robert

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 04 Sep 2009 21:42:54 +0100

Hi Robert,

>with the mapping problem i asked about?
Specific details on how to perform a mapping depend on URI type (at 
minimum), because different URI types have different syntax and structure.

---

From: Robert Burrell Donkin <[email-masked]>
Date: Fri, 4 Sep 2009 22:18:32 +0100

On Fri, Sep 4, 2009 at 9:42 PM, Alexey
Melnikov<[email-masked]> wrote:
>>>> this would be useful but how does it answer the specific question i
>>>> posed
>>>> above?
>>>>
>>>
>>> with

i really don't understand the relevance of this to the question

how does understanding the URI types that a sieve engine understands
helps a generator map an arbitrary string ('MyList', say) to a
particular URI (tag:MyList, say) in an interoperable fashion?

- robert