Subject: Re: [sieve] Last Call: draft-freed-sieve-notary (Sieve Email Filtering: Delivery Status Notifications and Deliver-By Extensions) to Proposed Standard

From: Dilyan Palauzov <[email-masked]>
Date: Sun, 16 May 2010 20:38:12 +0200

Hello,

For draft-george-sieve-vacation-time it was agreed, that providing  
"vacation-seconds" in "require" implies that "vacation" is also  
specified.

My suggestion is to include in draft-freed-sieve-notary that require  
"envelope-dsn"/"envelope-deliverby" implies require "envelope".

Със здраве
   Дилян

----- Message from [email-masked] ---------
     Date: Thu, 25 Mar 2010 12:49:21 -0700 (PDT)
     From: The IESG <[email-masked]>
Reply-To: [email-masked]
  Subject: [sieve] Last Call: draft-freed-sieve-notary (Sieve Email  
Filtering: Delivery Status Notifications and Deliver-By Extensions) to  
Proposed Standard
       To: IETF-Announce <[email-masked]>
       Cc: [email-masked]

> The IESG has received a request from the Sieve Mail Filtering Language WG
> (sieve) to consider the following document:
>
> - 'Sieve Email Filtering: Delivery Status Notifications and Deliver-By
>    Extensions '
>    <draft-freed-sieve-notary-07.txt> as a Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send substantive comments to the
> [email-masked] mailing lists by 2010-04-08. Exceptionally,
> comments may be sent to [email-masked] instead. In either case, please
> retain the beginning of the Subject line to allow automated sorting.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-freed-sieve-notary-07.txt
>
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=15894&rfc_flag=0
>
> _______________________________________________
> sieve mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sieve
>

----- End message from [email-masked] -----

---

From: [email-masked]
Date: Sun, 16 May 2010 14:53:05 -0700 (PDT)

> "envelope-dsn"/"envelope-deliverby" implies require "envelope".

I'm ambivalent about this suggestion. What do other people think?

				Ned

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Tue, 18 May 2010 12:39:37 +0200

> I'm ambivalent about this suggestion. What do other people think?

I'd just as soon not have another special rule.

require [ "bond", "bond-james" ] isn't pretty. But not worse than many 
oher sieve constructs. Further, generators already know to include 
require "foo" when using extension foo, so I don't think these "bond, 
james bond" rules are greatly necessary either.

Arnt