Subject: [sieve] [Technical Errata Reported] RFC6009 (2545)

From: RFC Errata System <[email-masked]>
Date: Tue, 5 Oct 2010 13:00:28 -0700 (PDT)

The following errata report has been submitted for RFC6009,
"Sieve Email Filtering: Delivery Status Notifications and Deliver-By Extensions".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6009&eid=2545

--------------------------------------
Type: Technical
Reported by: Alfred Hoenes <[email-masked]>

Section: 7.2

Original Text
-------------
   # Send a copy to my cell phone to be delivered before 10PM
   if currentdate :value "lt"
                  :comparator "i;ascii-numeric" "hour" "22"
   {
       if currentdate :matches "date" "*" {set "date" "RFCORIGINAL_TEXT";}
       if currentdate :matches "zone" "*" {set "zone" "RFCORIGINAL_TEXT";}
|      redirect :copy :bytimeabsolute "${date}T20:00:00${zone}"
                :bymode "return" "[email-masked]";
   }

Corrected Text
--------------
   # Send a copy to my cell phone to be delivered before 10PM
   if currentdate :value "lt"
                  :comparator "i;ascii-numeric" "hour" "22"
   {
       if currentdate :matches "date" "*" {set "date" "RFCCORRECTED_TEXT";}
       if currentdate :matches "zone" "*" {set "zone" "RFCCORRECTED_TEXT";}
|      redirect :copy :bytimeabsolute "${date}T22:00:00${zone}"
                :bymode "return" "[email-masked]";
   }

Notes
-----
Rationale:  "10PM" corresponds to  T22:00:00 , not  T20:00:00 .

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6009 (draft-freed-sieve-notary-09)
--------------------------------------
Title               : Sieve Email Filtering: Delivery Status Notifications and Deliver-By Extensions
Publication Date    : October 2010
Author(s)           : N. Freed
Category            : PROPOSED STANDARD
Source              : Sieve Mail Filtering Language
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: [email-masked]
Date: Tue, 05 Oct 2010 16:30:34 -0700 (PDT)

The error is real and the change of 20 to 22 is correct, however, there's
something screwy about the surrounding text in the listing - where it
says 

    RFCORIGINAL_TEXT
    
and

    RFCCORRECTED_TEXT

it should say

   ${0}

as it does in the RFC.

				Ned