Subject: [sieve] [Editorial Errata Reported] RFC5233 (3079)

From: RFC Errata System <[email-masked]>
Date: Thu, 5 Jan 2012 07:14:32 -0800 (PST)

The following errata report has been submitted for RFC5233,
"Sieve Email Filtering: Subaddress Extension".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5233&eid=3079

--------------------------------------
Type: Editorial
Reported by: Aaron Stone <[email-masked]>

Section: 4

Original Text
-------------
   A diagram showing the ADDRESS-PARTs of an email address where the
   detail information follows a separator character sequence of "+" is
   shown below:

          :user "+" :detail  "@" :domain
         \-----------------/
             :local-part

   A diagram showing the ADDRESS-PARTs of a email address where the
   detail information precedes a separator character sequence of "--" is
   shown below:

          :detail "--" :user  "@" :domain
         \------------------/
             :local-part

Corrected Text
--------------
   A diagram showing the ADDRESS-PARTs of an email address where the
   detail information follows a separator character sequence of "+" is
   shown below:

          :user "+" :detail  "@" :domain
         \-----------------/
             :localpart

   A diagram showing the ADDRESS-PARTs of a email address where the
   detail information precedes a separator character sequence of "--" is
   shown below:

          :detail "--" :user  "@" :domain
         \------------------/
             :localpart

Notes
-----
Throughout the document, the prose phrase "local-part" is hyphenated, while the syntactic word ":localpart" is not hyphenated.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5233 (draft-ietf-sieve-rfc3598bis-05)
--------------------------------------
Title               : Sieve Email Filtering: Subaddress Extension
Publication Date    : January 2008
Author(s)           : K. Murchison
Category            : PROPOSED STANDARD
Source              : Sieve Mail Filtering Language
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: [email-masked]
Date: Thu, 05 Jan 2012 10:06:03 -0800 (PST)

The correction seems fine, but as long as you're correcting this section
might as well change the "a email address" to "an email address" in the second
paragraph.

				Ned

> _______________________________________________
> sieve mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sieve

---

From: Aaron Stone <[email-masked]>
Date: Thu, 5 Jan 2012 10:21:08 -0800

Just happened to read back on the rejected erratum, and realized that
he'd caught the right error in the wrong place (local-part vs.
:localpart). Theoretically, :local-part is a technical error, but I
marked it editorial because it's in an example rather than a normative
section.

I could add the typo, but that's way on the editorial side :)

Cheers,
Aaron