Subject: [Sigtran] Notify

From: "reshma" <[email-masked]>
Date: Thu, 18 Apr 2002 15:22:00 +0530

Hi,

    In section 3.8.2 Notify  there is no information about Notify with status Type "Other" and status information "ASP Failure".When this should be  sent ?

Thanks,
Reshma

---

From: "Sundaresan M G" <[email-masked]>
Date: Thu, 18 Apr 2002 15:58:12 +0530

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************

Hi,

These attached mails should answer your question.

Best Regards,
Sundar.
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
reshma
  Sent: Thursday, 18 April 2002 3:22 PM
  To: [email-masked]
  Subject: [Sigtran] Notify

  Hi,

      In section 3.8.2 Notify  there is no information about Notify with
status Type "Other" and status information "ASP Failure".When this should be
sent ?

  Thanks,
  Reshma

Subject: Re: [Sigtran] M3UA : NTFY for ASP Failure
From: "Brian F. G. Bidulock" <[email-masked]>
To: "Vats, Umesh" <[email-masked]>
Cc: <[email-masked]>
Date: Tue, 16 Apr 2002 09:10:53 +0530

Umesh,

The SG always knows the list of AS to which the ASP
belongs at any given time.  When the ASP goes UP,
the SG uses this information to decide in which AS
the ASP has become ASP-INACTIVE.

It just so happens that in the case of complete
dynamic registration, the ASP belongs to no AS
and there is no other ASP that qualifies
as a candidate to receive the NTFY.  But this is
a corner case.

--brian

Vats, Umesh wrote:                                          (Mon, 15 Apr
2002 20:22:00)
> Hi  Brian
>
> The problem is until ASP goes ACTIVE for any AS,
> SG won't know the list of Application Servers to which
> the ASP belongs (e.g. take the case of dynamic RK
> registration).
>
> Then how will SG determine the list of ASPs to which
> NTFY is to be sent ?
>
> Umesh
>
>
> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Monday, April 15, 2002 8:05 PM
> To: Vats, Umesh
> Cc: [email-masked]'
> Subject: Re: [Sigtran] M3UA : NTFY for ASP Failure
>
>
> Umesh,
>
> Please see comments below...
>
> Vats, Umesh wrote:                                          (Mon, 15 Apr
> 2002 19:23:35)
> > Hi
> >
> > In M3UA draft 12 section 3.8.2, following statement is there :
> >
> > "For the ASP Failure case, the SGP is indicating to ASP(s)
> > in the AS that one of the ASPs has transitioned to ASP-DOWN.  The ASP
> > Identifier (if available) of the failed ASP MUST be placed in the
> > message."
> >
> > Suppose an ASP sends ASP-UP message to SGP. Now the ASP goes down.
> > Should SGP send NTFY("ASP Failure") message to ASPs ?
>
> Yes.
>
> > If yes, to what all ASPs should this NTFY message be sent(SGP won't
> > be knowing the list of Application Servers) ?
>
> To all ASPs that are in other than the ASP-DOWN state for AS in which
> the ASP has failed.
>
> > What all routing contexts should be included in the message ?
>
> The routing contexts of the AS for which the ASP has failed.
>
> >
> > I think these answers can be captured in implementor's guide also.
>
> Its a little bit obvious...
>
> --brian
>
> >
> > Umesh
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

Subject: RE: [Sigtran] M3UA : NTFY for ASP Failure
From: "Vats, Umesh" <[email-masked]>
To: <[email-masked]>, "Vats, Umesh" <[email-masked]>
Cc: <[email-masked]>
Date: Tue, 16 Apr 2002 08:52:00 +0530

Hi  Brian

The problem is until ASP goes ACTIVE for any AS,
SG won't know the list of Application Servers to which
the ASP belongs (e.g. take the case of dynamic RK 
registration).

Then how will SG determine the list of ASPs to which
NTFY is to be sent ?

Umesh

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, April 15, 2002 8:05 PM
To: Vats, Umesh
Cc: [email-masked]'
Subject: Re: [Sigtran] M3UA : NTFY for ASP Failure

Umesh,

Please see comments below...

Vats, Umesh wrote:                                          (Mon, 15 Apr
2002 19:23:35)
> Hi
> 
> In M3UA draft 12 section 3.8.2, following statement is there :
> 
> "For the ASP Failure case, the SGP is indicating to ASP(s) 
> in the AS that one of the ASPs has transitioned to ASP-DOWN.  The ASP 
> Identifier (if available) of the failed ASP MUST be placed in the 
> message."
> 
> Suppose an ASP sends ASP-UP message to SGP. Now the ASP goes down.
> Should SGP send NTFY("ASP Failure") message to ASPs ?

Yes.

> If yes, to what all ASPs should this NTFY message be sent(SGP won't
> be knowing the list of Application Servers) ?

To all ASPs that are in other than the ASP-DOWN state for AS in which
the ASP has failed.

> What all routing contexts should be included in the message ?

The routing contexts of the AS for which the ASP has failed.

> 
> I think these answers can be captured in implementor's guide also.

Its a little bit obvious...

--brian

> 
> Umesh
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

Subject: Re: [Sigtran] M3UA : NTFY for ASP Failure
From: "Brian F. G. Bidulock" <[email-masked]>
To: "Vats, Umesh" <[email-masked]>
Cc: <[email-masked]>
Date: Tue, 16 Apr 2002 08:35:01 +0530

Umesh,

Please see comments below...

Vats, Umesh wrote:                                          (Mon, 15 Apr
2002 19:23:35)
> Hi
>
> In M3UA draft 12 section 3.8.2, following statement is there :
>
> "For the ASP Failure case, the SGP is indicating to ASP(s)
> in the AS that one of the ASPs has transitioned to ASP-DOWN.  The ASP
> Identifier (if available) of the failed ASP MUST be placed in the
> message."
>
> Suppose an ASP sends ASP-UP message to SGP. Now the ASP goes down.
> Should SGP send NTFY("ASP Failure") message to ASPs ?

Yes.

> If yes, to what all ASPs should this NTFY message be sent(SGP won't
> be knowing the list of Application Servers) ?

To all ASPs that are in other than the ASP-DOWN state for AS in which
the ASP has failed.

> What all routing contexts should be included in the message ?

The routing contexts of the AS for which the ASP has failed.

>
> I think these answers can be captured in implementor's guide also.

Its a little bit obvious...

--brian

>
> Umesh
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

Subject: [Sigtran] M3UA : NTFY for ASP Failure
From: "Vats, Umesh" <[email-masked]>
To: <[email-masked]>
Date: Tue, 16 Apr 2002 07:53:35 +0530

Hi

In M3UA draft 12 section 3.8.2, following statement is there :

"For the ASP Failure case, the SGP is indicating to ASP(s) 
in the AS that one of the ASPs has transitioned to ASP-DOWN.  The ASP 
Identifier (if available) of the failed ASP MUST be placed in the 
message."

Suppose an ASP sends ASP-UP message to SGP. Now the ASP goes down.
Should SGP send NTFY("ASP Failure") message to ASPs ?
If yes, to what all ASPs should this NTFY message be sent(SGP won't
be knowing the list of Application Servers) ? What all routing contexts
should be included in the message ?

I think these answers can be captured in implementor's guide also.

Umesh

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran