Subject: RE: [Sigtran] M3UA : NTFY for ASP Failure

From: "Vats, Umesh" <[email-masked]>
Date: Mon, 15 Apr 2002 20:22:00 -0700

Hi  Brian

The problem is until ASP goes ACTIVE for any AS,
SG won't know the list of Application Servers to which
the ASP belongs (e.g. take the case of dynamic RK 
registration).

Then how will SG determine the list of ASPs to which
NTFY is to be sent ?

Umesh

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, April 15, 2002 8:05 PM
To: Vats, Umesh
Cc: [email-masked]'
Subject: Re: [Sigtran] M3UA : NTFY for ASP Failure

Umesh,

Please see comments below...

Vats, Umesh wrote:                                          (Mon, 15 Apr
2002 19:23:35)
> Hi
> 
> In M3UA draft 12 section 3.8.2, following statement is there :
> 
> "For the ASP Failure case, the SGP is indicating to ASP(s) 
> in the AS that one of the ASPs has transitioned to ASP-DOWN.  The ASP 
> Identifier (if available) of the failed ASP MUST be placed in the 
> message."
> 
> Suppose an ASP sends ASP-UP message to SGP. Now the ASP goes down.
> Should SGP send NTFY("ASP Failure") message to ASPs ?

Yes.

> If yes, to what all ASPs should this NTFY message be sent(SGP won't
> be knowing the list of Application Servers) ?

To all ASPs that are in other than the ASP-DOWN state for AS in which
the ASP has failed.

> What all routing contexts should be included in the message ?

The routing contexts of the AS for which the ASP has failed.

> 
> I think these answers can be captured in implementor's guide also.

Its a little bit obvious...

--brian

> 
> Umesh
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 15 Apr 2002 22:40:53 -0500

Umesh,

The SG always knows the list of AS to which the ASP
belongs at any given time.  When the ASP goes UP, 
the SG uses this information to decide in which AS
the ASP has become ASP-INACTIVE.

It just so happens that in the case of complete
dynamic registration, the ASP belongs to no AS
and there is no other ASP that qualifies
as a candidate to receive the NTFY.  But this is
a corner case.

--brian

Vats, Umesh wrote:                                          (Mon, 15 Apr 2002 20:22:00)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/