Subject: RE: [Sigtran] M3UA : Messages and Streams

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 16 Apr 2002 14:52:16 +0200

Hi guys, 

Reading the RFC again, I can not see a place where all these statements are clearly stated.

Sections: 1.4.7, 3.8.1 and 4.1.1 say something about that, 

Do you think we should complete section 1.4.7 with saying that
 - DATA message must not be sent thru stream 0 and that 
 - MGMT (BEAT and NOTIFY) messages MUST be sent thru stream 0
 - Other messages may be sent thru stream 0 when not correlation is needed or thru the corresponding stream different of zero when correlation is required.
?

IMO, since the main reason to send BEAT is to ensure that the M3UA peer is alive (independent of AS) it should be sent thru stream 0.

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Tuesday, April 16, 2002 1:50 AM
> To: Vats, Umesh
> Cc: [email-masked]'
> Subject: Re: [Sigtran] M3UA : Messages and Streams
> 
> 
> Umesh,
> 
> Its my understanding that ASPSM and RKM messages *are*
> management messages and must be sent on stream `0'.
> Except for BEAT and BEAT Ack which might be sent on
> a stream corresponding to an AS, depending on the
> reason for the BEAT/Ack.
> 
> IMO ASPTM messages should be sent on the stream that
> corresponds to the AS in question, as should SSNM.
> Where SSNM corresponds to multiple AS (has multiple RCs)
> it could either be sent on stream `0' or another stream
> corresponding to one or more of the AS.
> 
> The RFC is consistent with this interpretation.
> 
> --brian
> 
> Vats, Umesh wrote:                                          
> (Mon, 15 Apr 2002 12:45:23)
> > Hi
> > 
> > After going through draft12 of M3UA, I have following 
> understanding of 
> > Message class to stream mappings :
> > 
> > 1. DATA messages   : Always sent on a stream other than 0.
> > 2. MGMT messages  : Always sent on stream 0.
> > 3. ASPSM, ASPTM, RKM and SSNM messages can be sent
> >     on  any stream.
> > 
> > Is this understanding OK ?
> > 
> > thanks
> > Umesh
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 16 Apr 2002 08:11:50 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:                          (Tue, 16 Apr 2002 14:52:16)
> IMO, since the main reason to send BEAT is to ensure that the M3UA peer is
> alive (independent of AS) it should be sent thru stream 0.

BEAT was excluded from ASPSM and permitted to be sent over streams other
that stream `0' so that a UA could send BEAT with particular heartbeat
data and then know that when the BEAT Ack was received that the data from
the stream upon which it was sent has been flushed to the peer.  This
parallels changeback procedures in MTP3.  BEAT must remain on stream

There is also a purpose to sending NTFY messages on a stream corresponding
to the AS to which they refer.  (For the same reason that ASPTM is sent on
other than stream `0'.)  This is particularly important if per-stream
congestion controls are instituted.

Actually we went to great trouble to ensure that the wording in the
RFC was correct, even if it is not collected together nicely.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/