Subject: RE: [Sigtran] m3ua-implementors-guidev00 n+k traffic mode

From: "Vats, Umesh" <[email-masked]>
Date: Mon, 8 Apr 2002 09:27:59 -0700

Hi  Ken/Tolga

I agree with one of Tolga's suggestion that n+k
redundancy mode can be totally removed. Otherwise,
many other issues need to be taken care of for which
nothing is specified in draft e.g. 

1. How will ASPs know whether more than n ASPs have
   become ACTIVE for an AS at SGP (after which, the ASP
   should start sending traffic to SGP)
2. What will be state of AS at SGP if less than n ASPs
   are ACTIVE
3. What will be the state of AS at SGP if an ASP
   for an AS becomes INACTIVE and the total number of ASPs
   ACTIVE for an AS become n-1 

Either, all the above cases should be clearly specified
or n+k redundancy mode should be modified to 1+k redundancy
mode.

I think this can be covered in implementor's guide.

Umesh
-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]]
Sent: Monday, April 08, 2002 9:02 AM
To: [email-masked]
Subject: RE: [Sigtran] m3ua-implementors-guidev00 n+k traffic mode

Another issue related with n+k redundancy, if n is interpreted as
"required", I think there should be a way to tell in the traffic mode
parameter, what is the value of n.

   Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Tolga Asveren
> Sent: Monday, April 08, 2002 11:57 AM
> To: [email-masked]
> Subject: RE: [Sigtran] m3ua-implementors-guidev00 n+k traffic mode
>
>
> Here are some ideas about n+k traffic mode issue:
>
> The source of the problem is, how n should be interpreted in n+k case. It
> seems the initial idea was, 1 ACTIVE ASP is always enough and n shows the
> preferred number of ACTIVE ASPs. Then there was a shift to the opinion, to
> interprete n as the required number of ACTIVe ASPs. Currently there are
> conflicting statements in the draft about this issue.
>
> I don't know whether there is an agreement , but I favor the
> approach where
> n is interpreted as the required number of ACTIVE ASPs to consider AS in
> ACTIVE state. In my opinion, the main argument for this is, if we think 1
> ACTIVE ASP always enough to consider AS as ACTIVE, there is no need to
> define something special in the protocol to cover n+k redundancy case. How
> many ACTIVE ASPs are preferred depends totally on the SGP in such
> a case. In
> fact, maybe this also could be an option, to delete everyhting
> related with
> n+k redundacy from the draft (ecxept NTFY("Insufficient ASPs are active in
> AS", which will have the meaning "I want more ASPs ACTIVE for this AS" )
>
> Now, necessary changes to interprete n as the required number of ACTIVE
> ASPs(no guarantee that thi sis the full list)
>
> 1) Figure  5 :AS State Transition Diagram
>
> New Figure 5:
>
>                  Figure 5: AS State Transition Diagram
>
>                    one ASP trans to ACTIVE
>                    causing number of ACTIVE ASPs
>      +----------+  to be n                    +-------------+
>      |    AS-   |---------------------------->|     AS-     |
>      | INACTIVE |                             |   ACTIVE    |
>      |          |<---                         |             |
>      +----------+    \                        +-------------+
>         ^   |         \ Tr Expiry,                ^    |
>         |   |          \ at least one             |    |
>         |   |           \ ASP in ASP-INACTIVE     |    |
>         |   |            \                        |    |
>         |   |             \                       |    |
>         |   |              \                      |    |
> one ASP |   | all ASP       \           one ASP   |    | one ACTIVE
> trans   |   | trans to       \          trans to  |    | ASP trans to
> to      |   | ASP-DOWN        -------\   ASP-     |    | ASP-INACTIVE
> ASP-    |   |                         \  ACTIVE   |    | or
> ASP-DOWN causing
> INACTIVE|   |                    causing number   |    | number of ACTIVE
> ASPs
>         |   |                    of ACTIVE ASPs   |    | drop below n
>         |   |                    to be n \        |    |  (start Tr)
>         |   v                             \       |    v
>      +----------+                          \  +-------------+
>      |          |                           --|             |
>      | AS-DOWN  |                             | AS-PENDING  |
>      |          |                             |  (queueing) |
>      |          |<----------------------------|             |
>      +----------+    Tr Expiry and no ASP     +-------------+
>                      in ASP-INACTIVE state)
>
>     Tr = Recovery Timer
>
>
> I didn't touch transitions to AS-DOWN and AS-INACTIVE state. I am
> not sure,
> whether also for those states we should care about n or not (for
> example if
> n-1 ASPs are in INACTIVE state and 1 ASP is in DOWN state, is AS DOWN or
> INACTIVE in n+k redundancy case?)
>
>
>
> 2)4.3.4.3 ASP Active Procedures
>
> Old Text:
> An SGP or IPSP, upon reception of an ASP Active message for the first
> ASP in a Loadshare AS, MAY choose not to direct traffic to a newly
> active ASP until it determines that there are sufficient resources to
> handle the expected load (e.g., until there are "n" ASPs in state ASP-
> ACTIVE in the AS).  In this case, the SGP or IPSP SHOULD withhold the
> Notify (AS-ACTIVE) until there are sufficient resources.
>
> New Text:
> An SGP or IPSP, upon reception of an ASP Active message for the first
> ASP in a Loadshare AS, MUST not direct traffic to a newly active ASP until
> it determines that there are sufficient resources to handle the expected
> load (e.g., until there are "n" ASPs in state ASP-ACTIVE in the AS).  In
> this case, the SGP or IPSP SHOULD withhold the Notify (AS-ACTIVE) until
> there are sufficient resources.
>
>
>
>
>
>
>
>
>
> Old Text:
> For the n+k redundancy case, ASPs which are in that AS should coordinate
> among themselves the number of active ASPs in the AS, and should start
> sending traffic only after n ASPs are active.
>
>
> New Text:
> For the n+k redundancy case, ASPs which are in that AS should coordinate
> among themselves the number of active ASPs in the AS, and MUST not start
> sending traffic related with that AS, unless n ASPs are active for it.
>
>
>
>
>
>
> As I said above, another alternative is to get rid of n+k redundancy, to
> consider any AS in ACTIVE state when there is one ASP ACTIVE for it. This
> just will require some sentences to be deleted from the draft and
> interpretating NTFY("Insufficient ASP resources active in AS") in a
> different way.
>
>    Tolga
>
>
>
>
>
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 8 Apr 2002 13:11:32 -0400

Umesh,

The proposed AS state machine is an attempt to answer the questions you
asked. Please see comments below.

  Tolga

> From: Vats, Umesh [mailto:[email-masked]]
> Sent: Monday, April 08, 2002 12:28 PM
> To: 'Tolga Asveren'; [email-masked]
> Cc: 'Ken Morneault'
[TOLGA] With inter-ASP communication, which is implementation dependent.
> 2. What will be state of AS at SGP if less than n ASPs
[TOLGA] INACTIVe or DOWN depending on the state of ASPs.
>    ACTIVE for an AS become n-1
[TOLGA] The AS state switches to INACTIVE.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 8 Apr 2002 15:05:41 -0500

Umesh,

Tolga suggested that it be removed except for
NTFY("Insufficient ASPs active in AS").  I think
we agree that this NTFY message should stay.
When to send it is clear in the RFC.  The option
to withhold NTFY("AS Active") is  also clear.

Please see comments below...

--brian

Vats, Umesh wrote:                           (Mon, 08 Apr 2002 09:27:59)
>    should start sending traffic to SGP)

By counting active ASPs an comparing the number of
active ASPs to the provisioned number `n'.

> 2. What will be state of AS at SGP if less than n ASPs

Active, but the NTFY("AS Active") message could be
withheld as stated in the RFC.

>    ACTIVE for an AS become n-1 

Active, but the SGP immediately sends
NTFY("Insufficient ASPs active in AS").

> or n+k redundancy mode should be modified to 1+k redundancy

All of the above cases are clearly specified in the RFC.

--brian

> I think this can be covered in implementor's guide.

What additional clarifications beyond what already exists
in the RFC would you like to see?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/