Subject: [Sigtran] M3UA Version Control

From: John McLaine <[email-masked]>
Date: Mon, 22 Apr 2002 21:51:21 -0700 (PDT)

hi
from M3UA Version Control (Section 4.3.4.1.1) I
understand that, especially in ASP-SGP case, only SGP
will check the version field of only ASP UP message.
If it is found to be unsupported then it will behave
as specified in the draft... In other words Version
field of Common Header will never be checked, except
from ASP UP message.
Please tell me if i am mis-interpreting it.
And what ASP should do if it receives ERROR(INVALID
VERSION) when it hasn't sent ASP UP (or after receipt
of ASP UP ACK).
regards,
John.

__________________________________________________
Do You Yahoo!?
Yahoo! Games - play chess, backgammon, pool and more
http://games.yahoo.com/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Apr 2002 00:25:11 -0500

John,

I came across this in development as well.  When receiving
an ERR("Invalid Version") on anything but the initial
exchange, I ignore the error if there is an ack timer
running (e.g, for ASPAC, ASPIA), and it it is for DATA,
then I assume the other end is insane and terminate the
AS rather than lose too much data.  Certainly in this
situation the peer is non-compliant and even aborting
the association could be deemed acceptable.

--brian

John McLaine wrote:                   (Mon, 22 Apr 2002 21:51:21)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/