Subject: [Sigtran] asp id required

From: "Nahar,virendra" <[email-masked]>
Date: Sat, 20 Apr 2002 06:30:02 +0530

Hi
IUA implementation guide says
 ---------
   New text: (Section 3.3.3.1)
   ---------

     0x0e      ASP Identifier Required
     0x0f      Invalid ASP Identifier

   The "ASP Identifier Required" is sent by a SG in response
   to an ASP Up message which does not contain an ASP Identifier
   parameter when the SG requires one.  The ASP SHOULD resend the
   ASP Up message with an ASP Identifier.

   The "Invalid ASP Identifier" is send by a SG in response
   to an ASP Up message with an invalid (i.e., non-unique) ASP
   Identifier.
Does Above applies to M3UA Also

Thanks
Nahar
--
Virendra Nahar
HCL-Technologies Ltd
Networking Systems Lab
51, Jawaharlal Nehru Road
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.
Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
mailto:[email-masked]
############################################################
"He who has a why for life can put with any how."
                             Frederick Nietzsche
############################################################

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 19 Apr 2002 20:16:04 -0500

Nahar,

Yes, it applies to M3UA: Page 61: (same wording)

    The "ASP Identifier Required" is sent by a SGP in response 
    to an ASP Up message which does not contain an ASP Identifier 
    parameter when the SGP requires one.  The ASP SHOULD resend the
    ASP Up message with an ASP Identifier.

    The "Invalid ASP Identifier" is send by a SGP in response
    to an ASP Up message with an invalid (i.e., non-unique) ASP Identifier.

--brian

Nahar,virendra wrote:                              (Sat, 20 Apr 2002 06:30:02)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 19 Apr 2002 20:38:01 -0500

Nahar,

>     The "Invalid ASP Identifier" is send by a SGP in response
                                      ^^^^  should be `sent'

> >    The "Invalid ASP Identifier" is send by a SG in response
                                       ^^^^  should be `sent'

--brian

Brian F. G. Bidulock wrote:                        (Fri, 19 Apr 2002 20:16:04)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Ken Morneault <[email-masked]>
Date: Sun, 21 Apr 2002 20:34:31 -0400

Hmmm... sometimes cut-n-paste is not such a good thing.  i'll
fix this error.

Ken