Subject: RE: [Sigtran] M3UA : DATA meesages on Stream 0

From: "Vats, Umesh" <[email-masked]>
Date: Tue, 9 Apr 2002 15:57:13 -0700

Hi  Brian

Thanks for your clarification.
If its a strict requirement then, the result of the consensus 
should be captured in the implementor's guide. Establishment of association
with single stream should not be disallowed in M3UA and appropriate ERROR
responses should be mentioned.

Umesh 

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Tuesday, April 09, 2002 3:45 PM
To: Vats, Umesh
Cc: [email-masked]'
Subject: Re: [Sigtran] M3UA : DATA meesages on Stream 0

Umesh,

By concensus we removed single-stream operation in preferrence for
a split process model where a process reading from stream `0' cannot
handle DATA messages.

--brian

Vats, Umesh wrote:                                          (Tue, 09 Apr
2002 14:34:16)
> Hi
> 
> The following paragraph is there in section 4.1.1 of
> draft 12 of M3UA. This is related with sending out of DATA 
> messages from M3UA :
> 
> "In addition, the message needs to be sent on the appropriate SCTP 
> stream, again taking care to meet the message sequencing needs of the 
> signalling application. DATA messages MUST be sent on an SCTP stream
> other than stream '0'."
> 
> Does this mean that its not possible to have a single stream in an M3UA
> association ?
> If its possible to have single stream, then it should be possible to send
> DATA messages on stream 0.
> 
> Umesh
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 9 Apr 2002 18:19:49 -0500

Umesh,

Vats, Umesh wrote:                                          (Tue, 09 Apr 2002 15:57:13)
> responses should be mentioned.

I don't think that is necessary.  An ASP could choose to open a single
stream association and go ASP-INACTIVE just to receive NTFY messages
for some AS.  Just because an ASP forms an association does not require
it to exchange DATA: if it wishes to exchange DATA it needs two streams.
I shouldn't be necessary to clarify the obvious ramifications of the MUST.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/