Subject: RE: [Sigtran] M3UA : Messages and Streams

From: [email-masked]
Date: Thu, 18 Apr 2002 14:28:28 -0400

Javier,

I too do not like the state of things in the RFC regarding messsages and 
streams. I agree with you and Umesh that there must be in the 
Implementor's Guide an exact definition of what is a "Management message" 
for the purposes of stream selection and for the generation of the 
"Invalid Stream Identifier" error message.

This is currently very confusing because on one hand we have a message 
class named "Management (MGMT) messages", but on the other hand we also 
have classes named "SS7 Signalling Network Management (SSNM) Messages" and 
"Routing Key Management (RKM) Messages". Brian is apparently including 
SSNM, RKM and even other classes under the heading of "management 
messages", while many others, quite understandably, assume that only MGMT 
messages are "management messages". This is the kind of problem that is 
going to cause us interop problems down the road, and we should resolve it 
now.

Barry Nagelberg
Development Engineering Manager
RadiSys, Corp.
Signaling Products Design Center
[email-masked]
+1-856-642-9229 x237

"Javier Pastor-Balbas (ECE)" <[email-masked]>
Sent by: [email-masked]
04/18/02 10:48 AM

        To:     "[email-masked]'" <[email-masked]>, "Vats, Umesh" 
<[email-masked]>
        cc:     "Javier Pastor-Balbas (ECE)" <[email-masked]>, 
"[email-masked]'" <[email-masked]>
        Subject:        RE: [Sigtran] M3UA : Messages and Streams

If everyone is happy with what is stated in the RFC, then this will not be 
added to the Implementor's Guide.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, April 17, 2002 11:42 PM
> To: Vats, Umesh
> Cc: Javier Pastor-Balbas (ECE); [email-masked]'
> Subject: Re: [Sigtran] M3UA : Messages and Streams
> 
> 
> Vats,
> 
> What's in the RFC works for me.
> 
> --brian
> 
> 
> Vats, Umesh wrote: 
> (Wed, 17 Apr 2002 13:58:18)
> > Hi  Brian
> > 
> > I see following references to the message class/stream mappings
> > in draft 12. 
> > 
> > 1. The "Invalid Stream Identifier" error is sent if a 
> message is received 
> >    on an unexpected SCTP stream (e.g., a Management message 
> was received 
> >    on a stream other than "0").
> > 
> > 2. DATA messages MUST be sent on an SCTP stream
> >    other than stream '0'.
> > 
> > 3. ASPTM messages MAY be sent on one of the streams used to 
> carry the data 
> >    traffic related to the Routing Context(s), to minimize 
> possible message 
> >    loss.  BEAT and BEAT Ack messages MAY be sent using out-of-order 
> >    delivery, and MAY be sent on any stream.
> > 
> > >From these three references, one can draw following conclusions :
> > 1. DATA is never sent on stream 0.
> > 2. Management messages (Class 0 messages only as specified in 
> >    section 3.1.2) can be sent on stream 0 only.
> > 3. All other messages (ASPSM, RKM, ASPTM, SSNM) can be sent on any 
> >    stream.
> > 
> > If this is not the intended stream mapping, then some more
> > text is needed in the draft to clarify this. 
> > 
> > Umesh
> > 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "reshma" <[email-masked]>
Date: Wed, 24 Apr 2002 12:06:10 +0530

Hi All ,

So is this the final decision on Messages and Streams?

1. DATA is never sent on stream 0.
2. ASPSM, MGMT, RKM should be sent on stream 0 [Other than BEAT and BEAT
ACK]
3. SSNM , ASPTM , BEAT and BEAT ACKcan be sent on any stream.

Please clarify if i am wrong.

Thanks,
Reshma

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 24 Apr 2002 01:52:14 -0500

Reshma,

That's what it says in the RFC.

--brian

reshma wrote:                                              (Wed, 24 Apr 2002 12:06:10)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/