Subject: [Sigtran] partial match

From: "Nahar,virendra" <[email-masked]>
Date: Mon, 22 Apr 2002 23:50:43 +0530

Hi All
The draft says
1.Routing Keys SHOULD be unique in the sense that each received SS7
signalling message SHOULD have a full or partial match to a single
routing result.

2. When there is no Routing Key match, or only a partial match, for an
incoming SS7 message, a default treatment MAY be specified

For me both the statements are contradicting each other .Correct  me if wrong !!

Thanks
Nahar

--
Virendra Nahar
HCL-Technologies Ltd
Networking Systems Lab
51, Jawaharlal Nehru Road
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.
Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
mailto:[email-masked]
############################################################
"He who has a why for life can put with any how."
                             Frederick Nietzsche
############################################################

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 22 Apr 2002 13:49:38 -0500

Nahar,

They don't contradict: one says SHOULD and the other say MAY.

--brian

Nahar,virendra wrote:                              (Mon, 22 Apr 2002 23:50:43)
>    [1]mailto:[email-masked]
> References
>    1. mailto:[email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 23 Apr 2002 00:42:53 +0530

Hi  Brian
What I ment here was if the incoming message maps to partial match
can it be delivered to NIF e.g an AS is just configured for DPC say 1-1-1
& incoming data is DPC 1-1-1 OPC 2-2-2 & SI = 4, then its a partial
match for me but still it can be delivered to NIF->SS7 rather than
having default treatment....IS this OK

Thanks
Nahar

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 22 Apr 2002 15:46:26 -0500

Nahar,

Routing keys are not applied in the ->NIF->SS7 direction, only
in the ->ASP direction.

--brian

Nahar,virendra wrote:                              (Tue, 23 Apr 2002 00:42:53)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 22 Apr 2002 17:35:09 -0500

Nahar,

Yes, it can.

--brian

On Tue, 23 Apr 2002, Nahar,virendra wrote:

> Hi Brian
> What u mean to say here is that any incoming data msg from ASP can be given as it is
> to NIF->SS7 without checking weather such a  route exists or not
> ...............................
> 
> Thanks
> Nahar
> 

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 23 Apr 2002 04:11:04 +0530

hi ,
Then what does the below signifies
The DUNA message is sent from an SGP in an SG to all concerned ASPs
to indicate that the SG has determined that one or more SS7 destinations
are unreachable.  It is also sent by an SGP in response to a message
from the ASP to an unreachable SS7 destination

Thanks
Nahar

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 22 Apr 2002 18:19:25 -0500

Nahar,

That is a function of the NIF.

Nahar,virendra wrote:                              (Tue, 23 Apr 2002 04:11:04)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 23 Apr 2002 04:53:41 +0530

Hi
But the Draft Doesn't says that.
For me I always check the Affected point code list maintained at SG before
sending the data to NIF
...........................................................................
so the incoming data has to match atleast one AS at SG side ....................
and draft also says to validate the RC if its there with data

Thanks
Nahar

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 22 Apr 2002 19:57:29 -0500

Nahar,

The RFC places no requirements on what it done internal to the
implementation.  If the SS7 stack verifies, there is no need to
do so before the NIF.  For example, the ASP has no business
sending an OPC which does not correspond to the DPC in the RK
associated with the RC.  One can choose to allow that, forbid
it, discard without warning, process it anyway, ...  That is up
to the SG implementation.  As such, it can be clumped into that
implementation-specific cloud inside the architecture called the
NIF.  These functions are outside the scope of the RFC.  As
such, there is no contradiction in the passages you originally
quoted.  The SHOULD and the MAY are there especially to allow SG
implementors to do what is required of their implementations and
interworking with the SS7 stack and network, rather than to
impose one view of the world.

--brian

Nahar,virendra wrote:                              (Tue, 23 Apr 2002 04:53:41)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 23 Apr 2002 08:34:11 +0530

Hi Brian

I agree with ur view's but u said  =>DUNA also sent by an SGP in response to a message

> > >    from the ASP to an unreachable SS7 destination is a function of NIF
I disagree with it ,because NIF is just a transperent delivery agent  to & from MTP3.
e.g when we get a DAUD from ASP SG only has to respond with DUNA/ DAVA/ DRST/ SCON
from its local  database so the same applies to incomoing data message whose DPC is
marked
unreachable AT SG.
        thanks for making  clear that even if theres no RK matching incoming  data it
can be given to NIF->SS7.

Thanks
Nahar

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 22 Apr 2002 22:35:05 -0500

Nahar,

Nahar,virendra wrote:                   (Tue, 23 Apr 2002 08:34:11)
>    I disagree with it ,because NIF is just a transperent delivery agent

NIF is an implementation-dependent function which is outside the
scope of the RFC.

>    from its local  database so the same applies to incomoing data message
>    whose DPC is marked
>    unreachable AT SG.

This again is implementation-dependent.  There is no requirement to
maintain this information at the SGP.  Some SS7 stacks provide the
ability to audit the state of destinations.  Some implementations
might merely pass the DAUD to the SS7 stack.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/