Subject: RE: [Sigtran] duna for whole network done with RC]

From: "Vats, Umesh" <[email-masked]>
Date: Mon, 15 Apr 2002 16:57:34 -0700

Hi  Tolga/Nahar

MTP3 RESTART itself may happen just for one of the networks.
Suppose an MTP3 is operating in ITU and ANSI networks and
a link in ANSI network comes UP, then MTP3 restart for
ANSI network happens. In this case, DUNA with specific NA
is needed.

Umesh 

-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]]
Sent: Monday, April 15, 2002 2:50 PM
To: [email-masked]
Subject: RE: [Sigtran] duna for whole network done with RC]

Nahar,

Please note that NA is optional, whereas RC is semi-optional (currently
draft syas it is optional but it will be corrected in the implementors
guide)So, sending NA is never mandatory, but if you like you can send it
whenever you want.
In the MTP3 Restart scenario, you don't need to fill NA parmaeter to DUNA
but if there are associations which are serving more than one AS, for them
you have to put RC parameters.

   Tolga

> -----Original Message-----
> From: Nahar,virendra [mailto:[email-masked]]
> Sent: Monday, April 15, 2002 5:30 PM
> To: Tolga Asveren
> Cc: [email-masked]
> Subject: Re: [Sigtran] duna for whole network done with RC]
>
>
> Hi
>
> I fully agree with ur view point on simplicity .In case of MTP3
> RESTART at SG
> everything would be down right so no NA will be filled in outgoing DUNA
> (indicating Network appearence is down) to ASP . Am I correct in sending
> DUNA without NA  in this situation.
>
> Thanks
> Nahar
>
>
> Tolga Asveren wrote:
>
> > Nahar,
> > What if you have ASs belonging to different networks and if you
> loose your
> > connectivity only to one network? Then NA should be made
> mandatory to handle
> > such a case. All this would just complicate things(different
> > interpretations, what if scenarios, assumptions etc....). As a
> big-fan of
> > simplicity, personally I would prefer to keep RC mandatory for
> all cases, if
> > the association serves more than one AS. (last week I thought
> what you say
> > might make sense but then was convoinced it will just complicate things)
> >
> >    Tolga
> >
> > > -----Original Message-----
> > > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> > > Nahar,virendra
> > > Sent: Monday, April 15, 2002 4:52 PM
> > > To: Sigtran
> > > Subject: Re: [Sigtran] duna for whole network done with RC]
> > >
> > >
> > >
> > >
> > >
> > >
> > > Hi
> > > The MASK value in this case will  serves as All RC flag .
> > > I think  this case should be acceptable .
> > >
> > > Thanks
> > > nahar
> > >
> > > Thanks
> > > Nahar
> > >
> > > "Ong, Lyndon" wrote:
> > >
> > > > Hi Folks,
> > > >
> > > > I believe Tolga is correct, we had some discussion of this
> > > > a while back but ended up making RC required for SSNM if
> > > > you are using multiple RCs.  There was some concern expressed
> > > > about this at the time, we could explore if there are any
> > > > ways to simplify this (e.g., define some added flag or special
> > > > value of RC?)
> > > >
> > > > Cheers,
> > > >
> > > > Lyndon
> > > >
> > > > -----Original Message-----
> > > > From: Tolga Asveren [mailto:[email-masked]]
> > > > Sent: Monday, April 15, 2002 12:58 PM
> > > > To: [email-masked]
> > > > Subject: RE: [Sigtran] duna for whole network done with RC
> > > >
> > > > 3.4.1 says
> > > > "Routing Context.........
> > > > Where multiple Routing Keys and Routing Contexs are used
> across a common
> > > > association, the Routing Context(s) MUST be sent to
> identify concerned
> > > > traffic flows...."
> > > > So, in such a case RC is mandatory.
> > > >
> > > >     Tolga
> > > >
> > > > > -----Original Message-----
> > > > > From: Nahar,virendra [mailto:[email-masked]]
> > > > > Sent: Monday, April 15, 2002 3:39 PM
> > > > > To: Tolga Asveren
> > > > > Cc: [email-masked]
> > > > > Subject: Re: [Sigtran] duna for whole network done with RC
> > > > >
> > > > >
> > > > > Hi
> > > > > But Since RC is optional feature & since DUNA carries the
> > > > > required info why
> > > > > should it be mandated
> > > > > to put in this case !!
> > > > >
> > > > > Thanks
> > > > > Nahar
> > > > >
> > > > > Tolga Asveren wrote:
> > > > >
> > > > > > In my opinion, based on the current draft, you have to include
> > > > > RC for SSNM,
> > > > > > if the association is used for more than one AS, it does not
> > > > > matter whether
> > > > > > DUNA is for the whole network or not.
> > > > > >
> > > > > >     Tolga
> > > > > >
> > > > > > > -----Original Message-----
> > > > > > > From: Nahar,virendra [mailto:[email-masked]]
> > > > > > > Sent: Monday, April 15, 2002 3:29 PM
> > > > > > > To: Tolga Asveren
> > > > > > > Cc: [email-masked]
> > > > > > > Subject: Re: [Sigtran] duna for whole network done with RC
> > > > > > >
> > > > > > >
> > > > > > > Hi
> > > > > > > What if duna conveys whole network appearence is down
> & doesn't
> > > > > > > carries the RC
> > > > > > > list
> > > > > > > Thanks
> > > > > > > Nahar
> > > > > > >
> > > > > > > Tolga Asveren wrote:
> > > > > > >
> > > > > > > > This was discussed last week. I don't think it is correct to
> > > > > > > ignore RC list.
> > > > > > > > All of the relevant RCs should be listed in the message.
> > > > > > > >
> > > > > > > >    Tolga
> > > > > > > >
> > > > > > > > > -----Original Message-----
> > > > > > > > > From: [email-masked]
> > > > > > > [mailto:[email-masked]]On Behalf Of
> > > > > > > > > Nahar,virendra
> > > > > > > > > Sent: Monday, April 15, 2002 3:12 PM
> > > > > > > > > To: Sigtran
> > > > > > > > > Subject: [Sigtran] duna for whole network done with RC
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > Hi All
> > > > > > > > >   when an ASP gets a masked DUNA which is say
> equal to l (or
> > > > > > > > > greater than) the
> > > > > > > > >    number of bits in the PC  i.e it indicates that the
> > > > > entire network
> > > > > > > > >    appearance is affected .But if such a DUNA message
> > > is received
> > > > > > > > > with RC list
> > > > > > > > >    what sould be done .I am currently ignoring
> the RC list as
> > > > > > > DUNA conveys
> > > > > > > > >    entire network appearence is down.Is this OK
> > > > > > > > >
> > > > > > > > > Thanks
> > > > > > > > > Nahar
> > > > > > > > > --
> > > > > > > > > Virendra Nahar
> > > > > > > > > HCL-Technologies Ltd
> > > > > > > > > Networking Systems Lab
> > > > > > > > > 51, Jawaharlal Nehru Road
> > > > > > > > > Guindy Industrial Estate,
> > > > > > > > > Ekkatuthangal,
> > > > > > > > > Chennai - 600 097.
> > > > > > > > > Phone Off : +91 44 233 4174 or +91 44 233
> 4181(extn:261,218)
> > > > > > > > > mailto:[email-masked]
> > > > > > > > >
> ############################################################
> > > > > > > > > "He who has a why for life can put with any how."
> > > > > > > > >                              Frederick Nietzsche
> > > > > > > > >
> ############################################################
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > _______________________________________________
> > > > > > > > > Sigtran mailing list
> > > > > > > > > [email-masked]
> > > > > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > > > >
> > > > > > > > _______________________________________________
> > > > > > > > Sigtran mailing list
> > > > > > > > [email-masked]
> > > > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > > >
> > > > > > > --
> > > > > > > Virendra Nahar
> > > > > > > HCL-Technologies Ltd
> > > > > > > Networking Systems Lab
> > > > > > > 51, Jawaharlal Nehru Road
> > > > > > > Guindy Industrial Estate,
> > > > > > > Ekkatuthangal,
> > > > > > > Chennai - 600 097.
> > > > > > > Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
> > > > > > > mailto:[email-masked]
> > > > > > > ############################################################
> > > > > > > "He who has a why for life can put with any how."
> > > > > > >                              Frederick Nietzsche
> > > > > > > ############################################################
> > > > > > >
> > > > > >
> > > > > > _______________________________________________
> > > > > > Sigtran mailing list
> > > > > > [email-masked]
> > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > >
> > > > > --
> > > > > Virendra Nahar
> > > > > HCL-Technologies Ltd
> > > > > Networking Systems Lab
> > > > > 51, Jawaharlal Nehru Road
> > > > > Guindy Industrial Estate,
> > > > > Ekkatuthangal,
> > > > > Chennai - 600 097.
> > > > > Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
> > > > > mailto:[email-masked]
> > > > > ############################################################
> > > > > "He who has a why for life can put with any how."
> > > > >                              Frederick Nietzsche
> > > > > ############################################################
> > > > >
> > > >
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > >
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> > > --
> > > Virendra Nahar
> > > HCL-Technologies Ltd
> > > Networking Systems Lab
> > > 51, Jawaharlal Nehru Road
> > > Guindy Industrial Estate,
> > > Ekkatuthangal,
> > > Chennai - 600 097.
> > > Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
> > > mailto:[email-masked]
> > > ############################################################
> > > "He who has a why for life can put with any how."
> > >                              Frederick Nietzsche
> > > ############################################################
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
>
> --
> Virendra Nahar
> HCL-Technologies Ltd
> Networking Systems Lab
> 51, Jawaharlal Nehru Road
> Guindy Industrial Estate,
> Ekkatuthangal,
> Chennai - 600 097.
> Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
> mailto:[email-masked]
> ############################################################
> "He who has a why for life can put with any how."
>                              Frederick Nietzsche
> ############################################################
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 16 Apr 2002 05:39:59 +0530

Hi Umesh
True but we where discussing about the case when SG's MTP3 undergoes restart..

Thanks
Nahar

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 15 Apr 2002 20:23:21 -0400

Umesh,

I don't think for any case DUNA with NA is necessary. RC always implies NA.

 Tolga

> From: Vats, Umesh [mailto:[email-masked]]
> Sent: Monday, April 15, 2002 7:58 PM
> To: 'Tolga Asveren'; [email-masked]

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 16 Apr 2002 06:44:25 +0530

Hi Tolga
If ASP registers RK with no NA the draft says no NA means all NA
so in this case when a PC is affected thru one interface i.e NA then
NA becomes must in DUNA. Correct me if wrong........................

Thanks
Nahar

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 16 Apr 2002 08:52:47 -0400

Nahar,

Probably you are referring to the sentence (On page47 Network Appearence)
"The absence of the Network Appearence parameter in theRouting Key indicates
the use of any Network Appearence value"
I don't know the story behind this sentence, our maybe it is just wrong and
did somehow manage to survive till now. If it should be interpreted as "as
all of the NAs defined on SGP", it does not make too much sense to me -at
least for now-. I would expect something like "if there is traffic carried
belonging to more than one network, than it is mandatory etc.." Other
opinions?

   Tolga

> Sent: Monday, April 15, 2002 9:14 PM
> To: Tolga Asveren
> Cc: [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 16 Apr 2002 08:14:01 -0500

Tolga,

Well in fact it doesn't say "all" as Nahar says:  it says "any".  There
is a world of difference.  If during registration, the NA value is not
specified, the SG will assign it.  This has little to no bearing on when
and whether NA is sent in other messages.

--brian

Tolga Asveren wrote:                                        (Tue, 16 Apr 2002 08:52:47)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 16 Apr 2002 09:43:34 -0400

Brian,

If it should be interpreted like you said (as far as I understand it will
work like this: Based on DPC (or maybe also OPC) SGP will decide for the NA)
it makes sense to me.
But then it would be nice to add a new Registeration Status value as "NA
needed", for the cases where SGP is unable to find out NA value from other
parameters in REGREQ. (One might use "Invalid Network Apperarence" or
"Cannot Support Unique Routing" but they don't fit 100%, in my opinion)

   Tolga

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Tuesday, April 16, 2002 9:14 AM
> To: Tolga Asveren
> Cc: [email-masked]

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 16 Apr 2002 19:44:30 +0530

hi
If NA is not there in Reg Req I assume that its for all the valid networks  SG
is having link  with.
So if a PAUSE or RESUME indicated by SS7 which matches the OPC/DPC in this AS
which allows all NA then obviously putting NA in outgoing DUNA is must.
Else MGC/ASP receiving DUNA without NA will assume it to be affected for all NA
ASP
knows thru its configuration.........Pls clarify this confusion no NA means All
NA for RK REG

Thanks
Nahar

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 16 Apr 2002 10:30:53 -0400

Nahar,

Per Brian's explanation -which makes sense to me-, based on other parameters
in REGREQ, SGP will decide for NA.
For example DPC=1-1-1 in REGREQ. SGP knows 1-1-1 exists only in NetworkA,
which has NA=2. So, it assigns NA=2 for the new registered RK.

     Tolga

> Sent: Tuesday, April 16, 2002 10:15 AM
> To: Tolga Asveren
> Cc: [email-masked]
> > > > > > > > > > > > > > > This was discussed last week. I don't
> think it is
> > > > > > > correct to
> > > > > > > > > > > > > > ignore RC list.

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 16 Apr 2002 11:28:13 -0400

I think, in such a case SGP should send REGRESP with an appropriate
Registeration Status value indicating error.

   Tolga

> Sent: Tuesday, April 16, 2002 11:09 AM
> To: Tolga Asveren
> Cc: [email-masked]
> What if DPC=1-1-1exists in more then one Networks Its possible right
> Thanks
> Nahar
>
>
> Tolga Asveren wrote:
>
> > Nahar,
> >
> > > > > > > > I don't think for any case DUNA with NA is
> necessary. RC always
> > > > > > > implies NA.
> > > > > > > >
> > > > > > > >  Tolga
> > > > > > > >
> > > > > > > > > Please note that NA is optional, whereas RC is
> semi-optional
> > > > > > > (currently
> > > > > > > > > guide)So, sending NA is never mandatory, but if
> you like you
> > > > > > > can send it
> > > > > > > > > whenever you want.
> > > > > > > > > but if there are associations which are serving
> more than one
> > > > > > > AS, for them
> > > > > > > > > > everything would be down right so no NA will be
> filled in
> > > > > > > outgoing DUNA
> > > > > > > > > > > > > > > if the association is used for more
> than one AS,
> > > > > > > it does not
> > > > > > > > > > > > > > matter whether
> > > > > > > > > > > > > > > > Subject: Re: [Sigtran] duna for
> whole network
> > > > > > > done with RC
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Hi
> > > > > > > > > > > > > > > > > All of the relevant RCs should be
> listed in
> > > > > > > the message.
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >    Tolga
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > Subject: [Sigtran] duna for
> whole network
> > > > > > > done with RC
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > Hi All

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 16 Apr 2002 20:39:00 +0530

Hi

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 16 Apr 2002 22:57:22 +0530

Hi
Why an error needs to be send here because ASP wants to register this thru all
possible interfaces i.e  NA's ss7 is having
so wont it be wrong .

Thanks
Nahar

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 16 Apr 2002 23:31:53 +0530

Hi
But if both ASP and SG  knows via configuration the possible NA values then ASP
need not put the NA at all in registration
as ASP wants to get that RK registered thru all networks SG is linked to . If
this is not so then the text (page 47 )from the
draft should be removed right  else for me its confusing as my implementation
works fine with this text..

Thanks
Nahar

Tolga Asveren wrote:

> Nahar,
>
> In such a case, ASP should use separate REGREQs (and assuming that SGP won't
> be able to addign NA based on other parameters, ASP should also include NA)
>
>   Tolga
>
> > Sent: Tuesday, April 16, 2002 1:27 PM
> > To: Tolga Asveren; Sigtran
> >       (Tue,
> > > > > > > > 16 Apr 2002 08:52:47)
> > > > > > > > > Probably you are referring to the sentence (On
> > page47 Network
> > > > > > > > Appearence)
> > > > > > > > > "The absence of the Network Appearence parameter in
> > theRouting
> > > > > > > > Key indicates
> > > > > > > > > all of the NAs defined on SGP", it does not make
> > too much sense
> > > > > > > > to me -at
> > > > > > > > > > > > draft syas it is optional but it will be
> > corrected in the
> > > > > > > > implementors
> > > > > > > > > > > > In the MTP3 Restart scenario, you don't need
> > to fill NA
> > > > > > > > > > parmaeter to DUNA
> > > > > > > > > > > > > (indicating Network appearence is down) to
> > ASP . Am I
> > > > > > > > > > correct in sending
> > > > > > > > > > > > > > What if you have ASs belonging to
> > different networks
> > > > > > > > and if you
> > > > > > > > > > > > > loose your
> > > > > > > > > > > > > > might make sense but then was convoinced
> > it will just
> > > > > > > > > > > > complicate things)
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >    Tolga
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > But Since RC is optional feature &
> > since DUNA
> > > > > > > > carries the
> > > > > > > > > > > > > > > > > required info why
> > > > > > > > > > > > > > > > > should it be mandated
> > > > > > > > > > > > > > > > > to put in this case !!
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Thanks
> > > > > > > > > > > > > > > > > Nahar
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Tolga Asveren wrote:
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > In my opinion, based on the
> > current draft, you
> > > > > > > > > > have to include
> > > > > > > > > > > > > > > > > RC for SSNM,
> > > > > > > > > > > > > > > > > > > > >    appearance is affected
> > .But if such a
> > > > > > > > > > DUNA message
> > > > > > > > > > > > > > > > > > > > > "He who has a why for life
> > can put with
> > > > > > > > any how."
> > > > > > > > > > > > > > > > > > > > >
> > > > > > Frederick Nietzsche
> > > > > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > >

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 16 Apr 2002 14:18:45 -0400

Nahar,

But as Brian pointed out it is "any" not "all". So, I don't think your
interpretation was correct. But maybe a sentence might be added to make it
more clear, to prevent further misinterpretations.

   Tolga

> Sent: Tuesday, April 16, 2002 2:02 PM
> To: Tolga Asveren
> Cc: [email-masked]
> > > > > > > If NA is not there in Reg Req I assume that its for
> all the valid
> > > > > > > networks  SG
> > > > > > > is having link  with.
> > > > > > > knows thru its configuration.........Pls clarify this
> confusion
> > > > > > > no NA means All
> > > > > > > NA for RK REG
> > > > > > >
> > > > > > > Thanks
> > > > > > > Nahar
> > > > > > >
> > > > > > > Tolga Asveren wrote:
> > > > > > >
> > > > > > > > Brian,
> > > > > > > >
> > > > > > > > needed", for the cases where SGP is unable to find
> out NA value
> > > > > > > from other
> > > > > > > > > > I don't know the story behind this sentence,
> our maybe it is
> > > > > > > > > just wrong and
> > > > > > > > > > least for now-. I would expect something like
> "if there is
> > > > > > > > > traffic carried
> > > > > > > > > > > so in this case when a PC is affected thru
> one interface
> > > > > > > i.e NA then
> > > > > > > > > > > > > > I fully agree with ur view point on
> simplicity .In
> > > > > > > case of MTP3
> > > > > > > > > > > > > > RESTART at SG
> > > > > > > > > > > > > > > interpretations, what if scenarios,
> assumptions
> > > > > > > etc....). As a
> > > > > > > > > > > > > > big-fan of
> > > > > > > > > > > > > > > simplicity, personally I would prefer
> to keep RC
> > > > > > > mandatory for
> > > > > > > > > > > > > > all cases, if
> > > > > > > done with RC]
> > > > > > > > > > > > > > > > The MASK value in this case will
> serves as All
> > > > > > > RC flag .
> > > > > > > > > > > > > > > > > a while back but ended up making
> RC required
> > > > > > > for SSNM if
> > > > > > > > > > > > > > > > > you are using multiple RCs.
> There was some
> > > > > > > > > concern expressed
> > > > > > > > > > > > > > > > > about this at the time, we could
> explore if
> > > > > > > there are any
> > > > > > > > > > > > > > > > > ways to simplify this (e.g.,
> define some added
> > > > > > > > > flag or special
> > > > > > > > > > > > > > > > > value of RC?)
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Cheers,
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Lyndon
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Subject: RE: [Sigtran] duna for
> whole network
> > > > > > > done with RC
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > 3.4.1 says
> > > > > > > > > > > > > > > > > > > > > >    number of bits in
> the PC  i.e it
> > > > > > > > > > > indicates that the

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 16 Apr 2002 14:01:03 -0400

Nahar,

  Tolga

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 16 Apr 2002 12:59:47 -0500

Nahar,

It would be wrong because one RK is not allows to span multiple NA.
Thus "any" not "all".

--brian

Nahar,virendra wrote:                   (Tue, 16 Apr 2002 22:57:22)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Nahar,virendra" <[email-masked]>
Date: Wed, 17 Apr 2002 00:09:32 +0530

Hi
Okie  it implies any NA value .But the any value which SG is going to select
should
be known to ASP also via some configuration before inetrop else ASP cant
validate that any NA
value when it receives any message e.g DUNA with that NA value.Also if NA is not
there in RK
REG then SG should use some default PC type & this PC type will determine the
default NA
value also right or the NA might not be required at all as sg may be linked to
different ss7 context
but the absense of NA in REG REQ will lead to some default PC type & ss7 context
for
which ASP will never bother as this association is by default for some ss7
context & PC type is
know both to SG and ASP . Hope I am not confusing .
. Is this assumption right .Pls Clarify.

Thanks
Nahar