Subject: [Sigtran] M3UA : Messages and Streams

From: "Vats, Umesh" <[email-masked]>
Date: Mon, 15 Apr 2002 12:45:23 -0700

Hi

After going through draft12 of M3UA, I have following understanding of 
Message class to stream mappings :

1. DATA messages   : Always sent on a stream other than 0.
2. MGMT messages  : Always sent on stream 0.
3. ASPSM, ASPTM, RKM and SSNM messages can be sent
    on  any stream.

Is this understanding OK ?

thanks
Umesh

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 15 Apr 2002 18:50:08 -0500

Umesh,

Its my understanding that ASPSM and RKM messages *are*
management messages and must be sent on stream `0'.
Except for BEAT and BEAT Ack which might be sent on
a stream corresponding to an AS, depending on the
reason for the BEAT/Ack.

IMO ASPTM messages should be sent on the stream that
corresponds to the AS in question, as should SSNM.
Where SSNM corresponds to multiple AS (has multiple RCs)
it could either be sent on stream `0' or another stream
corresponding to one or more of the AS.

The RFC is consistent with this interpretation.

--brian

Vats, Umesh wrote:                                          (Mon, 15 Apr 2002 12:45:23)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/