Subject: [Sigtran] active/inactive with no rc

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 09 Apr 2002 01:41:44 +0530

Hi All
the draft say's
In the case where an ASP Inactive/Active  message does not
contain a Routing Context parameter, the receiver must know, via
configuration data, which Application Servers the ASP is a member and
move the ASP to the ASP-INACTIVE state in all Application Servers.
    The Term configuration data used above is for static configuration
or it applies to dyanamic also.To put my query asume the SG is having
5 AS(with RC) & ASP is part of all the AS's but for 3AS he is statically created

& for 2 AS ASP does a RegReq .So now an active/inactive comes with no RC
then ASP state should be changes in 3 AS (static for which no REG_REQ is done
by ASP)
or in  all 5 AS the state should get changed

Thanks in advance
Nahar

--
Virendra Nahar
HCL-Technologies Ltd
Networking Systems Lab
51, Jawaharlal Nehru Road
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.
Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
mailto:[email-masked]
############################################################
"He who has a why for life can put with any how."
                             Frederick Nietzsche
############################################################

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 8 Apr 2002 16:16:31 -0500

Nahar,

>    move the ASP to the ASP-INACTIVE state in all Application Servers.

What is unclear about this?

--brian

Nahar,virendra wrote:               (Tue, 09 Apr 2002 01:41:44)
>    then ASP state should be changes in 3 AS (static for which no REG_REQ
>    is done  by ASP)
>    [1]mailto:[email-masked]
> References
>    1. mailto:[email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 09 Apr 2002 02:55:28 +0530

Hi Brian
The definition of Configuration data is unclear..For me the configuration data I
assumed the static ones
i.e in the example I quoted only in the 3AS for which the ASP didn't do any reg
req I would make it
active & for other 2 as for which ASP did dyanamic Reg  I assumed that Active
will come with RC

Thanks
Nahar

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 8 Apr 2002 16:51:40 -0500

Nahar,

I would see your confusion if the statement in the RFC did not
say "all Application Servers".  It does not say "only for configured
Application Servers," it says "all Application Servers".  That would
include any AS which are AS-ACTIVE for the SGP from which the ASP
received the ASP-INACTIVE.

Ignore the "configuration data" and read it this way:

  In the case where an ASP Inactive/Active message does not
  contain a Routing Context parameter, the receiver must know...
  ...which Application Servers the ASP is a member and move
  the ASP to the ASP-INACTIVE state in all Application Servers.

--brian

Nahar,virendra wrote:               (Tue, 09 Apr 2002 02:55:28)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/