Subject: RE: [Sigtran] duna for whole network done with RC]

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 15 Apr 2002 17:11:44 -0400

Nahar,
What if you have ASs belonging to different networks and if you loose your
connectivity only to one network? Then NA should be made mandatory to handle
such a case. All this would just complicate things(different
interpretations, what if scenarios, assumptions etc....). As a big-fan of
simplicity, personally I would prefer to keep RC mandatory for all cases, if
the association serves more than one AS. (last week I thought what you say
might make sense but then was convoinced it will just complicate things)

   Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Nahar,virendra
> Sent: Monday, April 15, 2002 4:52 PM
> To: Sigtran
> Subject: Re: [Sigtran] duna for whole network done with RC]
>
>
>
>
>
>
> Hi
> The MASK value in this case will  serves as All RC flag .
> I think  this case should be acceptable .
>
> Thanks
> nahar
>
> Thanks
> Nahar
>
> "Ong, Lyndon" wrote:
>
> > Hi Folks,
> >
> > I believe Tolga is correct, we had some discussion of this
> > a while back but ended up making RC required for SSNM if
> > you are using multiple RCs.  There was some concern expressed
> > about this at the time, we could explore if there are any
> > ways to simplify this (e.g., define some added flag or special
> > value of RC?)
> >
> > Cheers,
> >
> > Lyndon
> >
> > -----Original Message-----
> > From: Tolga Asveren [mailto:[email-masked]]
> > Sent: Monday, April 15, 2002 12:58 PM
> > To: [email-masked]
> > Subject: RE: [Sigtran] duna for whole network done with RC
> >
> > 3.4.1 says
> > "Routing Context.........
> > Where multiple Routing Keys and Routing Contexs are used across a common
> > association, the Routing Context(s) MUST be sent to identify concerned
> > traffic flows...."
> > So, in such a case RC is mandatory.
> >
> >     Tolga
> >
> > > -----Original Message-----
> > > From: Nahar,virendra [mailto:[email-masked]]
> > > Sent: Monday, April 15, 2002 3:39 PM
> > > To: Tolga Asveren
> > > Cc: [email-masked]
> > > Subject: Re: [Sigtran] duna for whole network done with RC
> > >
> > >
> > > Hi
> > > But Since RC is optional feature & since DUNA carries the
> > > required info why
> > > should it be mandated
> > > to put in this case !!
> > >
> > > Thanks
> > > Nahar
> > >
> > > Tolga Asveren wrote:
> > >
> > > > In my opinion, based on the current draft, you have to include
> > > RC for SSNM,
> > > > if the association is used for more than one AS, it does not
> > > matter whether
> > > > DUNA is for the whole network or not.
> > > >
> > > >     Tolga
> > > >
> > > > > -----Original Message-----
> > > > > From: Nahar,virendra [mailto:[email-masked]]
> > > > > Sent: Monday, April 15, 2002 3:29 PM
> > > > > To: Tolga Asveren
> > > > > Cc: [email-masked]
> > > > > Subject: Re: [Sigtran] duna for whole network done with RC
> > > > >
> > > > >
> > > > > Hi
> > > > > What if duna conveys whole network appearence is down & doesn't
> > > > > carries the RC
> > > > > list
> > > > > Thanks
> > > > > Nahar
> > > > >
> > > > > Tolga Asveren wrote:
> > > > >
> > > > > > This was discussed last week. I don't think it is correct to
> > > > > ignore RC list.
> > > > > > All of the relevant RCs should be listed in the message.
> > > > > >
> > > > > >    Tolga
> > > > > >
> > > > > > > -----Original Message-----
> > > > > > > From: [email-masked]
> > > > > [mailto:[email-masked]]On Behalf Of
> > > > > > > Nahar,virendra
> > > > > > > Sent: Monday, April 15, 2002 3:12 PM
> > > > > > > To: Sigtran
> > > > > > > Subject: [Sigtran] duna for whole network done with RC
> > > > > > >
> > > > > > >
> > > > > > > Hi All
> > > > > > >   when an ASP gets a masked DUNA which is say equal to l (or
> > > > > > > greater than) the
> > > > > > >    number of bits in the PC  i.e it indicates that the
> > > entire network
> > > > > > >    appearance is affected .But if such a DUNA message
> is received
> > > > > > > with RC list
> > > > > > >    what sould be done .I am currently ignoring the RC list as
> > > > > DUNA conveys
> > > > > > >    entire network appearence is down.Is this OK
> > > > > > >
> > > > > > > Thanks
> > > > > > > Nahar
> > > > > > > --
> > > > > > > Virendra Nahar
> > > > > > > HCL-Technologies Ltd
> > > > > > > Networking Systems Lab
> > > > > > > 51, Jawaharlal Nehru Road
> > > > > > > Guindy Industrial Estate,
> > > > > > > Ekkatuthangal,
> > > > > > > Chennai - 600 097.
> > > > > > > Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
> > > > > > > mailto:[email-masked]
> > > > > > > ############################################################
> > > > > > > "He who has a why for life can put with any how."
> > > > > > >                              Frederick Nietzsche
> > > > > > > ############################################################
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > _______________________________________________
> > > > > > > Sigtran mailing list
> > > > > > > [email-masked]
> > > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > >
> > > > > > _______________________________________________
> > > > > > Sigtran mailing list
> > > > > > [email-masked]
> > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > >
> > > > > --
> > > > > Virendra Nahar
> > > > > HCL-Technologies Ltd
> > > > > Networking Systems Lab
> > > > > 51, Jawaharlal Nehru Road
> > > > > Guindy Industrial Estate,
> > > > > Ekkatuthangal,
> > > > > Chennai - 600 097.
> > > > > Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
> > > > > mailto:[email-masked]
> > > > > ############################################################
> > > > > "He who has a why for life can put with any how."
> > > > >                              Frederick Nietzsche
> > > > > ############################################################
> > > > >
> > > >
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> > > --
> > > Virendra Nahar
> > > HCL-Technologies Ltd
> > > Networking Systems Lab
> > > 51, Jawaharlal Nehru Road
> > > Guindy Industrial Estate,
> > > Ekkatuthangal,
> > > Chennai - 600 097.
> > > Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
> > > mailto:[email-masked]
> > > ############################################################
> > > "He who has a why for life can put with any how."
> > >                              Frederick Nietzsche
> > > ############################################################
> > >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
>
> --
> Virendra Nahar
> HCL-Technologies Ltd
> Networking Systems Lab
> 51, Jawaharlal Nehru Road
> Guindy Industrial Estate,
> Ekkatuthangal,
> Chennai - 600 097.
> Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
> mailto:[email-masked]
> ############################################################
> "He who has a why for life can put with any how."
>                              Frederick Nietzsche
> ############################################################
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 16 Apr 2002 02:22:01 +0530

Hi

Thanks
nahar

Thanks
Nahar

"Ong, Lyndon" wrote:

> > > > > >    appearance is affected .But if such a DUNA message is received
> > > > > > with RC list

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 16 Apr 2002 02:59:53 +0530

Hi

I fully agree with ur view point on simplicity .In case of MTP3 RESTART at SG
everything would be down right so no NA will be filled in outgoing DUNA
(indicating Network appearence is down) to ASP . Am I correct in sending
DUNA without NA  in this situation.

Thanks
Nahar

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 15 Apr 2002 17:49:58 -0400

Nahar,

Please note that NA is optional, whereas RC is semi-optional (currently
draft syas it is optional but it will be corrected in the implementors
guide)So, sending NA is never mandatory, but if you like you can send it
whenever you want.
In the MTP3 Restart scenario, you don't need to fill NA parmaeter to DUNA
but if there are associations which are serving more than one AS, for them
you have to put RC parameters.

   Tolga

> Sent: Monday, April 15, 2002 5:30 PM
> To: Tolga Asveren
> Cc: [email-masked]