Subject: RE: [Sigtran] M3UA : Messages and Streams

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 17 Apr 2002 20:01:15 +0200

Brian, 

See below..

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, April 17, 2002 7:25 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: [email-masked]'; Vats, Umesh
> Subject: Re: [Sigtran] M3UA : Messages and Streams
> 
> 
> Javier,
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Wed, 17 Apr 2002 18:31:35)
> > > 
> > > The RFC permits one to send BEAT, ASPTM, MGMT and SSNM on 
> stream `0'
> > > as well.
> > > 
> > 
> > I think the wording above also permits them on stream '0' 
> since MAY means
> > optionally. Anyway, wording can be improved to say it more 
> explicitly:
> > 
> > "ASPSM (except BEAT) and RKM MUST be sent on stream 0. The 
> rest of the
> > management messages (BEAT, ASPTM, MGMT, SSNM) MAY either be 
> sent on stream
> > '0' or  thru any other stream that could be reserved for an 
> specific AS (if
> > there exists such a stream-per-AS sconfiguration)"
> > 
> > BTW, I'm probably missing where the RFC says that BEAT, 
> ASPTM, MGMT and SSNM
> > can be sent on stream `0'. Do you refer to section 4.1.1 
> again? I think it
> > doesn't say nothing about stream '0'...
> 

> No, section 4.2.1.  It *used* to say that stream `0' was used 
> for ordering
> of non-Transfer, non-SSNM, message, except BEAT and BEAT Ack. 

This is now also out of the explanation in the RFC...

>  If you say
> that ASPSM (except BEAT) and RKM MUST be sent on stream `0', 
> then you will
> be changing the requirements in the RFC.  There is no such 
> MUST requirement
> today.  Also, there does not appear to be any 
> interoperability concerns over
> upon which stream a message is "received."  So why introduce 
> thie MUST now?
> 

Then, I would say that the error code "invalid stream identifier" example does not make sense for me, since it is not mandatory to send any management message on stream '0'.

"ASPSM (except BEAT) and RKM SHOULD be sent on stream 0. The rest of the management messages (BEAT, ASPTM, MGMT, SSNM) MAY either be sent on stream '0' or  thru any other stream that could be reserved for an specific AS (if there exists such a stream-per-AS configuration)."

Changing the req to SHOULD it only express a preferred preference. If we change it to MAY, we can change the complete explanation just saying that Transfer messages cannot be sent on stream '0'. And the "invalid stream" error code will be just valid whenever DATA msgs are sent on stream '0'.

What is your preferred approach ?
Other people opinion?

Cheers // Javier.

> --brian
> > Cheers // Javier.
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 17 Apr 2002 14:45:11 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:                          (Wed, 17 Apr 2002 20:01:15)
> 
> Then, I would say that the error code "invalid stream identifier" example
> does not make sense for me, since it is not mandatory to send any management
> message on stream '0'.
> 
> "ASPSM (except BEAT) and RKM SHOULD be sent on stream 0. The rest of the
> management messages (BEAT, ASPTM, MGMT, SSNM) MAY either be sent on stream
> '0' or  thru any other stream that could be reserved for an specific AS (if
> there exists such a stream-per-AS configuration)."
> 
> Changing the req to SHOULD it only express a preferred preference. If we
> change it to MAY, we can change the complete explanation just saying that
> Transfer messages cannot be sent on stream '0'. And the "invalid stream"
> error code will be just valid whenever DATA msgs are sent on stream '0'.
> 

Changing it to MAY results in what it already
says (or doesn't say) in the RFC.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/