Subject: RE: [Sigtran] M3UA : Messages and Streams

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 17 Apr 2002 18:03:39 +0200

Hi Brian, 

See below...

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, April 17, 2002 5:44 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: [email-masked]'; Vats, Umesh
> Subject: Re: [Sigtran] M3UA : Messages and Streams
> 
> 
> Javier,
> 
> Javier Pastor-Balbas (ECE) wrote:               (Wed, 17 Apr 
> 2002 16:42:22)
> > Hi Brian, 
> > 
> > My personal view is that all you are saying is not clearly 
> stated in the
> > draft (otherwise, say the section where it is). I know it 
> was previously
> > discussed but someone not familiar with the discussion that 
> were held in the
> > mailing list will probably not understand what you state 
> after reading the
> > spec.
> > 
> > What it is clear is that DATA messages MUST be sent thru any stream
> > different to stream #0 (section 4.1.1). And also that you 
> can send and ERROR
> > if a management message is received from any stream 
> different to #0 (section
> > 3.8.1). But it is not explained what are those management 
> messages... Does
> > it refer to MGMT messages class or to ASPSM or to ASPTM?
> 
> "Management messages" in the RFC always refers to other
> than SSNM, and DATA, which includes ASPSM, ASPTM, MGMT,
> RKMM.
> 
> Section 4.2.1:
> 
> " All non-Transfer and non-SSNM, messages, except BEAT and BEAT Ack, 
> " SHOULD be sent with sequenced delivery to ensure ordering.  ASPTM 
>                                                               ^^^^^
> " messages MAY be sent on one of the streams used to carry the data 
>   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> " traffic related to the Routing Context(s), to minimize 
> possible message 
>   
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> ^^^^^^^^^
> " loss.  BEAT and BEAT Ack messages MAY be sent using out-of-order 
>   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> " delivery, and MAY be sent on any stream.
>   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> 
> ASPTM and BEAT are clear from the passage above.  Its too bad that
> BEAT was not made an ASPTM message becase it would have made stating
> these things easier, but there it is.
> 

But I don't see explicitly that the name "management messages" is assigned to those message. People can get confuse about that....

BTW: does it "out-of-order" mean that a message has to be sent on stream #0? SCTP allows to send out-of order messages on any stream, if I remember well...

With the paragraph above you can not be sure of how to implement a stream mapping correctly. It is probably in the head of the folks discussing it but not in the document...

> > 
> > It is not either explained or recommended to have a stream 
> separation per
> > AS. It is just recommended to send sequenced traffic 
> messages thru the same
> > stream (section 1.4.7).
> 
> So?
> 
> > 
> > Therefore, IMO:
> >
> > - We should specify which are those "management messages" 
> staed in section
> > 3.8.1
> 
> See section 4.2.1.
> 
> >
> > - We should leave the option of assigning streams per AS 
> open but not
> > mandatory
> 
> See section 1.4.7.
> 
> > 
> > Therefore it seems that the only mandatory messages to be 
> transported thru
> > stream zero would be ASPUP/ASPUP_ACK and RKM messages since 
> the rest of the
> > management messages (ASPDN, ASPTM, MGMT, SSNM) could be related to a
> > specific AS and therefore sent thru any of the streams 
> reserved for that AS.
> 
> Could you explain just how ASPDN/Ack can be related to a specific AS?
> When ASPUP/Ack cannot?
> 

Ooops! No, I can't. ASPDN/Ack goes with ASPUP/DN  

> > This last group of messages could also be optionally sent 
> thru stream #0.
> > DATA messages will be never sent thru stream 0 and sequence 
> should be
> > ensured when required.
> > 
> > Do you agree on the general idea of this last paragraph ?
> 
> I agree with the statements in the RFC.  We had much 
> discussion about these
> three passages.
> 
> > 
> > If agreed I go along with Umesh about updating this in the 
> Implementor's
> > Guide. What do others think?
> 
> I don't have a problem with clarifying it in the IG, as long as
> it does not change the requirements from the RFC (like moving ASPDN
> from one group to another).

Saying that ASPSM (except BEAT) and RKM MUST be sent on stream 0 and the rest of the management messages (BEAT, ASPTM, MGMT, SSNM) could be related to a specific AS and therefore MAY be sent thru any of the streams reserved for that AS (if there exists such a configuration of streams).?

Cheers // Javier.

> --brian
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 17 Apr 2002 11:23:38 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:                          (Wed, 17 Apr 2002 18:03:39)

> Saying that ASPSM (except BEAT) and RKM MUST be sent on stream 0 and the
> rest of the management messages (BEAT, ASPTM, MGMT, SSNM) could be related
> to a specific AS and therefore MAY be sent thru any of the streams reserved
> for that AS (if there exists such a configuration of streams).?

The RFC permits one to send BEAT, ASPTM, MGMT and SSNM on stream `0'
as well.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/