Subject: RE: [Sigtran] M3UA : SSNM on streams other than 0

From: "Vats, Umesh" <[email-masked]>
Date: Wed, 10 Apr 2002 08:45:43 -0700

Hi  Brian

In this case, the following example for sending
ERROR("Invalid Stream Identifier") needs to be
corrected in draft 12.
Section 3.8.1 :

"
The "Invalid Stream Identifier" error is sent if a message is received 
on an unexpected SCTP stream (e.g., a Management message was received 
on a stream other than "0").  
"

thanks
Umesh
-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Tuesday, April 09, 2002 5:44 PM
To: Vats, Umesh
Cc: [email-masked]'
Subject: Re: [Sigtran] M3UA : SSNM on streams other than 0

Umesh,

Vats, Umesh wrote:                                          (Tue, 09 Apr
2002 16:41:37)
> Hi
> 
> As per draft 12 of M3UA, is it possible for an ASP to receive SSNM 
> messages on a stream other than '0' ?

Yes.

--brian

> 
> I have this doubt because in draft 10 of M3UA, following paragraph is
there
> in section 4.5.1
> 
> " DUNA, DAVA, SCON, and DRST messages MUST be sent sequentially and 
> processed at the receiver in the order sent.  SCTP stream "0" is 
> used to provide the sequencing. The only exception to this is if the 
> international congestion method (see Q.704) is used.  If so, the 
> Unordered bit in the SCTP DATA chunk MAY be used for the SCON message."
> 
> The paragraph mentioned above has been modified as follows
> in draft 12 of M3UA :
> 
> "DUNA, DAVA, SCON, and DRST messages may be sent sequentially and 
> processed at the receiver in the order sent."
> 
> Umesh
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ken Morneault <[email-masked]>
Date: Wed, 10 Apr 2002 12:56:33 -0400

Umesh,

I don't think the statement needs to be changed since
it was intended to apply to Management (class 0) 
messages.  However, if others feel it is necessary,
the statement could be qualified by adding "(class 0)".

Ken