Subject: [Sigtran] Length of the Messages

From: Arun Panda <[email-masked]>
Date: Tue, 23 Apr 2002 11:12:32 +0530

Hello,

According to the Draft, one of the M3UA SCON Message  field Concerned
DPC(Tag 0x0206) is of 32 bits. But the field Length is not specified in the
pictorial format of the SCON Message.
For example: the first field Network Appearance is of fixed Length and the
same is mentioned in the picture ( Length = 8). Why the other fields which
are also of fixed length( e.g . Concerned DPC and Cong Level) are not
depicted the same way in the picture.

For the Affected Point Code and Routing Context, it is understandable that
the Length varies depending on the number of APCs or RCs. but for the
conecrned DPC i don't see any reason for the Length to vary as it is always
comprises of 24 bits.
If i assume the Length of these fields(TLV Length) to be 8 octets always,
will be right?
Correct me if i'm wrong.

Thx
Arun

Things turn out the best for the people who make the best of the way things
turn out

Arun Panda
S/w Engg, Ind - Telesoft Pvt Ltd
104, Koramangala Indl Estate
V Block, Bangalore - 560095
Tel : 5521937 - 40 Ext : 419
mailto:[email-masked]

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Apr 2002 01:01:54 -0500

Arun,

The text says that the CPC length is 32-bits.  Nowhere does it
say that the length is variable.  Placing "Length" in a diagram
vs. "Length = 8" does not mean that the length is variable.

--brian

Arun Panda wrote:                                 (Tue, 23 Apr 2002 11:12:32)
> Tel: 5521937 - 40 Ext : 419
> mailto:[email-masked]
> 
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/