Subject: [Sigtran] na must

From: "Nahar,virendra" <[email-masked]>
Date: Sat, 20 Apr 2002 05:57:45 +0530

Hi

When SG gets registration request without NA ,but SG's configuaration is such
that
it requires NA in the RKREG, then in such a case what should be the return code
in REGRSP or an error message is sent with code missing parameter..........

Thanks
Nahar

--
Virendra Nahar
HCL-Technologies Ltd
Networking Systems Lab
51, Jawaharlal Nehru Road
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.
Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
mailto:[email-masked]
############################################################
"He who has a why for life can put with any how."
                             Frederick Nietzsche
############################################################

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 19 Apr 2002 19:47:05 -0500

Nahar,

First off, I assume you are talking about M3UA?

What parameter is missing?  The Routing Key parameter is their, it just
doesn't contain the NA field.

Your choices are:

        0           Successfully Registered
        1           Error - Unknown
        2           Error - Invalid DPC
        3           Error - Invalid Network Appearance
        4           Error - Invalid Routing Key
        5           Error - Permission Denied
        6           Error - Cannot Support Unique Routing
        7           Error - Routing Key not Currently Provisioned
        8           Error - Insufficient Resources
        9           Error - Unsupported RK parameter Field
       10           Error - Unsupported/Invalid Traffic Handling Mode

(3) is possible.
(4) is possible.
(6) is possible.
(7) is possible.

But I think most people agree that if there is no NA and one is required
that (6) is probably the best choice.

--brian

Nahar,virendra wrote:                              (Sat, 20 Apr 2002 05:57:45)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Nahar,virendra" <[email-masked]>
Date: Sat, 20 Apr 2002 06:21:04 +0530

Thanks Brian.....................
One more clarification
M-RK_REG confirm
   Direction: M3UA -> LM
   Purpose: ASP reports that it has received REG RSP message with
            registration status as successful from its peer.

   M-RK_DEREG confirm
   Direction: M3UA -> LM
   Purpose: ASP reports that it has received DEREG REQ message with
            deregistration status as successful from its peer.

The above confirm are sent in successful case only what should be done when
result is not success is this going to be implementation dependent

Thanks
Nahar

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 19 Apr 2002 20:13:29 -0500

Nahar,

The entire management interface is implementation dependent.  This
which appears in the RFC is only an example.  I would suggest that
you provide "M-RK_REG error" or some such for the negative case.

==brian

Nahar,virendra wrote:                              (Sat, 20 Apr 2002 06:21:04)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/