Subject: RE: [Sigtran] M3UA : NOTIFY procedures

From: "Vats, Umesh" <[email-masked]>
Date: Wed, 24 Apr 2002 08:22:08 -0700

Hi Brian/Ken

Some more clarifications are needed :
1. If an ASP is not part of any AS(as can happen in dynamic
   key registration, when ASP has sent ASPUP but hasn't
   sent any REG-REQ), and this ASP fails, NTFY message shouldn't
   be sent. Is this correct ? If not, then which all ASPs should
   receive the message as the list of application servers of which
   the failed ASP was member is not known ?

2. In ASP Failure case, should NTFY be sent to ACTIVE/INACTIVE 
   ASPs only ? 

Umesh

-----Original Message-----
From: Ken Morneault [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 5:37 AM
To: [email-masked]; Vats, Umesh
Cc: [email-masked]'
Subject: Re: [Sigtran] M3UA : NOTIFY procedures

Brian,

I agree that we should add the qualification that you mention.  We can
put this in the implementors guide.

Ken

At 01:49 AM 4/24/2002 -0500, Brian F. G. Bidulock wrote:
>Umesh,
>
>Please see comments below..
>
>Vats, Umesh wrote:                                          (Tue, 23 Apr
2002 22:00:51)
>> Hi
>> 
>> In Section 4.3.4.5(Notify procedures) of draft 12, 
>> the explanation of following scenarios is missing :
>> 
>> 1. Procedures needed if ASP fails(goes to ASP-DOWN state) but no AS
>>     state change occurs ?
>>     At SGP, if an ASP state changes from ACTIVE/INACTIVE to
>>     DOWN, NTFY message should be sent with the ASP-Id (if available)  of
the
>>     failed ASP even if state of none of Application Servers configured on
SG
>>     changes.
>
>ASP Failure is really for when an ASP fails, not when it willfully
>transitions to the ASP-DOWN state with an ASPDN request.  But, the
>RFC says "transitioned to ASP-DOWN" in section 3.8.2.  It might be
>usefull to qualify this in the IG with "when an ASP fails due to
>SCTP CI/RI".
>
>> 
>> 2. To which all ASPs should  NTFY('ASP Failure") message be sent  ?
>
>As per 3.8.2, the NTFY is sent to all the ASP in the AS for which
>the ASP has failed.  It doesn't matter if these are static or
>dynamic.
>
>>     a. In static RK configuration, list of all the application servers
>>         of which the failed ASP is a member should be prepared.
>>         NTFY should be sent to all the ASPs in ACTIVE/INACTIVE 
>>         state in this list of application servers.
>>     b. In dynamic configuration, if ASP has registered any routing key,
then
>>         follow the procedure similar to that specified for static RK
configuration
>>         above.
>>         If no key has been registered by the ASP, then NTFY message
shouldn't
>>         be generated by SGP.
>> 
>> 3. On an ASP failure(ASP state change to DOWN) if an AS state changes,
then
>>     SGP will endup sending two NTFY messages to ASP.
>>        First one is NTFY("ASP Failure")
>>        Second one may be NTFY("Insufficient Resources") or NTFY("AS
INACTIVE") or
>>        NTFY("AS PENDING") 
>
>Yes.  With the above correction, two NTFY would only be sent when
>an ASP has actually failed.  Only one would be sent when it willfully
>moves to the ASP-DOWN state.
>
>--brian
>
>> 
>> Umesh  
>>     
>> 
>> _______________________________________________
>> Sigtran mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/sigtran
>
>-- 
>Brian F. G. Bidulock
>[email-masked]
>http://www.openss7.org/
>
>_______________________________________________
>Sigtran mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/sigtran 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 24 Apr 2002 11:20:30 -0500

Umesh,

Vats, Umesh wrote:                                          (Wed, 24 Apr 2002 08:22:08)
>    the failed ASP was member is not known ?

The SGP MUST send the notify to all AS in which the failed ASP
is a member.  If that list is empty, then the SGP MUST send the
NTFY to an empty list.  This is a corner case and was mentioned
in the WG quite recently.

> 2. In ASP Failure case, should NTFY be sent to ACTIVE/INACTIVE 

All AS.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/