Subject: RE: [Sigtran] Length of the Messages

From: Arun Panda <[email-masked]>
Date: Tue, 23 Apr 2002 11:49:27 +0530

Thanks Brian,

I have one more doubt regarding the Point Codes.
The Draft(In the APC Description of Section 3.4.1) says that the APC has
different 
bit formats for ITU and ANSI standards.
Does this bit format valid only for the APC or for all all Point Codes?

I mean does the OPC & DPC in the DATA Message have the different bit formats
for ITU and ANSI as in the case of APC?

Thx
Arun

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Tuesday, April 23, 2002 11:32 AM
To: Arun Panda
Cc: [email-masked]
Subject: Re: [Sigtran] Length of the Messages

Arun,

The text says that the CPC length is 32-bits.  Nowhere does it
say that the length is variable.  Placing "Length" in a diagram
vs. "Length = 8" does not mean that the length is variable.

--brian

Arun Panda wrote:                                 (Tue, 23 Apr 2002
11:12:32)
> Hello,
> 
> According to the Draft, one of the M3UA SCON Message  field Concerned
> DPC(Tag 0x0206) is of 32 bits. But the field Length is not specified in
the
> pictorial format of the SCON Message.
> For example: the first field Network Appearance is of fixed Length and the
> same is mentioned in the picture ( Length = 8). Why the other fields which
> are also of fixed length( e.g . Concerned DPC and Cong Level) are not
> depicted the same way in the picture.
> 
> For the Affected Point Code and Routing Context, it is understandable that
> the Length varies depending on the number of APCs or RCs. but for the
> conecrned DPC i don't see any reason for the Length to vary as it is
always
> comprises of 24 bits.
> If i assume the Length of these fields(TLV Length) to be 8 octets always,
> will be right?
> Correct me if i'm wrong.
> 
> Thx
> Arun
> 
> Things turn out the best for the people who make the best of the way
things
> turn out
> 
> Arun Panda
> S/w Engg, Ind - Telesoft Pvt Ltd
> 104, Koramangala Indl Estate
> V Block, Bangalore - 560095
> Tel: 5521937 - 40 Ext : 419
> mailto:[email-masked]
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Apr 2002 01:28:13 -0500

Arun,

Arun Panda wrote:                                 (Tue, 23 Apr 2002 11:49:27)
> for ITU and ANSI as in the case of APC?

Yes.  See the description of OPC and DPC on Page 31.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/