Subject: RE: [Sigtran] SUA: stop an ASP for Ongoing traffic

From: "Zannin, Francois" <[email-masked]>
Date: Mon, 29 Apr 2002 18:24:25 +0200

Tolga,

I think that only the AS associated to an ASP knows that it has no more ongoing dialog. Only the AS can decide that the traffic can be stopped. A solution should be to have a message from the ASP for the SGP that indicate that the ASP do not want initiate new dialog but the traffic can continue for the CONTINUE, END and ABORT TCAP messages.

Can it be possible to add a "NOTIFY LIKE" message from the ASP to the SGP?

	Francois Z.

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Monday, April 29, 2002 6:10 PM
> To: [email-masked]
> Subject: RE: [Sigtran] SUA: stop an ASP for Ongoing traffic
> 
> 
> Francois,
> 
> I believe ASPIA/ASPIA-ACK should be enough for such a case. 
> ASPIA tells SGP
> that ASP wants to withdraw from handling traffic and SGP will send
> ASPIA-ACK, after all traffic is stopped.
> 
>    Tolga
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Zannin, Francois
> > Sent: Monday, April 29, 2002 10:54 AM
> > To: [email-masked]
> > Subject: [Sigtran] SUA: stop an ASP for Ongoing traffic
> >
> >
> > Hi,
> >
> > In draft SUA 13, 4.7.3.1 about TCAP traffic, it is said that
> > ongoing traffic for an AS passing through an inactive ASP is
> > returned in #UDTS message (TID for an inactive ASP).
> >
> > If we need to stop properly an ASP without ongoing transaction
> > traffic lost, what is the procedure to stop an ASP.
> >
> > In that case, we need to stop the distribution of  "new" messages
> > to the concerned ASP but we still need to send it messages for
> > it's TID and to accept messages from this ASP for the ss7 network.
> >
> > Currently I haven't seen any messages that inform the SG(p) that
> > the ASP has to be removed of the distribution of new traffic.
> >
> > Francois Z.
> >
> >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 29 Apr 2002 12:57:36 -0400

Francois,

Although it wouldn't be very elegant, SGP can also decide, whether there are
still dialogues alive on ASP (SGP knows for which dialogues a particular ASP
is responsible for and it can keep a list of open dialogues), and sends
ASPIAC-ACK only after there are no more open dialogues for this ASP. In my
view this is doable but I have to admit not very nice.

   Tolga

> From: Zannin, Francois [mailto:[email-masked]]
> Sent: Monday, April 29, 2002 12:24 PM
> To: Tolga Asveren; [email-masked]
> I think that only the AS associated to an ASP knows that it has
> no more ongoing dialog. Only the AS can decide that the traffic
> can be stopped. A solution should be to have a message from the
> ASP for the SGP that indicate that the ASP do not want initiate
> new dialog but the traffic can continue for the CONTINUE, END and
> ABORT TCAP messages.
>