Subject: RE: [Sigtran] M3UA : Messages and Streams

From: "Vats, Umesh" <[email-masked]>
Date: Wed, 17 Apr 2002 13:58:18 -0700

Hi  Brian

I see following references to the message class/stream mappings
in draft 12. 

1. The "Invalid Stream Identifier" error is sent if a message is received 
   on an unexpected SCTP stream (e.g., a Management message was received 
   on a stream other than "0").

2. DATA messages MUST be sent on an SCTP stream
   other than stream '0'.

3. ASPTM messages MAY be sent on one of the streams used to carry the data 
   traffic related to the Routing Context(s), to minimize possible message 
   loss.  BEAT and BEAT Ack messages MAY be sent using out-of-order 
   delivery, and MAY be sent on any stream.

From these three references, one can draw following conclusions :
1. DATA is never sent on stream 0.
2. Management messages (Class 0 messages only as specified in 
   section 3.1.2) can be sent on stream 0 only.
3. All other messages (ASPSM, RKM, ASPTM, SSNM) can be sent on any 
   stream.

If this is not the intended stream mapping, then some more
text is needed in the draft to clarify this. 

Umesh

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Wednesday, April 17, 2002 12:45 PM
To: Javier Pastor-Balbas (ECE)
Cc: [email-masked]'; Vats, Umesh
Subject: Re: [Sigtran] M3UA : Messages and Streams

Javier,

Javier Pastor-Balbas (ECE) wrote:                          (Wed, 17 Apr 2002
20:01:15)
> 
> Then, I would say that the error code "invalid stream identifier" example
> does not make sense for me, since it is not mandatory to send any
management
> message on stream '0'.
> 
> "ASPSM (except BEAT) and RKM SHOULD be sent on stream 0. The rest of the
> management messages (BEAT, ASPTM, MGMT, SSNM) MAY either be sent on stream
> '0' or  thru any other stream that could be reserved for an specific AS
(if
> there exists such a stream-per-AS configuration)."
> 
> Changing the req to SHOULD it only express a preferred preference. If we
> change it to MAY, we can change the complete explanation just saying that
> Transfer messages cannot be sent on stream '0'. And the "invalid stream"
> error code will be just valid whenever DATA msgs are sent on stream '0'.
> 

Changing it to MAY results in what it already
says (or doesn't say) in the RFC.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 17 Apr 2002 16:42:00 -0500

Vats,

What's in the RFC works for me.

--brian

Vats, Umesh wrote:                                          (Wed, 17 Apr 2002 13:58:18)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/