Subject: [Sigtran] unexpected message type

From: Arun Prasad <[email-masked]>
Date: Thu, 11 Apr 2002 15:47:35 +0530

Hi All,
    Some doubts regarding the wordings in the IUA Rfc (3057)

    In section 3.3.3.1,  the below two statements rises some doubts.....  The
first statement infers that an "Unexpected Message" is to be sent when any
message is received which is valid but received in an inappropriate state (regardless
of whether its unexpected msg class or msg type.....)
In the Second and Third statement..... the error "Unsupported Message Type"
is sent when the received message in invalid (ie., out of range) or that particular
"class" or  "type" is not supported ....  Till here its clear.....
Then why the words "unexpected" (which is underlined..) in the two statements...
This creates an ambiguity of whether to send "Unexpected Message" or
"Unsupported message" if any endpoint receives a message which is unexpected for
it (or in the current state of it...)

Not sure whether its an ambiguity or I missed something.......

The "Unexpected Message" error would be sent by an ASP if it received
   a QPTM message from an SG while it was in the Inactive state (the ASP
   could optionally drop the message and not send an Error).  It would
   also be sent by an ASP if it received a defined and recognized
   message that the SG is not expected to send (e.g., if the MGC
   receives an IUA Establish Request message).

 The "Unsupported Message Type" error would be sent if a message with
   an unexpected or unsupported Message Type is received.

The "Unsupported Message Class" error would be sent if a message with
   an unexpected or unsupported Message Class is received.

Thanks
-arun
--
****************************************************************
V.Arun Prasad
HCL Technologies Ltd.
51, Jawaharlal Nehru Road,
Ekkattuthangal,
Guindy Industrial Estate,
Chennai - 600097.

Contact # : 9144 - 2334174
            9144 - 2334181
            extn : 233
****************************************************************

---

From: Ken Morneault <[email-masked]>
Date: Thu, 11 Apr 2002 09:59:40 -0400

Arun,

In the case of "Unsupported Message Type", unexpected refers to a
message that has a message type that is defined but not expected
to be received in any state (i.e.  if a ASP UP message is received by 
the ASP).

Regards,

Ken

>   an unexpected or unsupported Message Class is received. 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran