Subject: [Sigtran] M3UA : Implementor's Guide. DUNA(*) message

From: "Vats, Umesh" <[email-masked]>
Date: Thu, 18 Apr 2002 09:37:47 -0700

> Hi    
> 
> In the implementor's guide, following statement is there in section 3.4.2
> :
> 
> "If the SG (all the SGPs) is isolated from the NIF, 
>  then all the users are isolated from the SS7 network.  
>  A DUNA(*) message MUST be sent. "
> 
In the draft 12 of M3UA section 3.4.1, following text is given :

   " A mask value equal (or greater than) the 
   number of bits in the PC indicates that the entire network 
   appearance is affected - this is used to indicate network isolation 
   to the ASP. "

In case ASP is communicating with the users located at SG (i.e. ASP and SG
have
separate point codes), then reception of DUNA(*) at ASP means that 
communication between ASP  and the users at SG is lost. But this shouldn't
happen because the associations between SG and ASP are UP.

How should ASP handle this ? Can we specify some text for this in the
implementor's
 guide ?

> Umesh

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 18 Apr 2002 13:22:55 -0400

Umesh,

1) As I mentioned one of my former messages about the M3UA Implementor's
Guide, I don't think it is appropriate to say "A DUNA(*) message MUST be
sent" in such a case. As long as one does not violate the protocol, one is
free to do anything. So, in the same situation, one also might drop the
associations, and this won't be in conflict with the protocol.

2) For the case you described, if SG is isolated from NIF, then most
probably it won't be able to reach also users at the same point code as SG
(Well, depending on implementation the case might be different) I also don't
think, the protocol should tell about implementation dependent cases (like
loosing connection to NIF etc....)

Because of both of those reasons, in my opinion it is better not to say
anything about this in the Implementor's Guide, especially "MUST" is too
much.

     Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Vats, Umesh
> Sent: Thursday, April 18, 2002 12:38 PM
> To: [email-masked]'
> Subject: [Sigtran] M3UA : Implementor's Guide. DUNA(*) message
>
>
> > Hi
> >

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 18 Apr 2002 16:08:39 -0500

Tolga,

I agree: the IG needs to have sending DUNA(*) removed.  It is also
appropriate to send ASPIA Ack.  DUNA(*) should never be sent when
there is not isolation with the SS7 network at the SG (it has nothing
to do with isolation between the ASP and SG).

Tolga Asveren wrote:                                        (Thu, 18 Apr 2002 13:22:55)
> anything about this in the Implementor's Guide, especially "MUST" is too

I completely agree.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/