Subject: RE: [Sigtran] M3UA : Implementor's guide ("Missing Parameter")

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 12 Apr 2002 14:32:28 +0200

Hi Brian, 

I think it is just a matter of getting a common agreement. If nobody objects, we will change the ERROR code to "No Configured AS for ASP" in next version. :-) 

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Friday, April 12, 2002 2:22 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: 'Vats, Umesh'; [email-masked]'; 'Ken Morneault'
> Subject: Re: [Sigtran] M3UA : Implementor's guide ("Missing 
> Parameter")
> 
> 
> Javier,
> 
> Please see comments below...
> 
> Javier Pastor-Balbas (ECE) wrote:               (Fri, 12 Apr 
> 2002 13:13:56)
> > Hi Umesh, 
> > 
> > In my understanding "No Configured AS for ASP" is only 
> valid when that
> > particular ASP has not been registered for any AS. 
> > 
> > But when we say that "the RC is missing and its 
> specification is needed
> > according to the used configuration", it tries to mean:
> >
> > - If it is needed, then it is mandatory for those cases 
> (that is included in
> > the "semioptional" term)
> >
> > - And it is mandatory because of the configuration that it is used
> > 
> > Consider the case when an ASP is registered for two ASs. In 
> that case, RC is
> > mandatory and "No Configured AS for ASP" would not be a 
> valid Error Code.
> > IMO, "Missing Parameter" fits better.
> 
> "No Configured AS for ASP" is precisely for this situation.  "No
> Configured AS for ASP" means that there is not a single AS
> configured for the ASP (thus RC is mandatory, because the ASP
> multiplexes multiple AS over a signle association).
> 
> I agree with Umesh: drop it from the Imp. Guide because the RFC
> is clear on this point.
> 
> --brian
> 
> 
> > 
> > Cheers // Javier.
> > 
> > 
> > > -----Original Message-----
> > > From: Vats, Umesh [mailto:[email-masked]]
> > > Sent: Friday, April 12, 2002 3:10 AM
> > > To: 'Ken Morneault'
> > > Cc: [email-masked]'
> > > Subject: [Sigtran] M3UA : Implementor's guide ("Missing 
> Parameter")
> > > 
> > > 
> > > Hi  Ken
> > > 
> > > In draft 12, following statements are present in section 3.8.1 :
> > > 
> > > The "Missing Parameter" error would be sent if a 
> mandatory parameter 
> > > were not included in a message. 
> > > 
> > > The "No Configured AS for ASP" error is sent if a message 
> is received 
> > > from a peer without a Routing Context parameter and it is not 
> > > known by n
> > > configuration data which Application Servers are referenced.
> > > 
> > > In the implementor's guide section 3.10.2, following text 
> is present :
> > > 
> > >        - If the RC is missing and its specification is needed 
> > > according
> > >           to the used configuration, the peer must respond 
> > > with an ERROR
> > >           message with Error Code = "Missing Parameter".
> > > 
> > > I believe, that the correct text in implementor's guide should
> > > be :
> > >         - If the RC is missing and its specification is 
> > > needed according
> > >           to the used configuration, the peer must respond 
> > > with an ERROR
> > >           message with Error Code = "No Confugured AS for ASP".
> > > 
> > > This is because :
> > >       a. RC is not a mandatory parameter (it is semi optional)
> > >       b. An error code for the handling of this case is already 
> > >          present in draft 12 ("No Configured AS for ASP")
> > > 
> > > Please let me know if my understanding is not OK.
> > > 
> > > Umesh
> > > 
> > > 
> > > 
> > > 
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 12 Apr 2002 07:46:49 -0500

Javier,

What is the point of making it that way in the next version when
it is already that way in the RFC?

--brian

Javier Pastor-Balbas (ECE) wrote:                          (Fri, 12 Apr 2002 14:32:28)
> Hi Brian, 
> 
> I think it is just a matter of getting a common agreement. If nobody
> objects, we will change the ERROR code to "No Configured AS for ASP" in next
> version. :-) 
> 
> Cheers // Javier.
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/