Subject: RE: [Sigtran] M3UA : Messages and Streams

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 17 Apr 2002 18:31:35 +0200

Brian, 

See below...

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, April 17, 2002 6:24 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: [email-masked]'; Vats, Umesh
> Subject: Re: [Sigtran] M3UA : Messages and Streams
> 
> 
> Javier,
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Wed, 17 Apr 2002 18:03:39)
> 
> > > 
> > > I don't have a problem with clarifying it in the IG, as long as
> > > it does not change the requirements from the RFC (like 
> moving ASPDN
> > > from one group to another).
> > 
> > Saying that ASPSM (except BEAT) and RKM MUST be sent on 
> stream 0 and the
> > rest of the management messages (BEAT, ASPTM, MGMT, SSNM) 
> could be related
> > to a specific AS and therefore MAY be sent thru any of the 
> streams reserved
> > for that AS (if there exists such a configuration of streams).?
> 
> The RFC permits one to send BEAT, ASPTM, MGMT and SSNM on stream `0'
> as well.
> 

I think the wording above also permits them on stream '0' since MAY means optionally. Anyway, wording can be improved to say it more explicitly:

"ASPSM (except BEAT) and RKM MUST be sent on stream 0. The rest of the management messages (BEAT, ASPTM, MGMT, SSNM) MAY either be sent on stream '0' or  thru any other stream that could be reserved for an specific AS (if there exists such a stream-per-AS sconfiguration)"

BTW, I'm probably missing where the RFC says that BEAT, ASPTM, MGMT and SSNM can be sent on stream `0'. Do you refer to section 4.1.1 again? I think it doesn't say nothing about stream '0'...

Cheers // Javier.

> > Cheers // Javier.
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 17 Apr 2002 12:25:04 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:                          (Wed, 17 Apr 2002 18:31:35)
> I think the wording above also permits them on stream '0' since MAY means
> optionally. Anyway, wording can be improved to say it more explicitly:
> 
> "ASPSM (except BEAT) and RKM MUST be sent on stream 0. The rest of the
> management messages (BEAT, ASPTM, MGMT, SSNM) MAY either be sent on stream
> '0' or  thru any other stream that could be reserved for an specific AS (if
> there exists such a stream-per-AS sconfiguration)"
> 
> BTW, I'm probably missing where the RFC says that BEAT, ASPTM, MGMT and SSNM
> can be sent on stream `0'. Do you refer to section 4.1.1 again? I think it
> doesn't say nothing about stream '0'...

No, section 4.2.1.  It *used* to say that stream `0' was used for ordering
of non-Transfer, non-SSNM, message, except BEAT and BEAT Ack.  If you say
that ASPSM (except BEAT) and RKM MUST be sent on stream `0', then you will
be changing the requirements in the RFC.  There is no such MUST requirement
today.  Also, there does not appear to be any interoperability concerns over
upon which stream a message is "received."  So why introduce thie MUST now?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/