Subject: [Sigtran] RK already registered

From: "Nahar,virendra" <[email-masked]>
Date: Mon, 01 Apr 2002 15:02:03 +0530

Hi
The implementators guide says
 New text: (Section 4.4.1)
    ---------

    If the SG determines that the received RK was already registered, the
    SGP returns a Registration Response message to the ASP, containing a
    Registration Result "Error - Cannot Support Unique Routing

This Error code applies when the given RK overlaps with that existing one
Getting an RK which is already registered might be due to the case that
ASP never got the successful registration result (i.e the REG Response got
lost).
So the ASP resends the registration REQ , I think the error code should be
Error-"RK already Provisioned."
    Or SG  just send a +ve response & move the ASP to inactive state or keep it
in the same state.!!Sending Error - Cannot Support Unique Routin would be
confusing in this case........

Pls clarify
Thanks
Nahar

--
Virendra Nahar
HCL-Technologies Ltd
Networking Systems Lab
51, Jawaharlal Nehru Road
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.
Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
mailto:[email-masked]
############################################################
"He who has a why for life can put with any how."
                             Frederick Nietzsche
############################################################

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 1 Apr 2002 03:59:42 -0600

Nahar,

Plesae clarify how a REG Response could get lost.

--brian

Nahar,virendra wrote:                                  (Mon, 01 Apr 2002 15:02:03)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/