Subject: [Sigtran] M3UA : NOTIFY procedures

From: "Vats, Umesh" <[email-masked]>
Date: Tue, 23 Apr 2002 22:00:51 -0700

Hi

In Section 4.3.4.5(Notify procedures) of draft 12, 
the explanation of following scenarios is missing :

1. Procedures needed if ASP fails(goes to ASP-DOWN state) but no AS
    state change occurs ?
    At SGP, if an ASP state changes from ACTIVE/INACTIVE to
    DOWN, NTFY message should be sent with the ASP-Id (if available)  of the

    failed ASP even if state of none of Application Servers configured on SG

    changes.

2. To which all ASPs should  NTFY('ASP Failure") message be sent  ?
    a. In static RK configuration, list of all the application servers
        of which the failed ASP is a member should be prepared.
        NTFY should be sent to all the ASPs in ACTIVE/INACTIVE 
        state in this list of application servers.
    b. In dynamic configuration, if ASP has registered any routing key, then
        follow the procedure similar to that specified for static RK
configuration
        above.
        If no key has been registered by the ASP, then NTFY message
shouldn't
        be generated by SGP.

3. On an ASP failure(ASP state change to DOWN) if an AS state changes, then
    SGP will endup sending two NTFY messages to ASP.
       First one is NTFY("ASP Failure")
       Second one may be NTFY("Insufficient Resources") or NTFY("AS
INACTIVE") or
       NTFY("AS PENDING") 

Umesh  

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 24 Apr 2002 01:49:17 -0500

Umesh,

Please see comments below..

Vats, Umesh wrote:                                          (Tue, 23 Apr 2002 22:00:51)
>     failed ASP even if state of none of Application Servers configured on SG

ASP Failure is really for when an ASP fails, not when it willfully
transitions to the ASP-DOWN state with an ASPDN request.  But, the
RFC says "transitioned to ASP-DOWN" in section 3.8.2.  It might be
usefull to qualify this in the IG with "when an ASP fails due to
SCTP CI/RI".

> 2. To which all ASPs should  NTFY('ASP Failure") message be sent  ?

As per 3.8.2, the NTFY is sent to all the ASP in the AS for which
the ASP has failed.  It doesn't matter if these are static or
dynamic.

>         follow the procedure similar to that specified for static RK configuration
>         above.
>         If no key has been registered by the ASP, then NTFY message shouldn't
>         be generated by SGP.
> 
>        Second one may be NTFY("Insufficient Resources") or NTFY("AS INACTIVE") or
>        NTFY("AS PENDING") 

Yes.  With the above correction, two NTFY would only be sent when
an ASP has actually failed.  Only one would be sent when it willfully
moves to the ASP-DOWN state.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Ken Morneault <[email-masked]>
Date: Wed, 24 Apr 2002 08:36:40 -0400

Brian,

I agree that we should add the qualification that you mention.  We can
put this in the implementors guide.

Ken