Subject: [Sigtran] M3UA : Implementor's guide ("Missing Parameter")

From: "Vats, Umesh" <[email-masked]>
Date: Thu, 11 Apr 2002 18:09:42 -0700

Hi  Ken

In draft 12, following statements are present in section 3.8.1 :

The "Missing Parameter" error would be sent if a mandatory parameter 
were not included in a message. 

The "No Configured AS for ASP" error is sent if a message is received 
from a peer without a Routing Context parameter and it is not known by n
configuration data which Application Servers are referenced.

In the implementor's guide section 3.10.2, following text is present :

       - If the RC is missing and its specification is needed according
          to the used configuration, the peer must respond with an ERROR
          message with Error Code = "Missing Parameter".

I believe, that the correct text in implementor's guide should
be :
        - If the RC is missing and its specification is needed according
          to the used configuration, the peer must respond with an ERROR
          message with Error Code = "No Confugured AS for ASP".

This is because :
      a. RC is not a mandatory parameter (it is semi optional)
      b. An error code for the handling of this case is already 
         present in draft 12 ("No Configured AS for ASP")

Please let me know if my understanding is not OK.

Umesh

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 12 Apr 2002 20:14:16 +0200

Brian, 

I'm not saying that. What I'm saying is that the section 10.2 of the Implementor's Guide tries to solve one issue that came up in the 2nd plugtest and that all the participants (OpenSS7 among them) seem to agree that was not clearly covered in M3UA. All that we have done in the Inmplementor's Guide is trying to reword a paragraph of the Inactive Procedures section within M3UA to cover it clearer.

The definition of that Error Code is kept as it is and it is NOT modified. 

Cheers // Javier.

-----Original Message-----
From: Brian F. G. Bidulock
To: Javier Pastor-Balbas (ECE)
Sent: 12/04/02 17:00
Subject: Re: [Sigtran] M3UA : Implementor's guide ("Missing Parameter")

Javier,

Are you saying that this excerpt from the RFC is unclear?

" The "No Configured AS for ASP" error is sent if a message is received 
" from a peer without a Routing Context parameter and it is not known by

" configuration data which Application Servers are referenced.

I think it is quite clear and quite to the point of what you are
trying to now say again in the IG.

=-brian
`

On Fri, 12 Apr 2002, Javier Pastor-Balbas (ECE) wrote:

> Brian, 
> 
> The point of this text (the whole text of section 3.10.2 in
Implementor's
> Guide) was completing the wording of the section for Inactive
Procedures to
> give answer to an scenario that came up in the Plugtest and was not
clearly
> covered.
> Cheers // Javier.

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦