Subject: [Sigtran] DRST

From: "Nahar,virendra" <[email-masked]>
Date: Wed, 24 Apr 2002 02:28:26 +0530

Hi
3.4.6 Destination Restricted (DRST)

The DRST message is optionally sent from the SGP to all concerned ASPs
to indicate that the SG has determined that one or more SS7
destinations are now restricted from the point of view of the SG, or
in response to a DAUD message if appropriate. The M3UA layer at the ASP
is expected to send traffic to the affected destination via an
alternate SG with route(s) of equal priority, but only if such an
alternate route exists and is available. If the affected destination
is currently considered unavailable by the ASP, The MTP3-User should
be informed that traffic to the affected destination can be resumed.
In this case, the M3UA layer should route the traffic through the SG
initiating the DRST message.
           Is the above bold text correct . I think it should be cannot be
resumed.
Also the last line says to route the traffic through the SG
initiating the DRST message.
    pls clarify
Thanks
Nahar

--
Virendra Nahar
HCL-Technologies Ltd
Networking Systems Lab
51, Jawaharlal Nehru Road
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.
Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
mailto:[email-masked]
############################################################
"He who has a why for life can put with any how."
                             Frederick Nietzsche
############################################################

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 23 Apr 2002 17:31:43 -0400

Nahar,

Yes, it is correct. Restricted means, "if you can route it via another SG,
it is better". So, if the affected PC was before unavailable, when it
switches status to restricted, this means, although not preferred , SG can
route messages to it. "through the SG initiating DRST" refers to the case,
if this PC is not available via another SG.

       Tolga
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Nahar,virendra
  Sent: Tuesday, April 23, 2002 4:58 PM
  To: Sigtran
  Subject: [Sigtran] DRST

  Hi

---

From: "Nahar,virendra" <[email-masked]>
Date: Wed, 24 Apr 2002 02:58:32 +0530

Hi
But how does SG behaves when its gets data for destination marked restricted.
If it drops it then ASP should not indicate RESUME to user if status changes
from unavailable to
DRST..................................................................
correct me if wrong  ?
Thanks
Nahar

Tolga Asveren wrote:

>  Nahar,Yes, it is correct. Restricted means, "if you can route it via another
> SG, it is better". So, if the affected PC was before unavailable, when it
> route messages to it. "through the SG initiating DRST" refers to the case, if
> this PC is not available via another SG.       Tolga
>
>      From: [email-masked] [mailto:[email-masked]]On
>      Behalf Of Nahar,virendra
>                 Is the above bold text correct . I think it should be
>      cannot be resumed.

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 23 Apr 2002 17:44:15 -0400

It won't drop it and will tru to route it.

   Tolga
  -----Original Message-----
  From: Nahar,virendra [mailto:[email-masked]]
  Sent: Tuesday, April 23, 2002 5:29 PM
  To: Tolga Asveren; Sigtran
  Subject: Re: [Sigtran] DRST

  Hi
  But how does SG behaves when its gets data for destination marked
restricted.
  If it drops it then ASP should not indicate RESUME to user if status
changes
  from unavailable to
DRST..................................................................
  correct me if wrong  ?
  Thanks
  Nahar
  Tolga Asveren wrote:

     Nahar,Yes, it is correct. Restricted means, "if you can route it via
another SG, it is better". So, if the affected PC was before unavailable,
when it switches status to restricted, this means, although not preferred ,
SG can route messages to it. "through the SG initiating DRST" refers to the
case, if this PC is not available via another SG.       Tolga
      -----Original Message-----
      From: [email-masked] [mailto:[email-masked]]On Behalf
Of Nahar,virendra
      Sent: Tuesday, April 23, 2002 4:58 PM
      To: Sigtran
      Subject: [Sigtran] DRST

      Hi
      in response to a DAUD message if appropriate. The M3UA layer at the
ASP