Subject: [Sigtran] nif/user not available

From: "reshma" <[email-masked]>
Date: Mon, 1 Apr 2002 19:18:06 +0530

Hi,

    When an ASP sends a ASPAC and if at that point user/NIF at the SG is not available which error code should SG send to peer.?

Thanks,
reshma

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 1 Apr 2002 09:08:49 -0500

I don't think any error should be sent, just SGP won't respond with
ASPAC-ACK.
BTW, related with this problem, I think it is quite inappropriate to
address, what should be done in case NIF is unavailable, in m3ua
implementors guide in a strong language. Especially using words like
"SHOULD" is too much, in my opinion. I think, as long as one does not
violate the m3ua draft, one is free to take any action. For example, if all
SGPs are isolated from hte NIF and if SGPs drop the associations, is it a
violation of the draft? I don't think so (I am not advocating SGPs should
behave like this, I just try to point out, it should be clearly said in this
section, that those are just implementation recommendations, not part of the
protocol)

     Tolga
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
reshma
  Sent: Monday, April 01, 2002 8:48 AM
  To: [email-masked]
  Subject: [Sigtran] nif/user not available

  Hi,

      When an ASP sends a ASPAC and if at that point user/NIF at the SG is
not available which error code should SG send to peer.?

  Thanks,
  reshma

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 1 Apr 2002 15:04:32 -0600

reshma,

ERR("Management Blocking").

I follow ERR("Management Blocking") with ASPIA-ACk to make sure...

--brian

reshma wrote:                                                  (Mon, 01 Apr 2002 19:18:06)
> 
>    Hi,
>    
>        When an ASP sends a ASPAC and if at that point user/NIF at the SG
>    is not available which error code should SG send to peer.?
>    
>    Thanks,
>    reshma

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 1 Apr 2002 16:28:45 -0500

In general, I feel uncomfortable about Error("Management Blocking"), because
other error codes are about erors in the protocol, and this one is about
operation of the system. If the SGP might send ASPIA-ACK, why is
Error("Management Blocking") needed?(Not just for this case, in general)

    Tolga

> Sent: Monday, April 01, 2002 4:05 PM
> To: reshma
> Cc: [email-masked]
> Subject: Re: [Sigtran] nif/user not available
>
>
> reshma,
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 1 Apr 2002 15:57:13 -0600

Tolga,

As I recall, in our discussions of ASPIA-ACK, we said that
for a partial failure the SGP woulds end ASPIA-ACK and
respond to further ASPAC requests with ERR("Management Blocking").
I add an additional ASPIA-ACK to avoid the situation where
the ASP has difficulty correlating the ERR message with the
ASPAC.

--brian

Tolga Asveren wrote:                                            (Mon, 01 Apr 2002 16:28:45)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 1 Apr 2002 17:46:03 -0500

Brian,

I remember but my point is, what is the difference between sending ASPIA-ACK
and Error("Management Blocking"). Does Error("Management Blocking") contain
more information? In my opinion, sending ASPDN-ACK or ASPIA-ACK depending on
the situation makes more sense. If there is a second ASPAC, ASPIA-ACK can be
sent again. I think, m3ua protocol does not need Error("Management
Blocking").

    Tolga

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Monday, April 01, 2002 4:57 PM
> To: Tolga Asveren
> Cc: [email-masked]
> > > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> > > Brian F. G. Bidulock

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 1 Apr 2002 17:56:39 -0600

Tolga,

Tolga Asveren wrote:                                            (Mon, 01 Apr 2002 17:46:03)
> sent again. I think, m3ua protocol does not need Error("Management

Perhaps not... but that's the way it was described.  Under the procedures for
ASP Active, you have two choices: respond with ASPAC Ack or respond with ERR.

Of course, ASPIA Ack can be sent at any time.  That is why I response with ERR
and ASPIA-Ack.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/