Subject: RE: [Sigtran] M3UA : DUPU message from ASP to SGP

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 12 Apr 2002 14:33:01 -0400

Umesh,

What I want to tell is as follows:

If you define your RK in PC granularity, this means you are happy with the
fact that all of it might go down. If you want finer granularity, you define
your RK as DPC+SI.
If you define your RK as DPC, there is nothing wrong that you send ASPIA,
when one part of it (let's say SCCP) is not functional. By configuration you
decided what the granularity of your entity is.

    Tolga

> -----Original Message-----
> From: Vats, Umesh [mailto:[email-masked]]
> Sent: Friday, April 12, 2002 2:16 PM
> To: 'Tolga Asveren'; [email-masked]
> Subject: RE: [Sigtran] M3UA : DUPU message from ASP to SGP
>
>
> Hi  Tolga
>
> I am sorry, I couldn't  understand your response.
>
> The only thing I am saying is that RK based on just
> the OPCs of ASP is a valid configuration (its similar
> to route sets in SS7 world which are based on remote
> point codes). For handling this, the already existing
> message in the protocol (DUPU) should be allowed in the
> reverse direction(ASP to SGP) also. I don't see any major
> variation from general understanding of M3UA protocol here.
>
> Otherwise, the draft should clearly specify that SI is
> the mandatory parameter of the routing key. This is also
> fine for me.
>
> Umesh
> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Friday, April 12, 2002 11:10 AM
> To: [email-masked]
> Subject: RE: [Sigtran] M3UA : DUPU message from ASP to SGP
>
>
> Umesh,
>
> My opinion is, the protocol gives you everything necessary to do
> the things
> fine, but if you insist on a configuration, which is not suitable for your
> needs, then it is not the problem of the protocol.
>
>     Tolga
>
> > -----Original Message-----
> > From: Vats, Umesh [mailto:[email-masked]]
> > Sent: Friday, April 12, 2002 1:31 PM
> > To: 'Tolga Asveren'; [email-masked]
> > Subject: RE: [Sigtran] M3UA : DUPU message from ASP to SGP
> >
> >
> > Hi Tolga
> >
> > If SI is made mandatory part of the RK, then its fine.
> > But rightnow, one can have RKs based on the OPCs of the ASP
> > (without any SI).
> > In this case, same RK will cater to traffic for multiple
> > users. In this scenario, if one user at ASP becomes unavailable,
> > then ASP should be able to send DUPU for that user.
> >
> > Umesh
> >
> > -----Original Message-----
> > From: Tolga Asveren [mailto:[email-masked]]
> > Sent: Friday, April 12, 2002 10:31 AM
> > To: [email-masked]
> > Subject: RE: [Sigtran] M3UA : DUPU message from ASP to SGP
> >
> >
> > Umesh,
> >
> > Related with this I don't think there is a consensus to add
> something. For
> > example I don't think it is necessary , because if you need SI
> > granularity,
> > then you should use appropriate RK type.
> >
> >    Tolga
> >
> > > -----Original Message-----
> > > From: [email-masked]
[mailto:[email-masked]]On Behalf Of
> > Vats, Umesh
> > Sent: Friday, April 12, 2002 1:10 PM
> > To: [email-masked]'
> > Cc: 'Javier Pastor-Balbas (ECE)'; 'Ken Morneault'
> > Subject: [Sigtran] M3UA : DUPU message from ASP to SGP
> >
> >
> > Hi  Javier/Ken
> >
> > I don't know whether I brought this issue up earlier or not.
> > In draft 12, following text is there :
> >
> > "3.4.5 Destination User Part Unavailable (DUPU)
> >
> > The DUPU message is used by an SGP to inform concerned ASPs that a
> > remote peer MTP3-User Part (e.g., ISUP or SCCP) at an SS7 node is
> > unavailable.
> >
> >                                        .......................
> >
> > "
> >
> > Where an ASP is connected with more than one SGs, ASP's point
> code differs
> > from the point codes of the SGs. In this case, DUPU can be sent
> by ASP to
> > SGP.
> > I think, this should be captured in implentor's guide. Its not necessary
> > that
> > SI (e.g SCCP, ISUP etc.)  will always be part of the routing key
> > configured
> > at SG.
> >
> > Umesh
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Vats, Umesh" <[email-masked]>
Date: Fri, 12 Apr 2002 11:15:58 -0700

Hi  Tolga

Umesh
-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]]
Sent: Friday, April 12, 2002 11:10 AM
To: [email-masked]
Subject: RE: [Sigtran] M3UA : DUPU message from ASP to SGP

Umesh,

My opinion is, the protocol gives you everything necessary to do the things
fine, but if you insist on a configuration, which is not suitable for your
needs, then it is not the problem of the protocol.

    Tolga

> Related with this I don't think there is a consensus to add something. For
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> > Vats, Umesh