Subject: RE: [Sigtran] M2PA Comment: T7 Timer

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 21 Jun 2002 19:06:59 +0200

Hi Brian ,

Would it be more consistent to use the transport layer for these issues in the IP network? 

MTP2 uses T7 to get reliability because it is only the wire what is below... We should adapt it to the IP architecture. 

I don't see any reasons to have T7 in M2PA if we use SCTP.

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Friday, June 21, 2002 6:50 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: Andrew Booth; [email-masked]
> Subject: Re: [Sigtran] M2PA Comment: T7 Timer
> 
> 
> Javier,
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Fri, 21 Jun 2002 17:36:45)
> > Hi Brian, 
> > 
> > This is not included in the current version of M2PA, or at 
> least I didn't
> > find it...
> 
> It was proposed and agreed since the last draft.
> 
> > 
> > What is the purpose to include this timer?
> 
> Consistency with MTP2.
> 
> --brian
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 21 Jun 2002 12:14:40 -0500

Javier,

No. MTP uses T7 at to detect excessive delay of acknowledgement.
There is no common equivalent in SCTP.  The use of lifetimes was
considered, however, as lifetimes are implementation dependent
and not a requirement part of an SCTP implementation, the M2PA
protocol needs to address this in a consistent fashion.

The use of additional timers in M2PA was discussed and agreed on
the list.  I refer you to the previous threads on this matter.
It might also help you understand the function of these additional
timers if you look at draft-bidulock-sigtran-m2pa-test-01.txt

--brian

Javier Pastor-Balbas (ECE) wrote:                          (Fri, 21 Jun 2002 19:06:59)
> MTP2 uses T7 to get reliability because it is only the wire what is below...
> We should adapt it to the IP architecture. 
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/