Subject: RE: [Sigtran] IPSP: SE vs DE

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 4 Jun 2002 08:39:30 +0200

Hi Tolga, 

These two methods are not comparable. They simply do different things. But for sure that if I have to choose one, I'll go for the current RFC with the IPSP. The reasons are in the list below.

Let's complete the table... (see below)

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Monday, June 03, 2002 8:03 PM
> To: [email-masked]
> Subject: RE: [Sigtran] IPSP: SE vs DE
> 
> 
> My opinion is:
> 
> First of all thinking that AS talks to SG is equivalent to 
> say that a web
> browser talks to a router, instead of a web server. It is 
> ASP-M3UA, which
> talks to SGP-M3UA. I think saying like this fits more to a 
> layered approach,
> otherwise for any communication at any level we can say AS is 
> talking to SG.
> In the context of M3UA stack, ASP corresponds to a physical 
> endpoint whereas
> AS is only a traffic range. So, for example, ASPUP is not 
> sent from AS to SG
> but from ASP-M3UA to SGP-M3UA (for example similarly if INAP 
> logic in a SSP
> sends an INAP message to a SCP, the corresponding MSUs will 
> possibly pass
> through some STPs. Does this mean that SSP talks to those 
> STPs?). An AS is a
> logical HLR, SCP etc... so its peer will be again a 
> corresponding entity, in
> IP domain or in SS7 domain.
> 
> Advantages of using SG-SG communication:
> ========================================
> 1- Has relaying functionality
> 2- Allows smooth interaction with SS7 network
> 3- For PC granularity, user application might run directly on 
> top of SGPF
> (of course with NIF)
> 4- Does not require separate state machines and separate 
> logics for peers in
> SS7 domain and in IP domain
> 
> 
> Advantages of SE IPSP
> ======================
>
> 1- Will provide direct symmetric communication for sub-PC granularity.

Let add a few more:

2- Will provide direct symmetric communication for PC granularity
3- Will provide direct symmetric communication for supra-PC granularity
4- No more messages needed
5- No more working items needed
6- No more standard process needed
7- Use of SG not needed to communicate two SS7 applications in the IP domain
8- Relaying function not needed in IP domain: we have routers
9- Allow an step forward moving from MTP2 to IP protocol to transport SS7 signaling
10- The future network without SS7 domain
11- The first network small operators could make (SS7 is more expensive)

Cheers // Javier.

> 
> Let's try to complete those two lists. What else could be 
> added to them?
> 
>  Tolga
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Javier Pastor-Balbas (ECE)
> > Sent: Monday, June 03, 2002 11:52 AM
> > To: [email-masked]'; Javier Pastor-Balbas (ECE)
> > Cc: [email-masked]'
> > Subject: RE: [Sigtran] IPSP: SE vs DE
> >
> >
> > Brian,
> >
> > Wrong concept. My AS can talk with a SG and ALSO with another AS.
> > The communication will be faster since the processing is half or
> > even less.
> >
> > What is the advantage of AS-SG-(SG)-AS regarding AS-AS ?? Please
> > list them.
> >
> > Cheers // Javier.
> >
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Monday, June 03, 2002 5:14 PM
> > > To: Javier Pastor-Balbas (ECE)
> > > Cc: [email-masked]'
> > > Subject: Re: [Sigtran] IPSP: SE vs DE
> > >
> > >
> > > Javier,
> > >
> > > Your IPSP will not work with an SG and therefore
> > > makes no sense.
> > >
> > > I still propose that IPSP be removed altogether as SG-SG
> > > communication is an better, easier and obvious replacement.
> > >
> > > --brian
> > >
> > > Javier Pastor-Balbas (ECE) wrote:
> > > (Mon, 03 Jun 2002 16:58:54)
> > > > Hi Brian,
> > > >
> > > > IPSP will avoid the use of SG and therefore it makes sense.
> > > >
> > > > Cheers // Javier.
> > > >
> > > > > -----Original Message-----
> > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > Sent: Monday, June 03, 2002 4:48 PM
> > > > > To: Javier Pastor-Balbas (ECE)
> > > > > Cc: [email-masked]'
> > > > > Subject: Re: [Sigtran] IPSP: SE vs DE
> > > > >
> > > > >
> > > > > Javier,
> > > > >
> > > > > As SE was clearly agreed as possible using an SG to 
> transfer and
> > > > > not requiring any new protocol or state machine description, I
> > > > > propose that IPSP be removed from the RFC altogether.  I also
> > > > > propose that the SG-SG be used to properly address 
> peer-to-peer
> > > > > communication.
> > > > >
> > > > > --brian
> > > > >
> > > > > Javier Pastor-Balbas (ECE) wrote:
> > > > > (Mon, 03 Jun 2002 16:24:07)
> > > > > > Hi guys,
> > > > > >
> > > > > > I propose to move forward. Most of the folks that are now
> > > > > > active seem to prefer the SE. Then, I propose to 
> remove the DE
> > > > > > exchange from the current RFC and leave only SE. Anyone
> > > > > > against?
> > > > > >
> > > > > >
> > > > > > Cheers // Javier.
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > _______________________________________________
> > > > > > Sigtran mailing list
> > > > > > [email-masked]
> > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > >
> > > > > --
> > > > > Brian F. G. Bidulock
> > > > > [email-masked]
> > > > > http://www.openss7.org/
> > > > >
> > > >
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> > > --
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 4 Jun 2002 09:15:45 -0400

Hi Javier,

I agree that they are not exactly compareable but if I have to choose one,
without hesitation, I would choose SG-SG. Some more comments to the items
you added to the list are below.

  Tolga

> From: Javier Pastor-Balbas (ECE)
> [mailto:[email-masked]]
> Sent: Tuesday, June 04, 2002 2:40 AM
> To: 'Tolga Asveren'; [email-masked]
> These two methods are not comparable. They simply do different
> things. But for sure that if I have to choose one, I'll go for
> the current RFC with the IPSP. The reasons are in the list below.
>
[TOLGA] SG-SG provides this
> 4- No more messages needed
[TOLGA] For intra-IP case, also for SG-SG no more messages needed.
> 5- No more working items needed
[TOLGA] We still need to discuss about SE IPSP. Till now, all of the
discussion was focused on DE approach.
> 6- No more standard process needed
[TOLGA] ?
> 7- Use of SG not needed to communicate two SS7 applications in
[TOLGA] For PC granularity also not needed for SG-SG case. Or better said,
one just need SG (which I think now we are interpreting more as IP-STP)
> 8- Relaying function not needed in IP domain: we have routers
[TOLGA] It is needed for a reasonable configuration if one goes to sub-PC
granularity. Do we have routers working based on CIC ranges? What about for
multiple operators case? And if sub-PC grabularity is not needed, then IPSP
also does not have any meaning. Because for PC granularity SG-SG provides
everything IPSP can provide and more.
> 9- Allow an step forward moving from MTP2 to IP protocol to
[TOLGA] That is in fact what SG-SG does
> 10- The future network without SS7 domain
[TOLGA] SG-SG also provides this and additionaly also provides easy SS7
communciation for the transition period, which most probably won't be very
short. In fact, although I don't like it, what I see is, people want to use
SIGTRAN
a) either to get a remote SS7 interface for their IP-SCPs, Softswitches
etc...
b) or to backhaul between two SS7 nodes over IP
> 11- The first network small operators could make (SS7 is more expensive)
[TOLGA] Why do you think for SG-SG SS7 is necessary? We have said several
times, SG should be interpreted as IP-STP. SS7 interface is only necessary,
if one want to communicate with nodes in SS7 domain.

---

From: "reshma" <[email-masked]>
Date: Tue, 4 Jun 2002 19:51:36 +0530

Hi Tolga,

> one just need SG (which I think now we are interpreting more as IP-STP)

[Reshma] But Then which configuration of SG-SG communication is this?

> everything IPSP can provide and more.

[Reshma] Whatever granularity we go into IPSP is always point -point and
relaying is not needed.I could'nt understand the example u gave .Can u
please
explain?

Thanks,
reshma

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 4 Jun 2002 10:38:11 -0400

Reshma,

> From: reshma [mailto:[email-masked]]
> Sent: Tuesday, June 04, 2002 10:22 AM
> To: Tolga Asveren; [email-masked]
[TOLGA]
 +------+              +------+
 |U.P./ |              |U.P./ |
 |NIF   |              |NIF   |
 +------+              +------+
 |      |              |      |
 |SGPF  +--------------+SGPF  |
 +------+              +------+
> relaying is not needed.I could'nt understand the example u gave .Can u
[TOLGA] To prevent changing CIC rnages in all of the nodes. Please refer to
my previous message for detailed explanation.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 4 Jun 2002 13:22:35 -0500

Tolga,

I agreew with Tolga: SG-SG can subsume IPSP SE, and therefore it the
best and only necessary solution.

--brian

Tolga Asveren wrote:                                        (Tue, 04 Jun 2002 09:15:45)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 4 Jun 2002 13:21:45 -0500

Javier,

SG-SG provides all the things that IPSP does and more because
it is also capable of doing IPSP SE.

--brian

Javier Pastor-Balbas (ECE) wrote:                          (Tue, 04 Jun 2002 08:39:30)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/