Subject: RE: [Sigtran] M2PA Comment: Multi-homing

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 21 Jun 2002 10:10:08 +0200

Brian, 

The excerpt I copied below about T7 comes from Q.703, i.e. MTP2, 
                                                           ^^^^
which is in charge of flow control in the SS7 network. This is the timer I suppose you were referring to trigger the changeover based on link failure. (T7 = Timer "excessive delay of acknowledgement")

In Q.704 (MTP3) you will just find the next: 

-> T7:Waiting for signalling data link connection acknowledgement.1 to 2 seconds.
It has nothing to do with SCTP's T3.

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Friday, June 21, 2002 9:54 AM
> To: Javier Pastor-Balbas (ECE)
> Cc: [email-masked]'
> Subject: Re: [Sigtran] M2PA Comment: Multi-homing
> 
> 
> Javier,
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Fri, 21 Jun 2002 09:39:13)
> > Hi Brian, 
> > 
> > My point was: I don't find any advantage in using the T7 
> timer since the
> > original function that this parameter has in MTP is well 
> performed by the
> > SCTP transport layer.
> 
> Poorly performed with the recommended SCTP protocol parameters.
> 
> > 
> > As I said before:
> > 
> > Why to use M2PA to deal with data recovery when in the IP 
> networks we
> > already have the means? Especially when SCTP was created 
> for that purpose.
> 
> But is deficient when used with the recommended protocol parameters.
> 
> > It would need the involvement of more layers and the 
> mechanisms will be not
> > as efficient. We now have a RELIABLE transport layer under 
> "MTP2" (M2PA) and
> > not a wire as in the SS7 case...
> 
> MTP2, which M2PA provides the equivalent of, is also a RELIABLE
> layer: it provides for retransmissions, positive and negative
> acknowledgements.
> 
> > Many of changeovers and rerouting procedures can be avoided 
> and therefore
> > efficiency is improved.
> 
> MTP3 performance requirements, however, are not acheived by SCTP
> recommended protocol parameters.  These MTP3 procedures do no go
> away simply because M2PA is used instead of MTP2.  M2PA does not
> specify changes to be made to MTP3.
> 
> --brian
> 
> > 
> > Cheers // Javier.
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Thursday, June 20, 2002 6:46 PM
> > > To: Javier Pastor-Balbas (ECE)
> > > Cc: [email-masked]'
> > > Subject: Re: [Sigtran] M2PA Comment: Multi-homing
> > > 
> > > 
> > > Javier,
> > > 
> > > Javier Pastor-Balbas (ECE) wrote:                          
> > > (Thu, 20 Jun 2002 13:35:52)
> > > > Hi Brian and others, 
> > > > 
> > > > Here are data from Q.703:
> > > > 
> > > > 
> > > > <start>
> > > > T7 = Timer "excessive delay of acknowledgement"
> > > > 	T7 (64) = 0.5-2 s	Bit rate of 64 kbit/s
> > > > 			For PCR method,	Values less than 0.8 s 
> > > should not be used
> > > > 	T7 (4.8) = 4-6 s	Bit rate of 4.8 kbit/s
> > > > <stop>
> > > > 
> > > > 
> > > > Therefore timer T7 has a recommended minimum value of 0.5 
> > > for a 64 kbps bit rate. 
> > > > 
> > > > Two main points here:
> > > > 
> > > > 1- SCTP's Fast Retransmission can be faster than that.
> > > 
> > > And will do so on a single-homed association.  There is no benefit
> > > from multi-homing here.
> > > 
> > > --brian
> > > 
> > > > 
> > > > 2- Considering RTT (which is a function of the bit rate the 
> > > path has) you
> > > > can also configure T3-rtx from SCTP to a minor value. 
> This is NOT
> > > > recommended because fast retransmission is considered as 
> > > the default mode to
> > > > recover for data loss. Otherwise innecessary retransmission 
> > > could happen
> > > > oftenly. Same reasons used to keep T3=1 seg can be applied 
> > > to keep T7=1 seg
> > > > 
> > > > Why to use M2PA to deal with data recovery when in the IP 
> > > networks we
> > > > already have the means? Especially when SCTP was created 
> > > for that purpose.
> > > > It would need the involvement of more layers and the 
> > > mechanisms will be not
> > > > as efficient. We now have a RELIABLE transport layer under 
> > > "MTP2" and not a
> > > > wire as in the SS7 case... Many of changeovers and 
> > > rerouting can be avoided
> > > > improving the efficiency.
> > > > 
> > > > 
> > > > Cheers // Javier.
> > > > 
> > > > 
> > > > > -----Original Message-----
> > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > Sent: Wednesday, June 19, 2002 8:16 PM
> > > > > To: Javier Pastor-Balbas (ECE)
> > > > > Subject: Re: [Sigtran] M2PA Comment: Multi-homing
> > > > > 
> > > > > 
> > > > > Javier,
> > > > > 
> > > > > On Wed, 19 Jun 2002, Javier Pastor-Balbas (ECE) wrote:
> > > > > 
> > > > > > Brian,
> > > > > > 
> > > > > > do you mean that M2PA has a timer to detect message loss 
> > > > > whose value is less
> > > > > > than SCTP's T3?
> > > > > 
> > > > > T7.
> > > > > 
> > > > > --brian
> > > > > 
> > > > > > 
> > > > > > Cheers // Javier.
> > > > > > 
> > > > > > > -----Original Message-----
> > > > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > > > Sent: Wednesday, June 19, 2002 6:02 PM
> > > > > > > To: Javier Pastor-Balbas (ECE)
> > > > > > > Cc: [email-masked]
> > > > > > > Subject: Re: [Sigtran] M2PA Comment: Multi-homing
> > > > > > > 
> > > > > > > 
> > > > > > > Javier,
> > > > > > > 
> > > > > > > M2PA includes acknowledgments.
> > > > > > > 
> > > > > > > --brian
> > > > > > > 
> > > > > > > Javier Pastor-Balbas (ECE) wrote:                 
>          
> > > > > > > (Wed, 19 Jun 2002 17:17:21)
> > > > > > > > Hi Brian,
> > > > > > > > 
> > > > > > > > Are you taking into account that in this case MTP3 goes 
> > > > > > > over SCTP? How can
> > > > > > > > MTP3 detect a link failure if SCTP didn't do it before?
> > > > > > > > 
> > > > > > > > Cheers // Javier.
> > > > > > > > 
> > > > > > > > > -----Original Message-----
> > > > > > > > > From: Brian F. G. Bidulock 
> [mailto:[email-masked]]
> > > > > > > > > Sent: Wednesday, June 19, 2002 5:04 PM
> > > > > > > > > To: Javier Pastor-Balbas (ECE)
> > > > > > > > > Cc: [email-masked]
> > > > > > > > > Subject: Re: [Sigtran] M2PA Comment: Multi-homing
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > Javier,
> > > > > > > > > 
> > > > > > > > > I mean that MTP3 detects non-optimal routes 
> as fast, and
> > > > > > > > > in many cases faster, than SCTP.
> > > > > > > > > 
> > > > > > > > > --brian
> > > > > > > > > 
> > > > > > > > > Javier Pastor-Balbas (ECE) wrote:                 
> > >          
> > > > > > > > > (Wed, 19 Jun 2002 16:48:59)
> > > > > > > > > > Hi Brian, 
> > > > > > > > > > 
> > > > > > > > > > Do you mean that sending the message on a 
> > > non-optimal route 
> > > > > > > > > when SCTP
> > > > > > > > > > detects that a remote address does not work is 
> > > faster than 
> > > > > > > > > retransmiting
> > > > > > > > > > DATA towards the next remote IP address?
> > > > > > > > > > 
> > > > > > > > > > Cheers // Javier.
> > > > > > > > > > 
> > > > > > > > > > > -----Original Message-----
> > > > > > > > > > > From: Brian F. G. Bidulock 
> > > [mailto:[email-masked]]
> > > > > > > > > > > Sent: Wednesday, June 19, 2002 3:44 PM
> > > > > > > > > > > To: Javier Pastor-Balbas (ECE)
> > > > > > > > > > > Cc: [email-masked]'; 
> [email-masked];
> > > > > > > > > > > [email-masked]; [email-masked]
> > > > > > > > > > > Subject: Re: [Sigtran] M2PA Comment: Multi-homing
> > > > > > > > > > > 
> > > > > > > > > > > 
> > > > > > > > > > > Javier,
> > > > > > > > > > > 
> > > > > > > > > > > I highly doubt that SCTP with an Rto.Min of 1 
> > > second will 
> > > > > > > > > > > have anywhere
> > > > > > > > > > > near the performance of MTP3 in detecting 
> > > even remote NIC 
> > > > > > > > > > > failures.  MTP3
> > > > > > > > > > > will fail the link in 1 second whereas 
> SCTP will only 
> > > > > > > > > start its first
> > > > > > > > > > > retransmission in 1 second with an Rto.Min of 1 
> > > > > second in the 
> > > > > > > > > > > case of a
> > > > > > > > > > > remote NIC failure.  Any use of SCTP multihoming 
> > > > > for M2PA is 
> > > > > > > > > > > marginal at
> > > > > > > > > > > best, given the current recommended and 
> > > required protocol 
> > > > > > > > > > > parameters for SCTP.
> > > > > > > > > > > IMO it would be foolish to accent SCTP 
> > > mutlihoming in the 
> > > > > > > > > > > draft as it is
> > > > > > > > > > > rather useless for M2PA.  Because it is not 
> > > forbidden, 
> > > > > > > > > however, it is
> > > > > > > > > > > permitted.  We have arlready exchanged more 
> > > text that the 
> > > > > > > > > > > subject deserves.
> > > > > > > > > > > 
> > > > > > > > > > > --brian
> > > > > > > > > > > 
> > > > > > > > > > > 
> > > > > > > > > > > Javier Pastor-Balbas (ECE) wrote:                 
> > > > >          
> > > > > > > > > > > (Wed, 19 Jun 2002 10:08:33)
> > > > > > > > > > > > Hi,
> > > > > > > > > > > > 
> > > > > > > > > > > > Although the well-known MTP3 procedures such as 
> > > > > changeover, 
> > > > > > > > > > > changeback,
> > > > > > > > > > > > forced and controlled rerouting can give a 
> > > > > certain degree 
> > > > > > > > > > > of reliability I
> > > > > > > > > > > > would support to include the multihoming 
> > > host. Upon the 
> > > > > > > > > > > failure of a remote
> > > > > > > > > > > > NIC, it will be a faster procedure to change 
> > > > > the remote IP 
> > > > > > > > > > > address inside
> > > > > > > > > > > > the association that triggering the MTP3 
> > > procedures. 
> > > > > > > > > > > Multihoming hosts would
> > > > > > > > > > > > certainly improve the performance in those 
> > > cases. It 
> > > > > > > > > would be then a
> > > > > > > > > > > > desirable feature IMHO.
> > > > > > > > > > > > 
> > > > > > > > > > > > Cheers // Javier.
> > > > > > > > > > > > 
> > > > > > > > > > > 
> > > > > > > > > > > -- 
> > > > > > > > > > > Brian F. G. Bidulock
> > > > > > > > > > > [email-masked]
> > > > > > > > > > > http://www.openss7.org/
> > > > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > -- 
> > > > > > > > > Brian F. G. Bidulock
> > > > > > > > > [email-masked]
> > > > > > > > > http://www.openss7.org/
> > > > > > > > > 
> > > > > > > 
> > > > > > > -- 
> > > > > > > Brian F. G. Bidulock
> > > > > > > [email-masked]
> > > > > > > http://www.openss7.org/
> > > > > > > 
> > > > > 
> > > > > -- 
> > > > > Brian F. G. Bidulock    ¦ The reasonable man adapts 
> > > himself to the ¦
> > > > > [email-masked]    ¦ world; the unreasonable one 
> > > persists in  ¦
> > > > > http://www.openss7.org/ ¦ trying  to adapt the  world  to 
> > > himself. ¦
> > > > >                         ¦ Therefore  all  progress  
> > > depends on the ¦
> > > > >                         ¦ unreasonable man. -- George 
> > > Bernard Shaw ¦
> > > > > 
> > > 
> > > -- 
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > > 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 21 Jun 2002 03:43:34 -0500

Javier,

SLT procedure will still take the link out of service (Q.707/T1.111.7) at
MTP3 faster than SCTP's recommended protocol parameters.

--brian

Javier Pastor-Balbas (ECE) wrote:                          (Fri, 21 Jun 2002 10:10:08)
> which is in charge of flow control in the SS7 network. This is the timer I
> suppose you were referring to trigger the changeover based on link failure.
> (T7 = Timer "excessive delay of acknowledgement")
> 
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/