Subject: [Sigtran] M2PA Comment:Retrieval State

From: "Ming Lin" <[email-masked]>
Date: Tue, 18 Jun 2002 09:16:37 +0800

Hi all,

I lose tracking of m2pa for a long time, so I am not clear that why we need 'RETRIEVAL ' state 
in M2PA Link State Transition Diagram.
I think 'RETRIEVAL ' is same as 'OOS' state, 
the evens happening in RETRIEVAL state also could happen in OOS state.

And there is not this state in MTP2(Q.703).

Could somebody tell me why we need RETRIEVAL state in M2PA?

Thanks&Regards
Lin Ming

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Lisa Gorgone <[email-masked]>
Date: Wed, 19 Jun 2002 18:13:41 +0200

We agree with you: we couldn't understand the reason why a retrieval
state is needed.
Furthermore, we think that passing through this state can lead to a
delay in the subsequent alignment procedure. Following the flow chart on

pages 20-21 of the draft, one can see that if MTP3 sends a "Start"
rather
than triggering the retrieval procedure, M2PA moves to OOS state whit no

further actions. From there it needs again an MTP3 "Start" to begin the
alignment procedure.
We think that this behaviour should be avoided. When MTP3 sends a
"Start" the
alignment has to begin immediately.

Regards
Lisa & Aldo