Subject: RE: [Sigtran] M2PA Comment: T7 Timer

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 21 Jun 2002 19:21:24 +0200

Brian ,

Could you refer me to the point where consensus was reached? 

Wasn't SCTP's T3 responsible to retx the message when the delay of acknowledgement is too big? Why don't use a correct setting of SCTP variables to get it?

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Friday, June 21, 2002 7:15 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: Andrew Booth; [email-masked]
> Subject: Re: [Sigtran] M2PA Comment: T7 Timer
> 
> 
> Javier,
> 
> No. MTP uses T7 at to detect excessive delay of acknowledgement.
> There is no common equivalent in SCTP.  The use of lifetimes was
> considered, however, as lifetimes are implementation dependent
> and not a requirement part of an SCTP implementation, the M2PA
> protocol needs to address this in a consistent fashion.
> 
> The use of additional timers in M2PA was discussed and agreed on
> the list.  I refer you to the previous threads on this matter.
> It might also help you understand the function of these additional
> timers if you look at draft-bidulock-sigtran-m2pa-test-01.txt
> 
> --brian
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Fri, 21 Jun 2002 19:06:59)
> > Hi Brian ,
> > 
> > Would it be more consistent to use the transport layer for 
> these issues in
> > the IP network? 
> > 
> > MTP2 uses T7 to get reliability because it is only the wire 
> what is below...
> > We should adapt it to the IP architecture. 
> > 
> > I don't see any reasons to have T7 in M2PA if we use SCTP.
> > 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 21 Jun 2002 13:15:47 -0500

Javier,

MTP3 expects a fixed maximum delay of acknowledgement from
MTP to MTP.  T3-rtx can increase almost unbounded.  Settings
of SCTP protocol parameters to yeild 0.5 - 2.0 seconds max
delay of acknowledgement are not recommneded.  M2PA and MTP3
include what some might refer to as application level acks.
These are above SCTP.  MTP3 and MTP2 have more stringent
requirements than SCTP can provide for.  This is neither
strange nor peculiar.  iSCSI for example, has application
level timers above the transport layer (even SCTP) which may
be far smaller than T3-rtx as dictated by RTO.Min.

--brian

Javier Pastor-Balbas (ECE) wrote:                          (Fri, 21 Jun 2002 19:21:24)
> Wasn't SCTP's T3 responsible to retx the message when the delay of
> acknowledgement is too big? Why don't use a correct setting of SCTP
> variables to get it?
> 
> Cheers // Javier.
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/