Subject: RE: [Sigtran] Re: Doubt of M3UA SCON message

From: "Wung, Joseph" <[email-masked]>
Date: Thu, 6 Jun 2002 09:28:32 -0400

1) How would the ASP in this case detect congestion that was casued by
   messages sent from a distant PC?  Shouldn't the congestion in this
   direction be detected by the SGP instead?

2) If the SGP is to send TFC in this case, can the STP it connects to be
able
   to handle the TFC from a non-STP node?  In SS7, TFC always originates
from
   the STP, so the STP does not expect TFC coming from a non-STP node.

Joe

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, June 06, 2002 12:00 AM
To: fangjishang
Cc: [email-masked]
Subject: [Sigtran] Re: Doubt of M3UA SCON message

fangjishang,

On Thu, 06 Jun 2002, fangjishang wrote:

> 
>    Dear Brian,
>    
>      I have a doubt in implementing the SCON message at ASP side.
>    
>      According to description in draft12, we have to fill Concerned DPC
>    field and Affected DPCs when we send SCON from ASP to SGP.
>    
>    Pls refer the case as shown in the diagram below,
>    
>                                                    AS1 : Signalling PC =
>    1
>                                                  _______
>                                  |--------------|       |
>        |-----|                   |              | ASP1  |
>        | SGP |-------------------|              |_______|
>        |-----|                   |              ________
>                                  |             |        |
>                                  |_____________|   ASP1 |
>                                                |________|
>                                                    AS2 : Signalling PC =
>    2
>    
>    When the ASP1 is congested, we should send SCON from ASP1 to SGP. My
>    doubt is:
>    <1>If ASP1 is operating in 2 diff AS (say AS1 and AS2), what should we
>    fill in "affected DPC list" and "Concerned DPC" parameter ? As per my
>    understanding, Affected DPC is 1 and 2(OPCs of AS1 & AS2). Concerned
>    DPC is either 1 or 2. Is it correct ? If this is so, what is the need
>    of "Concerned DPC" in SCON message ?

No, Concerned PC is the distant PC in the SS7 network which sent a
message that caused the congestion.

>    
>    <2> If SGP receives the SCON from ASP, what is the action to be taken
>    related to Concerned DPC ? what is the significance of "Concerned DPC"
>    in SCON sent from ASP to SGP ?

The SG might want to send TFC to the Concerned PC (DPC) with the
Affected PC as the OPC.  But that is implementation dependent.

--brian

>    Thanks and regards.
>    -Jesy

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 6 Jun 2002 09:52:38 -0400

Joe,

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Wung, Joseph
> Sent: Thursday, June 06, 2002 9:29 AM
> To: [email-masked]; fangjishang
> Cc: [email-masked]
> Subject: RE: [Sigtran] Re: Doubt of M3UA SCON message
>
>
[TOLGA] I think this point is discussible. Is congestion of ASP level3
congestion or just user part congestion? For user part congestion, as far as
I can remember, no procedures are defined.
>    the STP, so the STP does not expect TFC coming from a non-STP node.
[TOLGA] SGP can work in STP mode or SEP mode. And again as far as I
remember, even if it is seen as SEP, for ANSI96 TFC can be generated for
signalling point congestion. But as I indicated above, whether congestion of
ASP should be interpreted as signalling point congestion or not is another
issue.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Jun 2002 11:21:59 -0500

Joseph,

Wung, Joseph wrote:                                         (Thu, 06 Jun 2002 09:28:32)
>    direction be detected by the SGP instead?

The ASP knows the point codes of nodes from which it is receiving
messages.

>    able to handle the TFC from a non-STP node?  In SS7, TFC always
>    originates from the STP, so the STP does not expect TFC coming from a
>    non-STP node.

The standards (particularly ANSI) permit SEPs to send TFC.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/