Subject: RE: [Sigtran] IPSP: SE vs DE

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Mon, 3 Jun 2002 17:52:07 +0200

Brian, 

Wrong concept. My AS can talk with a SG and ALSO with another AS. The communication will be faster since the processing is half or even less.

What is the advantage of AS-SG-(SG)-AS regarding AS-AS ?? Please list them.

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Monday, June 03, 2002 5:14 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: [email-masked]'
> Subject: Re: [Sigtran] IPSP: SE vs DE
> 
> 
> Javier,
> 
> Your IPSP will not work with an SG and therefore
> makes no sense.
> 
> I still propose that IPSP be removed altogether as SG-SG
> communication is an better, easier and obvious replacement.
> 
> --brian
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Mon, 03 Jun 2002 16:58:54)
> > Hi Brian, 
> > 
> > IPSP will avoid the use of SG and therefore it makes sense.
> > 
> > Cheers // Javier.
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Monday, June 03, 2002 4:48 PM
> > > To: Javier Pastor-Balbas (ECE)
> > > Cc: [email-masked]'
> > > Subject: Re: [Sigtran] IPSP: SE vs DE
> > > 
> > > 
> > > Javier,
> > > 
> > > As SE was clearly agreed as possible using an SG to transfer and
> > > not requiring any new protocol or state machine description, I
> > > propose that IPSP be removed from the RFC altogether.  I also
> > > propose that the SG-SG be used to properly address peer-to-peer
> > > communication.
> > > 
> > > --brian
> > > 
> > > Javier Pastor-Balbas (ECE) wrote:                          
> > > (Mon, 03 Jun 2002 16:24:07)
> > > > Hi guys, 
> > > > 
> > > > I propose to move forward. Most of the folks that are now
> > > > active seem to prefer the SE. Then, I propose to remove the DE
> > > > exchange from the current RFC and leave only SE. Anyone
> > > > against?
> > > > 
> > > > 
> > > > Cheers // Javier.
> > > > 
> > > > 
> > > > 
> > > > 
> > > > 
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > > -- 
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 3 Jun 2002 11:23:08 -0500

Javier,

That's rather peculiar as you said that IPSP to SGP communication
was complex and unnecessary....

Which is it?

--brian

Javier Pastor-Balbas (ECE) wrote:                          (Mon, 03 Jun 2002 17:52:07)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 3 Jun 2002 14:02:30 -0400

My opinion is:

First of all thinking that AS talks to SG is equivalent to say that a web
browser talks to a router, instead of a web server. It is ASP-M3UA, which
talks to SGP-M3UA. I think saying like this fits more to a layered approach,
otherwise for any communication at any level we can say AS is talking to SG.
In the context of M3UA stack, ASP corresponds to a physical endpoint whereas
AS is only a traffic range. So, for example, ASPUP is not sent from AS to SG
but from ASP-M3UA to SGP-M3UA (for example similarly if INAP logic in a SSP
sends an INAP message to a SCP, the corresponding MSUs will possibly pass
through some STPs. Does this mean that SSP talks to those STPs?). An AS is a
logical HLR, SCP etc... so its peer will be again a corresponding entity, in
IP domain or in SS7 domain.

Advantages of using SG-SG communication:
========================================
1- Has relaying functionality
2- Allows smooth interaction with SS7 network
3- For PC granularity, user application might run directly on top of SGPF
(of course with NIF)
4- Does not require separate state machines and separate logics for peers in
SS7 domain and in IP domain

Advantages of SE IPSP
======================
1- Will provide direct symmetric communication for sub-PC granularity.

Let's try to complete those two lists. What else could be added to them?

 Tolga

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Javier Pastor-Balbas (ECE)
> Sent: Monday, June 03, 2002 11:52 AM
> To: [email-masked]'; Javier Pastor-Balbas (ECE)
> Cc: [email-masked]'
> Subject: RE: [Sigtran] IPSP: SE vs DE
>
>
> Brian,
>
> Wrong concept. My AS can talk with a SG and ALSO with another AS.
> The communication will be faster since the processing is half or
> even less.
>

---

From: "reshma" <[email-masked]>
Date: Tue, 4 Jun 2002 20:30:50 +0530

Hi Tolga ,

> Advantages of using SG-SG communication:

[Reshma] What if SI/CIC granularity is needed..?
As per your latest discusssion you introduced ASPSM and ASPTM messages,then
i think you need to have Statemachine also.Dont we?

THanks,
reshma

mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 4 Jun 2002 11:14:41 -0400

Reshma,

> From: reshma [mailto:[email-masked]]
> Sent: Tuesday, June 04, 2002 11:01 AM
> To: Tolga Asveren; [email-masked]
> > 4- Does not require separate state machines and separate logics
> for peers
> in
[TOLGA] I don't say one can use sub-PC granularity between SGs. ASPUP/ASPAC
are just introduced to make the peer SG aware of the readiness of M3UA layer
(in case of ASPUP) and TAL is replaced with ASPAC.