Subject: RE: [Sigtran] m3ua: IG : n+k redundancy - AS state machine

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 28 Jun 2002 12:01:34 +0200

Hi Tolga, 

This is the last rework. Hope this time you like it  :-)
It is the new text for section 4.3.2

----\/----

AS-DOWN: The Application Server is unavailable.  This state implies that the number of ASPs being in ASP-INACTIVE or ASP-DOWN is less than "n". Initially the AS will be in this state. An Application Server is in the AS-DOWN state when it is removed from a configuration.

AS-INACTIVE: The Application Server is available but no application traffic is active. This implies that there are at least n ASPs in either ASP-INACTIVE or ASP-ACTIVE but the total number of ASPs in ASP-ACTIVE state has not reach n.  The recovery timer T(r) is not running or has expired. 

AS-ACTIVE: The Application Server is available and application traffic is active.  This state implies that at least n ASPs are in the ASP-ACTIVE state.

AS-PENDING: An active ASP has transitioned from ASP-ACTIVE to ASP-INACTIVE or ASP-DOWN and it was the number n active ASP in the AS.  A recovery timer T(r) SHOULD be started and all incoming signalling messages SHOULD be queued by the SGP. If an ASP becomes ASP-ACTIVE before T(r) expires, the AS is moved to the AS-ACTIVE state and all the queued messages will be sent to the ASP. 

If T(r) expires before an ASP becomes ASP-ACTIVE, and the SGP has no alternative, the SGP may stops queuing messages and discards all previously queued messages. The AS will move to the AS-INACTIVE state if at least the number of ASPs in either ASP-INACTIVE or ASP-ACTIVE sum n, otherwise it will move to AS-DOWN state. 

Figure 5 shows an example AS state machine for the case where the AS/ASP data is preconfigured and a n+k redundancy model.  the AS/ASP configuration data iFor other cases where s created dynamically, there would be differences in the state machine, especially at creation of the AS. All the transitions are labeled and the explanations below the figure.  

             Figure 5: AS State Transition Diagram

     +----------+          IA2AC              +-------------+
     |    AS-   |---------------------------->|     AS-     |
     | INACTIVE |                             |   ACTIVE    |
     |          |<-----------                 |             |
     +----------+            \                +-------------+
        ^   |                 \                   ^    |
        |   | IA2DN            \ PN2IA            |    | AC2PN
        |   |                   \                 |    | 
  DN2IA |   |                    \          PN2AC |    | 
        |   v                     \               |    v
     +----------+                  \          +-------------+
     |          |                   ----------|             |
     | AS-DOWN  |                             | AS-PENDING  |
     |          |                  PN2DN      |  (queueing) |
     |          |<----------------------------|             |
     +----------+                             +-------------+

DN2IA: One ASP moves to ASP-INACTIVE causing that n ASPs are in either ASP-ACTIVE or ASP-INACTIVE states.

IA2DN: One ASP moves to ASP-DOWN causing that the number of ASPs in either ASP-ACTIVE or ASP-INACTIVE drops below n.

IA2AC: one ASP moves to ASP-ACTIVE, causing number of ASPs in the ASP-ACTIVE state to be n.

AC2PN: one ASP in ASP-ACTIVE state moves to ASP-INACTIVE or ASP-DOWN states, causing the number of ASPs in ASP-ACTIVE drop below n.

PN2AC: One ASP moves to ASP-ACTIVE causing the number of ASPs in the ASP-ACTIVE state to be n.

PN2IA: Tr Expiry, n or more ASPs are in either ASP-INACTIVE or ASP-ACTIVE state and number of ASPs in ASP-ACTIVE state is less than n.

PN2DN: Tr Expiry, the number of ASPs in either ASP-INACTIVE or ASP-ACTIVE state is less than n.

----/\----

Cheers // Javier.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 28 Jun 2002 10:32:34 -0400

Javier,

It is fine with me.

  Tolga

> -----Original Message-----
> From: Javier Pastor-Balbas (ECE)
> [mailto:[email-masked]]
> Sent: Friday, June 28, 2002 6:02 AM
> To: 'Tolga Asveren'; [email-masked]'
> Subject: RE: [Sigtran] m3ua: IG : n+k redundancy - AS state machine
> 
> 
> Hi Tolga, 
> 
> AS-DOWN: The Application Server is unavailable.  This state 
> implies that the number of ASPs being in ASP-INACTIVE or ASP-DOWN 
> is less than "n". Initially the AS will be in this state. An 
> Application Server is in the AS-DOWN state when it is removed 
> from a configuration.
> 
> AS-INACTIVE: The Application Server is available but no 
> application traffic is active. This implies that there are at 
> least n ASPs in either ASP-INACTIVE or ASP-ACTIVE but the total 
> number of ASPs in ASP-ACTIVE state has not reach n.  The recovery 
> timer T(r) is not running or has expired. 
> 
> AS-ACTIVE: The Application Server is available and application 
> traffic is active.  This state implies that at least n ASPs are 
> in the ASP-ACTIVE state.
> 
> AS-PENDING: An active ASP has transitioned from ASP-ACTIVE to 
> ASP-INACTIVE or ASP-DOWN and it was the number n active ASP in 
> the AS.  A recovery timer T(r) SHOULD be started and all incoming 
> signalling messages SHOULD be queued by the SGP. If an ASP 
> becomes ASP-ACTIVE before T(r) expires, the AS is moved to the 
> AS-ACTIVE state and all the queued messages will be sent to the ASP. 
> 
> If T(r) expires before an ASP becomes ASP-ACTIVE, and the SGP has 
> no alternative, the SGP may stops queuing messages and discards 
> all previously queued messages. The AS will move to the 
> AS-INACTIVE state if at least the number of ASPs in either 
> ASP-INACTIVE or ASP-ACTIVE sum n, otherwise it will move to 
> AS-DOWN state. 
> 
> Figure 5 shows an example AS state machine for the case where the 
> AS/ASP data is preconfigured and a n+k redundancy model.  the 
> AS/ASP configuration data iFor other cases where s created 
> dynamically, there would be differences in the state machine, 
> especially at creation of the AS. All the transitions are labeled 
> and the explanations below the figure.  
> 
> 
> 
> DN2IA: One ASP moves to ASP-INACTIVE causing that n ASPs are in 
> either ASP-ACTIVE or ASP-INACTIVE states.
> 
> IA2DN: One ASP moves to ASP-DOWN causing that the number of ASPs 
> in either ASP-ACTIVE or ASP-INACTIVE drops below n.
> 
> AC2PN: one ASP in ASP-ACTIVE state moves to ASP-INACTIVE or 
> ASP-DOWN states, causing the number of ASPs in ASP-ACTIVE drop below n.
> 
> PN2IA: Tr Expiry, n or more ASPs are in either ASP-INACTIVE or 
> ASP-ACTIVE state and number of ASPs in ASP-ACTIVE state is less than n.
>