Subject: RE: [Sigtran] IPSP: SE vs DE

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 5 Jun 2002 09:45:18 +0200

Brian, 

Let's be constructive.

How can an SS7 application over IP communicates with another application and at the same time with a SG? Please, explain your model. The one the WG is using is:

      AS1                     AS2
    +------+   IPSP Comm.   +------+
    |IPSP1 |================|IPSP2 |
    |ASP1  |                | ASP2 |
    +--+---+                +--+---+
       |                       |
       | AS-SG comm.           |
       |                       | AS-SG comm.
       |                       | 
       |        +------+       |
       |        | SGP1 |       |
       +--------+      +-------+
                +------+
                   || SG
                   ||
                   \/
                  To SS7

Questions:

1. What are the problems that you find in this model ?
2. What is your own equivalent model to solve those problems.? 
3. How does your model solve them?

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Tuesday, June 04, 2002 8:08 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: 'Tolga Asveren'; [email-masked]
> Subject: Re: [Sigtran] IPSP: SE vs DE
> 
> 
> Javier,
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Tue, 04 Jun 2002 15:51:39)
> > Hi Tolga, 
> > 
> > See my comments below...
> > 
> > > -----Original Message-----
> > > From: Tolga Asveren [mailto:[email-masked]]
> > > Sent: Tuesday, June 04, 2002 3:16 PM
> > > To: [email-masked]
> > > Subject: RE: [Sigtran] IPSP: SE vs DE
> > > 
> > > 
> > > Hi Javier,
> > > 
> > > I agree that they are not exactly compareable but if I have 
> > > to choose one,
> > > without hesitation, I would choose SG-SG. Some more comments 
> > > to the items
> > > you added to the list are below.
> > > 
> > >   Tolga
> > > 
> > > > -----Original Message-----
> > > > From: Javier Pastor-Balbas (ECE)
> > > > [mailto:[email-masked]]
> > > > Sent: Tuesday, June 04, 2002 2:40 AM
> > > > To: 'Tolga Asveren'; [email-masked]
> > > > Subject: RE: [Sigtran] IPSP: SE vs DE
> > > >
> > > >
> > > > Hi Tolga,
> > > >
> > > > These two methods are not comparable. They simply do different
> > > > things. But for sure that if I have to choose one, I'll go for
> > > > the current RFC with the IPSP. The reasons are in the 
> list below.
> > > >
> > > > Let's complete the table... (see below)
> > > >
> > > > > -----Original Message-----
> > > > > From: Tolga Asveren [mailto:[email-masked]]
> > > > > Sent: Monday, June 03, 2002 8:03 PM
> > > > > To: [email-masked]
> > > > > Subject: RE: [Sigtran] IPSP: SE vs DE
> > > > >
> > > > >
> > > > > My opinion is:
> > > > >
> > > > > First of all thinking that AS talks to SG is equivalent to
> > > > > say that a web
> > > > > browser talks to a router, instead of a web server. It is
> > > > > ASP-M3UA, which
> > > > > talks to SGP-M3UA. I think saying like this fits more to a
> > > > > layered approach,
> > > > > otherwise for any communication at any level we can say AS is
> > > > > talking to SG.
> > > > > In the context of M3UA stack, ASP corresponds to a physical
> > > > > endpoint whereas
> > > > > AS is only a traffic range. So, for example, ASPUP is not
> > > > > sent from AS to SG
> > > > > but from ASP-M3UA to SGP-M3UA (for example similarly if INAP
> > > > > logic in a SSP
> > > > > sends an INAP message to a SCP, the corresponding MSUs will
> > > > > possibly pass
> > > > > through some STPs. Does this mean that SSP talks to those
> > > > > STPs?). An AS is a
> > > > > logical HLR, SCP etc... so its peer will be again a
> > > > > corresponding entity, in
> > > > > IP domain or in SS7 domain.
> > > > >
> > > > > Advantages of using SG-SG communication:
> > > > > ========================================
> > > > > 1- Has relaying functionality
> > > > > 2- Allows smooth interaction with SS7 network
> > > > > 3- For PC granularity, user application might run directly on
> > > > > top of SGPF
> > > > > (of course with NIF)
> > > > > 4- Does not require separate state machines and separate
> > > > > logics for peers in
> > > > > SS7 domain and in IP domain
> > > > >
> > > > >
> > > > > Advantages of SE IPSP
> > > > > ======================
> > > > >
> > > > > 1- Will provide direct symmetric communication for sub-PC 
> > > granularity.
> > > >
> > > > Let me add a few more:
> > > >
> > > > 2- Will provide direct symmetric communication for PC 
> granularity
> > > [TOLGA] SG-SG provides this
> > 
> > But you need SG: 
> > - More expensive
> > - Processing time increased
> 
> You do not need SG, just SGPF.
>   - less expensive.
>   - processing time reduced.
> 
> > 
> > > > 3- Will provide direct symmetric communication for supra-PC 
> > > granularity
> > > > 4- No more messages needed
> > > [TOLGA] For intra-IP case, also for SG-SG no more messages needed.
> > 
> > But you need SG: 
> > - More expensive
> > - Processing time increased
> 
> You do not need SG, just SGPF.
>   - less expensive.
>   - processing time reduced.
> 
> > 
> > > > 5- No more working items needed
> > > [TOLGA] We still need to discuss about SE IPSP. Till now, 
> all of the
> > > discussion was focused on DE approach.
> > > > 6- No more standard process needed
> > > [TOLGA] ?
> > 
> > See RFC 2026
> > 
> > > > 7- Use of SG not needed to communicate two SS7 applications in
> > > > the IP domain
> > > [TOLGA] For PC granularity also not needed for SG-SG case. Or 
> > > better said,
> > > one just need SG (which I think now we are interpreting more 
> > > as IP-STP)
> > 
> > If you use SG: 
> > - More expensive
> > - Processing time increased
> 
> You do not need SG, just SGPF.
>   - less expensive.
>   - processing time reduced.
> 
> > You don't need to introduce this delay. Using IPSP 
> communication between ASes, is direct and it will avoid 
> unnecessary delays and intermediate nodes...
> > 
> > > > 8- Relaying function not needed in IP domain: we have routers
> > > [TOLGA] It is needed for a reasonable configuration if one 
> > > goes to sub-PC
> > > granularity. Do we have routers working based on CIC ranges? 
> > 
> > What reasonable configuration needs it? 
> > 
> > > What about for
> > > multiple operators case? And if sub-PC grabularity is not 
> > > needed, then IPSP
> > > also does not have any meaning. Because for PC granularity 
> > > SG-SG provides
> > > everything IPSP can provide and more.
> > 
> > Using SG-SG you need more nodes 
> > - More expensive
> > - Processing time increased
> 
> You do not need SG, just SGPF.
>   - less expensive.
>   - processing time reduced.
> 
> --brian
> 
> > 
> > Less quality but more expensive
> > 
> > > > 9- Allow an step forward moving from MTP2 to IP protocol to
> > > > transport SS7 signaling
> > > [TOLGA] That is in fact what SG-SG does
> > 
> > You don't need to introduce more nodes in addition to the 
> SS7 application talking one to each other using M3UA.
> > 
> > > > 10- The future network without SS7 domain
> > > [TOLGA] SG-SG also provides this and additionaly also 
> > > provides easy SS7
> > > communciation for the transition period, which most probably 
> > > won't be very
> > > short. In fact, although I don't like it, what I see is, 
> > > people want to use
> > > SIGTRAN
> > > a) either to get a remote SS7 interface for their IP-SCPs, 
> > > Softswitches
> > > etc...
> > > b) or to backhaul between two SS7 nodes over IP
> > 
> > Take a look to standardization fora for the third generation. 
> > 
> > > > 11- The first network small operators could make (SS7 is 
> > > more expensive)
> > > [TOLGA] Why do you think for SG-SG SS7 is necessary? We have 
> > > said several
> > > times, SG should be interpreted as IP-STP. SS7 interface is 
> > > only necessary,
> > > if one want to communicate with nodes in SS7 domain.
> > 
> > Read the definition for SG. IP-STP is not an SG in the same 
> way that SG is not necessary an SS7 STP. IP-STPs are just 
> IP-STPs. Another different thing is that you want to include 
> IP-STP functionality inside the same node as the SG. SG is 
> not necessary an SS7-STP either. Do I need to substitute 
> IP-STP in every place you put SG?  :-/
> > 
> > Direct communication is always cheaper and faster when possible.
> > 
> > Cheers // Javier.
> > 
> > 
> > 
> > > >
> > > >
> > > >
> > > > Cheers // Javier.
> > > >
> > > >
> > > > >
> > > > > Let's try to complete those two lists. What else could be
> > > > > added to them?
> > > > >
> > > > >  Tolga
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: [email-masked]
> > > > > [mailto:[email-masked]]On Behalf Of
> > > > > > Javier Pastor-Balbas (ECE)
> > > > > > Sent: Monday, June 03, 2002 11:52 AM
> > > > > > To: [email-masked]'; Javier Pastor-Balbas (ECE)
> > > > > > Cc: [email-masked]'
> > > > > > Subject: RE: [Sigtran] IPSP: SE vs DE
> > > > > >
> > > > > >
> > > > > > Brian,
> > > > > >
> > > > > > Wrong concept. My AS can talk with a SG and ALSO with 
> > > another AS.
> > > > > > The communication will be faster since the 
> processing is half or
> > > > > > even less.
> > > > > >
> > > > > > What is the advantage of AS-SG-(SG)-AS regarding 
> AS-AS ?? Please
> > > > > > list them.
> > > > > >
> > > > > > Cheers // Javier.
> > > > > >
> > > > > > > -----Original Message-----
> > > > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > > > Sent: Monday, June 03, 2002 5:14 PM
> > > > > > > To: Javier Pastor-Balbas (ECE)
> > > > > > > Cc: [email-masked]'
> > > > > > > Subject: Re: [Sigtran] IPSP: SE vs DE
> > > > > > >
> > > > > > >
> > > > > > > Javier,
> > > > > > >
> > > > > > > Your IPSP will not work with an SG and therefore
> > > > > > > makes no sense.
> > > > > > >
> > > > > > > I still propose that IPSP be removed altogether as SG-SG
> > > > > > > communication is an better, easier and obvious 
> replacement.
> > > > > > >
> > > > > > > --brian
> > > > > > >
> > > > > > > Javier Pastor-Balbas (ECE) wrote:
> > > > > > > (Mon, 03 Jun 2002 16:58:54)
> > > > > > > > Hi Brian,
> > > > > > > >
> > > > > > > > IPSP will avoid the use of SG and therefore it 
> makes sense.
> > > > > > > >
> > > > > > > > Cheers // Javier.
> > > > > > > >
> > > > > > > > > -----Original Message-----
> > > > > > > > > From: Brian F. G. Bidulock 
> [mailto:[email-masked]]
> > > > > > > > > Sent: Monday, June 03, 2002 4:48 PM
> > > > > > > > > To: Javier Pastor-Balbas (ECE)
> > > > > > > > > Cc: [email-masked]'
> > > > > > > > > Subject: Re: [Sigtran] IPSP: SE vs DE
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > Javier,
> > > > > > > > >
> > > > > > > > > As SE was clearly agreed as possible using an SG to
> > > > > transfer and
> > > > > > > > > not requiring any new protocol or state machine 
> > > description, I
> > > > > > > > > propose that IPSP be removed from the RFC 
> > > altogether.  I also
> > > > > > > > > propose that the SG-SG be used to properly address
> > > > > peer-to-peer
> > > > > > > > > communication.
> > > > > > > > >
> > > > > > > > > --brian
> > > > > > > > >
> > > > > > > > > Javier Pastor-Balbas (ECE) wrote:
> > > > > > > > > (Mon, 03 Jun 2002 16:24:07)
> > > > > > > > > > Hi guys,
> > > > > > > > > >
> > > > > > > > > > I propose to move forward. Most of the folks 
> > > that are now
> > > > > > > > > > active seem to prefer the SE. Then, I propose to
> > > > > remove the DE
> > > > > > > > > > exchange from the current RFC and leave 
> only SE. Anyone
> > > > > > > > > > against?
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > Cheers // Javier.
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > _______________________________________________
> > > > > > > > > > Sigtran mailing list
> > > > > > > > > > [email-masked]
> > > > > > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > > > > >
> > > > > > > > > --
> > > > > > > > > Brian F. G. Bidulock
> > > > > > > > > [email-masked]
> > > > > > > > > http://www.openss7.org/
> > > > > > > > >
> > > > > > > >
> > > > > > > > _______________________________________________
> > > > > > > > Sigtran mailing list
> > > > > > > > [email-masked]
> > > > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > > >
> > > > > > > --
> > > > > > > Brian F. G. Bidulock
> > > > > > > [email-masked]
> > > > > > > http://www.openss7.org/
> > > > > > >
> > > > > >
> > > > > > _______________________________________________
> > > > > > Sigtran mailing list
> > > > > > [email-masked]
> > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > >
> > > > >
> > > > > _______________________________________________
> > > > > Sigtran mailing list
> > > > > [email-masked]
> > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > >
> > > 
> > > 
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 5 Jun 2002 03:44:52 -0500

Javier,

I explained the model in a previous note, but you rather
ignored it.  Here it is again:

       _______           _______
      |       |         |       |
      | SGPF  |<------->|  SGPF |
      |_______|         |_______|

Simple.

If you want to put ASPF in the same box as SGPF you can do
this (but it is implementation dependent).

       _______           _______
      |       |         |       |
      | ASPF  |         |  ASPF |
      |_______|         |_______|
      |       |         |       |
      | SGPF  |<------->|  SGPF |
      |_______|         |_______|

No criss-cross.  This is SE IPSP without criss-cross.

If you want to do this, you can:

       _______           _______
      |       |         |       |
      |  ASP  |         |  ASP  |
      |_______|         |_______|
          ^                 ^
          |                 |
       ___v___           ___v___
      |       |         |       |
      | SGPF  |<------->|  SGPF |
      |_______|         |_______|

But all that is required to do any of this in a simple
and straightforward manner is describe this:

       _______           _______
      |       |         |       |
      | SGPF  |<------->|  SGPF |
      |_______|         |_______|

--brian

Javier Pastor-Balbas (ECE) wrote:                          (Wed, 05 Jun 2002 09:45:18)
> Brian, 
> 
> Let's be constructive.
> 
> How can an SS7 application over IP communicates with another application and
> at the same time with a SG? Please, explain your model. The one the WG is
> using is:
> 
> 
>       AS1                     AS2

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "reshma" <[email-masked]>
Date: Wed, 5 Jun 2002 14:32:59 +0530

Hi Brian,

    Comments below..

> ignored it.  Here it is again:

[Reshma] This indicates that 2 ASPs are talking through SGP :-(  
Is it not so..? Is SGPF equivalent to SGP or not..?

THanks,
reshma

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 5 Jun 2002 04:14:41 -0500

reshma,

reshma wrote:                                              (Wed, 05 Jun 2002 14:32:59)
> Is it not so..? Is SGPF equivalent to SGP or not..?

Yes, you could do this if you want, but you don't have to.
Draw it like this if you like:

        _______           _______
       |       |         |       |
       |  ASP  |         |  ASP  |
       |_______|         |_______|
           ^                 ^
           |                 |
        ___v___           ___v___
       |       |         |       |
       |  SGP  |<------->|  SGP  |
       |_______|         |_______|

You could even do this:

   _______     _______           _______
  |       |   |       |         |       |
  |  ASP  |   | ASPF  |         |  ASPF |
  |_______|   |_______|         |_______|
      ^       |       |         |       |
      +------>| SGPF  |<------->|  SGPF |
              |_______|         |_______|

It doesn't matter.  It is the SG-SG communication (per RFC
2719) that makes this possible.

But this is repeitious.  Tolga diagrammed this in the SG-SG
draft.  ASPF above is a non-protocol function and does not
need to be specified.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "reshma" <[email-masked]>
Date: Wed, 5 Jun 2002 15:00:01 +0530

Hi Brian,

    Thanks a lot for the reply.
Some more doubts...

> Draw it like this if you like:

[Reshma] Just to clarify .As per the M3ua draft SGP only receives and Acks
ASPTM/ASPSM messages but the SGP(SGPF) you say here must be capable of
sending
ASPTM/ASPSM also .right?

Thanks,
Reshma

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 5 Jun 2002 04:51:19 -0500

reshma,

reshma wrote:                                              (Wed, 05 Jun 2002 15:00:01)
> sending ASPTM/ASPSM also .right?

Which would you prefer?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "reshma" <[email-masked]>
Date: Wed, 5 Jun 2002 15:36:34 +0530

Hi Brian,

 Some more doubts...

> > sending ASPTM/ASPSM also .right?

[Reshma] If it has to work for IPSP-IPSP then it must be able to send
ASPTM/ASPSM
also.But then the name SGPF is misleading.What i understand from SGPF is
signalling
gateway process functionality which does not include the above mentioned
part.(sending
ASPTM/ASPSM messages).

Thanks,
Reshma

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 5 Jun 2002 08:33:22 -0500

reshma,

reshma wrote:                                              (Wed, 05 Jun 2002 15:36:34)
> ASPTM/ASPSM also.

Why?

> But then the name SGPF is misleading.

I don't think so.

> What i understand from SGPF is signalling gateway process functionality
> which does not include the above mentioned part.  (sending ASPTM/ASPSM
> messages).

It is possible to add some functionality to SGPF over ASP/SGP to
acheive SG-SG communication.  The current draft deos not use ASPTM/ASPSM
at all.  However, it is possible to reuse some messages to avoid adding
new ones.

Which would you prefer?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "reshma" <[email-masked]>
Date: Wed, 5 Jun 2002 19:30:11 +0530

Hi Brian,

    comments below..

> > > > [Reshma] Just to clarify .As per the M3ua draft SGP only receives
and
> > Acks

[Reshma] B'coz you said SG-SG supports IPSP-IPSP SE approach which means
it should be able to send ASPTM/ASPSM also.
    And also in the recent discussions you and Tolga discussed and said we
will change
TAL message back to ASPTM/ASPSM message .Is it not so?

> > But then the name SGPF is misleading.

[Reshma] If   SG-SG supports ASPTM/ASPSM  then it is else it is not.

> at all.  However, it is possible to reuse some messages to avoid adding

[Reshma] The only reason i prefer TAL is , there is no need for Statemachine
at all
coz there is no ASPTM/ASPSM  messages.
Also when there is no granularity required less than PC then ASPTM messages
are meaningless.Just ASPSMwill do.I feel the necesity of ASPTM messages
are only when there are multiple ASPs serving an AS.

Thanks,
reshma

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 5 Jun 2002 10:13:37 -0500

reshma,

reshma wrote:                                    (Wed, 05 Jun 2002 19:30:11)
> are only when there are multiple ASPs serving an AS.

I think it would be possible to reuse the ASP messages without the
need for any more state machine over the TAL approach.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "reshma" <[email-masked]>
Date: Thu, 6 Jun 2002 18:41:40 +0530

Hi Brian,

    Doubts below..

> need for any more state machine over the TAL approach.

[Reshma] If TAL is not used then the there must be chnges made to the
statemachine.
B'coz when u support ASP*M messages if  the ASP is in down state and if it
receives
ASPUP/ASPUP ACK it has to move to Inactive state whereas in usual
statemachine
the state changes only when ASPUUP is received.Or am i missing something?

Thanks,
reshma

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 6 Jun 2002 09:23:53 -0400

Reshma,

My opinion on this is below.

  Tolga

> From: reshma [mailto:[email-masked]]
> Sent: Thursday, June 06, 2002 9:12 AM
> To: [email-masked]
> Cc: Javier Pastor-Balbas (ECE); 'Tolga Asveren'; [email-masked]
[TOLGA] I don't interprete it exactly like this. In my opinion, it is better
to think ASPUP/ASPAC as something showing that the remote peer is totally
ready (ASPUP= M3UA is ready, ASPAC=SSNM announcement for
unavailable/restricted PCs is finished). Because there is no concept of RK,
there is no AS state machine necessary for SG-SG.

---

From: "reshma" <[email-masked]>
Date: Thu, 6 Jun 2002 19:02:37 +0530

Hi Tolga,

> there is no AS state machine necessary for SG-SG.

[Reshma] Okay ,But this was never discussed so i interpreted wronlgly and
was supporting TAL.I agree with this approach we dont need any statemachine
and
this initial setup can also be used for IPSP-IPSP communication (without an
SG bet
ween them).

Thanks,
Reshma

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 6 Jun 2002 09:59:05 -0400

Reshma,

> Sent: Thursday, June 06, 2002 9:33 AM
> To: Tolga Asveren; [email-masked]
> > > B'coz when u support ASP*M messages if  the ASP is in down
> state and if
> it
> > > receives
[TOLGA] This approach will then be reduced to run NIF/User Parts on top of
SGPF. I didn't find it elegant, but if you like you can rename it also IPSP.
In my opinion, rather than the naming, the provided functionality is
important.

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 6 Jun 2002 10:26:32 -0400

Reshma,

> Sent: Thursday, June 06, 2002 10:07 AM
> > > > [TOLGA] I don't interprete it exactly like this. In my
> opinion, it is
> > > better
> > > > unavailable/restricted PCs is finished). Because there is no concept
> of
> > > RK,
> > SGPF
> [Reshma] The name SGPF creates the whole confusion.What you call as
> NIF/User Parts on top of  SGPF,  functionality-wise is same as
> IPSP(IPSPF).
> Also it is clear that SGPF does more than this too so we cant call it as
> IPSPF.Also from all these discussions its understood that SGPF is not only
> SGP funtionality defined in m3ua draft but it has "some part of"(not all)
> SGP functionality+ some extra as defined in SG-SG draft .
>     SGPF in my opinion is only SGP functionality(as defined in m3ua
> draft )So you cant call this as SGPF.This name SGPF is very misleading.
[TOLGA] You are right that SGPF which can be used for IP-IP communciation
needs more functionality than defined in m3ua draft. That was one of the
reasons for SG-SG draft, to define the missing functionality for this. I
think, it won't be wrong that it inherits all of the functionality defined
in M3UA draft for SGPF, SPMC management (regardless whether it resides in IP
domain or in SS7 domain-for SS7 connectivity of course MTP3 interface is
necessary but this is not part of the M3UA protocol-) and routing
capability. So, I see it as SGPF as defined in M3UA draft + additional SGPF
functionality as defined in SG-SG (in fact some of the functionality in
SG-SG extension draft is necessary just for relaying and some is necessary
just for relaying between SS7 nodes, what is needed for point-to-point IP
domain communication is very minimal, it might be a good idea to organize
the SG-SG draft in a way, to reflect this separation)

---

From: "reshma" <[email-masked]>
Date: Thu, 6 Jun 2002 19:37:14 +0530

Hi Tolga,

of

NIF/User Parts on top of  SGPF,  functionality-wise is same as IPSP(IPSPF).

Thanks,
Reshma