Subject: [Sigtran] IPSP / SG-SG models applied to other UAs

From: "Lamberton, Marc" <[email-masked]>
Date: Tue, 11 Jun 2002 20:34:41 +0200

Hi all,

For a couple of weeks the discussions about IPSP vs SG-SG models have focused on m3ua because it seems simpler to agree on a model for m3ua, and then apply it on other UAs. Despite this "simplification" no concensus has been reached yet. Could we check how the two remaining models (IPSP-SE and SG-SG) would also apply to other UAs such as SUA or TUA ? If it comes out that one model fits to a wider range of UAs, could we agree that the 1st priority is to complete its definition ? This would also greatly help to stabilize implementations before the next plugtest.

SUA example:
------------
It seems that the SG-SG model supports well PC granularity (the SGs exchange SNM messages=PC reachability status). For SUA it might be extended with SNM messages=PC+[SSN]. But SUA RK can be much more that PC and SSN, it can also be GT (not talking about hostnames...). When an AS-1 addresses a message to an AS-2 with called address = GT2, the SG-1 needs to perform GTT first, and then route the message to SG-2 according to PC2 (output of GTT). Is that correct? It seems that a direct IPSP to IPSP communication with direct RK matching on GT, would avoid this additional step, and useless GTT rules definition.

SG-SG applied to SUA:
     _______                 _______ 
    |       |               |       |
    |  AS-1 |               |  AS-2 | RK=GT2
    |_______|               |_______|
     _______  |              _______   A
    |       | | RC1,        |       |  |
    |  ASP-1| | called=     |  ASP-2|  |    
    |_______| | GT2         |_______|  |
        |     |                 |      |
        |     |                 |      | RC2,
     ___|___  V              ___|___   | called=GT2
    |       |               |       |  |
    |  SG-1 |<------------->|  SG-2 |  |
    |_______|               |_______|
       GTT(GT2)=PC2              match GT2 to RC2
       =>route to SG-2

IPSP-SE applied to SUA:
     _______                 _______ 
    |       |RK=GT1/GT2;RC  |       | RK=GT2/GT1;RC
    |  AS-1 | |             |  AS-2 | 
    |_______| |called=      |_______|
     _______  |GT2           _______    
    |       | V             |       |   
    | IPSP-1|               | IPSP-2|       
    |_______|-------------->|_______|   
       Match GT2 to RC

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 11 Jun 2002 16:59:03 -0500

Marc

SUA already supports SG-SG communication (relay), but it is called IPSP in
SUA.  In SUA IPSP is not point to point (relay is supported).  Count the
occurrences of the phrase "SGP or IPSP" in the SUA draft and you will see
what I mean.  Also, from the examples SUA is SE and there are no effective
differences between IPSP SE and SG-SG the way that IPSP is described in SUA.

Therefore, IMO the IPSP described in SUA is no different from SG-SG.  M2UA
has a separate M2PA.  It is only for M3UA that the issue is so confused.

--brian

Lamberton, Marc wrote:                                 (Tue, 11 Jun 2002 20:34:41)
> Hi all,
> 
> For a couple of weeks the discussions about IPSP vs SG-SG models have
> focused on m3ua because it seems simpler to agree on a model for m3ua, and
> then apply it on other UAs. Despite this "simplification" no concensus has
> been reached yet. Could we check how the two remaining models (IPSP-SE and
> SG-SG) would also apply to other UAs such as SUA or TUA ? If it comes out
> that one model fits to a wider range of UAs, could we agree that the 1st
> priority is to complete its definition ? This would also greatly help to
> stabilize implementations before the next plugtest.
> 
> SUA example:
> ------------
> It seems that the SG-SG model supports well PC granularity (the SGs exchange
> SNM messages=PC reachability status). For SUA it might be extended with SNM
> messages=PC+[SSN]. But SUA RK can be much more that PC and SSN, it can also
> be GT (not talking about hostnames...). When an AS-1 addresses a message to
> an AS-2 with called address = GT2, the SG-1 needs to perform GTT first, and
> then route the message to SG-2 according to PC2 (output of GTT). Is that
> correct? It seems that a direct IPSP to IPSP communication with direct RK
> matching on GT, would avoid this additional step, and useless GTT rules
> definition.
> 
> 
> SG-SG applied to SUA:
>      _______                 _______ 
>     |       |               |       |
>     |  AS-1 |               |  AS-2 | RK=GT2
>     |_______|               |_______|
>      _______  |              _______   A
>     |       | | RC1,        |       |  |

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 11 Jun 2002 18:38:17 -0400

Marc,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Lamberton, Marc
> Sent: Tuesday, June 11, 2002 2:35 PM
> To: [email-masked]
> Subject: [Sigtran] IPSP / SG-SG models applied to other UAs
>
>
> Hi all,
>
> For a couple of weeks the discussions about IPSP vs SG-SG models
> have focused on m3ua because it seems simpler to agree on a model
> for m3ua, and then apply it on other UAs. Despite this
> "simplification" no concensus has been reached yet. Could we
> check how the two remaining models (IPSP-SE and SG-SG) would also
> apply to other UAs such as SUA or TUA ? If it comes out that one
> model fits to a wider range of UAs, could we agree that the 1st
> priority is to complete its definition ? This would also greatly
> help to stabilize implementations before the next plugtest.
>
> SUA example:
> ------------
> It seems that the SG-SG model supports well PC granularity (the
> SGs exchange SNM messages=PC reachability status). For SUA it
> might be extended with SNM messages=PC+[SSN]. But SUA RK can be
> much more that PC and SSN, it can also be GT (not talking about
> hostnames...). When an AS-1 addresses a message to an AS-2 with
> called address = GT2, the SG-1 needs to perform GTT first, and
> then route the message to SG-2 according to PC2 (output of GTT).
> Is that correct? It seems that a direct IPSP to IPSP
> communication with direct RK matching on GT, would avoid this
> additional step, and useless GTT rules definition.
>
>
> SG-SG applied to SUA:
>      _______                 _______
>     |       |               |       |
>     |  AS-1 |               |  AS-2 | RK=GT2
>     |_______|               |_______|
>      _______  |              _______   A
>     |       | | RC1,        |       |  |
[TOLGA] It should be also considered, how IPSP1 in your figure decides that
the message is intended for a specific RK. It will need to do GTT for this,
so translation is still there. In fact, the result will be the same like in
M3UA case: SGPF functionality will be shifted to ASP and it will be called
IPSP.
Particularly for M3UA case SGPF = SPMC management + Routing Functionality.
For M3UA-IPSP both of them are needed, so it is not like it is stated in the
draft "IPSP does not use services of a SG", it already has one inside. M3UA
is intended to provide MTP3 services to user parts, so in my opinion it is
logical that point-to-point relationship for M3UA is based on SPMC, like
point-to-point relationship for MTP3 is based on PC.