Subject: RE: [Sigtran] M3UA : Implementor's Guide. DUNA(*) message

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 21 Jun 2002 18:08:29 +0200

Hi Tolga, 

There were only three messages about this issue, not a long thread...  ;-)

So, how would you suggest to solve the NIF unavailability? People asked for a common procedure in the last Plugtest...

Cheers // Javier.

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Friday, June 21, 2002 6:07 PM
> To: [email-masked]
> Subject: RE: [Sigtran] M3UA : Implementor's Guide. DUNA(*) message
> 
> 
> Javier,
> 
> The point is, it can't be a MUST, as long as one does not violate the
> protocol, one is free to do anything. Furthermore, the draft shouldn't
> discuss implementation dependent failure scenarios. So, I 
> think this item
> should be removed from IG.
> Apart from this, I also find it quite ineffective that we 
> discuss the same
> things again and again after a conclusion is reached. This issue was
> discussed and I don't see any reason why to rediscuss it and 
> create another
> endless loop.
> 
>    Tolga
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Javier Pastor-Balbas (ECE)
> > Sent: Friday, June 21, 2002 11:48 AM
> > To: [email-masked]'
> > Subject: FW: [Sigtran] M3UA : Implementor's Guide. DUNA(*) message
> >
> >
> > Hi guys,
> >
> > While reading mails to update the IG, I found this one. I didn't
> > understand pretty well the reason:
> >
> > If connection to NIF is lost, the ASPs won't have connection to
> > the SS7 network. It is like SGP-ASP isolation from the 
> rest, isn't it?
> >
> > I'd appreciate your comments on this.
> >
> >
> > Cheers // Javier.
> >
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: Thursday, April 18, 2002 11:09 PM
> > To: Tolga Asveren
> > Cc: [email-masked]
> > Subject: Re: [Sigtran] M3UA : Implementor's Guide. DUNA(*) message
> >
> >
> > Tolga,
> >
> > I agree: the IG needs to have sending DUNA(*) removed.  It is also
> > appropriate to send ASPIA Ack.  DUNA(*) should never be sent when
> > there is not isolation with the SS7 network at the SG (it 
> has nothing
> > to do with isolation between the ASP and SG).
> >
> > Tolga Asveren wrote:                                        (Thu,
> > 18 Apr 2002 13:22:55)
> > > Umesh,
> > >
> > >
> > > 1) As I mentioned one of my former messages about the 
> M3UA Implementor's
> > > Guide, I don't think it is appropriate to say "A DUNA(*) 
> message MUST be
> > > sent" in such a case. As long as one does not violate the
> > protocol, one is
> > > free to do anything. So, in the same situation, one also 
> might drop the
> > > associations, and this won't be in conflict with the protocol.
> > >
> > > 2) For the case you described, if SG is isolated from 
> NIF, then most
> > > probably it won't be able to reach also users at the same point
> > code as SG
> > > (Well, depending on implementation the case might be different)
> > I also don't
> > > think, the protocol should tell about implementation dependent
> > cases (like
> > > loosing connection to NIF etc....)
> > >
> > > Because of both of those reasons, in my opinion it is 
> better not to say
> > > anything about this in the Implementor's Guide, 
> especially "MUST" is too
> > > much.
> >
> > I completely agree.
> >
> > --brian
> >
> > >
> > >      Tolga
> > >
> > > > -----Original Message-----
> > > > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of
> > > > Vats, Umesh
> > > > Sent: Thursday, April 18, 2002 12:38 PM
> > > > To: [email-masked]'
> > > > Subject: [Sigtran] M3UA : Implementor's Guide. DUNA(*) message
> > > >
> > > >
> > > > > Hi
> > > > >
> > > > > In the implementor's guide, following statement is there in
> > > > section 3.4.2
> > > > > :
> > > > >
> > > > > "If the SG (all the SGPs) is isolated from the NIF,
> > > > >  then all the users are isolated from the SS7 network.
> > > > >  A DUNA(*) message MUST be sent. "
> > > > >
> > > > In the draft 12 of M3UA section 3.4.1, following text is given :
> > > >
> > > >    " A mask value equal (or greater than) the
> > > >    number of bits in the PC indicates that the entire network
> > > >    appearance is affected - this is used to indicate 
> network isolation
> > > >    to the ASP. "
> > > >
> > > > In case ASP is communicating with the users located at SG
> > (i.e. ASP and SG
> > > > have
> > > > separate point codes), then reception of DUNA(*) at ASP 
> means that
> > > > communication between ASP  and the users at SG is lost. But
> > this shouldn't
> > > > happen because the associations between SG and ASP are UP.
> > > >
> > > > How should ASP handle this ? Can we specify some text 
> for this in the
> > > > implementor's
> > > >  guide ?
> > > >
> > > > > Umesh
> > > > >
> > > >
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> >
> > --
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> >
> >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 21 Jun 2002 14:15:43 -0400

Javier,

> From: Javier Pastor-Balbas (ECE)
> [mailto:[email-masked]]
> Sent: Friday, June 21, 2002 12:08 PM
> To: 'Tolga Asveren'; [email-masked]
> So, how would you suggest to solve the NIF unavailability? People
> asked for a common procedure in the last Plugtest...
[TOLGA] I don't understand why a common procedure for a implementation
dependent parts failure case is necessary. The protocol is clear, one takes
action which does not violate the protocol. Especially saying MUST is too
much.
As you can see what I don't agree is not what one probably will do in such a
case, but that some behavior is mandated in IG, for such a situation.