Subject: RE: [Sigtran] SG-SG, IPSP-IPSP, SE vs. DE ...

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 4 Jun 2002 17:15:01 +0200

Hi folks, 

I agree with John. This must stop. It has no sense start any new protocols unless we really see a need for it. We are just going around the same explanations. 

Why don't just finish all we have been doing for years? It's not worth starting new work lines without finishing the current ones.

Afterthat, if we see a clear need to go on, we'll do it.

Cheers // Javier.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, June 04, 2002 4:46 PM
> To: [email-masked]
> Subject: [Sigtran] SG-SG, IPSP-IPSP, SE vs. DE ...
> 
> 
> Hi all,  
> 
> I have had a lot of other things to take care of, but have 
> recently started wading
> through this stuff.  I think we just need to stop.  I would 
> be very happy
> to see someone produce a problem statement about why SG-to-SG 
> signaling
> is needed.  Maybe some text why the current drafts are not 
> sufficient. 
> Additionally, the same should be done for IPSP-to-IPSP.  Without any
> sort of problem statement, how can we get anywork done?  I do 
> think that
> from these problem statements, we can generalize somethings 
> from it and
> then do some productive work.   However, I'd suggest that we 
> are far down
> a rathole right now with little chance of getting out.
> 
> Lyndon, I'd suggest that we don't promote any work to WG item 
> until we sort
> this out.  My feeling is that there are different goals in 
> some of this
> work and we need to know what is the problem we are trying to solve.
> 
> thanks,
> John
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 5 Jun 2002 09:58:02 +0200

Hi Brian, 

See below...

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Tuesday, June 04, 2002 8:21 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sigtran] SG-SG, IPSP-IPSP, SE vs. DE ...
> 
> 
> John,
> 
> John Loughney wrote:                  (Tue, 04 Jun 2002 20:58:07)
> > Hi Brian,
> > 
> > > > Why do we need to worry about PCs in IP domains?  Why do we 
> > > need relaying
> > > > into SS7?  Your problem statement is not sufficient.
> > > 
> > > I remember you defending relaying for SUA rather vehemently.
> > > Did you think that the SG-SG and IPSP work applied only to
> > > M3UA?  IPSP behavior (be it SE, DE or SG-SG) is also needed
> > > for SUA.
> > 
> > I guess I need to add <rhetorical remark> </rhetorical remark> to 
> > my comments.
> > 
> > > I believe that the arhictecural framework RFC already provides
> > > the problem statement for this work.  In addition, it provides
> > > possible solution architectures.  The solution architecture
> > > as presented in the RFC is SG-SG communication.
> > 
> > I guess I may be slow, but to me it is not clear.
> >  
> > > It is this IPSP DE and even SE concept that is a diversion from
> > > the agreed SIGTRAN architecture.  Talking about DE and SE is a
> > > utter waste of time, and has been for almost a year.
> > 
> > Agreed.
> >  
> > > The SG-SG approach shown in the SIGTRAN architecture RFC is
> > > plain, simple apparent, and direct.  If we follow you suggestion
> > > use the problem statement and solution architectures from the
> > > agreed SIGTRAN architecture, then we can proceed immediately
> > > with SG-SG.
> > 
> > To me, the SG-SG would be for tunneling over an IP network, not
> > terminating inside an IP network.  There may be some comonality
> > in the different approaches, but right now, I don't see any
> > consensus building in any direction.  Better to step back,
> > and see what the real issues are and how to solve them.  
> > They may be perfectly clear to you, but I do not see that this
> > is true to everyone else.  My suggestion is to step back,
> > document and the go forward.
> 
> We had 12-14 people discussing SG-SG in a separate forum which led
> to the current draft.  We have only seen Javier dissent, 

I would like to know what I dissent... You seem my wife ;-)
All I have said is:
	1. Finish the current work
	2. Write extensions if needed

How many people were discussing the current drafts? More that 12-14 (figures that I doubt) were much more involved and during more time in writing them. Read the archives...

> all others
> have considered SG-SG as providing some value. 

Some others have pointed out that M2PA is enough... These people are out of your statistics (maybe included in the 12-14...)

> It is presented in
> RFC 2719, so it already had concensus at that time.
> 

Please indicate the page in RFC2719 where you found it... 
SG-SG can be considered useful in such a way. But it was not one of the scenarios included in RFC2719

Cheers // Javier.

> Why waste time talking about motherhood?  Why would we not simply
> proceed to complete the extension?
> 
> --brian
> 
> > 
> > John
> > 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/