Subject: RE: [Sigtran] M2PA Comment: Multi-homing

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 19 Jun 2002 17:17:21 +0200

Hi Brian,

Are you taking into account that in this case MTP3 goes over SCTP? How can MTP3 detect a link failure if SCTP didn't do it before?

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, June 19, 2002 5:04 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: [email-masked]
> Subject: Re: [Sigtran] M2PA Comment: Multi-homing
> 
> 
> Javier,
> 
> I mean that MTP3 detects non-optimal routes as fast, and
> in many cases faster, than SCTP.
> 
> --brian
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Wed, 19 Jun 2002 16:48:59)
> > Hi Brian, 
> > 
> > Do you mean that sending the message on a non-optimal route 
> when SCTP
> > detects that a remote address does not work is faster than 
> retransmiting
> > DATA towards the next remote IP address?
> > 
> > Cheers // Javier.
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Wednesday, June 19, 2002 3:44 PM
> > > To: Javier Pastor-Balbas (ECE)
> > > Cc: [email-masked]'; [email-masked];
> > > [email-masked]; [email-masked]
> > > Subject: Re: [Sigtran] M2PA Comment: Multi-homing
> > > 
> > > 
> > > Javier,
> > > 
> > > I highly doubt that SCTP with an Rto.Min of 1 second will 
> > > have anywhere
> > > near the performance of MTP3 in detecting even remote NIC 
> > > failures.  MTP3
> > > will fail the link in 1 second whereas SCTP will only 
> start its first
> > > retransmission in 1 second with an Rto.Min of 1 second in the 
> > > case of a
> > > remote NIC failure.  Any use of SCTP multihoming for M2PA is 
> > > marginal at
> > > best, given the current recommended and required protocol 
> > > parameters for SCTP.
> > > IMO it would be foolish to accent SCTP mutlihoming in the 
> > > draft as it is
> > > rather useless for M2PA.  Because it is not forbidden, 
> however, it is
> > > permitted.  We have arlready exchanged more text that the 
> > > subject deserves.
> > > 
> > > --brian
> > > 
> > > 
> > > Javier Pastor-Balbas (ECE) wrote:                          
> > > (Wed, 19 Jun 2002 10:08:33)
> > > > Hi,
> > > > 
> > > > Although the well-known MTP3 procedures such as changeover, 
> > > changeback,
> > > > forced and controlled rerouting can give a certain degree 
> > > of reliability I
> > > > would support to include the multihoming host. Upon the 
> > > failure of a remote
> > > > NIC, it will be a faster procedure to change the remote IP 
> > > address inside
> > > > the association that triggering the MTP3 procedures. 
> > > Multihoming hosts would
> > > > certainly improve the performance in those cases. It 
> would be then a
> > > > desirable feature IMHO.
> > > > 
> > > > Cheers // Javier.
> > > > 
> > > 
> > > -- 
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > > 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 19 Jun 2002 11:02:26 -0500

Javier,

M2PA includes acknowledgments.

--brian

Javier Pastor-Balbas (ECE) wrote:                          (Wed, 19 Jun 2002 17:17:21)
> Hi Brian,
> 
> Are you taking into account that in this case MTP3 goes over SCTP? How can
> MTP3 detect a link failure if SCTP didn't do it before?
> 
> Cheers // Javier.
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Andrew Booth <[email-masked]>
Date: Wed, 19 Jun 2002 13:16:43 -0400

Hi Brian,

Are you assuming here that a timer like timer T7 from q0703 ( Timer 
"excessive delay of acknowledgement" ) is included in M2PA?

Thanks,
Andrew

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 19 Jun 2002 13:13:55 -0500

Andrew,

The implementation is already permitted to use such a timer.

--brian

Andrew Booth wrote:                                        (Wed, 19 Jun 2002 13:16:43)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Andrew Booth <[email-masked]>
Date: Wed, 19 Jun 2002 16:33:51 -0400

Hi Brian,

Agreed.  I was looking for a clarification: you mentioned that MTP3 can 
detect the failure more quickly than SCTP, do you expect this to happen 
using a T7 timer or did you have some other way in mind?

Thanks,
Andrew