Subject: RE: [Sigtran] M2PA Comment: Multi-homing

From: [email-masked]
Date: Wed, 19 Jun 2002 17:38:12 +0100

Tolga

Figure you requested:

     Node-A                  Node-B
 |--------------|        |--------------|
 |  ----------  |        |  ----------  |
 |  |  M2PA  |  |        |  |  M2PA  |  |
 |  | host-1 |--------------| host-1 |  |
 |  ----------  |        |  ----------  |
 |  ----------  |        |  ----------  |
 |  |  M2PA  |  |        |  |  M2PA  |  |
 |  | host-2 |--------------| host-2 |  |
 |  ----------  |        |  ----------  |
 |  ----------  |        |  ----------  |
 |  |  M2PA  |  |        |  |  M2PA  |  |
 |  | host-3 |--------------| host-3 |  |
 |  ----------  |        |  ----------  |
 |  ----------  |        |  ----------  |
 |  |  M2PA  |  |        |  |  M2PA  |  |
 |  | host-4 |--------------| host-4 |  |
 |  ----------  |        |  ----------  |
 |--------------|        |--------------|

Regards,
Amish

"Tolga Asveren" <[email-masked]> on 19/06/2002 17:23:45

To:   [email-masked]
cc:    (bcc: Amish CHANA/EN/HTLUK)

Subject:  RE: [Sigtran] M2PA Comment: Multi-homing

Amish,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, June 19, 2002 12:00 PM
> To: Tolga Asveren
> Cc: [email-masked]
> Subject: RE: [Sigtran] M2PA Comment: Multi-homing
>
>
>
> Tolga,
>
> Consider the following scenario:
> - I have 4 associations between two signalling points.
> - Each association terminates on a different M2PA host.
> - I need 4 associations due to processing/throughput limitations
> on each M2PA
> host.
[TOLGA] Sorry, I couldn't understand exactly what the scenario is, a figure
might help, so that I can understand it. But regardless of that, -just
speculation, not based on a scientific data- I would expect that processing
power needed for a multihomed SCTP association would be similar to the
processing power needed for two non-multihomed SCTP associations. So, in
such a case, I would say, you can have only 2 multihomed associations with
the same processor.
>
> If all the associations are single-homed, then 2 associations are
> routed via
> path A and 2 associations are routed via path B.
> Now if path A fails the co procedure will route all the messages
> on to the 2
> associations handling path B.
> The first 2 hosts now try re-establish the associations while the
> second two
> hosts carry twice their load.
>
> If all the associations are dual-homed, then 2 associations use
> path A as the
> primary and 2 associations use path B as the primary.
> Now if path A fails, SCTP will use path B to transmit the
> messages for the first
> 2 hosts.
> In this case all the hosts carry traffic and also send heartbeat
> messages to the
> IP addresses on path A.
>
> In the above architecture multi-homing seems better.
>
> If you have a single host at either end, I assume either option could be
> suitable.
>
> A.
>

*******************************************************************************
Important.
Confidentiality: This communication is intended for the above-named person and
may be confidential and/or legally privileged. Any opinions expressed in this
communication are not necessarily those of the company. If it has come to you
in error you must take no action based on it, nor must you copy or show it to
anyone; please delete/destroy and inform the sender immediately.

Monitoring/Viruses
Orange may monitor all incoming and outgoing emails in line with current
legislation.  Although we have taken steps to ensure that this email and
attachments are free from any virus, we advise that in keeping with good
computing practice the recipient should ensure they are actually virus free.

Orange PCS Limited is a subsidiary of Orange SA and is registered in England No
2178917, with its address at St James Court, Great Park Road, Almondsbury Park,
Bradley Stoke, Bristol BS32 4QJ.
*******************************************************************************

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 19 Jun 2002 13:48:02 -0400

Amish,

> Sent: Wednesday, June 19, 2002 12:38 PM
> To: Tolga Asveren
> Cc: [email-masked]
[TOLGA] What I said was to use 2 non-multihomes SCTP associations instead of
one multihomed one. So, the figure should be
     Node-A                  Node-B
 |--------------|        |--------------|
 |  ----------  |        |  ----------  |
 |  |  M2PA  |--------------|  M2PA  |  |
 |  | host-1 |--------------| host-1 |  |
 |  ----------  |        |  ----------  |
 |  ----------  |        |  ----------  |
 |  |  M2PA  |--------------|  M2PA  |  |
 |  | host-2 |--------------| host-2 |  |
 |  ----------  |        |  ----------  |
 |  ----------  |        |  ----------  |
 |  |  M2PA  |--------------|  M2PA  |  |
 |  | host-3 |--------------| host-3 |  |
 |  ----------  |        |  ----------  |
 |  ----------  |        |  ----------  |
 |  |  M2PA  |--------------|  M2PA  |  |
 |  | host-4 |--------------| host-4 |  |
 |  ----------  |        |  ----------  |
 |--------------|        |--------------|
For example one association between  host-1s are for pathA and the other one
is for pathB.