Subject: RE: [Sigtran] IPSP: SE vs DE

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Mon, 3 Jun 2002 19:10:39 +0200

Hi Brian, 

See below...

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Monday, June 03, 2002 6:51 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: [email-masked]'
> Subject: Re: [Sigtran] IPSP: SE vs DE
> 
> 
> Javier,
> 
> As an AS is just the user of the MTP to MTP-User interface, 
> it does not help understanding to refer to AS-SG communication.
> An AS *always* communicates with *AS peers* using the MTP to
> MTP-User interface.

Wrong AS concept: as an example an AS is not an SS7 application in SS7 network... 
AS is an M3UA concept that refers to the user traffic range. It is virtual and includes the M3UA layer. The AS implementation is an ASP, IPSP or both.

> 
> Your statements do not help me understand the *protocol* between
> the IPSP and the SG and the state machine definitions, transitions
> and procedures that the IPSP uses in communicating with an SGP.
> In your view, what messages, state machines and procedures does
> the IPSP use in the case of communicating with an SGP?
> 
My statements do NOT try to help to understand how an IPSP can communicate with a SG, because it can not.

My statements try to say the following:
	- An SS7 application in the IP network, on the top of M3UA layer can communicate with another SS7 application in the IP network also on top of an M3UA layerusing all the procedures defined in IPSP communication.
	- If an SS7 application in the IP network, on top of M3UA layer wants to communicate with a SG that relays messages between MTP3 and M3UA using M3UA, that SS7 application will use all the procedures that allow an SS7 application communicating with the SG, that I also call AS-SG communication and are not the same procedures defined under the IPSP communication.

Sorry if I was not this clear

Cheers // Javier.

> 
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Mon, 03 Jun 2002 18:24:21)
> > Brian, 
> > 
> > IPSP communication between SG and AS has a very close 
> relation to using
> > SG-SG comm. between AS and SG... Neither of them make sense for me.
> > 
> > IPSP communication is defined to communicate two ASes. If 
> the AS wants to
> > communicate with the SG the AS will use SG-AS communication.
> > 
> > Cheers // Javier.
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Monday, June 03, 2002 6:23 PM
> > > To: Javier Pastor-Balbas (ECE)
> > > Cc: [email-masked]'
> > > Subject: Re: [Sigtran] IPSP: SE vs DE
> > > 
> > > 
> > > Javier,
> > > 
> > > That's rather peculiar as you said that IPSP to SGP communication
> > > was complex and unnecessary....
> > > 
> > > Which is it?
> > > 
> > > --brian
> > > 
> > > 
> > > Javier Pastor-Balbas (ECE) wrote:                          
> > > (Mon, 03 Jun 2002 17:52:07)
> > > > Brian, 
> > > > 
> > > > Wrong concept. My AS can talk with a SG and ALSO with 
> > > another AS. The communication will be faster since the 
> > > processing is half or even less.
> > > > 
> > > > What is the advantage of AS-SG-(SG)-AS regarding AS-AS ?? 
> > > Please list them.
> > > > 
> > > > Cheers // Javier.
> > > > 
> > > > > -----Original Message-----
> > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > Sent: Monday, June 03, 2002 5:14 PM
> > > > > To: Javier Pastor-Balbas (ECE)
> > > > > Cc: [email-masked]'
> > > > > Subject: Re: [Sigtran] IPSP: SE vs DE
> > > > > 
> > > > > 
> > > > > Javier,
> > > > > 
> > > > > Your IPSP will not work with an SG and therefore
> > > > > makes no sense.
> > > > > 
> > > > > I still propose that IPSP be removed altogether as SG-SG
> > > > > communication is an better, easier and obvious replacement.
> > > > > 
> > > > > --brian
> > > > > 
> > > > > Javier Pastor-Balbas (ECE) wrote:                          
> > > > > (Mon, 03 Jun 2002 16:58:54)
> > > > > > Hi Brian, 
> > > > > > 
> > > > > > IPSP will avoid the use of SG and therefore it makes sense.
> > > > > > 
> > > > > > Cheers // Javier.
> > > > > > 
> > > > > > > -----Original Message-----
> > > > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > > > Sent: Monday, June 03, 2002 4:48 PM
> > > > > > > To: Javier Pastor-Balbas (ECE)
> > > > > > > Cc: [email-masked]'
> > > > > > > Subject: Re: [Sigtran] IPSP: SE vs DE
> > > > > > > 
> > > > > > > 
> > > > > > > Javier,
> > > > > > > 
> > > > > > > As SE was clearly agreed as possible using an SG to 
> > > transfer and
> > > > > > > not requiring any new protocol or state machine 
> description, I
> > > > > > > propose that IPSP be removed from the RFC 
> altogether.  I also
> > > > > > > propose that the SG-SG be used to properly address 
> > > peer-to-peer
> > > > > > > communication.
> > > > > > > 
> > > > > > > --brian
> > > > > > > 
> > > > > > > Javier Pastor-Balbas (ECE) wrote:                 
>          
> > > > > > > (Mon, 03 Jun 2002 16:24:07)
> > > > > > > > Hi guys, 
> > > > > > > > 
> > > > > > > > I propose to move forward. Most of the folks 
> that are now
> > > > > > > > active seem to prefer the SE. Then, I propose to 
> > > remove the DE
> > > > > > > > exchange from the current RFC and leave only SE. Anyone
> > > > > > > > against?
> > > > > > > > 
> > > > > > > > 
> > > > > > > > Cheers // Javier.
> > > > > > > > 
> > > > > > > > 
> > > > > > > > 
> > > > > > > > 
> > > > > > > > 
> > > > > > > > _______________________________________________
> > > > > > > > Sigtran mailing list
> > > > > > > > [email-masked]
> > > > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > > > 
> > > > > > > -- 
> > > > > > > Brian F. G. Bidulock
> > > > > > > [email-masked]
> > > > > > > http://www.openss7.org/
> > > > > > > 
> > > > > > 
> > > > > > _______________________________________________
> > > > > > Sigtran mailing list
> > > > > > [email-masked]
> > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > 
> > > > > -- 
> > > > > Brian F. G. Bidulock
> > > > > [email-masked]
> > > > > http://www.openss7.org/
> > > > > 
> > > > 
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > > -- 
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 3 Jun 2002 12:44:22 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:                          (Mon, 03 Jun 2002 19:10:39)
> AS is an M3UA concept that refers to the user traffic range. It is virtual and includes the M3UA layer. The AS implementation is an ASP, IPSP or both.

I disagree: it is the correct AS concept.  As M3UA provides (and
transparently) the MTP to MTP-User interface, the traffic range
defined for an AS is defined in terms of an MTP-SAP.  There is little
difference between the user accessible via an MTP-SAP and the MTP-SAP
itself: particularly from the view of the underlying M3UA (beneath
the MTP-SAP) protocol.
> with a SG, because it can not.

Then an AS cannot communicate to an SG via an IPSP.  Now you
back where you started.

> 	- An SS7 application in the IP network, on the top of M3UA layer can
> 	communicate with another SS7 application in the IP network also on top
> 	of an M3UA layerusing all the procedures defined in IPSP
> 	communication.

Which procedures are defined?  I did not see any definitions of IPSP
procedures.  Merely vague statements that an IPSP "acts like" something
else.

> 	- If an SS7 application in the IP network, on top of M3UA layer wants
> 	to communicate with a SG that relays messages between MTP3 and M3UA
> 	using M3UA, that SS7 application will use all the procedures that
> 	allow an SS7 application communicating with the SG, that I also call
> 	AS-SG communication and are not the same procedures defined under the
> 	IPSP communication.

So you're saying that an AS must communicate with an SG via an ASP, which
means that IPSP does not support SG communication.  IPSPs must be isolated
from the SS7 network, making them rather useless in the near- to mid-term.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/