Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Mon, 3 Jun 2002 10:03:46 +0200

Hi Tolga, 

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 7:08 PM
> To: [email-masked]
> Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
> 
> 
> Javier,
> 
> > I was very involved from the beginning in the IPSP discussions
> > and I can tell you that the idea was never having a criss-crossed
> > model. In addition I think this is only a model you can use, but
> > for me much better models exists...
> >
> > What really happened is that we included the two approaches to
> > close the RFC, because discussions had no end.
> [TOLGA] I was also involved on those discussions from the 
> very beginning.
> For DE, from protocol point of view, the idea was to make 
> this happen with
> the defined ASP/SGP state machines and with already defined 
> messaging. That
> was the reason, why people were attracted by it (including 
> me). If one does
> not have SS7 connectivity, it is obvious that no MTP3 interworking is
> necessary, but this already belongs to non-protocol part. For 
> example there
> is a nice message from you explaining the DE approach during 
> the initial
> IPSP discussions. I think, it shows well, what people at that 
> time were
> referring to as DE approach.
> 
> (Date of message is 11/6/01)
> Hi Amish,
> 
> From my point of view, IPSP needs to:
> 
> - Send data msg to the other IPSP in the way an SGP sends a 
> message to an
> ASP
> - Receive data messages and distribute them to the ASs in the 
> same way ASP
> does
> it
> - Send ASPSM and ASPTM in the same way ASP does
> - Receive and treat ASPTM and ASPSM in the same way as SGP.
> 
> 
> Other classification of IPSP functionality:
> 
> As an SGP
> - Send data msg to the other IPSP in the way an SGP sends a 
> message to an
> ASP
> - Receive and treat ASPTM and ASPSM in the same way as SGP.
> 
> As an ASP
> - Receive data messages and distribute them to the ASs in the 
> same way ASP
> does
> it
> - Send ASPSM and ASPTM in the same way ASP does
> 
> (This last point has the particularity that only one ASP-UP 
> is needed. When
> an
> IPSP receives an ASPUP and sends back an ASPUP-Ack it does 
> not need to send
> another ASPUP to the peer and can consider the peer as INACTIVE)
> 
> 

This statements do not mean that an IPSP is modelled as a criss-crossed ASPF and SGPF. It is just a comparison.
If you say that a sphinx has the head as a human's head and the body as a lion's one, you don't deduce that an sphinx is made up of a criss-crossed lion with a human being...  :-/

Cheers // Javier.
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 3 Jun 2002 03:35:22 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:      (Mon, 03 Jun 2002 10:03:46)
> 
> This statements do not mean that an IPSP is modelled as a
> criss-crossed ASPF and SGPF. It is just a comparison.

When you describe an IPSP as having some SGP functionality so that
it can interact with another IPSP, yet acting exactly like an ASP
when interacting with an SGP, what are we to deduce except that an
IPSP is a combination of an ASPF and and SGPF?

Also, when IPSPs are talking to each other, what other than a
criss-crossed ASPF+SGPF can be deduced?

You say IPSP uses the protocol as already described for ASP and SGP
in the RFC, so what else can be deduced except that an IPSP is an
ASPF+SGPF?

When you consider two IPSPs, each made up of an ASPF and an SGPF
talking to each other, how else are they to do this except one's
ASPF talking to the other's SGPF and the other's ASPF talking to the
one's ASPF?

> If you say that a sphinx has the head as a human's head and the
> body as a lion's one, you don't deduce that an sphinx is made up
> of a criss-crossed lion with a human being...  :-/

Poor analogy.  Because you say that an endpoint acts as a client
when talking to a server, yet acts as a server when talking to a
client, does not make a model peer-to-peer.

If IPSP is something different then please describe it, because all
the statements made to date lead to the same conclusion: that an
IPSP talking to an IPSP is a criss-crossed ASPF+SGPF relationship.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/