Subject: RE: [Sigtran] m3ua: IG : n+k redundancy - AS state machine

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Thu, 27 Jun 2002 10:57:08 +0200

Tolga, 

See below...

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Wednesday, June 26, 2002 7:47 PM
> To: [email-masked]
> Subject: RE: [Sigtran] m3ua: IG : n+k redundancy - AS state machine
> 
> 
> Javier,
> 
> 1) For changing MAY to SHOULD or MUST, let's change it to 
> SHOULD. In 4.3.1,
> that it is not appropriate to send DATA to an ASP in 
> ASP-INACTIVE is stated
> with "SHOULD NOT", so I assume, people are happy with the 
> strictness level
> of SHOULD in this case, n+k case is similar.
> 

Agreed.

> 2) For n ASPs required for each state change, there are some 
> corner cases
> (assuming n is required for each state), like:
> n = 3
>   2 ASP are in ACTIVE state
>   1 ASP is in INACTIVE state
> What is the state of AS? Probably the answer is INACTIVE, 
> then this should
> be said nicely in the state machine or in a special note.
> 

Don't you think it is enough with the transition "n ASPs are in ACTIVE state" to move from AS_INACTIVE to AS_ACTIVE? 

Cheers // Javier.

>   Tolga
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Javier Pastor-Balbas (ECE)
> > Sent: Wednesday, June 26, 2002 12:28 PM
> > To: 'Tolga Asveren'; [email-masked]
> > Subject: RE: [Sigtran] m3ua: IG : n+k redundancy - AS state machine
> >
> >
> > Tolga,
> >
> > I was basically looking for simplicity. If we say that n are
> > needed to work, n are needed to work in all the states. IMO it is
> > more coherent to wait to get teh AS_INACTIVE state when the n
> > ASPs reach it. The n+k redundancy model means that an AS has to
> > be made of at least "n" ASPs to get the desired degree of
> > redundancy. If the n ASPs can not get an state, then the AS is in
> > the state below. An AS that is in the AS_INACTIVE state means the
> > the AS is available, i.e all the ASPs have got the 
> ASP_INACTIVE state.
> >
> >
> > Cheers // Javier.
> >
> > > -----Original Message-----
> > > From: Tolga Asveren [mailto:[email-masked]]
> > > Sent: Wednesday, June 26, 2002 6:35 PM
> > > To: [email-masked]
> > > Subject: RE: [Sigtran] m3ua: IG : n+k redundancy - AS 
> state machine
> > >
> > >
> > > Javier,
> > >
> > > > -----Original Message-----
> > > > From: Javier Pastor-Balbas (ECE)
> > > > [mailto:[email-masked]]
> > > > Sent: Wednesday, June 26, 2002 12:01 PM
> > > > To: 'Tolga Asveren'; [email-masked]
> > > > Subject: RE: [Sigtran] m3ua: IG : n+k redundancy - AS 
> state machine
> > > >
> > > >
> > > >
> > > > Tolga,
> > > >
> > > > If we consider n as required, we will need (require) n 
> ASP to get
> > > > one specific AS state.
> > > [TOLGA] Why(or similarly why not) for transitions from DOWN
> > > to INACTIVE
> > > state should we need n ASPs? n is the number of ASPs required
> > > to be ACTIVE
> > > to handle the anticipated traffic. So, for transitions
> > > to/from ACTIVE state
> > > it makes sense. What will we gain (or loose) by switching 
> AS state to
> > > INACTIVE with only 1 INACTIVE ASP? In fact, as far as I can
> > > see, to care
> > > about n (or not to care about it) while switching to INACTIVE
> > > state will
> > > just change, when NTFY("AS INACTIVE") is going to be sent, so
> > > IMO not big
> > > deal.
> > > >
> > > > Cheers // Javier.
> > > >
> > > >
> > > > > -----Original Message-----
> > > > > From: Tolga Asveren [mailto:[email-masked]]
> > > > > Sent: Wednesday, June 26, 2002 5:43 PM
> > > > > To: [email-masked]
> > > > > Subject: RE: [Sigtran] m3ua: IG : n+k redundancy - AS
> > > state machine
> > > > >
> > > > >
> > > > > Javier,
> > > > >
> > > > > For transitions to/from AS-INACTIVE from/to AS-DOWN I am not
> > > > > sure whether n
> > > > > ASPs should be in INACTIVE state or just 1 is enough. I tend
> > > > > to think, 1 ASP
> > > > > should be enough to declare AS as INACTIVE. IMO n is only
> > > > > important as the
> > > > > number of ACTIVE ASPs to handle the traffic, that was the
> > > > > reason, why I left
> > > > > transitions between AS-DOWN/AS-INACTIVE as in the AS
> > > State Transition
> > > > > Diagram in the draft (but this issue is still to be 
> discussed).
> > > > >
> > > > >     Tolga
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: Javier Pastor-Balbas (ECE)
> > > > > > [mailto:[email-masked]]
> > > > > > Sent: Wednesday, June 26, 2002 11:01 AM
> > > > > > To: [email-masked]
> > > > > > Cc: 'Tolga Asveren'
> > > > > > Subject: RE: [Sigtran] m3ua: IG : n+k redundancy - AS
> > > state machine
> > > > > >
> > > > > >
> > > > > > Hi guys,
> > > > > >
> > > > > > This is the modified AS state machine applied to the n+k
> > > > > > redundancy. I've completed the one that Tolga sent several
> > > > > mails ago.
> > > > > >
> > > > > >
> > > > > >              Figure 5: AS State Transition Diagram
> > > > > >
> > > > > >
> > > > > >      +----------+ n ASPs are in ACTIVE state  
> +-------------+
> > > > > >      |    AS-   |---------------------------->|     
> AS-     |
> > > > > >      | INACTIVE |                             |   
> ACTIVE    |
> > > > > >      |          |<---                         |     
>         |
> > > > > >      +----------+    \                        
> +-------------+
> > > > > >         ^   |         \          one ASP trans to ^    |
> > > > > >         |   |          \       ASP-ACTIVE causing |
> > > | one ACTIVE
> > > > > >         |   |           \        number of ACTIVE |    |
> > > > > ASP trans to
> > > > > >         |   |            \           ASPs to be n |    |
> > > > > ASP-INACTIVE
> > > > > >         |   |             \                       |
> > > | or ASP-DOWN
> > > > > >         |   |              \                      | 
>    | causing
> > > > > > n ASPs  |   | one ASP       \                     |
> > > | number of
> > > > > > are in  |   | trans to       \                    |
> > > | ACTIVE ASPs
> > > > > > ASP-    |   | ASP-DOWN        -------\            | 
>    | drop
> > > > > > INACTIVE|   |                         \           |
> > > | (start Tr)
> > > > > > or ASP- |   |                          \          |    |
> > > > > > ACTIVE  |   |                           \         |    |
> > > > > > state   |   |                  Tr expiry \        |    |
> > > > > >         |   v          The ASPs needed to \       |    v
> > > > > >      +----------+       reach n ACTIVE are \  
> +-------------+
> > > > > >      |          |     still in ASP-INACTIVE --|     
>         |
> > > > > >      | AS-DOWN  |                      state  | 
> AS-PENDING  |
> > > > > >      |          |                             |  
> (queueing) |
> > > > > >      |          |<----------------------------|     
>         |
> > > > > >      +----------+    Tr Expiry and the ASPs   
> +-------------+
> > > > > >                      needed to reach n ACTIVE
> > > > > >                      ASPs are in ASP-DOWN state
> > > > > >
> > > > > >
> > > > > > Any missing transitions?
> > > > > >
> > > > > >
> > > > > > Cheers // Javier.
> > > > >
> > > > >
> > > > > _______________________________________________
> > > > > Sigtran mailing list
> > > > > [email-masked]
> > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > >
> > >
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 27 Jun 2002 08:52:50 -0400

Javier,

> Sent: Thursday, June 27, 2002 4:57 AM
> Don't you think it is enough with the transition "n ASPs are in
> ACTIVE state" to move from AS_INACTIVE to AS_ACTIVE?
[TOLGA] The problem case is not that one. If we reconsider the example I
gave :
n = 3 (so, we need 3 ACTIVE ASPs to declare AS as ACTIVE and similarly we
need 3 INACTIVE ASPs to declare to declare AS as INACTIVE. If there is 1
INACTIVE ASP and 2 ACTIVE ASPs, based on the basic rule, AS will be in DOWN
state, because there aren't 3 ACTIVE ASPs and there aren't 3 INACTIVE ASPs.
I think, it is better to think AS in INACTIVE state in such a case, although
it seems there is not too much difference between AS=DOWN or AS=INACTIVE
from other procudres point of view, just when NTFY("AS INACTIVE") is sent
changes.
So, to cover the cases like in the above example, we just need put an
explanation to clarify the situation.