Subject: [Sigtran] M2PA Question

From: Andrew Booth <[email-masked]>
Date: Mon, 24 Jun 2002 10:40:59 -0400

Hi All,

The last weeks discussion on M2PA got me thinking a bit.  This questions 
could be interpreted as "flame bait", so I'm going to preface it with a 
disclaimer:

Note: THIS IS NOT A PROPOSAL FOR CHANGE, I'm just asking.

Preamble:
The principle differences between SCTP and TCP are that SCTP
i) supports multiple streams
ii) supports multi-homing
iii) is packet based rather than stream based

Note that:
1) M2PA doesn't use SCTP multi-streaming.
2) It is unclear whether SCTPs multi-homing capabilities provides any 
advantages over multiple single-homed associations on a multi-homed host 
( for M2PA ).  In short, M2PA might be just as well off not using SCTPs 
multi-homing features.
3) M2PA does have a message header that includes a length indicator.

Question:
Is there any reason why we shouldn't allow M2PA/TCP/IP, which should in 
principle involve less overhead?  Do we use any of the features of SCTP 
that are not in TCP?

Thanks,
Andrew

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 24 Jun 2002 11:03:38 -0500

Andrew,

Andrew Booth wrote:                                        (Mon, 24 Jun 2002 10:40:59)
> principle involve less overhead?  Do we use any of the features of SCTP 

Message delimitation.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Andrew Booth <[email-masked]>
Date: Mon, 24 Jun 2002 14:11:48 -0400

Hi Brian,

>>principle involve less overhead?  Do we use any of the features of SCTP 
The M2PA header contains a length indicator.  Isn't that enough for 
message delimitation?

Thanks,
Andrew

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 24 Jun 2002 13:26:20 -0500

Andrew,

The length indicator was included to make the UAs suitable for
use with other IP transports such as TCP.  Just because we
included that does not mean that use with TCP is recommended.

One of TCP's major failings in contrast to SCTP is path failure
detection during times of no (or low) data transfer.  SCTP's
heartbeat mechanism is far superior to TCP's keepalive mechanism
which can take up to a number of minutes to detect path failures.
SCTP can detect the same path failures in seconds.

In addition SCTP has the ability to rapidly and securely establish
and restart associations, which TCP does not have.

Also, M2PA does use multiple streams: one for status messages
and another for data.  TCP has only the poor one-byte OOB
equivalent.

Certainly there are many reasons why SCTP should be used in place
of TCP in this situation.  See the SCTP AS for more details.

--brian

Andrew Booth wrote:                                        (Mon, 24 Jun 2002 14:11:48)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Sarju Garg" <[email-masked]>
Date: Tue, 25 Jun 2002 12:39:41 +0530

Hi all,

I am newbie for M2PA.  I am collecting details about M2PA before starting
implementing it:
1. The last draft is 05. When are we expecting the next draft.
2. when is next interop event and which M2PA version is most accepted.
3. I am unable to open sigtran archive. probably it is not at this location:
https://www1.ietf.org/mail-archive/working-groups/sigtran/current/maillist.h
tml . is there a seperate archive for M2PA.
4. I have read the interop test and issues. Is are other docs similiar to
this

Thanks
Sarju