Subject: RE: [Sigtran] SG-SG, IPSP-IPSP, SE vs. DE ...

From: [email-masked]
Date: Tue, 4 Jun 2002 18:44:52 +0300

Tolga,

> The problem: Applications in IP domain should be able to 
> communicate to each other.

Here you get into problems.

> IPSP: Provides symmetric/direct communication between two 
> M3UA entities. Can be used also for sub-PC granularity.
> 
> SG-SG (or IP-STP) : Provides relaying (in my opinion needed to have
> concentration nodes for a reasonable configuration in case of 
> RKs with CIC
> ranges), and direct communication for PC granularity. In addition, it
> provides also relaying between SS7 nodes over IP (it can be 
> thougth as M3PA)
> 
> What IPSP and SG/SG can do is overlapping for PC granularity. 
> It is not exactly one v.s. another.

Why do we need to worry about PCs in IP domains?  Why do we need relaying
into SS7?  Your problem statement is not sufficient.

John

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 4 Jun 2002 12:54:23 -0500

John,

John Loughney wrote:                                         (Tue, 04 Jun 2002 18:44:52)
> into SS7?  Your problem statement is not sufficient.

I remember you defending relaying for SUA rather vehemently.
Did you think that the SG-SG and IPSP work applied only to
M3UA?  IPSP behavior (be it SE, DE or SG-SG) is also needed
for SUA.

I believe that the arhictecural framework RFC already provides
the problem statement for this work.  In addition, it provides
possible solution architectures.  The solution architecture
as presented in the RFC is SG-SG communication.

It is this IPSP DE and even SE concept that is a diversion from
the agreed SIGTRAN architecture.  Talking about DE and SE is a
utter waste of time, and has been for almost a year.

The SG-SG approach shown in the SIGTRAN architecture RFC is
plain, simple apparent, and direct.  If we follow you suggestion
use the problem statement and solution architectures from the
agreed SIGTRAN architecture, then we can proceed immediately
with SG-SG.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 4 Jun 2002 13:57:25 -0400

John,

My goal is not to start another long thread but please see my questions
below.

 Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, June 04, 2002 11:45 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [Sigtran] SG-SG, IPSP-IPSP, SE vs. DE ...
>
>
> Tolga,
>
[TOLGA] If we don't care about PC, how can we identify traffic ranges? In my
opinion regardless of whether we speak of SG-SG or IPSP-IPSP even for pure
IP domain communication we will need the concept of PC and SPMC, because
user parts are corraleted with a specific PC.
What I mean by relaying for SS7 nodes is, to relay between SS7 nodes. As I
mentioned before, relaying capability will also allow concentration nodes
for easier configuration.

I think it won't be wrong to say that IP-STP will bring the missing relaying
functionality to M3UA (in fact it was recently agreed that SGP can relay
between ASPs, it is directly connected to). In my  opinion relaying might be
usefull:
1- To be able to  have concentration nodes (needed for easy configuration
and also if one wants for direct communication in PC granularity)
2- To be able to  relay between SS7 nodes

I see IP-STP as a needed fucntionality, especially during the migration from
pure TDM to a mixed TDM/IP network.