Subject: RE: [Sigtran] IPSP: SE vs DE

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Mon, 3 Jun 2002 18:24:21 +0200

Brian, 

IPSP communication between SG and AS has a very close relation to using SG-SG comm. between AS and SG... Neither of them make sense for me.

IPSP communication is defined to communicate two ASes. If the AS wants to communicate with the SG the AS will use SG-AS communication.

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Monday, June 03, 2002 6:23 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: [email-masked]'
> Subject: Re: [Sigtran] IPSP: SE vs DE
> 
> 
> Javier,
> 
> That's rather peculiar as you said that IPSP to SGP communication
> was complex and unnecessary....
> 
> Which is it?
> 
> --brian
> 
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Mon, 03 Jun 2002 17:52:07)
> > Brian, 
> > 
> > Wrong concept. My AS can talk with a SG and ALSO with 
> another AS. The communication will be faster since the 
> processing is half or even less.
> > 
> > What is the advantage of AS-SG-(SG)-AS regarding AS-AS ?? 
> Please list them.
> > 
> > Cheers // Javier.
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Monday, June 03, 2002 5:14 PM
> > > To: Javier Pastor-Balbas (ECE)
> > > Cc: [email-masked]'
> > > Subject: Re: [Sigtran] IPSP: SE vs DE
> > > 
> > > 
> > > Javier,
> > > 
> > > Your IPSP will not work with an SG and therefore
> > > makes no sense.
> > > 
> > > I still propose that IPSP be removed altogether as SG-SG
> > > communication is an better, easier and obvious replacement.
> > > 
> > > --brian
> > > 
> > > Javier Pastor-Balbas (ECE) wrote:                          
> > > (Mon, 03 Jun 2002 16:58:54)
> > > > Hi Brian, 
> > > > 
> > > > IPSP will avoid the use of SG and therefore it makes sense.
> > > > 
> > > > Cheers // Javier.
> > > > 
> > > > > -----Original Message-----
> > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > Sent: Monday, June 03, 2002 4:48 PM
> > > > > To: Javier Pastor-Balbas (ECE)
> > > > > Cc: [email-masked]'
> > > > > Subject: Re: [Sigtran] IPSP: SE vs DE
> > > > > 
> > > > > 
> > > > > Javier,
> > > > > 
> > > > > As SE was clearly agreed as possible using an SG to 
> transfer and
> > > > > not requiring any new protocol or state machine description, I
> > > > > propose that IPSP be removed from the RFC altogether.  I also
> > > > > propose that the SG-SG be used to properly address 
> peer-to-peer
> > > > > communication.
> > > > > 
> > > > > --brian
> > > > > 
> > > > > Javier Pastor-Balbas (ECE) wrote:                          
> > > > > (Mon, 03 Jun 2002 16:24:07)
> > > > > > Hi guys, 
> > > > > > 
> > > > > > I propose to move forward. Most of the folks that are now
> > > > > > active seem to prefer the SE. Then, I propose to 
> remove the DE
> > > > > > exchange from the current RFC and leave only SE. Anyone
> > > > > > against?
> > > > > > 
> > > > > > 
> > > > > > Cheers // Javier.
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > _______________________________________________
> > > > > > Sigtran mailing list
> > > > > > [email-masked]
> > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > 
> > > > > -- 
> > > > > Brian F. G. Bidulock
> > > > > [email-masked]
> > > > > http://www.openss7.org/
> > > > > 
> > > > 
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > > -- 
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 3 Jun 2002 11:51:17 -0500

Javier,

As an AS is just the user of the MTP to MTP-User interface, 
it does not help understanding to refer to AS-SG communication.
An AS *always* communicates with *AS peers* using the MTP to
MTP-User interface.

Your statements do not help me understand the *protocol* between
the IPSP and the SG and the state machine definitions, transitions
and procedures that the IPSP uses in communicating with an SGP.
In your view, what messages, state machines and procedures does
the IPSP use in the case of communicating with an SGP?

--brian

Javier Pastor-Balbas (ECE) wrote:                          (Mon, 03 Jun 2002 18:24:21)
> Brian, 
> 
> IPSP communication between SG and AS has a very close relation to using
> SG-SG comm. between AS and SG... Neither of them make sense for me.
> 
> IPSP communication is defined to communicate two ASes. If the AS wants to
> communicate with the SG the AS will use SG-AS communication.
> 
> Cheers // Javier.
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/