Subject: RE: [Sigtran] IPSP: SE vs DE

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Mon, 3 Jun 2002 16:58:54 +0200

Hi Brian, 

IPSP will avoid the use of SG and therefore it makes sense.

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Monday, June 03, 2002 4:48 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: [email-masked]'
> Subject: Re: [Sigtran] IPSP: SE vs DE
> 
> 
> Javier,
> 
> As SE was clearly agreed as possible using an SG to transfer and not
> requiring any new protocol or state machine description, I 
> propose that
> IPSP be removed from the RFC altogether.  I also propose that 
> the SG-SG
> be used to properly address peer-to-peer communication.
> 
> --brian
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Mon, 03 Jun 2002 16:24:07)
> > Hi guys, 
> > 
> > I propose to move forward. Most of the folks that are now 
> active seem to
> > prefer the SE. Then, I propose to remove the DE exchange 
> from the current
> > RFC and leave only SE. Anyone against?
> > 
> > 
> > Cheers // Javier.
> > 
> > 
> > 
> > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 3 Jun 2002 11:32:34 -0400

If I think on real-life cases, an IPSP also does not seem too usefull to me.
Especially having peers working in sub-PC granularity and which are
symmetric, won't be something very easy to configure and maintain. For me,
always Figure-1 in SG-SG draft looks very elegant and realistic. What are
other opinions?

   Tolga

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brian F. G. Bidulock
> Sent: Monday, June 03, 2002 11:14 AM
> Your IPSP will not work with an SG and therefore
> makes no sense.
>
> I still propose that IPSP be removed altogether as SG-SG
> communication is an better, easier and obvious replacement.
>
> --brian
>
> Javier Pastor-Balbas (ECE) wrote:                          (Mon,
> 03 Jun 2002 16:58:54)
> > Hi Brian,
> >
> > > As SE was clearly agreed as possible using an SG to transfer and
> > > not requiring any new protocol or state machine description, I
> > > propose that IPSP be removed from the RFC altogether.  I also
> > > propose that the SG-SG be used to properly address peer-to-peer
> > > communication.
> > >
> > > --brian
> > >
> > > > active seem to prefer the SE. Then, I propose to remove the DE
> > > > exchange from the current RFC and leave only SE. Anyone
> > > > against?
> > > >
> > > >
> > > > Cheers // Javier.
> > > >
> > > >
> > > >
> > > >
> > > >

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 3 Jun 2002 10:13:46 -0500

Javier,

--brian

Javier Pastor-Balbas (ECE) wrote:                          (Mon, 03 Jun 2002 16:58:54)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "reshma" <[email-masked]>
Date: Tue, 4 Jun 2002 19:36:36 +0530

Hi Tolga,

    Are u saying that 2 IPSPs talking using an SG which will act as relay
point?

Thanks,
reshma

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 4 Jun 2002 10:28:39 -0400

Reshma,

> From: reshma [mailto:[email-masked]]
> Sent: Tuesday, June 04, 2002 10:07 AM
> To: Tolga Asveren; [email-masked]
[TOLGA] No. For PC granularity:
 +------+              +------+
 |U.P./ |              |U.P./ |
 |NIF   |              |NIF   |
 +------+              +------+
 |      |              |      |
 |SGPF  +--------------+SGPF  |
 +------+              +------+

And if one want to distribute the User Parts:

        -----              -----
      //     \\          //     \\
     |  ASP    |        |  ASP    |
     |  Cloud 1|        |  Cloud 2|
      \\     //          \\     //
        --+--              --+--
          |                  |
          |                  |
       +--+--+            +--+--+
       | SG1 +------------+ SG2 |
       +--+--+            +--+--+
          |                  |
          |                  |
          |                  |
          |     +-----+      |
          +-----+ SG3 +------+
                +--+--+
                   |
                   |
                 --+--
               //     \\
              |  ASP    |
              |  Cloud 3|
               \\     //
                 -----

> > > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> > > Brian F. G. Bidulock

---

From: "reshma" <[email-masked]>
Date: Tue, 4 Jun 2002 20:12:58 +0530

Hi Tolga,

> [TOLGA] No. For PC granularity:

[Reshma] The above config seems to support IPSP-IPSP.But here what u call
as SGPF is very confusing (Everyone has different meaning for SGPF).
As per the current SG-SG draft u have defined TAL message  for the startup.
But as per your recent discussion you have introduced back ASPUP,ASPAC
messages for this purpose.B'coz of that in the above figure you should not
name
those blocks as SGPFs as they are not really SGPFs they will have MGC
functionalities
also (Sending ASPSM and ASPTM msgs).

> And if one want to distribute the User Parts:

[Reshma] Sorry, but i dont get how can this configuration support IPSP-IPSP?

Thanks,
Reshma
> > > If I think on real-life cases, an IPSP also does not seem too usefull
to
> > me.