Subject: RE: [Sigtran] RE: IPSP-IPSP

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Mon, 17 Jun 2002 18:24:04 +0200

Hi Tolga, 

See below..

> [TOLGA] If one has those security concerns, they are also 
> applicable for
> ASP/SGP case (except for own SPC). So, if dynamic RC and 
> AspId is allowed
> for ASP/SGP case, why shouldn't it be allowed for IPSP case?

Sorry, I was just giving a personal opinion. You can have dynamic RCs if you desire so. The main problem  we have is dealing with two ASes with just a SE approach to start communication where the ASPid can travel just in one direction. 

I don't see it as a big deal to define it statically, but if you guys prefer to have the same flexibility we can figure out how to do it dinamically. 

I don't think that including a new ASPUP is a good idea, since you are breaking the general rule of answering an ASPUP with an ASPUP-ACK message. And also one of the key points of the SE: just having one exchange of messages. 

My suggestion is one of the following:
	- Use the first 4 octets of Info String in ASPUP-ACK to include this parameter
	- Allow an optional parameter "ASP ID" to be included in ASPUP-ACK just before Info String.

I personally prefer the second.

Cheers // Javier.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 17 Jun 2002 14:09:41 -0400

Javier,

> -----Original Message-----
> From: Javier Pastor-Balbas (ECE)
> [mailto:[email-masked]]
> Sent: Monday, June 17, 2002 12:24 PM
> To: 'Tolga Asveren'; [email-masked]
> Subject: RE: [Sigtran] RE: IPSP-IPSP
>
>
> Hi Tolga,
>
> See below..
>
>
> Sorry, I was just giving a personal opinion. You can have dynamic
> RCs if you desire so. The main problem  we have is dealing with
> two ASes with just a SE approach to start communication where the
> ASPid can travel just in one direction.
>
> I don't see it as a big deal to define it statically, but if you
> guys prefer to have the same flexibility we can figure out how to
> do it dinamically.
>
> I don't think that including a new ASPUP is a good idea, since
> you are breaking the general rule of answering an ASPUP with an
> ASPUP-ACK message. And also one of the key points of the SE: just
> having one exchange of messages.
[TOLGA] What I meant was two exchange two ASPUP/ASPUP-ACKs but the second
proposal below seems also nice to me. Exchange of one message is really a
key point of SE, but only for ASPAC, because it is the single ASPAC which
dictates that the RK identifies the traffic at both ends. ASPUP has nothing
to do with it.